
12 Preparing Theme Symbology
This chapter presents a set of tools used to prepare or edit themes, and to 
manage Theme files. By attaching a theme to a vector element, you 
automatically assign a symbology to this element and a set of parameters that 
defines its characteristics and meaning.
Overview
Themes are user-definable presentation attributes that can be 
assigned to elements of a design file. Each theme is given a name 
which represents the common feature that the elements represent 
and identifies the associated symbology set. 

Themes are particularly useful in applications such as mapping 
that require symbolic representation of data. An unlimited 
number of themes are supported on each level and they are used 
to display the elements in MicroStation’s views with various sets 
of visual display attributes. You can assign a theme to any 
element or attach a centroid cell and an associated theme to a 
closed element.

The theme concept allows you to automatically and easily assign 
a symbology and a set of parameters or attributes to all elements 
with the same characteristics and meaning. With themes, you can 
classify elements. All elements belonging to the same class will be 
attached to the same theme and will have the same symbology.

When you place elements with the Vectorize tool box or when 
you convert raster objects into design line strings, text or symbols, 
you can select the appropriate themes that correspond to the 
objects and automatically assign classes to the elements you 
create. If the None theme is selected, the MicroStation element 
settings for color, style, and weight are used, and no theme tag is 
given to the element.

Examples of parameters or attributes connected to a theme are 
line weight, line style, pattern, hatch, color, or class name (road, 
street, pipe, etc.). A theme can have specialized attributes for text 
such as font type, height, width, line spacing, line length, 
intercharacter spacing, justification, angle, underline, or slant.
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Overview
This chapter describes the following tool boxes:

• Theme — used to tell the theme attached to an element, to 
change the theme of elements, or to select all elements with a 
given theme.

• Theme File — used to manage Theme files.

It also describes the following dialog boxes:

• Theme Styler — used to prepare or edit themes and to 
manage Theme files.

• Hatch Editing — used to produce or edit hatch items, and to 
manage Hatch files.

• Pattern Editing — used to produce or edit patterns, and to 
manage Pattern files.

• Text Attributes — used to set theme parameters related to 
text.

• Cell Attributes — used to set theme parameters related to 
cells.

• Update Design File dialog box — used to selectively replace 
the element symbology in the active design file with the 
theme symbology.
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Definitions
Definitions
In order to use themes and the related tools efficiently, you 
should be familiar with some important definitions: 

Theme A theme is assigned to an element in order to classify 
and graphically represent it in the same manner as all 
other elements of the same class. A theme is specified by 
a set of graphical characteristics common to all elements 
assigned the same theme, such as the color, the type or 
weight of a line, a pattern, a hatch, and so forth. 

Theme File A Theme file is a set of themes saved together in a file. 
In a Theme file, an individual theme is identified by a 
name and a number. 

Hatch A hatch fills a closed space with repeated hatch lines. A 
hatch is defined by a set of parameters such as the type 
(hatch or crosshatch) the color of lines, the spacing 
between lines, the direction of lines, and so forth.

Hatch File A Hatch file is a set of hatch items saved together in a 
file. In a Hatch file, an individual hatch is identified by a 
number. 

Pattern A pattern fills a closed space with repeated cells. A pat-
tern is a set of parameters such as the cell to be 
repeated, the spacing between cells, the size and the 
direction in which they are repeated, and so forth. 

Pattern File A Pattern file is a set of pattern items saved together in a 
file. In a Pattern file, an individual pattern is identified 
by a number. 

Cell A cell is a drawing template with its own graphical 
attributes, which can be copied to various places and at 
various scales. In a pattern, a cell can be copied repeat-
edly to fill a closed surface. 

Symbology A symbology is a set of graphical attributes used to dis-
play elements. Symbology can be associated with the 
elements themselves, with levels, or with themes. An 
element can be displayed differently according to the 
symbology used in a specific situation. 
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Theme tool box
The Theme tool box is used to show the theme attached to an 
element, to change the theme of elements, to select all elements 
with a given theme, or to open the Theme Styler dialog box.

Tools in this box work with the following MicroStation element 
types: Cell, Line, Line String, Shape, Complex Shape, Complex 
Chain, Text Node, Text, Curve, Ellipse, Circle, Arc and B-Spline.

Change Theme tool
Used to change the theme of an element or the theme of all 
elements in a selection set. 

➤ To change the theme of an element

1. Select Change Theme. 

2. Select the new theme in the tool settings window. 

3. Identify the element by clicking on it. 

4. Accept the element (or reject and retry). 

✍ The Change Theme tool does not apply the theme symbology to 
the design file. You must update the design file to do so.

➤ To change the theme of the elements in a selection set

1. Select the elements with the MicroStation Element Selection 
tool. 

2. Select Change Theme.

3. Select the new theme in the tool settings window.

4. Accept the selection (or reject and retry). 

Query Theme tool
Used to report what theme is attached to an element.

➤ To find the theme of an element

1. Select Query Theme. 

2. Identify the element by clicking on it. 

3. Accept the element (or reject and retry). 

4. Reset to accept the query. 

Theme tool box

Change Theme tool

Query Theme tool
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Select by Theme tool
Used to create a selection set from a specified theme. 

➤ To select all elements associated with a theme

1. Select the Select by Theme tool.

2. Select the theme in the tool settings window.

3. Accept (or reject and retry). 

The resulting selection set contains all elements of the design 
file associated with the selected theme. 

Theme Styler Dialog tool
Used to open the Theme Styler dialog box. (See “Theme Styler 
dialog box” on page 12-6.)

Theme File tool box
The Theme File tool box includes all necessary tools to manage 
Theme files (THM files). A Theme file is used to save a set of 
themes. It can be opened later and be edited or used with various 
converting operations. The same functions can also be accessed 
from the File menu of the Theme Styler dialog box. 

Any time unsaved changes to themes are going to be lost, a 
warning message displays giving you the option to save the file.

New Theme File tool
Choose New Theme File to create a new Theme file. The 
temporary name Untitled is given to the new theme set, which 
contains two themes: (def) and (none). The theme set becomes a 
Theme file when it is saved and given a name. If a Theme file is 
open, it closes before the new theme set is created. If changes 
have been made to the previous theme set, you are warned to 
save your changes. Press OK in the warning box to do so, or 
Cancel to remove the previous theme set without saving the 
changes.

Open Theme File tool
Choose Open Theme File to open an existing Theme file. If a 
Theme file is open, it closes before the new theme set is opened. 

Select by Theme tool

Theme Styler Dialog tool

Theme File tool box

New Theme File tool
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If changes have been made to the previous theme set, you are 
warned to save your changes. Press OK in the warning box to do 
so, or Cancel to remove the previous theme set without saving 
the changes. 

Save Theme File tool
Choose Save Theme File to save the current theme set with the 
present name, in the same directory, and on the same disk. If the 
theme set is Untitled, or if the current Theme file is write 
protected, a dialog box allows you to save the theme set under 
any filename, in any directory, and on any disk. The file is created 
and becomes the current Theme file. 

Theme Styler Dialog tool
Used to open the Theme Styler dialog box. (See “Theme Styler 
dialog box” on page 12-6.)

Theme Styler dialog box
The Theme Styler dialog box is used to create and edit themes, 
and to manage Theme files. The title bar of the dialog box 
displays the name of the active Theme file. If a Theme file is not 
open, Untitled displays as the filename.

Open Theme File tool

Save Theme File tool

Theme Styler Dialog tool

Theme Styler
dialog box
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Add

Used to add a new theme to the Theme file. 

➤ To add a theme

1. Enter a new number in the No. field. 

2. Enter or edit all other parameters. 

3. Click Add. 

The new theme now displays in the Theme list box. 

W When themes are added, modified, or deleted, the theme set in 
memory is changed, but the Theme file does not automatically 
update. To update it, use Save from the File menu or the Save 
Theme File tool.

Modify

Used to modify any descriptive parameter of the selected theme. 

➤ To modify a theme

1. Select a theme by clicking the corresponding line in the 
Theme list box. 

2. Edit all appropriate parameters.

3. Click Modify. 

Delete

Used to delete the selected theme from the current Theme file. 

➤ To delete a theme

1. Select a theme by clicking the corresponding line in the 
Theme list box. 

2. Click Delete. 

The deleted theme is then removed from the Theme list box.

✍ The (def) and (none) themes cannot be deleted. 

Global parameters

Global Scale 

Used to select a display scale for the Theme file. This scale will be 
applied to all hatch items, patterns, or cells in the Theme file. 
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Hatch File

The Hatch File field displays the name of the Hatch file attached 
to the Theme file. If no Hatch file is attached to the current 
Theme file, Hatch File is dimmed. 

Pattern File

The Pattern File field displays the name of the Pattern file 
attached to the Theme file. If no Pattern file is attached to the 
Theme file, Pattern File is dimmed. 

Description

No

The No field indicates the number of the selected theme. To add a 
new theme, enter a new number into this field. This number must 
be unique in a Theme file.

Name

Used to enter or to display the name of the selected theme. The 
name is a code assigned to a theme. 

Level

The Level field specifies the MicroStation level assigned to the 
selected theme and is a value ranging from 1 to 63. 

Description

Use the Description field to enter a short description for the 
selected theme. 

Use

Indicates whether the selected theme can be used or not. If it is 
turned off, the selected theme does not display in the Theme 
menu options with various tools. It is not removed from the 
theme file and can be enabled later by turning on the Use check 
button for this individual theme.

Visible

Used to selectively display themes. Elements that belong to 
themes with the Visible status turned on are displayed. If the 
status is turned off for an individual theme, all elements that 
belong to this theme are not displayed. To turn on or off the 
Visible status of a theme, select this theme in the Theme list box 
and click the Visible check button.
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Line
Line

Contour Color

Use the Contour Color field to specify the color contour assigned 
to the selected theme. The color is applied to linear elements and 
to the perimeter of polygons and is a value ranging from 0 to 255. 
The color is chosen by entering the number into the field next to 
the color button, or selected with the color picker that pops up 
when you click the color button.

Line Style

Use the Line Style option menu to choose the line style assigned 
to the selected theme. The line style is applied to linear elements 
and to the perimeter of polygons. It is a value ranging from 0 to 7.

Line Weight

Use the Line Weight option menu to choose the line weight 
assigned to the selected theme. The line weight is applied to 
linear elements and to the perimeter of polygons. It is a value 
ranging from 0 to 15. 

Surface

Hatch #

Use the Hatch # field to assign a hatch number to a selected 
theme. Hatch items, as well as pattern items, are used to fill 
closed elements. The Hatch # “0” yields no hatch. 

Pattern #

Use the Pattern # field to assign a pattern number to the selected 
theme. Pattern items, as well as hatch items, are used to fill closed 
elements. The Pattern # “0” yields no pattern. 

Fill

Fill toggle and Color

If Fill is on, closed elements are automatically filled. The color is 
chosen by entering the number into the field next to the color 
button or selected with the color picker that pops up when you 
click the color button. 

You can also fill (as a background color) a closed area which has 
previously been patterned or hatched. If the Display toggle in the 
Options menu is on, the Fill color does not cover the hatch or the 
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pattern associated to the design elements in the display. When the 
Display check button is off (default), the Fill color can hide the 
hatch or pattern associated with the design elements. To avoid 
this situation, update your design file. (See “Update Design File 
dialog box” on page 12-19.) 

If you want to update your design file with a fill, turn on the Fill 
check button in the Update Design File dialog box. If the Fill 
check button is on, the Fill color is updated in the design file. If 
the Hatch/Pattern check button is off, you are warned that the fill 
color can cover the hatch or pattern of your closed elements.

W The fill does not take into account an element that is marked as a 
hole. 

Text Attributes
This button opens the Text Attributes dialog box. 

Use the Text Attributes dialog box to define the parameters of the 
font belonging to the selected theme.

Font

A theme can be attached to text. Use the Font field to enter the 
font number that corresponds to the desired MicroStation font. 

Color

Use the Color field to specify the color, a value ranging from 0 to 
255, assigned to text in the selected theme. The color is chosen by 
entering the number into the field next to the color button, or 
selected with the color picker that pops up when you click the 
color button. 

Text Attributes
dialog box
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Cell Attributes
Height

Used to set the height of the font.

Width

Used to set the width of the font.

Line Spacing

Used to select the line spacing.

Interchar Spacing

Used to select the spacing between characters.

Slant

Used to select the slant.

Underline

Used to underline text.

Vertical Text

Used to align text vertically in columns.

Single Line Justification

Use the Horizontal and the Vertical buttons to select the single-
line justification, horizontal and vertical.

Multi Line Justification

Use the Horizontal and the Vertical buttons to select the multi-line 
justification, horizontal and vertical.

Cell Attributes
This button opens the Cell Attributes dialog box. 
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Use the Cell Attributes dialog box to define the parameters of the 
cell belonging to the selected theme.

Name

Use the Name field to assign a cell to the selected theme. Specify 
it by providing the name of a cell from the cell library that is 
attached to the active design file. The cell library can be examined 
with the Cell Library dialog box which is accessed by choosing 
the Cells option from the MicroStation Element menu.

✍ The cell connected to the selected theme can be placed in the 
design file with the Convert Cell tools from the Text/Cells tool 
box. If you assign a theme to an existing cell, this cell is replaced 
by the cell connected to the new theme. 

Color

Use the Color field to specify the color, a value ranging from 0 to 
255, assigned to the cell in the selected theme. The color is 
chosen by entering the number into the field next to the color 
button, or selected with the color picker that pops up when you 
click the color button. 

X Scale

Used to set the scale of the x-axis.

Y Scale

Used to set the scale of the y-axis.

Use Symbology

Turn on the Use Symbology toggle to display the cells that belong 
to the current theme with the theme symbology: Level, Line Style, 
and Line Weight. Turn it off to display the cells with their own 
symbology. 

✍ Turning on the Use Symbology toggle does not affect the display 
of a cell used as a MicroStation Descartes pattern item. 

Cell Attributes
dialog box
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Theme Styler menu

File > New

Choose New to create a new Theme file. The temporary name 
Untitled is given to the new theme set, which contains two 
themes: (def) and (none). The theme set becomes a Theme file 
when it is saved and given a name. If a Theme file is open, it 
closes before the new theme set is created. If changes have been 
made to the previous theme set, you are warned to save your 
changes. Press OK in the warning box to do so, or Cancel to 
remove the previous theme set without saving the changes. 

File > Open

Choose Open to open an existing Theme file. If a Theme file is 
open, it closes before the new theme set opens. If changes have 
been made to the previous theme set, you are warned to save 
your changes. Press OK in the warning box to do so, or Cancel to 
remove the previous theme set without saving the changes. 

File > Save/Save As

Choose Save to save the current theme set with the present name, 
in the same directory, and on the same disk. If the theme set is 
Untitled, or if the current Theme file is write protected, this 
feature functions identically to Save As. Choose Save As to save 
the theme set under any filename, in any directory, and on any 
disk. The file is created and becomes the current Theme file. 

Hatch > Select

Choose Select from the Hatch menu to open the Select Hatch File 
dialog box. Use this dialog box to open and attach an existing 
Hatch file to the current Theme file. If a Hatch file is open, it 
closes before the new one opens. After a Hatch file opens, its 
filename displays in the Hatch File field of the Theme Styler 
dialog box. 

Hatch > Edit

Choose Edit to access the Hatch Editing dialog box, which is used 
to set the parameters to produce or edit hatch items, as well as to 
manage Hatch files. A Hatch file can contain several hatch items. 
A hatch is the repeated placement of hatch lines filling a closed 
area at specified intervals and angles (See “Hatch Editing dialog 
box” on page 12-16).
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Pattern > Select

Choose Select from the Pattern menu to open the Select Pattern 
File dialog box. Use this dialog box to open and attach an existing 
Pattern file to the current Theme file. If a Pattern file is open, it 
closes before the new one opens. After a Pattern file opens, its 
filename displays in the Pattern File field in the upper part of 
Theme Styler dialog box.

Pattern > Edit

Choose Edit from the Pattern menu to open the Pattern Editing 
dialog box. Use this dialog box to set all the parameters used to 
produce or edit pattern items, as well as to manage Pattern files. 
A Pattern file can contain several pattern items. A pattern is the 
repeated placement of a cell to fill a closed area at a specified 
interval and angle (See “Pattern Editing dialog box” on page 
12-18).

Tools > Theme

Selecting Theme from the Tools menu gives access to the Theme 
tool box which allows you to change the theme of an element, to 
display the theme of an element, to select the elements associated 
with the current theme, or to open the Theme Styler dialog box 
(see “Theme tool box” on page 12-4).

Tools > Theme File

Selecting Theme File from the Tools menu gives access to the 
Theme File tool box which allows you to create a new Theme 
file, to open an existing Theme file, to save changes in a Theme 
file, or to open the Theme Styler dialog box (see “Theme File tool 
box” on page 12-5).

Options > Display (toggle)

This toggle controls if the theme should be applied to the 
elements at display time. If off, the theme attributes are ignored 
and the display of elements follows MicroStation conventions. If 
on, the elements display using the theme symbology, provided 
that the MicroStation view attributes are set properly with the 
View Attributes dialog box.

If you assign a theme, change the theme of an existing element, 
or if you modify the symbology of a theme, the new theme 
symbology correctly displays if the Display toggle is on. If it is off, 
you must update your design file to see the new symbology. (See 
“Update Design File dialog box” on page 12-19.)
12-14 MicroStation Descartes User’s Guide



Preparing Theme Symbology
Theme Styler menu
✍ Turning on Display can increase the time for updating a view. In 
any situation where time is critical, turn off Display.

Options > Set All Use

Used to activate all current themes. The names and numbers of all 
themes can be used with tools that require a theme. It sets the 
Use toggle for each theme in the set.

Options > Clear All Use

Used to disable all current themes, except the themes (def) and 
(none). The names and numbers of all other themes are not 
accessible when using commands requiring a theme, but they are 
not removed from the theme file. It clears the Use toggles for 
each theme in the set.

Option > Set All Visible

Used to make all themes visible. It sets the Visible toggle for each 
theme in the set.

Option > Clear All Visible

Used to make all themes invisible. It clears the Visible toggle for 
each theme in the set.

✍ The Visible toggle in the Theme Styler dialog box is used to 
selectively display themes. Elements that belong to themes with 
the Visible status are displayed. If the Visible status is off for a 
theme, all elements that belong to this theme are not displayed. 
To turn on or off the Visible status of an individual theme, select 
the theme in the Theme list box and click the Visible check 
button. You can also turn on or off the Visible status of all themes 
by using the Set All Visible and Clear All Visible items in the 
Options menu. 

Options > Update Design File 

Use Update Design File to update element attributes in the active 
design file with the theme attributes of the active Theme file. 
Choose this item from the Options menu to identify the attributes 
that should be taken into account in the update of the design file. 

This operation applies a selection of theme attributes to the 
design file by changing the element symbology of the individual 
elements in the design file to a new symbology corresponding to 
the theme attributes. (For more information see “Update Design 
File dialog box” on page 12-19.)
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Hatch Editing dialog box
The Hatch Editing dialog box is used to set the parameters to 
produce or edit hatch items, and to manage Hatch files. A Hatch 
file can contain several hatch items. A hatch is the repeated 
placement of hatch lines filling a closed area at specified intervals 
and angles. 

The No. list box displays a list of hatch items sorted by numbers. 
A hatch is selected by clicking on the corresponding line in the 
list, which then highlights. To add a new hatch item, enter a new 
number into the No field, enter or edit all other parameters, and 
click Add. A highlighted hatch item is deleted by clicking the 
Delete button or modified to the current attribution set by clicking 
the Modify button.

W When hatch items are added, modified, or deleted, the hatch set 
in memory is changed, but the Hatch file does not automatically 
update. To update it, use Save from the File menu.

✍ The following hatch parameters are available to define a new 
hatch item or to edit an existing one.

No (field)

Used to display the number of the selected hatch item, or to enter 
a new number to insert a new item into the Hatch file. The 
number entered into this field is the one used to specify the hatch 
number in the Theme Styler dialog box. 

Type

Used to choose between two types of hatch items: Hatch or Cross 
Hatch. Hatch is the repeated placement of a line through a closed 
area at a specified interval and angle. Cross Hatch is the repeated 

Hatch Editing
dialog box
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placement of two series of hatch lines through a closed area at a 
specified interval and angle. 

Line Style

Use the Line Style option menu to choose among eight styles of 
lines for a hatch. The Line Style is a value ranging from 0 to 7.

Line Weight

Use the Line Weight option menu to specify the width of the line 
used for a hatch. The Line Weight is a value ranging from 0 to 15.

Color

The Color field specifies the color used for the hatch lines. It is a 
value ranging from 0 to 255. The color is chosen by entering the 
number into the field next to the color button, or selected with 
the color picker that pops up when you click the color button.

Spacing

Use the Spacing field to set the repeated interval between the 
hatch lines.

Angle

Hatch lines can be drawn at a specified angle from the design 
plane positive x-axis. For the Cross Hatch, set the angle of the 
two series of hatch lines by entering the values in degrees, in the 
range 0 to 360.

✍ The Hatch file name is saved with a Theme file.
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Pattern Editing dialog box
The Pattern Editing dialog box is used to set all the parameters 
needed to produce or edit pattern items, as well as to manage 
Pattern files. A Pattern file can contain several pattern items. A 
pattern is the repeated placement of a cell to fill a closed area at a 
specified interval and angle.

The Pattern No. list box displays a list of pattern items in 
numerical order. A pattern is selected by clicking on the 
corresponding line in the list, which then highlights. To add a 
new pattern item, enter a new number into the No field, enter or 
edit all other parameters, and click Add. A highlighted pattern 
item is deleted by clicking the Delete button or modified to the 
current attribution set by clicking the Modify button.

✍ If the pattern number you key in to the No field already exists, a 
pattern item will not be added.

W When pattern items are added, modified or deleted, the pattern 
set in memory is changed, but the Pattern file does not 
automatically update. To update it, use Save from the File menu.

No (field)

The No field displays the number of the selected pattern item, or 
is used to enter a new number for inserting a new item into the 
Pattern file. The number entered is the one that is used to specify 
the pattern number in the Theme Styler dialog box. 

Cell

Use the Cell field to assign a cell to the selected pattern item. The 
cell is assigned by entering the name of a cell from the cell library 
attached to the active design file. The cell library can be examined 
with the Cells setting box. It is accessed by choosing the item 

Pattern Editing
dialog box
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Cells in the MicroStation Element menu. (See the MicroStation 
User’s Guide.) 

Row Spacing and Column Spacing

Use the Column Spacing field to set the interval between cells 
repeated along a row, i.e., the interval between columns. Use the 
Row Spacing field to set the repeated interval between rows. 

Scale

Use the Scale field to set a scale factor which is applied to cells 
when displaying patterns. The scale factor resizes a cell at 
appropriate dimensions according to the scale of the active design 
file. A scale factor greater than 1.0 scales size upward. A scale 
factor less than 1.0 scales size downward. A factor of 1.0 prevents 
rescaling. 

Angle

Use the Angle field to specify the angle between the design plane 
positive x-axis and a row of repeated patterns.

✍ The Pattern file name is saved with a Theme file.

Update Design File dialog box
Used to update element symbology in the active design file with 
the theme symbology set of the current Theme file. Check the 
appropriate boxes to identify the attributes that should be taken 
into account in updating the design file.

With this operation, you apply a selection of theme attributes to 
the design file by changing the symbology of individual elements 
in the design file with a new symbology corresponding to the 
theme attributes.

Update Design File
dialog box
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Level

If on, the level of the elements in the design file is replaced with 
the level associated with the themes attached to these elements.

If off, the levels of elements in the design file remain unchanged. 

Color

If on, the color attribute of the elements in the design file is 
replaced with the color associated with the theme of these 
elements.

Line Style

If on, the line style attribute of the elements in the design file is 
replaced with the line style associated with the theme of these 
elements. 

Line Weight

If on, the line weight attribute of the elements in the design file is 
replaced with the line weight associated with the theme of these 
elements. 

Hatch/Pattern

If on, the existing hatch or pattern associated with the elements in 
the design file is replaced with the hatch or pattern associated 
with the theme of these elements. If off and if the Fill check 
button is on, you are warned that the fill color can cover the 
hatch or pattern of your closed elements. 

W Patterns and hatches already present in the design file are NOT 
affected when Update Design File is run. All patterns and hatches 
created with Theme Styler are ADDED to the design File.

Text

If on, the text assigned to the theme is saved in the design file. 

Cell

If on: 

• The cells in the design file that are associated to a theme are 
replaced with the cell indicated (if there is one) in the Name 
field in the Cell Attributes dialog box. 

• If Use Symbology in the Cell Attributes dialog box is off, all 
cells that are associated to a theme are saved in the design file 
with their own symbology. 
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• If Use Symbology in the Cell Attributes dialog box is on, the 
theme symbology (level, color, line style, and line weight) is 
applied to the cells. 

If off, the cells in the design file remain unchanged.

W If Use Symbology in the Cell Attributes dialog box is on, the 
existing Shared Graphic Cells are replaced by Normal Graphic 
Cells in the design file and the size of your file increases. 

Fill

If on, the fill color is updated in the design file. If off, you are 
warned that the fill color can cover the hatch or the pattern of 
your closed elements. 

Time

Displays the percentage of progress when updating elements in 
the design file.

All

Used to turn on all options.

Run

Used to start the design file updating process. 
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