
8 Registering Images and Vector Data
This chapter describes the Register utility and all the related features. Register is 
used to geometrically correct images or vector data to a given coordinate 
system by warping them to fit a reference or base document. The base 
document can be an image, a vector file, a drawing, a map sheet, or a list of 
known points (from a GPS system, for example). 
Warping Images with Register
In Chapter 7 (Transforming Images), you learned how to warp an 
image with the Warp Image tool from the Image Transform tool 
box. This tool uses control points, like Register, but it is used only 
for simple, straightforward transformations.

Register permits more control on establishing the transformation 
models and gives access to more sophisticated features, such as:

• Dynamic warping which overlays existing vector data over 
the uncorrected image, so you can verify the actual 
transformation model and decide whether it is good enough 
for running the resampling of the image. 

• More flexibility for entering and managing control points. Any 
control point can be moved or deleted. 

• Polynomials models which can be used for more severe 
distortion.

• A No-Residual Transformation model for precision in control 
points.

• Any number of control points. When there are more Dynamic 
Warping in Views Displaying Uncorrected Data than the 
minimum required, residuals can be used for inspecting and 
analyzing the actual model.

• Transformation of vector data through the same model.

• Batch resampling of images.
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Transformation Models
Transformation Models
Various warping transformation models are supported: 

• Helmert

• Similitude

• Affine

• Projective

• Thin Plate Spline - No Residuals

• Polynomial

The unique design of Register permits you to visually determine if 
the transformation model is accurate. Since base vector data is 
displayed over the target image, it is simple to identify 
inaccuracies in the model. To assist you in the warping process, 
Register displays statistical information about the accuracy of the 
transformation model. You can also dynamically change the 
transformation model and interactively edit the control points on 
the base document. 

When the transformation model is accurate, as many images as 
necessary can be resampled. Resampling methods include nearest 
neighbor, bilinear interpolation, and cubic convolution. 

Concepts
Registering images or vectors requires that their geometry be 
altered to fit another geometry taken as a reference. The process 
consists of two steps. First, a transformation model is built. 
Second, the images or vectors are resampled through this 
transformation model. 

Throughout this chapter, the terms base and uncorrected are used 
with a very specific meaning: 

• The base is the system of coordinates taken as a reference 
and onto which the uncorrected data is registered. The base 
can be vectors, digital images, hard copy, a series of known 
points, or some other geometric source. 

• The uncorrected data is a digital document targeted to fit the 
base after it is transformed through a mathematical model.
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Building a Model
Building a Model 
Building a model requires that a set of mathematical functions be 
built to establish correspondence between any point in the base 
geometry and the corresponding point in the target geometry. 

The way that Register establishes this set of functions is by 
placing a set of corresponding points, called control points, and 
interpolating for the remainder of space around the control 
points. The control points are represented by color marks in both 
base and uncorrected spaces. The interpolation is done with 
smooth two dimensional functions like Helmert, Affine, 
Similitude, Projective, and up to a third degree Polynomial.

To test the accuracy of the interpolation, Register warps a 
representation of the base vector data to fit the uncorrect data. 
This visualization illustrates the fit that occurs when you resample 
the uncorrect data to fit the base data. 

This visual feedback assists you as you gather more points and 
improve the fit. After enough points are gathered to satisfy the 
requirements of the selected transformation model, the uncorrect 
image or vectors can be resampled using this model. Since the fit 
has already been determined visually, the result is “what you see 
is what you get” resampling.

Warping the base vector data is done dynamically and is normally 
fast. It is recommended that you warp a small but significant set 
of base vector data. The set of base vector data can be acquired 
by extraction from one or several base documents, in digital or 
analog formats: design files, digital images, analog maps, 
drawings, plans, lists of known points, and so forth. 

With a design file, extract a few representative elements or parts 
of elements. With a digital image, extract a few representative 
elements by interpretation. With a hard copy document, digitize a 
few representative elements. With a list of known points, no base 
vector data set is needed to use the dynamic warping capability 
since the control point marks play this role. 

You can also use Register to build a model without a set of base 
vector data and without dynamic warping, which resembles the 
method that is commonly used with most geometric correction 
software. However, with this method there is no means to test the 
accuracy of the model prior to resampling the image or vector 
file. 

Another unique feature of Register is the alleviation of the 
constraint of finding “true” or “exact” control points. With 
Register, you can use “fuzzy” control points, because of the visual 
feedback provided by dynamic warping. 
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Standard Registration Transformation Models
A true or exact control point is a point which can be precisely 
identified on both the base data set and on the data to be 
registered. Examples include the crossing of two roads, the corner 
of a part, the corner of a building, and so forth. A fuzzy control 
point is a point which can be localized approximately on both 
documents. Examples include the center of a lake, window, or 
field, or the top or side of a car, and so forth. 

When you use fuzzy control points, pick each point 
approximately in the base space and pin it in the uncorrected 
space by determining its general position. The dynamic warping 
shows if your placement is accurate enough. If not, just move the 
point.

The following design elements are supported for dynamic 
warping:

Standard Registration Transformation Models
When you install MicroStation Descartes, several standard 
transformation models (RGR files) are copied to the 
DCARTES\STANDARD directory (offered as the default directory). 

• Arcs • Text Nodes 

• Cells • B-Spline Poles 

• Complex shapes • Complex chains of strings

• Ellipses • Curves 

• Circles • Lines

• Line Strings • Shapes

• Shared Cells • Text 
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Image Resampling
These models support basic transformations such as mirrors and 
rotations of an image. Standard models provided are:

• NEUTRAL.RGR

• 45CLOCK.RGR

• 90CLOCK.RGR

• 135CLOCK.RGR

• 180CLOCK.RGR

• 135COUNT.RGR

• 90COUNT.RGR

• 45COUNT.RGR

• HMIRROR.RGR

• VMIRROR.RGR

W The rotation and the mirror models use (0,0) as the origin of the 
output image. If you want the output image to be in the same 
spatial reference as the input image, edit the origin of the output. 

Image Resampling
The image resampling process creates a new image, pixel by 
pixel, by establishing an appropriate value for each pixel. The 
resulting image is similar to the one from which it is calculated, 
with a very close radiometry and with a slightly different 
geometry.

There are two steps in the image resampling process:

• For each pixel of the output image, the first step is to find the 
corresponding point in the input image by passing it through 
the established transformation model. 

• The second step is to calculate the value of the output pixel 
by using the value of one or several pixels located on or 
around the corresponding point in the input image. 

The Nearest Neighbor algorithm uses only one input pixel. 
Bilinear Interpolation uses the four nearest neighbors and 
calculates the weighted mean. Cubic Convolution uses a four by 
four matrix of pixels and calculates a type of weighted mean. 

The Nearest Neighbor algorithm is faster, but it can cause jagged 
edges or lines on the output image. The Cubic Convolution 
algorithm takes longer, but the result is much smoother. The 
MicroStation Descartes User’s Guide 8-5



8 Registering Images and Vector Data
Vector Resampling
Bilinear Interpolation is a compromise between the other two 
methods in both speed and image quality. 

The image resampling process can be independent of the process 
of building a model with control points. It is used with various 
other kinds of models such as translations, rotations, and scale 
changes, or even with a neutral model used only to cut images 
into pieces or to change the resolution of images. A set of 
standard models is provided with MicroStation Descartes. 

Image Resampling can also be done dynamically by choosing to 
use the transformation matrix of the image. This process is 
achieved simply by turning OFF the Create a New Image option 
from the Register dialog box.

Vector Resampling
The vector resampling process copies or moves the selected 
design elements through the transformation model. The design 
elements are selected from the master file or from any reference 
file by using a fence or a selection set. You control whether each 
design element type will be considered or ignored by the 
transformation model. This flexibility is useful when processing 
many elements. 

Register dialog box
Access the Register dialog box by choosing Register from the 
Utilities menu of Image Manager, or by selecting the Register 
dialog button from the Register tool box. The title bar of the 
Register dialog box displays the name of the current model. If a 
model is not open or if the current model has not been given a 
name, Untitled displays as the file name.

Register
dialog box
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Model Selected

Use the Model Selected option menu to select the type of model. 
The Actual Model field provides feedback on the actual model 
that can be calculated from currently captured control points. 

Below the menu bar of the dialog box and the Model Selection 
area, the control points used to control the building of a model 
are displayed. 

This information provides feedback to assist you in the building 
of a model with control points. It includes nine columns, which 
contain the number of a control point, its on/off status, the X and 
Y coordinates of this point in the base and uncorrected system, 
and the residuals of this point relative to the actual model.

✍ A model built with Register is a set of equations that define the 
correspondence between a point in the uncorrected system of 
coordinates and the equivalent point in the base system of 
coordinates. The open/close status of the Register dialog box is 
saved with a project. 

For each model in the following list, the minimum number of 
required control points is indicated:

✍ This parameter is saved with a project.

The Helmert model
The Helmert model, also called “rigid body,” performs a rotation 
and two translations (X and Y); however, no scaling is done. This 

Model     Min Pts

Helmert 2

Similitude 2

Affine-1 3

Projective 4

Thin Plate Spline 4

Polynomial-2 6

Polynomial-3 10
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model guarantees that the uncorrected data retains its proportions 
since the image or design elements are only moved and rotated. 

The Similitude model
The Similitude model performs a rotation, two translations (X and 
Y), and a scaling that has the same factor for the x- and y-axis. 
You can use a Similitude model to cut an image, to rotate an 
image, or to register two images with the same deformation 
relative to each other.

The Affine-1 model
The Affine-1 performs a rotation, two translations (X and Y), and 
applies a different scale factor for the x-, y-axis as well as a factor 
that changes the orthogonality of these axes. You can use the 
Affine-1 model to register a document that has very little 
deformation such as a scanned map. 

The Helmert model

The Similitude model

The Affine model
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The Projective model
The Projective model projects one plane into another plane. Like 
the Similitude and the Polynomial-1 models, it can be used to 
register a document that has very little deformation. For example, 
you can use it to register an aerial photograph that has little relief.

Thin Plate Spline model
The Thin Plate Spline model is based on a four variable 
mathematical algebraic formula. This means that this model 
requires at least four pair of control points to resolve the 
transformation model.

The benefits of this model resides in the fact that in order to 
compensate for the distortion caused by the rubbersheeting, 
instead of moving the control points to accommodate the residual 
values as in the traditional models, the Thin Plate Spline does not 
move the control points but instead, applies a correction 
elsewhere around the control points.

The trade-off is where it will most often be required to enter more 
control points than a traditional model. Control points will be 
positioned where the two systems (correct and uncorrected) do 
not aligned. Control points must be entered until the tanglement 
is satisfactory.

The Polynomial-2 and 3 models
The Polynomial-2 and 3 models are used to register documents 
that have moderate relief. However, they are not suitable for 
documents that contain accentuated relief. For example, you can 
use these models to register aerial photographs of a city with low 

The Projective model
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hills, but should not use these models to register aerial 
photographs of a mountainous region.

Actual Model

When there are not enough points to build the requested model, 
a provisional model, needing less points, is calculated to support 
the dynamic warping. 

When the minimum number of points is reached for the model 
requested, the Actual Model field displays the same name as the 
Selected Model option menu. If Dynamic Warping in Views 
Displaying Uncorrected Data is on and for any reason the model 
cannot be calculated with the present set of control points, the 
actual model shown is None. 

✍ If Dynamic Warping in Views Displaying Uncorrected Data is off, 
the actual model is None and the model is not updated after a 
control point is added, removed, or modified. 

Control Point #

The Control Point # column provides a sequential number for all 
control points entered. If a point is removed or if a new point is 
inserted between two existing points, the list renumbers.

On

The On column indicates whether the corresponding control 
point is on or off in the calculation of the actual model. A mark X 
indicates on. An empty space indicates that this point is turned 
off. Double-clicking a line of the list toggles the status of the 
corresponding control point between on and off. 

Base System X, Y

The X and Y columns under Base System display the coordinates 
of control points in the “base” system of coordinates. This system 
is the one into which the image is to be transformed after it is 
resampled by applying the model. 

The Polynomial models
8-10 MicroStation Descartes User’s Guide



Registering Images and Vector Data
Register dialog box
Uncorrected System X, Y 

The X and Y columns under Uncorrected System display the 
coordinates of control points in the “uncorrected” system of 
coordinates. 

Residuals X, Y, XY

The residual of a control point is the difference in location 
between the position where a control point is pinned on the 
uncorrected system as compared to the position it should be 
according to the actual model. When a model is built with the 
minimum number of control points, such as four points for the 
Projective, there is no residual (except for Helmert). This situation 
means that the model “trusts” you and puts the calculated point 
exactly where you pinned it on the uncorrected system. 

In fact, since the model has only the minimum number of points, 
it must make this assumption. As soon as an extra point is 
provided, it can compare the position you “guessed” with the 
position it calculates through the model. The difference between 
your “guess” and the calculated position is the residual. 

After a model is updated, the distance between the two 
corresponding marks reveals the residual for this pair of control 
points. As long as there is not an extra point, the model is exact, 
i.e., there is no residual (except for Helmert). Consequently, the 
two corresponding marks of each pair coincide.

The model supported is always the best fit to all points, when 
extra points are provided. Normally, when a control point is 
inconsistent with the others, its residual is greater. The residuals 
displayed in the Control Points List box are indications of points 
that can need adjustment. Turning off the point with the greatest 
residual normally improves the actual model. 

Residuals are distances. The three columns X, Y, and XY under 
Residuals indicate the X component, the Y component, and the 
magnitude (XY) of this distance. 

The Helmert model differs from the other models in respect to 
residuals. Because this model guarantees that the body of the 
uncorrected geometry stays rigid (without scale modification), the 
minimum number of control points usually generates residuals. In 
fact, with two control point pairs, the Helmert model moves and 
rotates the rigid body until the residuals are minimized. 

✍ If you turn off the only extra point, the new residuals are zero, 
but do not interpret this situation to mean that all points are 
satisfactory. There is not a residual when there is not an extra 
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control point (except for Helmert), independent of whether the 
points are appropriate.

On/Total 

The On/Total field displays the number of control points turned 
on over the total number of control points in the present list. 

Standard Deviation X, Y, XY

The Standard Deviation field displays the standard deviation for 
each set of residuals, one for each of the X, Y, and XY columns. 
The standard deviation values provide a good assessment of the 
model, and supplement the individual residuals. 

File menu
The File menu provides access to all necessary options to manage 
Register files. A Register file is used to save a transformation 
model for later use. The same functions (New, Open, Save, Save 
As) can also be accessed from the Register File tool box (page 
8-25). 

Edit menu
The Edit menu provides access to various tools and dialog boxes 
that are used to create or modify a model. Use these features to 
enter, modify, delete, highlight, or locate pairs of control points, 
and to identify the coordinate system to which the base data 
belongs. 

Edit > Add Control Points

Choose Add Control Points from the Edit menu to manually enter 
a pair of control points: (Base X, Base Y) and (Uncorrected X, 
Uncorrected Y). 

The On/Off check button toggles this pair of points between on 
or off. When on, the pair of points is taken into account for the 
calculation of the actual model and the corresponding marks 
display in the appropriate views. When off, this pair is suppressed 
and the marks are not shown. The points, however, can be turned 
on and used again by using the Modify Control Points dialog box. 

The new pair of points is always added after the previously 
selected line. If the new line is inserted before the last existing 
line, a renumbering of the following lines results. 

In some situations, this result might not be desirable. Consider 
when an analog hard copy map is used as the base data. In this 

Add Control Points 
dialog box
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case, the corresponding numbers would be written directly on the 
map. Any changes in the sequence of the numbers requires a 
renumbering of the points on the hard copy. To avoid 
renumbering in such cases, add points to the end of the list. 

✍ If you wish to toggle points on or off, double-click on the 
corresponding line. 

Edit > Modify Control Points

Choose Modify Control Points to modify the selected pair of 
control points by manually editing the following coordinates: 
(Base X, Base Y) and (Uncorrected X, Uncorrected Y). 

The On/Off check button toggles this pair of points between on 
or off. When on, a pair is taken into account for the calculation of 
the actual model and the corresponding marks display in the 
appropriate views. When off, this pair of points is suppressed and 
the marks are not displayed. Alternatively, double-click on the 
corresponding line to toggle points on or off. 

Edit > Delete Control Points

Choose Delete Control Points to remove the selected pair of 
control points from the list. 

W Removing a line from the list results in renumbering of all 
subsequent lines. 

Edit > Highlight Control Points

Choose Highlight Control Points to highlight the selected pair of 
control points. This feature uses the same color that MicroStation 
uses for highlighting elements when they are selected or 
identified. 

Edit > Locate Control Points

Choose Locate Control Points to locate and highlight the selected 
pair of control points in the center of views that are set for 
locating control points (See “View > Views Used to Locate Control 
Points” on page 8-16). This feature is useful for rapidly panning to 
the location of control points that are not visible. The highlighting 
is done with the same color that MicroStation uses for selecting 
elements. 

Edit > Coordinate System

Choose Coordinate System to enter a description for the 
coordinate system for the base data. The coordinate system 
identified here should be the one into which the image or vectors 

Modify Control Points 
dialog box
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will be transformed when it is resampled through the resulting 
model (the base coordinate system, i.e., the system to which the 
base vector data belongs). 

View menu
The View menu provides access to two toggles. One toggle 
controls the dynamic warping mechanism and the other, the 
display of control points. Dialog boxes are also provided to 
permit you to select the views which will display the dynamic 
warping of vector on uncorrected data and to select the views 
which will display the location of control points. A final dialog 
box is used to set the warping window. 

View > Dynamic Warping in Views Displaying 
Uncorrected Data

Dynamic Warping in Views Displaying Uncorrected Data permits 
you to control the dynamic warping mechanism inside each view 
where uncorrected data is displayed. 

If on, activates both the dynamic warping mechanism and the 
updating of the model. Each time that a pair of control points is 
entered or modified, the model is updated and the base vector 
data is warped. Base vector data is redrawn in views where 
uncorrected data is displayed, as an overlay to the uncorrected 
image(s) or vector(s), after being geometrically transformed 
through the actual model. 

If on and the model cannot be calculated with the present set of 
control points, the actual model displayed will be None and the 
dynamic warping will not be activated.

Turn off to inhibit both the dynamic warping mechanism and the 
updating of the model; then, the Actual Model shown will be 
None. 

The dynamic warping process can take time to complete. If you 
wish to abort it, press the <Esc> key. It is recommended that you 
use a small set of base vector data in order to accelerate the 
dynamic warping process. If using a small set of base vector data 
is not practical, set the warping window so that only the design 

Coordinate System
dialog box
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elements inside the area that you wish to register are warped (See 
“View > Warping Window” on page 8-17).

You can also control the warping process for each supported 
design element type (See “Settings > Elements Transformation” on 
page 8-19).

Panning in a view displaying uncorrected data is not 
recommended when dynamic warping is on. The warping of 
vectors takes some time and in some circumstances causes 
MicroStation to not trap the release of the data point button. 
When this happens, the panning does not stop and performance 
is seriously degraded. To prevent this situation, move the mouse 
to another window and click the Reset button (or press the <Esc> 
key and immediately click the Data button) several times until the 
panning ceases. 

✍ The status of this parameter is saved with a project. 

View > Views Displaying Uncorrected Data

Choose Views Displaying Uncorrected Data to identify the view 
or views where the uncorrected data (the images or vectors to be 
corrected) will be displayed. If Dynamic Warping in Views 
Displaying Uncorrected Data is on, the base vector data will be 
warped over the uncorrected data in the specified views. It will 
be redrawn after being geometrically transformed through the 
actual model. In all other views, vector data will behave normally. 
The check button Also Display Non-Warped Elements controls the 
presence or absence of non-warped elements (i.e., the original 
design elements without transformation) in uncorrected views. 

✍ The list of views that display uncorrected data and the status of 
the check button for displaying non-warped elements is saved 
with a project. 

View Displaying
Uncorrected Data

dialog box
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View > Views Used to Locate Control Points

Choose Views Used to Locate Control Points to identify the view 
or views where the Locate Control Points feature will be activated 
(See “Edit > Locate Control Points” on page 8-13). 

When the Auto Locate on Base Control Point Pinning toggle is on, 
the selected views will be automatically zoomed around a base 
control point just after it is pinned.

Use this feature when you want to refine the pinning of control 
points after you have done it approximately in a view with a 
smaller scale.

For example, use View 1 for a synoptic display of the whole 
image. Use View 2 as the detailed view where a zoom occurs 
automatically after a base control point is selected. Then, View 2 
should be selected in the Views Used To Locate Control Points 
dialog box.

Here is a typical procedure you can follow as an example.

➤ To use a synoptic view and a detailed view when pinning 
control points

1. Turn on View 2 in the Views Used To Locate Control Points 
dialog box. 

2. Turn on the Auto Locate on Base Control Point Pinning 
toggle.

3. Select the Place Control Points tool from the Register tool 
box.

4. Pin a base control point in View 1. View 2 automatically 
zooms around this point.

5. If the pinning of this point needs refinement, press the Reset 
button. That removes the last base control point and allows 
you to pin it again (in the zoomed view).

6. Pin the uncorrected control point and iterate the process from 
step 4.

Views Used to Locate
Control Points

dialog box
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✍ The list of views that are used to locate control points is saved 
with a project. 

View > Warping Window

Choose Warping Window to set the size of the warping window. 
The warping window is the extent in which the dynamic warping 
occurs if Dynamic Warping in Views Displaying Uncorrected Data 
from the View menu is on. You should set the size of the warping 
window if the extent of the design elements is larger than the area 
that you wish to register. If you choose this option, the time to 
warp the design elements is reduced since registration does not 
consider the elements outside of the warping window. 

✍ The status of this parameter is saved with a project. 

Use the option menu to choose the method to set the warping 
window. You may choose among the following options:

• No Extent Limits 

• Base Data Extent 

• Marks Extent

• User Specified Extent 

No Extent Limits sets no limits to the window (the default value). 

Base Data Extent sets the size of the warping window to that of 
the base data. You can adjust this size by using the Plus/Minus 
field. Entering a positive value increases the window by that 
percentage. Entering a negative value (with a minus sign) 
decreases the window by that percentage. The Base Data Extent 
updates when the Fit Active Design tool from the View Control 
palette is used. 

Marks Extent sets the size of the warping window to the extent of 
all open marks. You can adjust this size by using the Plus/Minus 
field; note that this option is not accessible unless you have input 
at least two marks. 

Warping Window
dialog box
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User Specified Extent lets you manually set the warping window 
in the Window group. 

Use the Origins and Dimension groups to manually enter the 
origin and the dimensions of the warping window. When Base 
Data Extent or Marks Extent are chosen from the option menu, 
these groups display the actual parameters that define the 
window. This window displays in the Views Displaying 
Uncorrected Data. 

View > Show Control Points

Show Control Points permits you to control the display of control 
point marks. 

If on, activates the display of the control points mechanism. Then, 
both control points for all pairs of points are displayed according 
to the selected colors (See “Settings > Colors for Control Points” 
on page 8-18). 

If off, suppresses the display of the control points mechanism. 

✍ The status of this parameter is saved with a project. 

Tools menu
The Tools menu of Register has two items:

• Choose Register to open the Register tool box (See page 
8-20).

• Choose Register File to open the Register File tool box (See 
page 8-25).

Settings menu
Use Register/Settings to set the colors of the symbols that are used 
to mark the control points, to toggle on or off the Warning When 
Renumbering option, or to access the Elements Transformation 
dialog box.

Settings > Colors for Control Points

Choose Colors for Control Points to set the colors for the symbols 
that are used to mark control points. Colors for the base control 
points mark and the uncorrected control points mark can be set 
independently. Next to each field where the color number is 
entered, the actual color corresponding to this number displays 
on a color button. You can also select the color with the color 
picker that pops up when you click the color button. 

Colors for Control 
Points dialog box
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✍ The color numbers for the marks are saved with a project.

Settings > Warning when Renumbering

Warning when Renumbering permits you to be warned when the 
list of control points is going to be renumbered. If a line is 
inserted or deleted before the last existing line in the control 
points list box, a renumbering of the next points results. 

If on, you are warned when a renumbering is about to occur. 

If off, you are not warned when a renumbering is about to occur. 

✍ To avoid renumbering, add points to the end of the list or turn a 
line off instead of deleting it. 

✍ The status of this parameter is saved with a project. 

Settings > Elements Transformation

Choose Elements Transformation to control which design element 
types are used for the dynamic warping process, the Copy Vectors 
command, and the Move Vectors command. To disable a specific 
design element type for the transformation process, select the 
None option for the appropriate option button. 

To enable a specific design element type, select the appropriate 
option for each design element type:

• All Coordinates

• Origin Only

• Stroking & All Coordinates

Elements Transformation
dialog box
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When All Coordinates is selected, the transformation model is 
applied to each (X,Y) coordinate of the element. 

When Origin Only is selected, the transformation model is 
applied only on the origin of the element. Others characteristics 
such as rotation angle, scale, and so forth are not modified. 

When Stroking & All Coordinates is selected, the transformation 
process modifies the original structure (i.e., center point, start 
angle, etc.) of the element. First, the element is stroked into a 
complex chain based on the specified Tolerance. Second, the 
transformation model is applied to each (X,Y) coordinate of the 
element. If the element does not transform as expected, adjust the 
Tolerance and repeat the process. 

✍ The status of supported design elements types and tolerances are 
saved with a project. 

Apply menu

Apply > To Image

Selecting To Image from the Apply menu opens the Resampling 
dialog box. Use the Resampling dialog box to set all parameters 
to resample an image through a geometric correction model built 
with Register.

Register tool box
This tool box provides access to tools you can use to place, 
move, or delete control points, to copy or move vectors through 
the actual model, or to prepare the resampling of the actual 
image. The last button opens the Register dialog box, but it does 
not need to be open to use the other tools. 

Place Control Points tool
Click the Place Control Points tool to place a new pair of control 
points. 

➤ To place control points

1. Select Place Control Points. 

2. Move the base control point mark to the desired place relative 
to the base data. 

Register tool box

Place Control
Points tool
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3. Pin the base control point mark. 

4. Move the uncorrected control point mark to the 
corresponding place on the uncorrected data. 

5. Pin the uncorrected control point mark. 

The resulting pair of control points then displays in the control 
points list box in the Register dialog box, with the status set to on. 
The pair is inserted just after the previously selected line and the 
new line is now selected (highlighted). If Dynamic Warping in 
Views Displaying Uncorrected Data is on, the model updates and 
the base vector data warping updates in the specified views. 

After a model is updated, the distance between the two 
corresponding marks reveals the residual for this pair of control 
points. As long as there are not extra points, the model is exact, 
i.e., there is no residual. Consequently, the two corresponding 
marks of each pair coincide. 

✍ Alternatively, you can pin any control point using the 
MicroStation XY= key-in. However, the tentative point mechanism 
is supported only with base data and not with uncorrected data.

Move Control Point tool
Click the Move Control Point tool to move an existing control 
point mark. 

➤ To move a control point

1. Select the Move Control Point tool.

2. Identify an existing control point mark (a base control point 
mark or an uncorrected control point mark). 

3. Accept the control point mark, or reject and retry. 

4. Move the control point mark to the desired place relative to 
the base or to the uncorrected data. 

5. Pin the control point mark. 

The line in the list box corresponding to the modified control 
point is now selected (highlighted) and is rewritten with the 
adjusted coordinates. If Dynamic Warping in Views Displaying 
Uncorrected Data is on, the model updates and the base vector 
data warping refreshes in the specified views. 

After a model is updated, the distance between the two 
corresponding marks indicates the residual for this pair of control 

Move Control
Point tool
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points. As long as there is no extra point, the model is exact, i.e., 
there is no residual. Consequently, the two corresponding marks 
of each pair coincide. 

✍ Only the points turned on can be modified with Move Control 
Point, since the points turned off are not marked. If you want to 
toggle points on or off, double-click on the corresponding line. 

Delete Control Points tool
Click the Delete Control Points tool to remove an existing pair of 
control points from the control points list box. 

➤ To remove (delete) a pair of control points

1. Select the Delete Control Points tool.

2. Identify an existing control point mark, whether it is a base 
control point mark or an uncorrected control point mark. 

3. Accept the control point mark, or reject and retry.

When the identified point is accepted, both marks that belong to 
this pair are deleted and the corresponding line is removed from 
the list box. The rest of the list is renumbered. If Dynamic 
Warping in Views Displaying Uncorrected Data is on, the model 
updates and the base vector data warping refreshes in the 
specified views.

After a model is updated, the distance between the two 
corresponding marks reflects the residual for this pair of control 
points. As long as there are no extra points, the model is exact, 
i.e., there is no residual. Consequently, the two corresponding 
marks of each pair coincide. 

✍ Only the points turned on can be deleted with the Delete Control 
Point tool, since the points turned off are not marked. If you want 
to toggle points on or off, double-click on the corresponding line. 

Copy Vector tool
Click the Copy Vector tool to copy vectors through the active 
transformation model. To control which design elements types 
should be affected (See “Settings > Elements Transformation” on 
page 8-19).

Delete Control
Points tool

Copy Vector tool
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➤ To apply the registration model to the vectors

1. Select the Copy Vector tool.

2. Choose the Direction of the transformation from the option 
button. Choices are Base to Uncorrected or Uncorrected to 
Base. 

3. Identify an element from the appropriate geometry (Base or 
Uncorrected) according to the selected Direction. 

4. Accept the element, or reject and retry. 

➤ To constrain the copy with a Fence or Selection Set

1. Select the Copy Vector tool.

2. Choose the Direction of the transformation from the option 
button. Choices are Base to Uncorrected or Uncorrected to 
Base. 

3. Draw a fence or build a Selection Set using the MicroStation 
tools. 

4. Select the Copy Vector tool again. 

5. You are asked to confirm the operation on all selected 
elements. Click OK to proceed or Cancel to cancel. 

If there is not an active transformation model, you are informed. 
In this circumstance, you should load a transformation model 
using the File/Open option from the Register dialog box or build 
one using the Control Points tools from the Register tool box. 

✍ When Dynamic Warping in Views Displaying Uncorrected Data is 
on and the toggle Also Display Non-Warped Elements is off, 
MicroStation Descartes prevents MicroStation from displaying 
original design vectors in Uncorrected Views. Consequently, the 
vectors transformed by the current command do not display. If 
this is the case when you select Copy Vectors, you are provided 
with the option to turn on the display of non-warped elements. 

Move Vector tool
Click the Move Vector tool to move vectors through the active 
transformation model. To control which design elements types 
should be supported (See “Settings > Elements Transformation” 
on page 8-19).Move Vector tool
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➤ To apply the registration model to the vectors

1. Select the Move Vector tool.

2. Choose the Direction of the transformation from the option 
button. Choices are Base to Uncorrected or Uncorrected to 
Base.

3. Identify an element from the appropriate geometry (Base or 
Uncorrected) according to the selected Direction (elements 
from a Reference file or locked elements cannot be 
identified). 

4. Accept the element, or reject and retry. 

➤ To constrain the move with a Fence or Selection Sets

1. Select the Move Vector tool.

2. Choose the Direction of the transformation from the option 
button. Choices are Base to Uncorrected or Uncorrected to 
Base. 

3. Draw a fence or build a Selection Set using the MicroStation 
tools. 

4. Select the Move Vector tool again. 

5. If at least one of the selected elements is in a reference file, 
you are informed that this operation is not possible. 
Otherwise, you are asked to confirm the operation on all 
selected elements. Locked elements are not moved. Click OK 
to proceed or Cancel to cancel. 

W If there is not an active transformation model, you are informed. 
In this circumstance, you should load a transformation model 
using the File/Open option from the Register dialog box or build 
one using the Control Points tools from the Register tool box. 

✍ When Dynamic Warping in Views Displaying Uncorrected Data is 
on and the toggle Also Display Non-Warped Elements is off, 
MicroStation Descartes prevents MicroStation from displaying 
original design vectors in Uncorrected Views. Consequently, the 
vectors transformed by the current command do not display. If 
this is the case when you select Move Vectors, you are provided 
with the option to turn on the display of non-warped elements. 
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Resample Image tool
Used to open the Resampling dialog box and quickly prepare a 
“fresh” resampling page by setting all parameters with default 
values:

• In the Job Manager group, the tool goes to the first free page.

• Input Image: the active image (if there is no active image 
when Resample Image is pressed, a message displays).

• Model: the current model, which is previously saved (if the 
current model is Untitled, it will be given the name of Input 
Image with the RGR extension).

• Output Image: the same name as Input Image, but with a 
sequential number (1, 2, 3, etc.) added at the end of the 
name. If the name already has eight characters, the last 
character(s) can be overwritten by the added digits.

• Window: All Input Image.

• In the Resampling group, all usual default are used.

You can edit any parameter, or keep all defaults and run the page 
at once.

Register Dialog tool
Used to open the Register dialog box (See page 8-6).

Register File tool box
The Register File tool box includes all necessary tools to manage 
Register files.

A Register file is used to save a transformation model for later use. 
When it is given a name, it is saved with the project. Any time 
unsaved changes are going to be lost, a warning message displays 
giving you an option to save the file.

New Register File tool
Used to create a new Register file. 

Resample Image tool

Register Dialog tool

Register File tool box
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➤ To create a new Register file

1. Select New Register File.

If a Register file is already open, it closes. The new file is not 
given a name until it is saved with the Save Register File tool.

Open Register File tool
Used to open a Register file. 

➤ To open an existing Register file

1. Select Open Register File.

2. Use the File Navigation dialog box to choose an existing file.

If a Register file is already open, it is first closed.

Save Register File tool
Used to save a Register file. 

➤ To save an unnamed Register file

1. Select Save Register File.

2. Use the File Navigation dialog box to name the file.

➤ To save a Register file already named

1. Select Save Register File.

The file will be saved with the same name.

Register Dialog tool
Used to open the Register dialog box (See page 8-6).

New Register File tool

Open Register File tool

Save Register File tool

Register Dialog tool
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Resampling File tool box
The Resampling File tool box includes all necessary tools to 
manage Resampling files (RSP files). A Resampling file is used to 
save a schedule of images to be resampled. It can be opened later 
and be edited or batch processed. The same functions can also be 
accessed from the File menu of Resampling dialog box. 

Any time unsaved changes are going to be lost, a warning 
message displays giving you the option to save the file.

New Resampling File tool
Used to create a new Resampling file.

➤ To create a new Resampling file

1. Select the New Resampling File tool.

If a Resampling file is already open, it closes. The new file is 
not given a name until it is saved with the Save Resampling 
File tool.

Open Resampling File tool
Used to open a Resampling file 

➤ To open an existing Resampling file

1. Select the Open Resampling File tool.

2. Use the File Navigation dialog box to choose an existing file.

If a Resampling file is already open, it first closes.

Save Resampling File tool
Used to save a Resampling file.

➤ To save an unnamed Resampling file

1. Select the Save Resampling File tool.

2. Use the File Navigation dialog box to name the file.

➤ To save a Resampling file already named

1. Select the Save Resampling File tool.

The file will be saved with the same name.

Resampling File tool box

New Resampling File tool

Open Resampling 
File tool

Save Resampling File tool
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Resampling Dialog tool
Used to open the Resampling dialog box (See page 8-28).

Resampling dialog box
The Resampling dialog box is used to apply a geometric 
correction model to an uncorrected image. The input data is 
transformed into an output data set that belongs to the base 
coordinate system, directly compatible with the base vector data 
that was used to create the model. Choose To Image from the 
Apply menu of the Register dialog box to access the Resampling 
dialog box.

Create a new image
Used to choose whether you would like to actually resample the 
image or simply use the transformation matrix to apply your 
changes.

The toggle is automatically checked when the Resampling dialog 
box opens, but when a Helmert, Similitude, or Affine model is 
selected, the toggle is automatically unchecked but remains 
enabled. When a Projective or Polynomial model is selected, the 
toggle is checked and disabled, since the transformation matrix 
does not support these models.

✍ Because the transformation matrix is a new addition to 
MicroStation Descartes, Register operations performed solely with 
the transformation matrix will not appear if the file is opened in 
MicroStation Descartes 6.0. If you plan to use an image in a 
previous version of MicroStation Descartes and would like it 
transformed, you may wish to resample the image at this time.

Resampling Dialog tool

Resampling dialog box
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✍ Only file formats which support a transformation matrix will 
maintain mirroring operations stored in the transformation matrix. 
For all file formats without a transformation matrix, such as 
standard TIFF or BMP files, MicroStation Descartes adds a sister 
file (hgr or worldfile). However, if this TIFF or BMP are opened in 
an application where worldfiles are not supported, the 
information in the transformation matrix will not be applied to the 
image. If you plan to use a file format which does not support a 
transformation matrix in another application, you may wish to 
select Create A New Image and resample the image at this time.

If you decide to use a file format that does not support a 
transformation matrix, it is possible to resample the image using 
its own transformation matrix. In order to do this, simply leave 
the Model: field empty and resample. You can also resample a file 
with its own transformation matrix by using Save As or Batch 
Convert.

Input Image field
The Input Image field displays the name of the input image file. 
Click the Select button to open the File Selection dialog box. This 
dialog box is used to select an existing image file for resampling. 

Model field
The Model field displays the name of the transformation model 
file. If there is an active model in the Register dialog box, it 
displays in this field. You are prompted to save it if you have 
made changes since the last save.

To change the current selection, click the Select button to open 
the File Selection dialog box. This dialog box is used to select an 
existing RGR transformation model file for the resampling 
process. 

W A model is always connected to the input image through the 
following parameters found in the header: Origin, Dimensions, 
and Pixel Size. If you change any of them, the model is no longer 
valid for this image. 

Output Image field
The Output Image field displays the name of the output image 
file. Click the Select button to open the File Selection dialog box. 
This dialog box lets you specify the name of the image file that 
will be created by resampling. 
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All Input Image
Use All Input Image to define the output window in such a 
manner that it covers the input image entirely. 

All Input Image/Input
Click the Input button with the All Input Image option to open 
the Input Image Window dialog box. The name of the input 
image displays in the title bar. No parameter of this dialog box 
can be edited. This dialog box is used only to display the actual 
window of the input image, as well as with content reflected in 
the header of this image. 

All Input Image/Output
Click the Output button with the All Input Image option to open 
the Output Window dialog box. The name of the output image 
displays in the title bar.

If an output image is not selected, Untitled is displayed. No 
window parameter (origin or dimension) of this dialog box can 
be edited. The dialog box is used only to display the window of 
the output image.

The output window is calculated automatically to cover the entire 
input image. Only the description of the output image and the 
pixel size can be entered using the Output Window dialog box. 
This information is used to prepare the header of the output 
image.

Specified through Input
Use the Specified through Input option to define the output 
window through another window which is set in the input system 
of coordinates.

Specified Through Input/Input
Click the Input button to specify the origin and the dimensions of 
the input window. The name of the input image and other 
information is displayed, but cannot be edited. When the output 
window is set through the input space, it adjusts accordingly and 
in such a manner that it covers the input window entirely. 

Specified Through Input/Output
Click the Output button to open the Output Window dialog box. 
The name of the output image displays in the title bar. If an image 
is not selected, Untitled is displayed. No window parameter 
(origin or the dimensions) of this dialog box can be edited. The 
dialog box is used only to display the window of the target output 
image. The values are calculated automatically to cover the input 
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window entirely. Only the description of the output image and 
the pixel size can be entered using the Output Window dialog 
box. This information is used to prepare the header of the output 
image.

Warping Window
Use the Warping Window option to define the output window by 
setting its equivalent to the warping window defined with the 
Warping Window dialog box.

✍ The Input and Output buttons behave like the All Input Image 
option (See page 8-30).

Specified in Output Space
Use the Specified in Output Space option to define the output 
window by setting it directly in the output space.

✍ With the Specified in Output Space option, the Input button is not 
accessible.

Specified in Output Space/Output
Click Output button with the Specified in Output Space option to 
open the Output Window dialog box. The name of the output 
image displays in the title bar. If an image is not selected, Untitled 
is displayed. This dialog box can be used to specify the true 
origin and dimensions of the output window. All other fields can 
also be entered or edited in order to prepare the header of the 
output image.

Type
Three algorithms can be chosen through the Type option menu:

• Nearest Neighbor

• Bilinear Interpolation

• Cubic Convolution

The Nearest Neighbor algorithm uses only one input pixel. 
Bilinear Interpolation uses the four nearest neighbors and 
calculates the weighted mean. Cubic Convolution uses a four by 
four matrix of pixels and calculates a type of weighted mean.

The Nearest Neighbor algorithm is faster, but it can cause jagged 
edges or lines on the output image. Cubic Convolution usually 
produces the best results, but the calculation requires more time 
to process than the other algorithms. The Bilinear Interpolation 
provides a compromise in quality of output and time to process.
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✍ With a gray scale image, all three options are offered. With a color 
image, only Nearest Neighbor is available.

Pixel Size
Use the Pixel Size field to enter the size of pixels for the output 
image. Only square pixels are supported; the entered value is 
taken as the X and Y dimensions of the pixels.

✍ Except for special effects, it is recommended that you set the 
pixel size of the output image equal to or close to the pixel size of 
the input image.

Background Color
The background color is a color number or index used to 
initialize the output image file prior to resampling. Therefore, any 
part of the output image which is not covered by resampled 
pixels remains this color. You can enter the background color 
index into the Background Color field. You can also select the 
color with the color picker that pops up when you click the color 
button. 

Color Range
The Color Range restricts the resampled pixels colors to be within 
a specific interval. For each resampled pixel, a color number 
smaller than the minimum receives the minimum color value and 
a color greater than the maximum receives the maximum color 
value. This feature could be used, for example, to ensure that the 
pixels of the image foreground does not use the same color value 
as the background color. 

Data Compression
Use the Data Compression option menu to choose among the 
following data compression options:

None Choose None to resample an image as a file without com-
pression. The exact file size is provided by the File Size 
indicator. 

Deflate Applies the Deflate compression algorithm to the HMR 
output image. No data is lost in this compression scheme. 
The Deflate option is available for 8 bit format images.

PackBits PackBits is available only for 1 bit format images. The out-
put files are compressed without data loss. The File Size 
indicator displays the maximum size of your output file. 
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Estimated File Size field
The Estimated File Size field provides an estimate of the projected 
size of the image file that would be created without compression. 
If compression is selected, the resulting file size cannot be 
estimated precisely because it can vary substantially with the 
image content. 

Page Up/Page Down
In Register, each file submitted for resampling has each of the 
resampling parameters displayed in the Job Manager group 
boxes. The values for each file can be viewed and edited by 
scrolling the individual pages. Use the Page Up or Page Down 
buttons to move from the current page to the previous or next 
page. If the Page Down button is pressed when there is not an 
additional page, a prompt asks you if you wish to open a new 
page. If you open a new page, it is created with the default 
parameters. 

Delete Page
Click the Delete Page button to delete the current page and all of 
its parameters. This page is removed and all following pages are 
renumbered. If the first and only page is deleted, it remains open 
and the parameters are established with the default settings. 

Delete All
Click the Delete All button to delete all pages but the first page. 
The parameters of the first page are established with the default 
settings. 

Run Page
Click the Run Page button to start the resampling process 
according to the parameters of the current page. Before a job is 
run, the available disk space is checked based on the estimated 
file size. If the Data Compression is None and there is not enough 
space, the resampling job is not run and you are notified by a 
warning box.

CCITT3 Often spoken of as Group III compression, is available 
only for 1 bit format images. The output files are com-
pressed without data loss. The File Size indicator displays 
the maximum size of output file. 

CCITT4 Often spoken of as Group IV compression, is available 
only for 1 bit format images. The output files are com-
pressed without data loss. The File Size indicator displays 
the maximum size of output file. 
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While the batch program is running, a Progress window provides 
feedback. After the job is completed or terminated, a Report line 
displays the result of the processing corresponding to this page. It 
indicates whether the processing was successful and, if not, it 
declares what error or event caused it to be unsuccessful. 

Run All
Click the Run All button to start the resampling process of all 
pages, one at a time, according to the parameters of each page. 
While the batch program is running, a Progress window provides 
feedback. For each page, a Report line displays the result of the 
batch processing job corresponding to this page. It indicates 
whether the processing of this job was successful and, if not, it 
declares what error or event caused it to be unsuccessful. 

Page
The Page field indicates the number of the current page and the 
total number of pages prepared. 

Report
For each page, a Report line displays the result of the processing 
that corresponds to this page. It indicates whether the processing 
was successful and, if not, it declares what error or event caused 
it to be unsuccessful. 

File menu
The File menu of Resampling provides access to all necessary 
options to manage Resampling files (RSP files). A Resampling file 
is used to save a schedule of images to be resampled. It can be 
opened later and be batch processed. The same functions (New, 
Open, Save, Save As) can also be accessed from the Resampling 
File tool box (See page 8-27). 

Tools menu
Choose Resampling File from the Tools menu of Resampling to 
open the Resampling File tool box (See page 8-27).
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