
4 Navigating MicroStation Descartes
This chapter describes how to load and start MicroStation Descartes and how 
to navigate through the user interface to access all functions or features such as 
dialog boxes, tool boxes, tools, or any specific item in a menu. 
Loading and Starting MicroStation Descartes
There are several ways to load and start MicroStation Descartes.

The way you choose to load MicroStation Descartes determines if 
its user interface will be more or less integrated with the 
MicroStation’s interface.

For instance, here are two procedures you can follow to start 
MicroStation Descartes:

• The first one minimally integrates the MicroStation Descartes 
user interface with the MicroStation user interface.

• The second one fully integrates the MicroStation Descartes 
user interface with the MicroStation user interface.

➤ To load MicroStation Descartes with a key-in and have 
minimal integration

1. Start MicroStation as usual (with a workspace such as 
“default”).

2. From the Utilities menu of MicroStation, choose Key-in to 
open the Key-in window.

3. In the Key-in window’s key-in field, type MDL LOAD 
DCARTES.

The Image Manager dialog box opens and the item 
Descartes - Image Manager is then added to the File menu of 
MicroStation.

You have a minimal integration. No other item is added to the 
MicroStation menu. The Image Manager dialog box gives access 
to all of the features of MicroStation Descartes. The MicroStation 
Descartes interface can be accessed only from Image Manager. 
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Loading and Starting MicroStation Descartes
See “Image Manager Menu Structure” on page 4-3, for a complete 
description of this menu structure.

➤ To load MicroStation Descartes with the “dcartes” 
workspace and have a full integration

1. Start MicroStation.

2. From the Workspace option menu of MicroStation Manager, 
choose “dcartes.”

3. Click OK.

You have a full integration. The item Descartes - Image Manager 
is added to the File menu of MicroStation, and all menu items of 
MicroStation Descartes are integrated in the appropriate menus of 
MicroStation.

There is a one-to-one equivalence between the items of the 
“dcartes” workspace, which are spread among the items of the 
MicroStation menus, and the Image Manager menu items (except 
the names of the four last images that appear in the File menu of 
Image Manager).

With the “dcartes” workspace, items can have a more explicit 
name (for example, Image Project instead of Project), or be at a 
different menu level (for example, File > Open > Image instead of 
File > Open). All items of all menus of Image Manager are 
described in this chapter (for example, see “Image Manager File 
menu” on page 4-7). With each description, a note explicitly tells 
the name and level of the equivalent item in the MicroStation 
menu.

You can also develop other ways of loading and starting 
MicroStation Descartes by creating workspaces on your own. You 
can take “dcartes” as a template and make as many changes as 
you want and save it under a new name. See “Customizing the 
Workspace” on page 18-3, for more information on customizing a 
workspace.

✍ With this workspace, MicroStation Descartes will be loaded 
automatically as a MS_DGNAPPS. To disable it, you must delete 
the name dcartes from the list of applications loaded at startup, 
located in the MicroStation configuration variable MS_DGNAPPS. 
If you disable it, you will need to type in “MDL LOAD DCARTES” 
to load the application.
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Image Manager Menu Structure
When you choose Descartes - Image Manager in the File menu of 
MicroStation, the Image Manager dialog box displays. The title bar 
displays the name of the present project in the form: Image 
Manager - Project Filename. If a project is not open or if the 
present project has not been given a name, Untitled is displayed 
as the file name.

The menu bar of Image Manager provides access to seven menus:

• File

• Edit

• Display

• Settings

• Tools

• Utilities

• Help

The contents of each menu is listed as follows.

Image Manager dialog box
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File
• New

• Open

• Close

• Close All

• Save

• Save As

• Properties >

• Project >

• Batch Conversion

• Print/Plot

• Binary Print/Plot >

• Last image

• Second last image

• Third last image

• Fourth last image

Properties >
• General

• Color Table

• Location

• Histogram

Project >
• New

• Open

• Save

• Save As

• Attach

• Detach

• Import Raster Reference

• Export Raster Reference

• Copy Project...

• Publish to Viewer
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Edit
• Set Active Image

• Undo

• Redo

• Copy

• Paste

• Paste To Design

Display
• Bring to Front

• Send to Back

• Images On

• Images Off

• Fit Images To View

• Fit All Images To View

• Actual Resolution (1:1)

• Apply to

• Apply to All

• Contrast/Brightness

Settings
• Copy/Paste

• Raster Snap on Tentative

• Image Servers...

• Preferences > 

• Project

• Undo

• Stamp Vector

• Vectorize

• Lock

• View Image Attributes
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Preferences > 
• Memory

• Color Distribution

• MSI Client Cache

Tools
• Image Main

• Prepare

• Edit

• Convert To Vector

• Clean Up

• Color Filter 

• Color Filter File

• Copy/Paste

• Erase 

• Image Control

• Image File 

• Image Transform

• Local Transform

• Mosaic

• Node File

• Paint

• Register

• Register File

• Resampling File

• Stamp Vector

• Text/Cells

• Theme

• Theme File

• Undo/Redo 

• Vectorize
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Utilities
• Color Compression

• Color Filter

• Contrast Stretch

• Density Slicing

• Image Channels

• Transparent Colors

• Translucent Colors

• Register

• Theme Styler

Help
• Contents

• About Descartes

Image Manager File menu
The Image Manager File menu gives access to all features for 
managing Image files and Project files, to batch conversion of 
images from or to foreign formats, or to printing and plotting 
capabilities. Finally, the four most recently opened images are 
directly accessible.

✍ If you loaded MicroStation Descartes with the “dcartes” 
workspace, the same items (except the four last images) are 
spread among the items of the MicroStation File menu. There, 
items can have a more explicit name (for example: Image Project 
instead of Project), or be at a different menu level (for example: 
File > Open > Image instead of File > Open). In the descriptions 
that follow, a note explicitly tells the name and level of each item 
in the MicroStation menu.

New (Image)
Used to open the New Image dialog box. See “New Image dialog 
box” on page 5-17.

✍ In the MicroStation menu with the “dcartes” workspace, choose 
File > New > Image. This is equivalent to selecting the New 
Image tool from the Image File tool box. 
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Open (Images)
Used to open the Open Image dialog box. See “Open Images 
dialog box” on page 5-19.

✍ In the MicroStation menu with the “dcartes” workspace, choose 
File > Open > Image. This is equivalent to selecting the Open 
Images tool from the Image File tool box. In this dialog box, a 
toggle button appears immediately under the List Files of Type 
option button. This toggle button is Add Converted Types to Files 
List. When this toggle is off (default value), only the HMR format 
is shown in the list of files. 

We recommend using the HMR format for best performance at all 
levels. To convert files permanently to the HMR format, use the 
Batch Conversion tool. When this toggle is on, other supported 
formats will be added to the List Files of Type option button. 
These file types will be converted automatically to an optimized 
temporary file at load time, causing an initial delay, but ensuring 
optimal display performances during the working session.

Close (Images)
Used to close the selected images in the active view. See “Closing 
images” on page 5-16.

✍ In the MicroStation menu with the “dcartes” workspace, choose 
File > Close > Image.

Close All (Images)
Used to close all images in all views. See “Closing images” on 
page 5-16.

✍ In the MicroStation menu with the “dcartes” workspace, choose 
File > Close > All Images.

Save 
Used to save changes to the active image. See “Saving images” on 
page 5-15.

✍ In the MicroStation menu with the “dcartes” workspace, choose 
File > Save Image. This is equivalent to selecting the Save Image 
tool from the Image File tool box. 
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Save (Image) As
Used to open the Save As dialog box and to save the active image 
under a new name. See “Saving images” on page 5-15.

✍ In the MicroStation menu with the “dcartes” workspace, choose 
File > Save As > Image.

(Image) Properties
Gives access to the Image Properties sub menu.

✍ In the MicroStation menu with the “dcartes” workspace, choose 
File > Image Properties.

(Image) Properties > General
Used to open the General Image Properties dialog box. See 
“Inspecting or editing image properties” on page 5-12.

✍ In the MicroStation menu with the “dcartes” workspace, choose 
File > Image Properties > General.

(Image) Properties > Color Table
Used to open the Color Table Editor dialog box. See “Color Table 
Editor dialog box” on page 6-5.

✍ In the MicroStation menu with the “dcartes” workspace, choose 
File > Image Properties > Color Table.

(Image) Properties > Location
Used to open the Image Location Editor dialog box. See “Image 
Location Editor dialog box” on page 5-27.

✍ In the MicroStation menu with the “dcartes” workspace, choose 
File > Image Properties > Location.

(Image) Properties > Histogram
Used to open the Histogram Display dialog box. See “Histogram 
Display dialog box” on page 6-2.
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✍ In the MicroStation menu with the “dcartes” workspace, choose 
File > Image Properties > Histogram.

(Image) Project
Gives access to the Image Project sub menu. See “Image Manager 
File > Project sub menu” on page 4-11.

✍ In the MicroStation menu with the “dcartes” workspace, choose 
File > Image Project.

Batch Conversion
Used to open the Batch Conversion dialog box. See “Batch 
Conversion dialog box” on page 15-1.

✍ In the MicroStation menu with the “dcartes” workspace, choose 
File > Batch Conversion.

Print/Plot
Used to open the MicroStation Plot dialog box. See “Descartes 
Plotting dialog boxes” on page 17-11.

✍ In the MicroStation menu with the “dcartes” workspace, choose 
File > Print/Plot. This is equivalent to selecting the Print Images 
tool from the Image File tool box. 

Last image name 
Used to open the last image.

✍ This has no equivalent item in the MicroStation menu.

Second last image name
Used to open the second last image.

✍ This has no equivalent item in the MicroStation menu.

Third last image name
Used to open the third last image.
4-10 MicroStation Descartes User’s Guide



Navigating MicroStation Descartes
Fourth last image name
✍ This has no equivalent item in the MicroStation menu.

Fourth last image name
Used to open the fourth last image.

✍ This has no equivalent item in the MicroStation menu.

Image Manager File > Project sub menu

New (Project)
Used to close the current project and to start a new one by 
clearing all project settings and resetting all relevant parameters to 
default values. The Image Manager dialog box closes.

The new project is given the temporary name Untitled which is 
displayed in the title bar of the Image Manager dialog box (when 
reopened). See “MicroStation Descartes Projects” on page 3-4.

✍ In the MicroStation menu with the “dcartes” workspace, choose 
File > Image Project > New.

Open (Project)
Used to close the current project and to open an existing one with 
the Open Project dialog box. 

The name of the open project displays in the title bar of the 
Image Manager dialog box. See “MicroStation Descartes Projects” 
on page 3-4.

✍ In the MicroStation menu with the “dcartes” workspace, choose 
File > Image Project > Open.

Save (Project)
Used to save changes to the current Project file, whose name is 
displayed in the title bar of the Image Manager dialog box. If the 
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temporary name Untitled is displayed in the title bar of the Image 
Manager dialog box, then choosing Save does the following:

• If Auto Save and Attach is off (see “Attaching a project to a 
design file” on page 3-7), the Save Project dialog box opens 
and you choose a name and a path.

• If Auto Save and Attach is on, the Project file is given the 
same name as the design file, with the extension PRJ.

See “MicroStation Descartes Projects” on page 3-4.

✍ In the MicroStation menu with the “dcartes” workspace, choose 
File > Image Project > Save.

Save (Project) As
Used to save the current project into a Project file with the Save 
Project dialog box. See “MicroStation Descartes Projects” on page 
3-4.

✍ In the MicroStation menu with the “dcartes” workspace, choose 
File > Image Project > Save As.

Attach (Project)
Used to attach the current project to the active design file. See 
“MicroStation Descartes Projects” on page 3-4.

✍ In the MicroStation menu with the “dcartes” workspace, choose 
File > Image Project > Attach.

Detach (Project)
Used to detach the current project from the active design file. See 
“MicroStation Descartes Projects” on page 3-4.

✍ In the MicroStation menu with the “dcartes” workspace, choose 
File > Image Project > Detach.

Import Raster Reference
Detaches all raster reference files from the design file and attaches 
them to the project. See “Supporting Raster Reference Files” on 
page 3-13.
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✍ In the MicroStation menu with the “dcartes” workspace, choose 
File > Image Project > Import Raster Reference.

Export Raster Reference
Detaches images from the project and attaches them directly to 
the design file as raster reference files. See “Supporting Raster 
Reference Files” on page 3-13.

✍ In the MicroStation menu with the “dcartes” workspace, choose 
File > Image Project > Export Raster Reference.

Image Manager Edit menu
The Image Manager Edit menu gives access to features for 
choosing the active image, for undoing or redoing changes to 
images, or copying and pasting images or pieces of images.

✍ If you loaded MicroStation Descartes with the “dcartes” 
workspace, the same items are spread among the items of the 
MicroStation Edit menu. There, items can have a more explicit 
name (for example, Image Undo instead of Undo). In the 
descriptions that follow, a note explicitly tells the name of each 
item in the MicroStation menu.

Set Active Image
Used to make the selected image the active image. See “Choosing 
the active image” on page 5-8.

✍ In the MicroStation menu with the “dcartes” workspace, choose 
Edit > Select Images/Set Active Image. This is equivalent to 
selecting the Select Images/Active Image tool from the Image 
Control tool box.

(Image) Undo 
Used to undo the last raster editing operation. Undo reverts the 
image to its state before the previous operation was executed. 
Each prior operation can be undone sequentially. See “Undo tool 
box” on page 11-24.
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✍ In the MicroStation menu with the “dcartes” workspace, choose 
Edit > Image Undo. This is equivalent to selecting the Undo 
Image tool from the Undo tool box.

(Image) Redo
Redo reverts the image to its state prior to the last undo. Prior 
Undo operations can be redone sequentially. See “Undo tool box” 
on page 11-24.

✍ In the MicroStation menu with the “dcartes” workspace, choose 
Edit > Image Redo. This is equivalent to selecting the Redo tool 
from the Undo tool box.

(Image) Copy 
Used to copy an area from the active image to the clipboard. See 
“Copy/Paste tool box” on page 11-23.

✍ In the MicroStation menu with the “dcartes” workspace, choose 
Edit > Image Copy. This is equivalent to selecting the Copy Image 
Area tool from the Copy/Paste tool box.

(Image) Paste 
Used to paste the image area in the clipboard at a specified 
location in the active image. See “Copy/Paste tool box” on page 
11-23.

✍ In the MicroStation menu with the “dcartes” workspace, choose 
Edit > Image Paste. This is equivalent to selecting the Paste Image 
Area tool from the Copy/Paste tool box.

(Image) Paste to Design
Used to paste the image area in the clipboard as a design raster 
element, anywhere on the design. See “Copy/Paste tool box” on 
page 11-23.

✍ In the MicroStation menu with the “dcartes” workspace, choose 
Edit > Image Paste to Design. This is equivalent to selecting the 
Paste Image Area as Design Element tool from the Copy/Paste 
tool box.
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Image Manager Display menu
With the Image Manager Display menu, you control a list of 
images in each view and decide how to display these images. You 
can turn on or off individual images, control how they are 
stacked, and change the scale to display all images or parts of 
images.

✍ If you loaded MicroStation Descartes with the “dcartes” 
workspace, the same items are found in a sub menu under the 
item Image Display of the MicroStation File menu. In the 
descriptions that follow, a note explicitly tells the name of each 
item in the MicroStation menu.

Bring to Front 
Moves the selected images forward and displays these images on 
top of all other overlapping images in the specified view. See 
“Image Control tool box” on page 5-33.

✍ In the MicroStation menu with the “dcartes” workspace, choose 
File > Image Display > Bring to Front. This is equivalent to 
selecting the Bring Images to Front tool from the Image Control 
tool box.

Send to Back 
Moves the selected images backward and displays these images 
under all other overlapping images in the specified view. See 
“Image Control tool box” on page 5-33.

✍ In the MicroStation menu with the “dcartes” workspace, choose 
File > Image Display > Send to Back. This is equivalent to 
selecting the Send Images to Back tool from the Image Control 
tool box.

Images On
Used to turn on the selected images in the specified view.

✍ In the MicroStation menu with the “dcartes” workspace, choose 
File > Image Display > Images On.
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Images Off
Used to turn off the selected images in the specified view.

✍ In the MicroStation menu with the “dcartes” workspace, choose 
File > Image Display > Images Off.

Fit Images to View 
Displays the selected images from the list associated with the 
view within the display window for the specified view. See 
“Image Control tool box” on page 5-33.

✍ In the MicroStation menu with the “dcartes” workspace, choose 
File > Image Display > Fit Images to View. This is equivalent to 
selecting the Fit Images to View tool from the Image Control tool 
box.

Fit All Images to View
Displays all visible images from the list associated with the view 
within the display window for the specified view. See “Image 
Control tool box” on page 5-33.

✍ In the MicroStation menu with the “dcartes” workspace, choose 
File > Image Display > Fit All Images to View. This is equivalent 
to selecting the Fit All Images to View tool from the Image 
Control tool box.

Actual Resolution (1:1)
Displays the selected image and adjusts zoom factor for optimal 
viewing resolution, where one pixel in the image is equal to one 
pixel on the display. The other images are adjusted accordingly. 
See “Image Control tool box” on page 5-33.

✍ In the MicroStation menu with the “dcartes” workspace, choose 
File > Image Display > Actual Resolution (1:1). This is equivalent 
to selecting the Actual Image Resolution (1:1) tool from the Image 
Control tool box.
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Apply to
Used to copy the list of images of the present view into the list of 
the other views specified in the Apply to dialog box. See 
“Applying a list of images to other views” on page 5-5.

✍ In the MicroStation menu with the “dcartes” workspace, choose 
File > Image Display > Apply to.

Apply to All
Used to copy the list of images of the present view into the lists of 
all other open views. See “Applying a list of images to other 
views” on page 5-5.

✍ In the MicroStation menu with the “dcartes” workspace, choose 
File > Image Display > Apply to All.

Contrast/Brightness
Used to open the Contrast/Brightness dialog box. See “Contrast/
Brightness controls” on page 5-5.

✍ In the MicroStation menu with the “dcartes” workspace, choose 
Workspace > Image Display > Contrast/Brightness.

Image Manager Settings menu
The Image Manager Settings menu gives access to various settings 
boxes.

✍ If you loaded MicroStation Descartes with the “dcartes” 
workspace, the same items are integrated among the items of the 
MicroStation Settings or Workspace menus, where they can be on 
a different menu level. In the descriptions that follow, a note 
explicitly tells the name and the level of each item in the 
MicroStation menu.

Copy/Paste
Used to open the Copy Image Settings dialog box. See “Copy 
Image Settings dialog box” on page 11-24.
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✍ In the MicroStation menu with the “dcartes” workspace, choose 
Settings > Image > Copy/Paste. This is equivalent to selecting the 
Copy Image Settings tool from the Copy/Paste tool box.

Raster Snap on Tentative
Used to open the Raster Snap on Tentative dialog box and specify 
how the Raster Snap on Tentative mechanism can be used with 
any appropriate command from MicroStation, MicroStation 
Descartes, or third party applications. This mechanism applies to 
the active image only.

Entity

The Entity option menu lets you choose whether to snap at the 
center of the raster lines (Line), or on the edges of the raster 
objects or lines (Outline), or not to snap at all (None).

Filter 

Used to select a color filter from the open Color Filter file, to 
determine the raster objects or lines on which to snap. If the 
active image is a two-color image, there are two options instead 
of a color filter: Foreground and Background.

✍ In the MicroStation menu with the “dcartes” workspace, choose 
Settings > Image > Raster Snap on Tentative.

Preferences > Memory
Used to open the Memory Allocation dialog box. See “Memory 
Allocation dialog box” on page 3-20.

✍ In the MicroStation menu with the “dcartes” workspace, choose 
Workspace > Image Preferences > Memory.

Preferences > Color Distribution
Used to open the Color Distribution dialog box. See “Color 
Distribution dialog box - MicroStation 95 and SE” on page 3-22.

✍ In the MicroStation menu with the “dcartes” workspace, choose 
Workspace > Image Preferences > Color Distribution.
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Project
Used to open the Project Settings dialog box. See “Attaching a 
project to a design file” on page 3-7.

✍ In the MicroStation menu with the “dcartes” workspace, choose 
Settings > Image > Project.

Undo
Used to open the Undo Image Settings dialog box. See “Undo 
Image Settings dialog box” on page 11-25.

✍ In the MicroStation menu with the “dcartes” workspace, choose 
Settings > Image > Undo. This is equivalent to selecting the Undo 
Image Settings tool from the Undo tool box.

Stamp Vector
Used to open the Stamp Vector Settings dialog box. See “Stamp 
Vector Settings dialog box” on page 11-18.

✍ In the MicroStation menu with the “dcartes” workspace, choose 
Settings > Image > Stamp Vector. This is equivalent to selecting 
the Stamp Vector Settings tool from the Stamp Vector tool box.

Vectorize
Used to open the Vectorize Settings dialog box. See “Vectorize 
Settings dialog box” on page 13-30.

✍ In the MicroStation menu with the “dcartes” workspace, choose 
Settings > Image > Vectorize. This is equivalent to selecting the 
Vectorize Settings tool from the Vectorize tool box.

Lock
Used to open the Image Lock dialog box.

Image Lock
dialog box
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This dialog box is an alternate access to the Automatic Vector 
Stamping toggle. (See “Stamp Vector Settings dialog box” on page 
11-18.)

✍ In the MicroStation menu with the “dcartes” workspace, choose 
Settings > Image > Lock.

View Image Attributes
Used to open the View Image Attributes dialog box. See “View 
Image Attributes dialog box” on page 5-30.

✍ In the MicroStation menu with the “dcartes” workspace, choose 
Settings > View Image Attributes.

Image Manager Tools menu
With the Image Manager Tools menu, you can access all 
MicroStation Descartes tool boxes. All the functionality of 
MicroStation Descartes is available through tool boxes. 

✍ If you loaded MicroStation Descartes with the “dcartes” 
workspace, all MicroStation Descartes tool boxes and tool frames 
can be accessed from the Image sub menu of the Tools menu in 
MicroStation. In the descriptions that follow, a note explicitly tells 
the name of each item in the MicroStation menu.

Tool boxes

Each tool box gives access to a few tools of the same family. 

All tool boxes can be accessed from the Image Manager Tools 
menu, where they are listed in alphabetical order.

Alternatively, the tool boxes specific to an application may be 
accessed from the Tools menu of the dialog box related to this 
application. For instance, the Register dialog box gives access to 
two tool boxes: Register and Register File.

Tool Frames

Four tool frames are provided with MicroStation Descartes. They 
are the four first items in the Image Manager Tools menu.

✍ You can build your own sets of tool boxes and tool frames by 
picking any tools from MicroStation Descartes or from 
MicroStation itself, and by putting them into new boxes or frames. 
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Image Main
See “Customizing MicroStation Descartes” on page 18-1, for 
further information on customizing tool boxes and tool frames.

Image Main
Used to open the Image Main tool frame. This tool frame gives 
access to all other tool boxes and, consequently, to all the 
functionality of MicroStation Descartes.

✍ In the MicroStation menu with the “dcartes” workspace, choose 
Tools > Image > Image Main.

Prepare
Used to open the Prepare Image tool frame. This tool frame gives 
access to all tools needed for transforming or registering images.

✍ In the MicroStation menu with the “dcartes” workspace, choose 
Tools > Image > Prepare.

Edit
Used to open the Edit Image tool frame. This tool frame gives 
access to all tools needed for editing images.

✍ In the MicroStation menu with the “dcartes” workspace, choose 
Tools > Image > Edit.

Convert To Vector
Used to open the Convert to Vector tool frame. This tool frame 
gives access to all tools needed for converting raster to vector.

✍ In the MicroStation menu with the “dcartes” workspace, choose 
Tools > Image > Convert to Vector.

Clean Up
Opens the Clean Up tool box and gives access to the following 
tools (see “Clean Up tool box” on page 11-20):

• Remove Speckle - Area

• Remove Holes - Area

• Measure Speckle 
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✍ In the MicroStation menu with the “dcartes” workspace, choose 
Tools > Image > Clean Up.

Color Filter 
Opens the Color Filter tool box and gives access to the following 
tools (see “Color Filter tool box” on page 10-2):

• Add to Filter

• Subtract from Filter

• Highlight Filter

• Color Filter Dialog

✍ In the MicroStation menu with the “dcartes” workspace, choose 
Tools > Image > Color Filter.

Color Filter File
Opens the Color Filter File tool box and gives access to the 
following tools (see “Color Filter File tool box” on page 10-4):

• New Color Filter File

• Open Color Filter File

• Save Color Filter File

• Color Filter Dialog

✍ In the MicroStation menu with the “dcartes” workspace, choose 
Tools > Image > Color Filter File.

Copy/Paste
Opens the Copy/Paste tool box and gives access to the following 
tools (see “Copy/Paste tool box” on page 11-23):

• Copy Image Area

• Paste Image Area

• Paste Image Area as Design Element

• Copy Image Settings

✍ In the MicroStation menu with the “dcartes” workspace, choose 
Tools > Image > Copy/Paste.
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Erase 
Opens the Erase tool box and gives access to the following tools 
(see “Erase tool box” on page 11-4):

• Erase with Rectangular Brush

• Erase with Circular Brush

• Erase with Oblique Brush

• Erase Area

✍ In the MicroStation menu with the “dcartes” workspace, choose 
Tools > Image > Erase.

Image Control
Opens the Image Control tool box and gives access to the 
following tools (see “Image Control tool box” on page 5-33):

• Select Images/Active Image

• Bring Images to Front

• Send Images to Back

• Fit Images to View

• Fit All Images to View

• Actual Image Resolution (1:1)

✍ In the MicroStation menu with the “dcartes” workspace, choose 
Tools > Image > Image Control.

Image File
Opens the Image File tool box and gives access to the following 
tools (see “Image File tool box” on page 5-35):

• New Image

• Open Images

• Save Image

• Print Images

• Image Manager Dialog

✍ In the MicroStation menu with the “dcartes” workspace, choose 
Tools > Image > Image File.
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Image Transform
Opens the Image Transform tool box and gives access to the 
following tools (see “Image Transform tool box” on page 7-10):

• Modify Image

• Move Image

• Scale Image 

• Mirror Image

• Square Image

• Warp Image

• Rotate Image

• Merge Images

• Corridor Images

✍ In the MicroStation menu with the “dcartes” workspace, choose 
Tools > Image > Image Transform.

Local Transform
Opens the Local Transform tool box and gives access to the 
following tools (see “Local Transform tool box” on page 7-2):

• Move Image Area 

• Scale Image Area

• Rotate Image Area

• Horizontal Mirror Image Area

• Vertical Mirror Image Area

• Place Image Area

✍ In the MicroStation menu with the “dcartes” workspace, choose 
Tools > Image > Local Transform.
4-24 MicroStation Descartes User’s Guide



Navigating MicroStation Descartes
Node File
Node File
Opens the Node File tool box and gives access to the following 
tools (see “The Node File tool box” on page 13-29):

• New Node File

• Open Node File

• Save Node File

• Save Node File As

✍ In the MicroStation menu with the “dcartes” workspace, choose 
Tools > Image > Node File.

Paint
Opens the Paint tool box and gives access to the following tools 
(see “Paint tool box” on page 11-2):

• Paint with Rectangular Brush

• Paint with Circular Brush

• Paint with Oblique Brush

• Paint Area

✍ In the MicroStation menu with the “dcartes” workspace, choose 
Tools > Image > Paint.

Register
Opens the Register tool box and gives access to the following 
tools (see “Register tool box” on page 8-20):

• Place Control Points

• Move Control Point

• Delete Control Points

• Copy Vector

• Move Vector

• Resample Image

• Register Dialog

✍ In the MicroStation menu with the “dcartes” workspace, choose 
Tools > Image > Register.
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Register File
Opens the Register File tool box and gives access to the following 
tools (see “Register File tool box” on page 8-25):

• New Register File

• Open Register File

• Save Register File

• Register Dialog

✍ In the MicroStation menu with the “dcartes” workspace, choose 
Tools > Image > Register File.

Resampling File
Opens the Resampling File tool box and gives access to the 
following tools (see “Resampling File tool box” on page 8-27):

• New Resampling File

• Open Resampling File

• Save Resampling File

• Resampling Dialog

✍ In the MicroStation menu with the “dcartes” workspace, choose 
Tools > Image > Resampling File.

Stamp Vector
Opens the Stamp Vector tool box and gives access to the 
following tools (see “Stamp Vector tool box” on page 11-6):

• Stamp Vector

• Match Stamp Vector Settings

• Stamp Vector Settings

✍ In the MicroStation menu with the “dcartes” workspace, choose 
Tools > Image > Stamp Vector.
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Text/Cells
Opens the Text/Cells tool box and gives access to the following 
tools (see “Text/Cells tool box” on page 14-1):

• Select Horizontal Text

• Select Oriented Text

• Convert Text

• Convert Cell

• Convert Horizontal Cell

• Convert Oriented Cell

✍ In the MicroStation menu with the “dcartes” workspace, choose 
Tools > Image > Text/Cells.

Theme
Opens the Theme tool box and gives access to the following tools 
(see “Theme tool box” on page 12-4):

• Change Theme

• Query Theme

• Select by Theme

• Theme Styler Dialog

✍ In the MicroStation menu with the “dcartes” workspace, choose 
Tools > Image > Theme.

Theme File
Opens the Theme File tool box and gives access to the following 
tools (see “Theme File tool box” on page 12-5):

• New Theme File

• Open Theme File

• Save Theme File

• Theme Styler Dialog

✍ In the MicroStation menu with the “dcartes” workspace, choose 
Tools > Image > Theme File.
MicroStation Descartes User’s Guide 4-27



4 Navigating MicroStation Descartes
Image Manager Utilities menu
Undo/Redo 
Opens the Undo tool box and gives access to the following tools 
(see “Undo tool box” on page 11-24):

• Undo Image

• Redo Image

• Undo Image Settings

✍ In the MicroStation menu with the “dcartes” workspace, choose 
Tools > Image > Undo/Redo.

Vectorize
Opens the Vectorize tool box and gives access to the following 
tools (see “Vectorize tool box” on page 13-7):

• Place Element

• Continue Element

• Insert Element

• Convert Lines

• Convert All Connected Lines

• Convert Contour Lines

• Convert Circle

• Place Nodes 

• Delete Nodes

• Vectorize Settings

✍ In the MicroStation menu with the “dcartes” workspace, choose 
Tools > Image > Vectorize.

Image Manager Utilities menu
The Image Manager Utilities menu gives access to various dialog 
boxes for enhancing or registering images, creating color 
composites, preparing images for transparency or translucency, or 
generating color filters or themes.

✍ If you loaded MicroStation Descartes with the “dcartes” 
workspace, the same items are integrated among the items of the 
MicroStation Utilities menu. There, items can be at a different 
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menu level (for example, Utilities > Image Enhancements > 
Density Slicing instead of Utilities > Density Slicing). In the 
descriptions that follow, a note explicitly tells the name and level 
of each item in the MicroStation menu.

Color Compression
Used to open the Color Compression dialog box. See “Color 
Compression dialog box” on page 6-14.

✍ In the MicroStation menu with the “dcartes” workspace, choose 
Utilities > Image Enhancements > Color Compression.

Color Filter
Used to open the Color Filter dialog box. See “Color Filter dialog 
box” on page 10-5.

✍ In the MicroStation menu with the “dcartes” workspace, choose 
Utilities > Image Color Filter.

Contrast Stretch
Used to open the Contrast Stretch dialog box. See “Contrast 
Stretch dialog box” on page 6-7.

✍ In the MicroStation menu with the “dcartes” workspace, choose 
Utilities > Image Enhancements > Contrast Stretch.

Density Slicing
Used to open the Density Slicing dialog box. See “Density Slicing 
dialog box” on page 6-10.

✍ In the MicroStation menu with the “dcartes” workspace, choose 
Utilities > Image Enhancements > Density Slicing.

Image Channels
Used to open the Image Channels dialog box. See “Image 
Channels dialog box” on page 6-3.

✍ In the MicroStation menu with the “dcartes” workspace, choose 
Utilities > Image Enhancements > Image Channels.
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Transparent Colors
Used to open the Transparent Colors dialog box. See “Transparent 
Colors dialog box” on page 6-18.

✍ In the MicroStation menu with the “dcartes” workspace, choose 
Utilities > Image Enhancements > Transparent Colors.

Translucent Colors
Used to open the Translucent Colors dialog box. See “Translucent 
Colors dialog box” on page 6-20.

✍ In the MicroStation menu with the “dcartes” workspace, choose 
Utilities > Image Enhancements > Translucent Colors.

Register
Used to open the Register dialog box. See “Register dialog box” 
on page 8-6.

✍ In the MicroStation menu with the “dcartes” workspace, choose 
Utilities > Register.

Theme Styler
Used to open the Theme Styler dialog box. See “Theme Styler 
dialog box” on page 12-6.

✍ In the MicroStation menu with the “dcartes” workspace, choose 
Utilities > Theme Styler.

Image Manager Help menu
The Image Manager Help menu uses the MicroStation help engine 
and follows all MicroStation help conventions. Most of the content 
of this guide is included on-line and can be accessed through 
Help. For information on how to use MicroStation Help, see the 
MicroStation documentation.

✍ If you loaded MicroStation Descartes with the “dcartes” 
workspace, the help items are integrated among the items of the 
MicroStation Help menu. In the descriptions that follow, a note 
explicitly tells the name of these items in the MicroStation menu.
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Contents
Provides access to the MicroStation on-line Help dialog box and 
lets you review the topics and subtopics related to MicroStation 
Descartes.

✍ In the MicroStation menu with the “dcartes” workspace, choose 
Help > Descartes.

About MicroStation Descartes
Opens a window which displays information on the present 
version of MicroStation Descartes.

✍ In the MicroStation menu with the “dcartes” workspace, choose 
Help > About Descartes.
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