
Appendix A:MicroStation Descartes 
Key-in Tables
Overview

This appendix provides a comprehensive list of the MicroStation Descartes key-
ins. More than 1200 key-ins are listed and defined.

The list is broken into key-in tables. An additional table presents the file 
formats and file types that are supported in MicroStation Descartes. Here is a 
description of the contents of each table. 

New Key-ins in MicroStation Descartes Version 7
This section lists all the new key-ins introduced in Version 7, see 
“New Key-ins in MicroStation Descartes Version 7” on page A-5.

MicroStation Descartes Key-ins
This section lists all key-ins prior to Version 7, see “MicroStation 
Descartes Key-ins” on page A-47.

Project Key-ins
These key-ins begin with IMG.

The Project Key-ins table contains the key-ins for managing the 
image project, for getting help and for exiting MicroStation 
Descartes. 

See “Project Key-ins” on page A-47

Image Edit Key-ins
These key-ins begin with IMGEDIT.
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Image Manager Key-ins
The Image Edit Key-ins table contains the key-ins working with:

• All features described in chapter 6, Enhancing Images;

• All tools of the Local Transform tool box, described in 
chapter 7;

• All features described in chapter 9, Preparing and Managing 
Color Filters;

• All features described in chapter 10, Editing Images.

See “Image Edit Key-ins” on page A-52. 

Image Manager Key-ins
These key-ins begin with IMGMANAGER.

The Image Manager Key-ins table contains the key-ins working 
with:

• All features described in chapter 5, Displaying Images with 
Image Manager;

• All features described in chapter 14, Converting Image 
Formats;

• All features described in chapter 15, Plotting and Printing 
Images.

See “Image Manager Key-ins” on page A-93. 

Image File Formats
This table gives a comprehensive list of all file formats and file 
types that are supported in MicroStation Descartes. Supported 
data compression types are also listed. Choose the appropriate 
options in this table for completing the following key-ins in the 
Image Manager Key-ins table:

Key-in: IMGMANAGER BATCHCONVER SETOUTPUTSETTING 
<Extension> <Pixel Type> <Compression> 
<Directory>

Key-in: IMGMANAGER SAVEAS SETOUTPUTSETTING 
<Extension> <Pixel Type> <Compression> 

See “Image File Formats” on page A-120
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Register Key-ins
Register Key-ins
These key-ins begin with IMGREGISTER.

The Register Key-ins table contains the key-ins working with all 
features described in chapter 8, Registering Images and Vector 
Data.

See “Register Key-ins” on page A-122. 

Theme Key-ins
These key-ins begin with IMGTHEME.

The Theme Key-ins table contains the key-ins working with all 
features described in chapter 11, Preparing Theme Symbology.

See “Theme Key-ins” on page A-144. 

Image Transform Key-ins
These key-ins begin with IMGTRANSFORM.

The Image Transform Key-ins table contains the key-ins working 
with all tools of the Image Transform tool box, described in 
chapter 7.

See “Image Transform Key-ins” on page A-171. 

Vectorize Key-In
These key-ins begin with IMGVECTORIZE.

The Vectorize Key-ins table contains the key-ins working with:

• All features described in chapter 12, Vectorizing;

• All features described in chapter 13, Converting Text and 
Cells from Raster to Vector.

See “Vectorize Key-In” on page A-176. 

Generic Plot Key-ins
These key-ins begin with IMGGENPLOT.

The Generic Plot Key-ins table contains the key-ins working with 
generic features described in chapter 15, Plotting and Printing 
Images.

See “Generic Plot Key-ins” on page A-191.
MicroStation Descartes User’s Guide A-3



MicroStation Descartes Key-in Tables
PostScript Plot Key-ins
✍ For using the Generic Plot Key-ins, the current plot driver must be 
“dcgen.plt.” To load this driver, choose Driver in the Setup menu 
of the Plot dialog box, and select its name in the dialog box that 
displays.

PostScript Plot Key-ins
These key-ins begin with IMGPSPLOT.

The PostScript Plot Key-ins table contains the key-ins working 
with PostScript features described in chapter 15, Plotting and 
Printing Images.

See “PostScript Plot Key-ins” on page A-194.

✍ For using the PostScript Plot Key-ins, the current plot driver must 
be “dcps.plt”. To load this driver, choose Driver in the Setup 
menu of the Plot dialog box, and select its name in the dialog box 
that displays.

RTL Plot Key-ins
These key-ins begin with IMGRTLPLOT.

The RTL Plot Key-ins table contains the key-ins working with the 
RTL features described in chapter 15, Plotting and Printing 
Images.

See “RTL Plot Key-ins” on page A-198.

✍ For using the RTL Plot Key-ins, the current plot driver must be 
“dcrtl.plt.” To load this driver, choose Driver in the Setup menu of 
the Plot dialog box, and select its name in the dialog box that 
displays.
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New Key-ins in MicroStation Descartes Version 7
New Key-ins in MicroStation Descartes Version 7

Image Manager Key-ins

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface

IMGMANAGER 
BATCHA GETRES-
AMPLED (status)

Output: SHORT KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Returns the resam-
pling status for the 
creation of a Img (24 
bits) file.

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
BATCHA SETRES-
AMPLEDOFF

NONE KIN_SUCCESS Sets the resampling 
to OFF for the cre-
ation of a Img (24 
bits) file.

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
BATCHA SETRES-
AMPLEDON

NONE KIN_SUCCESS Sets the resampling 
to ON for the cre-
ation of a Img (24 
bits) file.

Image Manager 
>File > Batch Con-
version

IMGMANAGER 
BATCHA SETLO-
CATION [location 
format]

Input: [STRING] KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Set the location file 
format used to store 
georeference infor-
mation. The valid 
value for location 
format string are: 
“HGR” and “World-
File”. 

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
BATCHA GETLO-
CATION [location 
format]

Input: [STRING] KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Get the location file 
format used to store 
georeference infor-
mation. The return 
value for location 
format string are: 
“HGR” and “World-
File”. 

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
BATCHBMP 
GETRESAMPLED 
(status)

Output: SHORT KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Returns the resam-
pling status for the 
creation of a Win-
dows BMP file.

Image Manager > 
File > Batch Conver-
sion
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Image Manager Key-ins
IMGMANAGER 
BATCHBMP SET-
RESAMPLEDOFF

NONE KIN_SUCCESS Sets the resampling 
to OFF for the cre-
ation of a Windows 
BMP file.

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
BATCHBMP SET-
RESAMPLEDON

NONE KIN_SUCCESS Sets the resampling 
to ON for the cre-
ation of a Windows 
BMP file.

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
BATCHBMP SET-
LOCATION [loca-
tion format]

Input: [STRING] KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Set the location file 
format used to store 
georeference infor-
mation. The valid 
value for location 
format string are: 
“HGR” and “World-
File”. 

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
BATCHBMP GET-
LOCATION [loca-
tion format]

Input: [STRING] KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Get the location file 
format used to store 
georeference infor-
mation. The return 
value for location 
format string are: 
“HGR” and “World-
File”. 

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
BATCHCAL 
GETRESAMPLED 
(status)

Output: SHORT KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Returns the resam-
pling status for the 
creation of a CALS 
file.

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
BATCHCAL SET-
RESAMPLEDOFF

NONE KIN_SUCCESS Sets the resampling 
to OFF for the cre-
ation of a CALS file.

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
BATCHCAL SET-
RESAMPLEDON

NONE KIN_SUCCESS Sets the resampling 
to ON for the cre-
ation of a CALS file.

Image Manager > 
File > Batch Conver-
sion

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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Image Manager Key-ins
IMGMANAGER 
BATCHCAL SET-
LOCATION [loca-
tion format]

Input: [STRING] KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Set the location file 
format used to store 
georeference infor-
mation. The valid 
value for location 
format string are: 
“HGR” and “World-
File”. 

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
BATCHCAL GET-
LOCATION [loca-
tion format]

Input: [STRING] KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Get the location file 
format used to store 
georeference infor-
mation. The return 
value for location 
format string are: 
“HGR” and “World-
File”. 

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
BATCHCIT  
GETRESAMPLED 
(status)

Output: SHORT KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Returns the resam-
pling status for the 
creation of a Inter-
graph CIT file.

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
BATCHCIT SETRE-
SAMPLEDOFF

NONE KIN_SUCCESS Sets the resampling 
to OFF for the cre-
ation of a Intergraph 
CIT file.

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
BATCHCIT SETRE-
SAMPLEDON

NONE KIN_SUCCESS Sets the resampling 
to ON for the cre-
ation of a Intergraph 
CIT file.

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
BATCHCOT  
GETRESAMPLED 
(status)

Output: SHORT KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Returns the resam-
pling status for the 
creation of a Inter-
graph COT file.

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
BATCHCOT SET-
RESAMPLEDOFF

NONE KIN_SUCCESS Sets the resampling 
to OFF for the cre-
ation of a Intergraph 
COT file.

Image Manager > 
File > Batch Conver-
sion

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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Image Manager Key-ins
IMGMANAGER 
BATCHCOT SET-
RESAMPLEDON

NONE KIN_SUCCESS Sets the resampling 
to ON for the cre-
ation of a Intergraph 
COT file.

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
BATCHHMR  
GETRESAMPLED 
(status)

Output: SHORT KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Returns the resam-
pling status for the 
creation of a HMR 
file.

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
BATCHHMR SET-
RESAMPLEDOFF

NONE KIN_SUCCESS Sets the resampling 
to OFF for the cre-
ation of a HMR file.

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
BATCHHMR SET-
RESAMPLEDON

NONE KIN_SUCCESS Sets the resampling 
to ON for the cre-
ation of a HMR file.

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
BATCHJPG  
GETRESAMPLED 
(status)

Output: SHORT KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Returns the resam-
pling status for the 
creation of a JPEG 
file.

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
BATCHJPG SETRE-
SAMPLEDOFF

NONE KIN_SUCCESS Sets the resampling 
to OFF for the cre-
ation of a JPEG file.

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
BATCHJPG SETRE-
SAMPLEDON

NONE KIN_SUCCESS Sets the resampling 
to ON for the cre-
ation of a JPEG file.

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
BATCHJPG SET-
LOCATION [loca-
tion format]

Input: [STRING] KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Set the location file 
format used to store 
georeference infor-
mation. The valid 
value for location 
format string are: 
“HGR” and “World-
File”. 

Image Manager > 
File > Batch Conver-
sion

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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Image Manager Key-ins
IMGMANAGER 
BATCHJPG GET-
LOCATION [loca-
tion format]

Input: [STRING] KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Get the location file 
format used to store 
georeference infor-
mation. The return 
value for location 
format string are: 
“HGR” and “World-
File”. 

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
BATCHP  GETRES-
AMPLED (status)

Output: SHORT KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Returns the resam-
pling status for the 
creation of a Img file.

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
BATCHP SETRESA-
MPLEDOFF

NONE KIN_SUCCESS Sets the resampling 
to OFF for the cre-
ation of a Img file.

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
BATCHP SETRESA-
MPLEDON

NONE KIN_SUCCESS Sets the resampling 
to ON for the cre-
ation of a Img file.

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
BATCHP SETLO-
CATION [location 
format]

Input: [STRING] KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Set the location file 
format used to store 
georeference infor-
mation. The valid 
value for location 
format string are: 
“HGR” and “World-
File”. 

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
BATCHP GETLO-
CATION [location 
format]

Input: [STRING] KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Get the location file 
format used to store 
georeference infor-
mation. The return 
value for location 
format string are: 
“HGR” and “World-
File”. 

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
BATCHPCX  
GETRESAMPLED 
(status)

Output: SHORT KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Returns the resam-
pling status for the 
creation of a PCX 
file.

Image Manager > 
File > Batch Conver-
sion

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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Image Manager Key-ins
IMGMANAGER 
BATCHPCX SET-
RESAMPLEDOFF

NONE KIN_SUCCESS Sets the resampling 
to OFF for the cre-
ation of a PCX file.

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
BATCHPCX SET-
RESAMPLEDON

NONE KIN_SUCCESS Sets the resampling 
to ON for the cre-
ation of a PCX file.

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
BATCHPCX SET-
LOCATION [loca-
tion format]

Input: [STRING] KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Set the location file 
format used to store 
georeference infor-
mation. The valid 
value for location 
format string are: 
“HGR” and “World-
File”. 

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
BATCHPCX GET-
LOCATION [loca-
tion format]

Input: [STRING] KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Get the location file 
format used to store 
georeference infor-
mation. The return 
value for location 
format string are: 
“HGR” and “World-
File”. 

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
BATCHRGB  
GETRESAMPLED 
(status)

Output: SHORT KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Returns the resam-
pling status for the 
creation of a Inter-
graph RGB file.

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
BATCHRGB SET-
RESAMPLEDOFF

NONE KIN_SUCCESS Sets the resampling 
to OFF for the cre-
ation of a Intergraph 
RGB file.

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
BATCHRGB SET-
RESAMPLEDON

NONE KIN_SUCCESS Sets the resampling 
to ON for the cre-
ation of a Intergraph 
RGB file.

Image Manager > 
File > Batch Conver-
sion

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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Image Manager Key-ins
IMGMANAGER 
BATCHRGB SET-
LOCATION [loca-
tion format]

Input: [STRING] KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Set the location file 
format used to store 
georeference infor-
mation. The valid 
value for location 
format string are: 
“HGR” and “World-
File”. 

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
BATCHRGB GET-
LOCATION [loca-
tion format]

Input: [STRING] KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Get the location file 
format used to store 
georeference infor-
mation. The return 
value for location 
format string are: 
“HGR” and “World-
File”. 

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
BATCHRLE  
GETRESAMPLED 
(status)

Output: SHORT KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Returns the resam-
pling status for the 
creation of a Inter-
graph RLE file.

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
BATCHRLE SETRE-
SAMPLEDOFF

NONE KIN_SUCCESS Sets the resampling 
to OFF for the cre-
ation of a Intergraph 
RLE file.

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
BATCHRLE SETRE-
SAMPLEDON

NONE KIN_SUCCESS Sets the resampling 
to ON for the cre-
ation of a Intergraph 
RLE file.

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
BATCHRS  GETRE-
SAMPLED (status)

Output: SHORT KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Returns the resam-
pling status for the 
creation of a Sun 
Raster file.

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
BATCHRS SETRES-
AMPLEDOFF

NONE KIN_SUCCESS Sets the resampling 
to OFF for the cre-
ation of a Sun Raster 
file.

Image Manager > 
File > Batch Conver-
sion

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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Image Manager Key-ins
IMGMANAGER 
BATCHRS SETRES-
AMPLEDON

NONE KIN_SUCCESS Sets the resampling 
to ON for the cre-
ation of a Sun Raster 
file.

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
BATCHRS SETLO-
CATION [location 
format]

Input: [STRING] KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Set the location file 
format used to store 
georeference infor-
mation. The valid 
value for location 
format string are: 
“HGR” and “World-
File”. 

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
BATCHRS GETLO-
CATION [location 
format]

Input: [STRING] KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Get the location file 
format used to store 
georeference infor-
mation. The return 
value for location 
format string are: 
“HGR” and “World-
File”. 

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
BATCHTG4  
GETRESAMPLED 
(status)

Output: SHORT KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Returns the resam-
pling status for the 
creation of a Inter-
graph TG4 file.

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
BATCHTG4 SET-
RESAMPLEDOFF

NONE KIN_SUCCESS Sets the resampling 
to OFF for the cre-
ation of a Intergraph 
TG4 file.

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
BATCHTG4 SET-
RESAMPLEDON

NONE KIN_SUCCESS Sets the resampling 
to ON for the cre-
ation of a Intergraph 
TG4 file.

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
BATCHTGA  
GETRESAMPLED 
(status)

Output: SHORT KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Returns the resam-
pling status for the 
creation of a Targa 
file.

Image Manager > 
File > Batch Conver-
sion

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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Image Manager Key-ins
IMGMANAGER 
BATCHTGA SET-
RESAMPLEDOFF

NONE KIN_SUCCESS Sets the resampling 
to OFF for the cre-
ation of a Targa file.

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
BATCHTGA SET-
RESAMPLEDON

NONE KIN_SUCCESS Sets the resampling 
to ON for the cre-
ation of a Targa file.

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
BATCHTGA SET-
LOCATION [loca-
tion format]

Input: [STRING] KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Set the location file 
format used to store 
georeference infor-
mation. The valid 
value for location 
format string are: 
“HGR” and “World-
File”. 

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
BATCHTGA GET-
LOCATION [loca-
tion format]

Input: [STRING] KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Get the location file 
format used to store 
georeference infor-
mation. The return 
value for location 
format string are: 
“HGR” and “World-
File”. 

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
BATCHTIF GET-
GCS 

Output: [STRING] KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Get the Geographic 
Coordinate System 
name used for the 
creation of a GeoTiff 
file.

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
BATCHTIF GET-
PROJECTION

Output: [STRING] KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Get the Projection 
name used for the 
creation of a GeoTiff 
file.

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
BATCHTIF  
GETRESAMPLED 
(status)

Output: SHORT KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Returns the resam-
pling status for the 
creation of a TIFF 
file.

Image Manager > 
File > Batch Conver-
sion

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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Image Manager Key-ins
IMGMANAGER 
BATCHTIF SET-
GCS 

Input: [STRING] KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Set the Geographic 
Coordinate System 
name used for the 
creation of a GeoTiff 
file. The Geographic 
Coordinate System 
name must be 
present in the file 
geotifcs.cfg.

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
BATCHTIF SET-
PROJECTION 

Input: [STRING] KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Set the Projection 
name used for the 
creation of a GeoTiff 
file. The Projection 
name must be 
present in the file 
geotifcs.cfg.

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
BATCHTIF SETRE-
SAMPLEDDON

NONE KIN_SUCCESS Sets the resampling 
to ON for the cre-
ation of a TIFF file.

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
BATCHTIF SETRE-
SAMPLEDOFF

NONE KIN_SUCCESS Sets the resampling 
to OFF for the cre-
ation of a TIFF file.

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
BATCHTIF SETLO-
CATION [location 
format]

Input: [STRING] KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Set the location file 
format used to store 
georeference infor-
mation. The valid 
value for location 
format string are: 
“HGR” and “World-
File”. 

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
BATCHTIF GET-
LOCATION [loca-
tion format]

Input: [STRING] KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Get the location file 
format used to store 
georeference infor-
mation. The return 
value for location 
format string are: 
“HGR” and “World-
File”. 

Image Manager > 
File > Batch Conver-
sion

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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IMGMANAGER 
BSAVEASRLE  
GETRESAMPLED 
(status)

Output: SHORT KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Returns the resam-
pling status for the 
creation of a Inter-
graph RLE file.

Image Manager > 
File > Save As

IMGMANAGER 
DISPLAY GET-
GLOBALFIT

Input: NONE Out-
put: SHORT

KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Returns the status of 
the Fit All Images 
and Design Ele-
ments to View.

IMGMANAGER 
DISPLAY SETGLO-
BALFITON

Input: NONE KIN_SUCCESS 
KIN_ERROR

Set the status of the 
toggle Fit All Images 
and Design Ele-
ments to ON.

IMGMANAGER 
DISPLAY SETGLO-
BALFITOFF

Input: NONE KIN_SUCCESS 
KIN_ERROR

Set the status of the 
toggle Fit All Images 
and Design Ele-
ments to OFF.

IMGMANAGER 
DISPLAY GLO-
BALFIT

Input: [SHORT] KIN_SUCCESS 
KIN_ERROR

Fits all visible image 
and all design ele-
ments to a view. If 
view is not specified, 
a data point is 
required to identify 
the desired view.

IMGMANAGER 
DISPLAY Recon-
nect <view num-
ber> [file name]

Input: SHORT 
[STRING]

KIN_INVALID_VIE
W KIN_ERROR 
KIN_SUCCESS 
KIN_FILE_NOT_F
OUND 
KIN_PERM_DENIE
D

Tries to reconnect 
the specified image 
in the specified view. 
If no filename is 
specified, tries to 
reconnect the 
selected images in 
the specified view.

Image Manager > 
Display> Reconnect

IMGMANAGER 
DLGCACHESET-
TING OPEN

NONE KIN_ERROR 
KIN_PERM_DENIE
D KIN_SUCCESS

Opens the Internet 
Client Cache Set-
tings  dialog. 

Image Manager > 
Settings > Prefer-
ences > MSI Client 
Cache

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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IMGMANAGER 
DLGSERVERSET-
TING CLOSE

NONE KIN_ERROR 
KIN_SUCCESS 
KIN_PERM_DENIE
D

Closes the Image 
Servers Settings  dia-
log. 

Image Manager > 
File> Settings > 
Image Servers

IMGMANAGER 
DLGSERVERSET-
TING OPEN

NONE KIN_ERROR 
KIN_PERM_DENIE
D KIN_SUCCESS

Opens the Image 
Servers Setting  dia-
log. 

Image Manager > 
File> Settings > 
Image Servers

IMGMANAGER 
INTERNETCACHE 
GETCACHINGTH-
RESHOLD (thresh-
old)

Output: LONG KIN_ERROR 
KIN_PERM_DENIE
D KIN_SUCCESS

Returns the mini-
mum file size of the 
file to put in the 
cache. (in Kb)

Image Manager > 
Settings > Prefer-
ences > MSI Client 
Cache

IMGMANAGER 
INTERNETCACHE 
GETDIRECTORY 
(directory)

Output: STRING KIN_INVALID_PAR
AM KIN_SUCCESS 
KIN_PERM_DENIE
D

Returns the HIP local 
cache directory.

Image Manager > 
Settings > Prefer-
ences > MSI Client 
Cache

IMGMANAGER 
INTERNETCACHE 
GETDISKMAX-
SIZE (size)

Output: LONG KIN_ERROR 
KIN_PERM_DENIE
D KIN_SUCCESS

Returns the maxi-
mum size of the 
disk cache. (in Mb)

Image Manager > 
Settings > Prefer-
ences > MSI Client 
Cache

IMGMANAGER 
INTERNETCACHE 
GETMEMORY-
MAXSIZE (size)

Output: LONG KIN_ERROR 
KIN_PERM_DENIE
D KIN_SUCCESS

Returns the maxi-
mum size of the 
memory cache. (in 
Mb)

Image Manager > 
Settings > Prefer-
ences > MSI Client 
Cache

IMGMANAGER 
INTERNETCACHE 
SETCACHINGTH-
RESHOLD <thresh-
old>

Input: LONG KIN_ERROR 
KIN_PERM_DENIE
D 
KIN_INVALID_PAR
AM KIN_SUCCESS

Sets the minimum 
file size of the file to 
put in the cache. (in 
Kb)

Image Manager > 
Settings > Prefer-
ences > MSI Client 
Cache

IMGMANAGER 
INTERNETCACHE 
SETDIRECTORY 
<directory>

Input: STRING KIN_ERROR 
KIN_INVALID_PAR
AM KIN_SUCCESS 
KIN_PERM_DENIE
D

Sets the HIP local 
cache directory.

Image Manager > 
Settings > Prefer-
ences > MSI Client 
Cache

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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IMGMANAGER 
INTERNETCACHE 
SETDISKMAXSIZE 
<size>

Input: LONG KIN_ERROR 
KIN_PERM_DENIE
D KIN_SUCCESS

Sets the maximum 
size of the disk 
cache. (in Mb)

Image Manager > 
Settings > Prefer-
ences > MSI Client 
Cache

IMGMANAGER 
INTERNETCACHE 
SETMEMORYMAX-
SIZE <size>

Input: LONG KIN_ERROR 
KIN_PERM_DENIE
D KIN_SUCCESS

Sets the maximum 
size of the memory 
cache. (in Mb)

Image Manager > 
Settings > Prefer-
ences > MSI Client 
Cache

IMGMANAGER 
LOCATION 
GETAFFANGLE 
(angle)

Output: STRING KIN_NOIMAGE 
KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Returns the affinity 
angle recorded in the 
active image.

Image Manager > 
File > Properties > 
Location

IMGMANAGER 
LOCATION GET-
PIXELSIZELOCK 
(status)

Output: SHORT KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Returns the status of 
the pixel size lock.

Image Manager > 
File > Properties > 
Location

IMGMANAGER 
LOCATION GET-
PIXELSIZEX (size)

Output: STRING KIN_NOIMAGE 
KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Returns the pixel 
width recorded in 
the active image.

Image Manager > 
File > Properties > 
Location

IMGMANAGER 
LOCATION GET-
PIXELSIZEY (size)

Output: STRING KIN_NOIMAGE 
KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Returns the pixel 
height recorded in 
the active image.

Image Manager > 
File > Properties > 
Location

IMGMANAGER 
LOCATION 
GETROTANGLE 
(angle)

Output: STRING KIN_NOIMAGE 
KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Returns the rotation 
angle recorded in the 
active image.

Image Manager > 
File > Properties > 
Location

IMGMANAGER 
LOCATION 
GETSCALEFAC-
TOR (value)

Ouput: DOUBLE KIN_NOIMAGE 
KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Returns the scale fac-
tor for the active 
image. 

Image Manager > 
Tools > Image Trans-
form

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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IMGMANAGER 
LOCATION SET-
AFFANGLE 
<angle>

Input: STRING KIN_NOIMAGE 
KIN_FILE_READ_
ONLY 
KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Sets the affinity angle 
to record into the 
active image.

Image Manager > 
File > Properties > 
Location

IMGMANAGER 
LOCATION SETD-
PIX <value>

Input: LONG KIN_NOIMAGE 
KIN_FILE_READ_
ONLY 
KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Set the dpi about 
the X-axis for the 
active image.

Image Manager > 
File> Properties > 
Location

IMGMANAGER 
LOCATION SETD-
PIY <value>

Input: LONG KIN_NOIMAGE 
KIN_FILE_READ_
ONLY 
KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Set the dpi about 
the Y-axis for the 
active image.

Image Manager > 
File> Properties > 
Location

IMGMANAGER 
LOCATION SET-
PIXELSIZELOCK-
OFF (status)

NONE KIN_SUCCESS 
KIN_ERROR

Sets the status of the 
pixel size lock to 
OFF.

Image Manager > 
File > Properties > 
Location

IMGMANAGER 
LOCATION SET-
PIXELSIZE-
LOCKON (status)

NONE KIN_SUCCESS 
KIN_ERROR

Sets the status of the 
pixel size lock to 
ON.

Image Manager > 
File > Properties > 
Location

IMGMANAGER 
LOCATION SET-
PIXELSIZEX <size>

Input: STRING KIN_NOIMAGE 
KIN_FILE_READ_
ONLY 
KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Sets the pixel width 
to record into the 
active image.

Image Manager > 
File > Properties > 
Location

IMGMANAGER 
LOCATION SET-
PIXELSIZEY <size>

Input: STRING KIN_NOIMAGE 
KIN_FILE_READ_
ONLY 
KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Sets the pixel height 
to record into the 
active image.

Image Manager > 
File > Properties > 
Location

Key-In Parameters Returned Error 
Codes

Description Graphical 
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IMGMANAGER 
LOCATION SET-
ROTANGLE 
<angle>

Input: STRING KIN_NOIMAGE 
KIN_FILE_READ_
ONLY 
KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Sets the rotation 
angle to record into 
the active image.

Image Manager > 
File > Properties > 
Location

IMGMANAGER 
LOCATION SET-
SCALEFACTOR 
<value>

Input: DOUBLE KIN_NOIMAGE 
KIN_FILE_READ_
ONLY 
KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Set the scale factor of 
the active image.

Image Manager > 
Tools > Image Trans-
form

IMGMANAGER 
NEWIMAGE 
GETAFFANGLE 
(Rotation angle)

Output: STRING KIN_INVALID_PAR
AM KIN_SUCCESS

Returns the affinity 
angle of the new 
image.

Image Manager > 
File > New > Loca-
tion

IMGMANAGER 
NEWIMAGE GET-
DPIY (value)

Ouput: LONG KIN_INVALID_PAR
AM KIN_SUCCESS

Returns the dpi Y of 
the new image. 

Idem

IMGMANAGER 
NEWIMAGE GET-
PIXELSIZEX (Pix-
elSize X)

Output: STRING KIN_INVALID_PAR
AM KIN_SUCCESS

Returns the pixel size 
X of the new image 
in Working units. 
(ex: 1:150.000)

Image Manager > 
File > New > Loca-
tion

IMGMANAGER 
NEWIMAGE GET-
PIXELSIZEY (Pix-
elSize Y)

Output: STRING KIN_INVALID_PAR
AM KIN_SUCCESS

Returns the pixel size 
Y of the new image 
in Working units. 
(ex: 1:150.000)

Image Manager > 
File > New > Loca-
tion

IMGMANAGER 
NEWIMAGE 
GETROTANGLE 
(Rotation angle)

Output: STRING KIN_INVALID_PAR
AM KIN_SUCCESS

Returns the rotation 
angle of the new 
image.

Image Manager > 
File > New > Loca-
tion

IMGMANAGER 
NEWIMAGE 
GETSCALEFAC-
TOR (value)

Ouput: DOUBLE KIN_INVALID_PAR
AM KIN_SUCCESS

Returns the scale fac-
tor of the new 
image. 

Idem

Key-In Parameters Returned Error 
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Interface
MicroStation Descartes User’s Guide A-19



MicroStation Descartes Key-in Tables
Image Manager Key-ins
IMGMANAGER 
NEWIMAGE SET-
AFFANGLE <Affin-
ity angle>

Input: STRING KIN_INVALID_PAR
AM KIN_SUCCESS

Sets the affinity angle 
of the new image.

Image Manager > 
File > New > Loca-
tion

IMGMANAGER 
NEWIMAGE SETD-
PIX <value>

Input: LONG KIN_INVALID_PAR
AM KIN_SUCCESS

Set the dpi X of the 
new image.

Image Manager > 
File > New > Loca-
tion

IMGMANAGER 
NEWIMAGE SETD-
PIY <value>

Input: LONG KIN_INVALID_PAR
AM KIN_SUCCESS

Set the dpi Y of the 
new image.

Idem

IMGMANAGER 
NEWIMAGE SET-
PIXELSIZEX <Pix-
elSize X>

Input: STRING KIN_INVALID_PAR
AM KIN_SUCCESS

Sets the pixel size X 
of the new image in 
Working units. (ex: 
1:150.000)

Image Manager > 
File > New > Loca-
tion

IMGMANAGER 
NEWIMAGE SET-
PIXELSIZEY <Pix-
elSize Y>

Input: STRING KIN_INVALID_PAR
AM KIN_SUCCESS

Sets the pixel size Y 
of the new image in 
Working units. (ex: 
1:150.000)

Image Manager > 
File > New > Loca-
tion

IMGMANAGER 
NEWIMAGE SET-
ROTANGLE <Rota-
tion angle>

Input: STRING KIN_INVALID_PAR
AM KIN_SUCCESS

Sets the rotation 
angle of the new 
image.

Image Manager > 
File > New > Loca-
tion

IMGMANAGER 
NEWIMAGE SET-
SCALEFACTOR 
<value>

Input: DOUBLE KIN_INVALID_PAR
AM KIN_SUCCESS

Sets the scale factor 
of the new image.

Idem

IMGMANAGER 
PLOTINVERTBW 
GET

Output: SHORT KIN_INVALID_PAR
AM KIN_SUCCESS

Return the status of 
the black and white 
1 bit plot invertion.

IMGMANAGER 
PLOTINVERTBW 
SETOFF

NONE KIN_SUCCESS Disable invertion of 
1 bit black and white 
images.

IMGMANAGER 
PLOTINVERTBW 
SETON

NONE KIN_SUCCESS Enable invertion of 
1 bit black and white 
images.

Key-In Parameters Returned Error 
Codes

Description Graphical 
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IMGMANAGER 
SAVEASA  GETRE-
SAMPLED (status)

Output: SHORT KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Returns the resam-
pling status for the 
creation of a Img (24 
bits) file.

Image Manager > 
File > Save As

IMGMANAGER 
SAVEASA SETRES-
AMPLEDOFF

NONE KIN_SUCCESS Sets the resampling 
to OFF for the cre-
ation of a Img (24 
bits) file.

Image Manager > 
File > Save As

IMGMANAGER 
SAVEASA SETRES-
AMPLEDON

NONE KIN_SUCCESS Sets the resampling 
to ON for the cre-
ation of a Img (24 
bits) file.

Image Manager > 
File > Save As

IMGMANAGER 
SAVEASA SETLO-
CATION [location 
format]

Input: [STRING] KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Set the location file 
format used to store 
georeference infor-
mation. The valid 
value for location 
format string are: 
“HGR” and “World-
File”. 

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
SAVEASA GETLO-
CATION [location 
format]

Input: [STRING] KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Get the location file 
format used to store 
georeference infor-
mation. The return 
value for location 
format string are: 
“HGR” and “World-
File”. 

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
SAVEASBMP  
GETRESAMPLED 
(status)

Output: SHORT KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Returns the resam-
pling status for the 
creation of a Win-
dows BMP file.

Image Manager > 
File > Save As

IMGMANAGER 
SAVEASBMP SET-
RESAMPLEDOFF

NONE KIN_SUCCESS Sets the resampling 
to OFF for the cre-
ation of a Windows 
BMP file.

Image Manager > 
File > Save As

Key-In Parameters Returned Error 
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IMGMANAGER 
SAVEASBMP SET-
RESAMPLEDON

NONE KIN_SUCCESS Sets the resampling 
to ON for the cre-
ation of a Windows 
BMP file.

Image Manager > 
File > Save As

IMGMANAGER 
SAVEASBMP SET-
LOCATION [loca-
tion format]

Input: [STRING] KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Set the location file 
format used to store 
georeference infor-
mation. The valid 
value for location 
format string are: 
“HGR” and “World-
File”. 

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
SAVEASBMP GET-
LOCATION [loca-
tion format]

Input: [STRING] KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Get the location file 
format used to store 
georeference infor-
mation. The return 
value for location 
format string are: 
“HGR” and “World-
File”. 

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
SAVEASCAL  
GETRESAMPLED 
(status)

Output: SHORT KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Returns the resam-
pling status for the 
creation of a Inter-
graph CAL file.

Image Manager > 
File > Save As

IMGMANAGER 
SAVEASCAL SET-
RESAMPLEDOFF

NONE KIN_SUCCESS Sets the resampling 
to OFF for the cre-
ation of a Intergraph 
CAL file.

Image Manager > 
File > Save As

IMGMANAGER 
SAVEASCAL SET-
RESAMPLEDON

NONE KIN_SUCCESS Sets the resampling 
to ON for the cre-
ation of a Intergraph 
CAL file.

Image Manager > 
File > Save As

Key-In Parameters Returned Error 
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IMGMANAGER 
SAVEASCAL SET-
LOCATION [loca-
tion format]

Input: [STRING] KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Set the location file 
format used to store 
georeference infor-
mation. The valid 
value for location 
format string are: 
“HGR” and “World-
File”. 

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
SAVEASCAL GET-
LOCATION [loca-
tion format]

Input: [STRING] KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Get the location file 
format used to store 
georeference infor-
mation. The return 
value for location 
format string are: 
“HGR” and “World-
File”. 

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
SAVEASCIT  
GETRESAMPLED 
(status)

Output: SHORT KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Returns the resam-
pling status for the 
creation of a Inter-
graph CIT file.

Image Manager > 
File > Save As

IMGMANAGER 
SAVEASCIT SETRE-
SAMPLEDOFF

NONE KIN_SUCCESS Sets the resampling 
to OFF for the cre-
ation of a Intergraph 
CIT file.

Image Manager > 
File > Save As

IMGMANAGER 
SAVEASCIT SETRE-
SAMPLEDON

NONE KIN_SUCCESS Sets the resampling 
to ON for the cre-
ation of a Intergraph 
CIT file.

Image Manager > 
File > Save As

IMGMANAGER 
SAVEASCOT  
GETRESAMPLED 
(status)

Output: SHORT KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Returns the resam-
pling status for the 
creation of a Inter-
graph COT file.

Image Manager > 
File > Save As

IMGMANAGER 
SAVEASCOT SET-
RESAMPLEDOFF

NONE KIN_SUCCESS Sets the resampling 
to OFF for the cre-
ation of a Intergraph 
COT file.

Image Manager > 
File > Save As

Key-In Parameters Returned Error 
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IMGMANAGER 
SAVEASCOT SET-
RESAMPLEDON

NONE KIN_SUCCESS Sets the resampling 
to ON for the cre-
ation of a Intergraph 
COT file.

Image Manager > 
File > Save As

IMGMANAGER 
SAVEASHMR  
GETRESAMPLED 
(status)

Output: SHORT KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Returns the resam-
pling status for the 
creation of a HMR 
file.

Image Manager > 
File > Save As

IMGMANAGER 
SAVEASHMR SET-
RESAMPLEDOFF

NONE KIN_SUCCESS Sets the resampling 
to OFF for the cre-
ation of a HMR file.

Image Manager > 
File > Save As

IMGMANAGER 
SAVEASHMR SET-
RESAMPLEDON

NONE KIN_SUCCESS Sets the resampling 
to ON for the cre-
ation of a HMR file.

Image Manager > 
File > Save As

IMGMANAGER 
SAVEASHPCX SET-
RESAMPLEDOFF

NONE KIN_SUCCESS Sets the resampling 
to OFF for the cre-
ation of a PCX file.

Image Manager > 
File > Save As

IMGMANAGER 
SAVEASPCX SET-
LOCATION [loca-
tion format]

Input: [STRING] KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Set the location file 
format used to store 
georeference infor-
mation. The valid 
value for location 
format string are: 
“HGR” and “World-
File”. 

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
SAVEASPCX GET-
LOCATION [loca-
tion format]

Input: [STRING] KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Get the location file 
format used to store 
georeference infor-
mation. The return 
value for location 
format string are: 
“HGR” and “World-
File”. 

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
SAVEASJPG  
GETRESAMPLED 
(status)

Output: SHORT KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Returns the resam-
pling status for the 
creation of a JPEG 
file.

Image Manager > 
File > Save As

Key-In Parameters Returned Error 
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IMGMANAGER 
SAVEASJPG SET-
RESAMPLEDOFF

NONE KIN_SUCCESS Sets the resampling 
to OFF for the cre-
ation of a JPEG file.

Image Manager > 
File > Save As

IMGMANAGER 
SAVEASJPG SET-
RESAMPLEDON

NONE KIN_SUCCESS Sets the resampling 
to ON for the cre-
ation of a JPEG file.

Image Manager > 
File > Save As

IMGMANAGER 
SAVEASJPG SET-
LOCATION [loca-
tion format]

Input: [STRING] KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Set the location file 
format used to store 
georeference infor-
mation. The valid 
value for location 
format string are: 
“HGR” and “World-
File”. 

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
SAVEASJPG GET-
LOCATION [loca-
tion format]

Input: [STRING] KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Get the location file 
format used to store 
georeference infor-
mation. The return 
value for location 
format string are: 
“HGR” and “World-
File”. 

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
SAVEASP  GETRE-
SAMPLED (status)

Output: SHORT KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Returns the resam-
pling status for the 
creation of a Img file.

Image Manager > 
File > Save As

IMGMANAGER 
SAVEASP SETRES-
AMPLEDOFF

NONE KIN_SUCCESS Sets the resampling 
to OFF for the cre-
ation of a Img file.

Image Manager > 
File > Save As

IMGMANAGER 
SAVEASP SETRES-
AMPLEDON

NONE KIN_SUCCESS Sets the resampling 
to ON for the cre-
ation of a Img file.

Image Manager > 
File > Save As
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IMGMANAGER 
SAVEASP SETLO-
CATION [location 
format]

Input: [STRING] KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Set the location file 
format used to store 
georeference infor-
mation. The valid 
value for location 
format string are: 
“HGR” and “World-
File”. 

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
SAVEASP GETLO-
CATION [location 
format]

Input: [STRING] KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Get the location file 
format used to store 
georeference infor-
mation. The return 
value for location 
format string are: 
“HGR” and “World-
File”. 

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
SAVEASPCX  
GETRESAMPLED 
(status)

Output: SHORT KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Returns the resam-
pling status for the 
creation of a PCX 
file.

Image Manager > 
File > Save As

IMGMANAGER 
SAVEASPCX SET-
RESAMPLEDON

NONE KIN_SUCCESS Sets the resampling 
to ON for the cre-
ation of a PCX file.

Image Manager > 
File > Save As

IMGMANAGER 
SAVEASRGB  
GETRESAMPLED 
(status)

Output: SHORT KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Returns the resam-
pling status for the 
creation of a Inter-
graph RGB file.

Image Manager > 
File > Save As

IMGMANAGER 
SAVEASRGB SET-
RESAMPLEDOFF

NONE KIN_SUCCESS Sets the resampling 
to OFF for the cre-
ation of a Intergraph 
RGB file.

Image Manager > 
File > Save As

IMGMANAGER 
SAVEASRGB SET-
RESAMPLEDON

NONE KIN_SUCCESS Sets the resampling 
to ON for the cre-
ation of a Intergraph 
RGB file.

Image Manager > 
File > Save As

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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Image Manager Key-ins
IMGMANAGER 
SAVEASRGB SET-
LOCATION [loca-
tion format]

Input: [STRING] KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Set the location file 
format used to store 
georeference infor-
mation. The valid 
value for location 
format string are: 
“HGR” and “World-
File”. 

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
SAVEASRGB GET-
LOCATION [loca-
tion format]

Input: [STRING] KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Get the location file 
format used to store 
georeference infor-
mation. The return 
value for location 
format string are: 
“HGR” and “World-
File”. 

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
SAVEASRLE SET-
RESAMPLEDOFF

NONE KIN_SUCCESS Sets the resampling 
to OFF for the cre-
ation of a Intergraph 
RLE file.

Image Manager > 
File > Save As

IMGMANAGER 
SAVEASRLE SET-
RESAMPLEDON

NONE KIN_SUCCESS Sets the resampling 
to ON for the cre-
ation of a Intergraph 
RLE file.

Image Manager > 
File > Save As

IMGMANAGER 
SAVEASRS  
GETRESAMPLED 
(status)

Output: SHORT KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Returns the resam-
pling status for the 
creation of a Sun 
Raster file.

Image Manager > 
File > Save As

IMGMANAGER 
SAVEASRS SETRE-
SAMPLEDOFF

NONE KIN_SUCCESS Sets the resampling 
to OFF for the cre-
ation of a Sun Raster 
file.

Image Manager > 
File > Save As

IMGMANAGER 
SAVEASRS SETRE-
SAMPLEDON

NONE KIN_SUCCESS Sets the resampling 
to ON for the cre-
ation of a Sun Raster 
file.

Image Manager > 
File > Save As

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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Image Manager Key-ins
IMGMANAGER 
SAVEASRS SETLO-
CATION [location 
format]

Input: [STRING] KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Set the location file 
format used to store 
georeference infor-
mation. The valid 
value for location 
format string are: 
“HGR” and “World-
File”. 

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
SAVEASRS GETLO-
CATION [location 
format]

Input: [STRING] KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Get the location file 
format used to store 
georeference infor-
mation. The return 
value for location 
format string are: 
“HGR” and “World-
File”. 

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
SAVEASTG4  
GETRESAMPLED 
(status)

Output: SHORT KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Returns the resam-
pling status for the 
creation of a Inter-
graph TG4 file.

Image Manager > 
File > Save As

IMGMANAGER 
SAVEASTG4 SET-
RESAMPLEDOFF

NONE KIN_SUCCESS Sets the resampling 
to OFF for the cre-
ation of a Intergraph 
TG4 file.

Image Manager > 
File > Save As

IMGMANAGER 
SAVEASTG4 SET-
RESAMPLEDON

NONE KIN_SUCCESS Sets the resampling 
to ON for the cre-
ation of a Intergraph 
TG4 file.

Image Manager > 
File > Save As

IMGMANAGER 
SAVEASTGA  
GETRESAMPLED 
(status)

Output: SHORT KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Returns the resam-
pling status for the 
creation of a Targa 
file.

Image Manager > 
File > Save As

IMGMANAGER 
SAVEASTGA SET-
RESAMPLEDOFF

NONE KIN_SUCCESS Sets the resampling 
to OFF for the cre-
ation of a Targa file.

Image Manager > 
File > Save As

IMGMANAGER 
SAVEASTGA SET-
RESAMPLEDON

NONE KIN_SUCCESS Sets the resampling 
to ON for the cre-
ation of a Targa file.

Image Manager > 
File > Save As

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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Image Manager Key-ins
IMGMANAGER 
SAVEASTGA SET-
LOCATION [loca-
tion format]

Input: [STRING] KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Set the location file 
format used to store 
georeference infor-
mation. The valid 
value for location 
format string are: 
“HGR” and “World-
File”. 

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
SAVEASTGA GET-
LOCATION [loca-
tion format]

Input: [STRING] KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Get the location file 
format used to store 
georeference infor-
mation. The return 
value for location 
format string are: 
“HGR” and “World-
File”. 

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
SAVEASTIF GET-
GCS 

Output: [STRING] KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Get the Geographic 
Coordinate System 
name used for the 
creation of a GeoTiff 
file.

Image Manager > 
File > Save As

IMGMANAGER 
SAVEASTIF GET-
PROJECTION

Output: [STRING] KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Get the Projection 
name used for the 
creation of a GeoTiff 
file.

Image Manager > 
File > Save As

IMGMANAGER 
SAVEASTIF  
GETRESAMPLED 
(status)

Output: SHORT KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Returns the resam-
pling status for the 
creation of a TIFF 
file.

Image Manager > 
File > Save As

IMGMANAGER 
SAVEASTIF SET-
GCS 

Input: [STRING] KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Set the Geographic 
Coordinate System 
name used for the 
creation of a GeoTiff 
file. The Geographic 
Coordinate System 
name must be 
present in the file 
geotifcs.cfg.

Image Manager > 
File > Save As

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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Image Manager Key-ins
IMGMANAGER 
SAVEASTIF SET-
PROJECTION 

Input: [STRING] KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Set the Projection 
name used for the 
creation of a GeoTiff 
file. The Projection 
name must be 
present in the file 
geotifcs.cfg.

Image Manager > 
File > Save As

IMGMANAGER 
SAVEASTIF SETRE-
SAMPLEDDON

NONE KIN_SUCCESS Sets the resampling 
to ON for the cre-
ation of a TIFF file.

Image Manager > 
File > Save As

IMGMANAGER 
SAVEASTIF SETRE-
SAMPLEDOFF

NONE KIN_SUCCESS Sets the resampling 
to OFF for the cre-
ation of a TIFF file.

Image Manager > 
File > Save As

IMGMANAGER 
SAVEASTIF SET-
LOCATION [loca-
tion format]

Input: [STRING] KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Set the location file 
format used to store 
georeference infor-
mation. The valid 
value for location 
format string are: 
“HGR” and “World-
File”. 

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
SAVEASTIF GET-
LOCATION [loca-
tion format]

Input: [STRING] KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Get the location file 
format used to store 
georeference infor-
mation. The return 
value for location 
format string are: 
“HGR” and “World-
File”. 

Image Manager > 
File > Batch Conver-
sion

IMGMANAGER 
SERVER ADD 
<alias server 
name>

Input: STRING INVALID_PARAM 
KIN_ERROR 
KIN_SUCCESS 
KIN_PERM_DENIE
D

Adds a new alias 
name to the current  
Image Servers file.

Image Manager > 
Settings > Image 
Servers 

IMGMANAGER 
SERVER DELETE 
<alias server 
name>

Input: STRING INVALID_PARAM 
KIN_ERROR 
KIN_SUCCESS 
KIN_PERM_DENIE
D

Deletes the specified 
Image Server from 
the opened Image 
Server file. 

Image Manager > 
Settings > Image 
Servers 

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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Image Manager Key-ins
IMGMANAGER 
SERVER GETCON-
NECTION < alias 
server  name > 
(connection)

Input: STRING 
Output: STRING

KIN_ERROR 
KIN_INVALID_SER
VER 
KIN_INVALID_PAR
AM KIN_SUCCESS 
KIN_PERM_DENIE
D

Returns the type of 
connection of speci-
fied server (SOCKET 
or HTTP).

Image Manager > 
Settings > Image 
Servers 

IMGMANAGER 
SERVER GETEX-
TENSION < alias 
server  name > 
(extension)

Input: STRING 
Output: STRING

KIN_ERROR 
KIN_INVALID_SER
VER 
KIN_INVALID_PAR
AM KIN_SUCCESS 
KIN_PERM_DENIE
D

Returns the exten-
sion of the specified 
server.

Image Manager > 
Settings > Image 
Servers

IMGMANAGER 
SERVER GETN-
BRETRIES (nb 
retries)

Output: INT KIN_INVALID_PAR
AM KIN_SUCCESS 
KIN_PERM_DENIE
D

Returns the number 
of retries for a con-
nection lost.

Image Manager > 
Settings > Image 
Servers

IMGMANAGER 
SERVER GET-
PORT < alias 
server  name > 
(port)

Input: STRING 
Output: LONG

KIN_INVALID_SER
VER 
KIN_INVALID_PAR
AM KIN_SUCCESS 
KIN_PERM_DENIE
D

Returns the port of 
the specified server.

Image Manager > 
Settings > Image 
Servers

IMGMANAGER 
SERVER GETSERV-
ERNAME < alias 
server  name > 
(server name)

Input: STRING 
Output: STRING

KIN_INVALID_SER
VER 
KIN_INVALID_PAR
AM KIN_SUCCESS 
KIN_PERM_DENIE
D

Returns the name of 
the specified server.

Image Manager > 
Settings > Image 
Servers

IMGMANAGER 
SERVER SETCON-
NECTION < alias 
server  name> 
<SOCKET | HTTP 
>

Input: STRING, 
STRING

KIN_INVALID_SER
VER 
KIN_INVALID_PAR
AM KIN_SUCCESS 
KIN_PERM_DENIE
D

Sets the type of con-
nection of the speci-
fied server.

Image Manager > 
Settings > Image 
Servers 

Key-In Parameters Returned Error 
Codes

Description Graphical 
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Image Manager Key-ins
IMGMANAGER 
SERVER SETEX-
TENSION < alias 
server  name > 
<extension>

Input: STRING, 
STRING

KIN_ERROR 
KIN_INVALID_SER
VER 
KIN_INVALID_PAR
AM KIN_SUCCESS 
KIN_PERM_DENIE
D

Sets the extension of 
the specified server.

Image Manager > 
Settings > Image 
Servers 

IMGMANAGER 
SERVER SETNBRE-
TRIES <nb retries>

Input: INT KIN_ERROR 
KIN_SUCCESS 
KIN_PERM_DENIE
D 
KIN_PERM_DENIE
D

Sets the number of 
retries for a connec-
tion lost.

Image Manager > 
Settings > Image 
Servers 

IMGMANAGER 
SERVER SETPORT 
< alias server  
name > <port>

Input: STRING, 
LONG

KIN_INVALID_SER
VER 
KIN_INVALID_PAR
AM KIN_SUCCESS 
KIN_PERM_DENIE
D

Sets the port of the 
specified server.

Image Manager > 
Settings > Image 
Servers 

IMGMANAGER 
SERVER SETSERV-
ERNAME < alias 
server  name > 
<server name>

Input: STRING, 
STRING

KIN_INVALID_SER
VER 
KIN_INVALID_PAR
AM KIN_SUCCESS 
KIN_PERM_DENIE
D

Sets the name of the 
specified server.

Image Manager > 
Settings > Image 
Servers 

IMGMANAGER 
SRVFILE GET (file 
name)

Output: STRING KIN_ERROR 
KIN_INVALID_PAR
AM KIN_SUCCESS 
KIN_PERM_DENIE
D

Returns the current 
Image Servers file 
name. 

Image Manager > 
Settings > Image 
Servers > File

IMGMANAGER 
SRVFILE NEW

NONE KIN_ERROR 
KIN_SUCCESS 
KIN_PERM_DENIE
D

Create a new Image 
Servers file.

Image Manager > 
Settings > Image 
Servers > File

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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GeoTIFF KeyIns
IMGMANAGER 
SRVFILE OPEN 
[filename]

Input: [STRING] KIN_ERROR 
KIN_SUCCESS 
KIN_PERM_DENIE
D

Opens the specified 
Image Servers file. If 
filename is not speci-
fied, the Select 
Images Servers file 
dialog is opened. 
Note: Input parame-
ter must be given to 
get a valid returned 
error code.

Image Manager > 
Settings > Image 
Servers > File

IMGMANAGER 
SRVFILE SAVE

NONE KIN_ERROR 
KIN_SUCCESS 
KIN_PERM_DENIE
D

Save changes to the 
current Image Serv-
ers file.

Image Manager > 
Settings > Image 
Servers > File

IMGMANAGER 
SRVFILE SAVEAS 
[filename]

Input: [STRING] KIN_ERROR 
KIN_SUCCESS 
KIN_PERM_DENIE
D

Saves the current 
Image Servers file 
under the specified 
filename. If filename 
is not specified, the 
Select Image Servers 
File dialog is 
opened. Note: Input 
parameter must be 
given to get a valid 
returned error code.

Image Manager > 
Settings > Image 
Servers > File

GeoTIFF KeyIns

IMG GEOTIFFDE-
FAULTUNIT GET 
[unitLabel]

Output: STRING KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Returns the default 
unit used to interpret 
Geotiff files georefer-
ence data if no unit 
is defined in the geo-
tiff geocoding tags. 
The value is returned 
as a unit label. Units 
label are defined in 
ini file. If no output 
parameter are speci-
fied, we display cur-
rent value on screen.

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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Stamping Key-ins
IMG GEOTIFFDE-
FAULTUNIT SET 
<unitLabel>

Input: STRING KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Sets the default unit 
used to interpret 
Geotiff files georefer-
ence data if no unit 
is defined in the geo-
tiff geocoding tags. 
Units label are 
defined in ini file.

Stamping Key-ins

IMGEDIT STAMP 
AUTOSETTINGS

NONE KIN_ERROR 
KIN_SUCCESS

Set the Stamp Set-
tings with the Line 
Weight and Style dis-
played at the 
desired Zoom magni-
fication

Image Manager > 
Tools > Stamp >  
Automatic Stamp 
Vector Settings

Mosaic Key-ins

IMGMOSA BAL-
ANCE TONE

NONE KIN_SUCCESS Start the Balance 
Tone command.

Image Manager > 
Tools > Mosaic

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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Mosaic Key-ins
IMGMOSA BAL-
TONE BATCHEXE-
CUTE

NONE KIN_ERROR 
KIN_SUCCESS

Execute the Balance 
Tone command on 
selected images in 
Image Manager. Use 
IMGMOSA BAL-
TONE SETBATCH-
VIEW to specify the 
view into which the 
command will be 
applied. If selected 
mode is Average, at 
least two images 
must be selected in 
the specified view. 
If mode is Reference, 
at least one image 
must be selected, 
and a reference 
image must be speci-
fied with IMGMOSA 
BALTONE SET-
BATCHREFIMG.

Unavailable in the 
graphical interface

IMGMOSA BAL-
TONE GETAVER-
AGEAREA (Area)

Output: STRING KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Get current source 
area for “average” 
mode. (Area = ALL | 
OVERLAP)

Image Manager > 
Tools > Mosaic

IMGMOSA BAL-
TONE GET-
BATCHREFIMG 
(ImageName)

Output: STRING KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Get the name of the 
reference image set 
with IMGMOSA BAL-
TONE SETBATCHRE-
FIMG.

Unavailable in the 
graphical interface

IMGMOSA BAL-
TONE GET-
BATCHREFVIEW 
(View)

Output: SHORT KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Get the view that 
was set with IMG-
MOSA BALTONE 
SETBATCHREFVIEW

Unavailable in the 
graphical interface

IMGMOSA BAL-
TONE GET-
BATCHVIEW 
(View)

Output: SHORT KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Get the view that 
was set with IMG-
MOSA BALTONE 
SETBATCHVIEW

Unavailable in the 
graphical interface

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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Mosaic Key-ins
IMGMOSA BAL-
TONE GETHIS-
TORES 
(Resolution)

Output: SHORT KIN_INVALID_PAR
AM KIN_SUCCESS

Get current image 
resolution used to 
compute histogram 
of an area during 
Balance Tone pro-
cessing. (Resolution 
= 1, 2, 4, 8, 16, 32, 
64, ...)

Unavailable in the 
graphical interface

IMGMOSA BAL-
TONE GETMODE 
(Mode)

Output: STRING KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Get current mode for 
Balance Tone com-
mand. (Mode = 
AVERAGE | REFER-
ENCE)

Image Manager > 
Tools > Mosaic

IMGMOSA BAL-
TONE GETRE-
FAREA (RefArea)

Output: STRING KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Get current source 
area for “from refer-
ence” mode. 
(RefArea = ALL | 
OVERLAP | BLOCK 
| ORBLOCK | ELE-
MENT | FENCE)

Image Manager > 
Tools > Mosaic

IMGMOSA BAL-
TONE SETAVER-
AGEAREA < ALL 
| OVERLAP >

Input: STRING KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Set current source 
area for “average” 
mode. 

Image Manager > 
Tools > Mosaic

IMGMOSA BAL-
TONE SET-
BATCHREFIMG 
<ImageName>

Input: STRING KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Used in conjunction 
with IMGMOSA BAL-
TONE BATCHEXE-
CUTE. This key-in 
sets the reference 
image for batch pro-
cessing.

Unavailable in the 
graphical interface

IMGMOSA BAL-
TONE SET-
BATCHREFVIEW 
<View>

Input: SHORT KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Used in conjunction 
with IMGMOSA BAL-
TONE BATCHEXE-
CUTE. This key-in 
sets the view of the 
reference image for 
batch processing.

Unavailable in the 
graphical interface

Key-In Parameters Returned Error 
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Description Graphical 
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Mosaic Key-ins
IMGMOSA BAL-
TONE SETBATCH-
VIEW <View>

Input: SHORT KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Used in conjunction 
with IMGMOSA BAL-
TONE BATCHEXE-
CUTE. This key-in 
sets the view into 
which the Balance 
Tone command will 
be applied.

Unavailable in the 
graphical interface

IMGMOSA BAL-
TONE SETHIS-
TORES 
<Resolution>

Input: SHORT KIN_INVALID_PAR
AM KIN_SUCCESS

Set current image 
resolution used to 
compute histogram 
of an area during 
Balance Tone pro-
cessing. (Resolution 
= 1, 2, 4, 8, 16, 32, 
64, ...)

Unavailable in the 
graphical interface

IMGMOSA BAL-
TONE SETMODE 
<AVERAGE | REF-
ERENCE >

Input: STRING KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Set current mode for 
Balance Tone com-
mand.

Image Manager > 
Tools > Mosaic

IMGMOSA BAL-
TONE SETRE-
FAREA <ALL | 
OVERLAP | 
BLOCK | 
ORBLOCK | ELE-
MENT | FENCE >

Input: STRING KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Set current source 
area for “from refer-
ence” mode. 

Image Manager > 
Tools > Mosaic

IMGMOSA 
DEFINE SEAM

NONE KIN_SUCCESS Start the Define Seam 
command.

Image Manager > 
Tools > Mosaic

Key-In Parameters Returned Error 
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Mosaic Key-ins
IMGMOSA DEF-
SEAM BATCHEXE-
CUTE

NONE KIN_ERROR 
KIN_SUCCESS

Execute the Define 
Seam command on 
two selected images 
in Image Manager. 
Use IMGMOSA DEF-
SEAM SETBATCH-
VIEW to specify the 
view into which the 
command will be 
applied. Exactly two 
images must be 
selected in the speci-
fied view.

Unavailable in the 
graphical interface

IMGMOSA DEF-
SEAM GETBATCH-
VIEW (View)

Output: SHORT KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Get the view that 
was set with IMG-
MOSA DEFSEAM 
SETBATCHVIEW

Unavailable in the 
graphical interface

IMGMOSA DEF-
SEAM 
GETONOFFFEATH
ERING (Status)

Output: SHORT KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Return the status of 
the “Feathering” tog-
gle (Status = TRUE | 
FALSE).

Image Manager > 
Tools > Mosaic

IMGMOSA DEF-
SEAM 
GETONOFF-
SAVESEAM (Status)

Output: SHORT KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Return the status of 
the “Save Seam” tog-
gle (Status = TRUE | 
FALSE).

Image Manager > 
Tools > Mosaic

IMGMOSA DEF-
SEAM GETSEAM-
TYPE (Type)

Output: STRING KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Get current seam 
type for Define Seam 
command. (Type = 
QUICK | USER | 
ELEMENT)

Image Manager > 
Tools > Mosaic

IMGMOSA DEF-
SEAM GETTRANSP 
(Color)

Output: SHORT KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Get current “Trans-
parent Background 
Color” from the Tool 
Settings dialog. (0 to 
255)

Image Manager > 
Tools > Mosaic

IMGMOSA DEF-
SEAM GET-
WIDTH (Width)

Output: DOUBLE KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Get current feather-
ing width (in master 
units) from the Tool 
Settings dialog.

Image Manager > 
Tools > Mosaic

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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Mosaic Key-ins
IMGMOSA DEF-
SEAM SETBATCH-
VIEW <View>

Input: SHORT KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Used in conjunction 
with IMGMOSA DEF-
SEAM BATCHEXE-
CUTE.  Use this key-
in to specify the view 
into which the 
Define Seam com-
mand will be 
applied. 

Unavailable in the 
graphical interface

IMGMOSA DEF-
SEAM SET-
OFFFEATHERING

NONE KIN_ERROR 
KIN_SUCCESS

Set “Feathering” tog-
gle to OFF.

Image Manager > 
Tools > Mosaic

IMGMOSA DEF-
SEAM SETOFF-
SAVESEAM

NONE KIN_ERROR 
KIN_SUCCESS

Set “Save Seam” tog-
gle to OFF.

Image Manager > 
Tools > Mosaic

IMGMOSA DEF-
SEAM SETON-
FEATHERING

NONE KIN_ERROR 
KIN_SUCCESS

Set “Feathering” tog-
gle to ON.

Image Manager > 
Tools > Mosaic

IMGMOSA DEF-
SEAM SETON-
SAVESEAM

NONE KIN_ERROR 
KIN_SUCCESS

Set “Save Seam” tog-
gle to ON.

Image Manager > 
Tools > Mosaic

IMGMOSA DEF-
SEAM SETSEAM-
TYPE <QUICK | 
USER | ELEMENT 
>

Input: STRING KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Set current seam 
type for Define Seam 
command.

Image Manager > 
Tools > Mosaic

IMGMOSA DEF-
SEAM SETTRANSP 
<Color>

Input: SHORT KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Set current “Trans-
parent Background 
Color” of the Tool 
Settings dialog. (0 to 
255)

Image Manager > 
Tools > Mosaic

IMGMOSA DEF-
SEAM SETWIDTH 
<Width>

Input: DOUBLE KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Set current feathering 
width (in master 
units) of the Tool 
Settings dialog. 

Image Manager > 
Tools > Mosaic

Key-In Parameters Returned Error 
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Register Key-ins
IMGMOSA IMG-
VERSION GET 
(version) (subver-
sion) (revision) 
(subrevision)

Output: SHORT 
SHORT SHORT 
SHORT

KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Returns the required 
version, subversion, 
revision and subrevi-
sion of Reprograph-
ics that should be 
used with this ver-
sion of Mosaic.

IMGMOSA TOOL-
MOSA CLOSE

NONE KIN_SUCCESS Close the Mosaic tool 
box.

Image Manager > 
Tools > Mosaic

IMGMOSA TOOL-
MOSA OPEN

NONE KIN_SUCCESS Open the Mosaic 
tool box.

Image Manager > 
Tools > Mosaic

IMGMOSA VER-
SION GET (ver-
sion) (subversion) 
(revision) (subrevi-
sion)

Output: SHORT 
SHORT SHORT 
SHORT

KIN_INVALID_PAR
AM KIN_ERROR 
KIN_SUCCESS

Returns the current 
version, subversion, 
revision and subrevi-
sion of Mosaic.

Register Key-ins

IMGREGISTER 
MODEL SETTPS

NONE KEY_SUCCESS Set the current trans-
formation model to 
Thin Plate Spline.

Image Manager > 
Utilities > Register

IMGREGISTER 
RSPINDPIX GET 
(value)

Ouput: LONG KIN_INVALID_PAR
AM KIN_SUCCESS

Return the dpi X of 
the input window. 

Idem

IMGREGISTER 
RSPINDPIY GET 
(value)

Ouput: LONG KIN_INVALID_PAR
AM KIN_SUCCESS

Return the dpi Y of 
the input window. 

Idem

IMGREGISTER 
RSPINSCALEFAC-
TOR GET (value)

Ouput: DOUBLE KIN_INVALID_PAR
AM KIN_SUCCESS

Returns the scale fac-
tor of the input win-
dow 

Image Manager > 
Utilities > Register 
>   Apply>  To Image 
> Window Input

IMGREGISTER 
RSPOUTDPIX 
GET (value)

Ouput: LONG KIN_INVALID_PAR
AM KIN_SUCCESS

Returns the dpi X of 
the output window. 

Idem

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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IMGREGISTER 
RSPOUTDPIX SET 
<value>

Input: LONG KIN_INVALID_PAR
AM KIN_SUCCESS

Sets the dpi X of the 
output window.

Idem

IMGREGISTER 
RSPOUTDPIY 
GET (value)

Ouput: LONG KIN_INVALID_PAR
AM KIN_SUCCESS

Returns the dpi Y of 
the output window. 

Idem

IMGREGISTER 
RSPOUTDPIY SET 
<value>

Input: LONG KIN_INVALID_PAR
AM KIN_SUCCESS

Sets the dpi Y of the 
output window.

Idem

IMGREGISTER 
RSPOUTSCALE-
FACTOR GET 
(value)

Output: DOUBLE KIN_INVALID_PAR
AM KIN_SUCCESS

Returns the scale fac-
tor of the output 
window 

Image Manager > 
Utilities > Register 
>   Apply>  To Image 
> Window Output

IMGREGISTER 
RSPOUTSCALE-
FACTOR SET 
<value>

Input: DOUBLE KIN_INVALID_PAR
AM KIN_SUCCESS

Sets the scale factor 
of the output win-
dow 

Idem

Image Transform Key-ins

IMGTRANSFORM 
IMAGE MODIFY

NONE KIN_NOIMAGE 
KIN_FILE_READ_
ONLY 
KIN_SUCCESS

Start the Modify 
Image command.

Image Manager > 
Tools > Image Trans-
form

IMGTRANSFORM 
MODIFY 
GETAFFINITY 
(value)

Output: DOUBLE KIN_INVALID_PAR
AM KIN_SUCCESS

Return the affinity 
angle. 

Image Manager > 
Tools > Image Trans-
form

IMGTRANSFORM 
MODIFY GETD-
PIX (value)

Ouput: LONG KIN_INVALID_PAR
AM KIN_SUCCESS 
KIN_PERM_DENIE
D

Return the dpi about 
the X-axis. 

Image Manager > 
Tools > Image Trans-
form

IMGTRANSFORM 
MODIFY GETD-
PIY (value)

Ouput: LONG KIN_INVALID_PAR
AM KIN_SUCCESS 
KIN_PERM_DENIE
D

Return the dpi about 
the Y-axis. 

Image Manager > 
Tools > Image Trans-
form

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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IMGTRANSFORM 
MODIFY GET-
LOCKPIXELSIZE 
(State)

Output: SHORT KIN_INVALID_PAR
AM KIN_SUCCESS

Returns the status of 
the locking option 
for the pixel size and 
dpi.

Image Manager > 
Tools > Image Trans-
form

IMGTRANSFORM 
MODIFY GET-
ORIGINX (value)

Ouput: STRING KIN_INVALID_PAR
AM KIN_SUCCESS

Return the abscissa 
of the image origin, 
In Working units (ex: 
1:150.000) . 

Image Manager > 
Tools > Image Trans-
form

IMGTRANSFORM 
MODIFY GET-
ORIGINY (value)

Ouput: DOUBLE KIN_INVALID_PAR
AM KIN_SUCCESS

Return the ordinate 
of the image origin. 

Image Manager > 
Tools > Image Trans-
form

IMGTRANSFORM 
MODIFY GETPIX-
ELSIZEX (value)

Ouput: STRING KIN_INVALID_PAR
AM KIN_SUCCESS

Return the pixel 
width of the image, 
in Working units 
(ex: 1:150.000)

Image Manager > 
Tools > Image Trans-
form

IMGTRANSFORM 
MODIFY GETPIX-
ELSIZEY (value)

Ouput: STRING KIN_INVALID_PAR
AM KIN_SUCCESS

Return the pixel 
height of the image, 
in Working units 
(ex: 1:150.000) 

Image Manager > 
Tools > Image Trans-
form

IMGTRANSFORM 
MODIFY GETRO-
TATION (value)

Ouput: DOUBLE KIN_INVALID_PAR
AM KIN_SUCCESS

Return the rotation 
angle. 

Image Manager > 
Tools > Image Trans-
form

IMGTRANSFORM 
MODIFY 
GETSCALEFAC-
TOR (value)

Ouput: DOUBLE KIN_INVALID_PAR
AM KIN_SUCCESS 
KIN_PERM_DENIE
D

Return the scale fac-
tor. 

Image Manager > 
Tools > Image Trans-
form

IMGTRANSFORM 
MODIFY SET-
AFFINITY <value>

Input: DOUBLE KIN_INVALID_PAR
AM  KIN_SUCCESS 
KIN_PERM_DENIE
D

Set the affinity angle. Image Manager > 
Tools > Image Trans-
form

IMGTRANSFORM 
MODIFY SETD-
PIX <value>

Input: LONG KIN_INVALID_PAR
AM  KIN_SUCCESS 
KIN_PERM_DENIE
D

Set the dpi about 
the X-axis.

Image Manager > 
Tools > Image Trans-
form

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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IMGTRANSFORM 
MODIFY SETD-
PIY <value>

Input: LONG KIN_INVALID_PAR
AM  KIN_SUCCESS 
KIN_PERM_DENIE
D

Set the dpi about 
the Y-axis.

Image Manager > 
Tools > Image Trans-
form

IMGTRANSFORM 
MODIFY SET-
LOCKPIXEL-
SIZEOFF

NONE KIN_SUCCESS Sets the locking 
option of pixel size 
and dpi to OFF.

Image Manager > 
Tools > Image Trans-
form

IMGTRANSFORM 
MODIFY SET-
LOCKPIXEL-
SIZEON

NONE KIN_SUCCESS Sets the locking 
option of pixel size 
and dpi to ON.

Image Manager > 
Tools > Image Trans-
form

IMGTRANSFORM 
MODIFY SET-
ORIGINX <value>

Input: STRING KIN_INVALID_PAR
AM  KIN_SUCCESS 
KIN_PERM_DENIE
D

Set the abscissa of 
the image origin. 
value is in Working 
units (ex: 1:150.000).

Image Manager > 
Tools > Image Trans-
form

IMGTRANSFORM 
MODIFY SET-
ORIGINY <value>

Input: STRING KIN_INVALID_PAR
AM  KIN_SUCCESS 
KIN_PERM_DENIE
D

Set the ordinate of 
the image origin. 
value is in Working 
units (ex: 1:150.000)

Image Manager > 
Tools > Image Trans-
form

IMGTRANSFORM 
MODIFY SETPIX-
ELSIZEX <value>

Input: DOUBLE KIN_INVALID_PAR
AM  KIN_SUCCESS 
KIN_PERM_DENIE
D

Set the pixel width of 
the image.

Image Manager > 
Tools > Image Trans-
form

IMGTRANSFORM 
MODIFY SETPIX-
ELSIZEY <value>

Input: DOUBLE KIN_INVALID_PAR
AM  KIN_SUCCESS 
KIN_PERM_DENIE
D

Set the pixel height 
of the image.

Image Manager > 
Tools > Image Trans-
form

IMGTRANSFORM 
MODIFY SETRO-
TATION <value>

Input: DOUBLE KIN_INVALID_PAR
AM  KIN_SUCCESS 
KIN_PERM_DENIE
D

Set the rotation 
angle.

Image Manager > 
Tools > Image Trans-
form

IMGTRANSFORM 
MODIFY SET-
SCALEFACTOR 
<value>

Input: DOUBLE KIN_INVALID_PAR
AM  KIN_SUCCESS 
KIN_PERM_DENIE
D

Set the scale factor. Image Manager > 
Tools > Image Trans-
form

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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IMGTRANSFORM 
NEWIMAGE GET 
(State)

Output: SHORT KIN_INVALID_PAR
AM KIN_SUCCESS

Returns the current 
status of the “Create 
a new image” toggle 
(ON/OFF) used by 
the Image Transform 
tools.

Image Manager > 
Tools > Image Trans-
form

IMGTRANSFORM 
NEWIMAGE 
SETON

NONE KIN_ERROR 
KIN_SUCCESS

Sets the current sta-
tus of the “Create a 
New Image” toggle 
to ON.

Image Manager > 
Tools > Image Trans-
form

IMGTRANSFORM 
NEWIMAGE SET-
OFF

NONE KIN_ERROR 
KIN_SUCCESS

Sets the current sta-
tus of the “Create a 
New Image” toggle 
to OFF.

Image Manager > 
Tools > Image Trans-
form

Theme Styler Key-ins

IMGTHEME 
THEME GETNUM-
BERBYDGN <file 
number> <file 
position> (theme 
number)

Input: SHORT, 
LONG Output: 
LONG

KIN_ERROR 
KIN_INVALID_TH
EME 
KIN_INVALID_PAR
AM KIN_SUCCESS

Return the theme 
number of the speci-
fied DGN element.

Image Manager >  
Utilities > Theme 
Styler

IMGTHEME 
THEME SETNUM-
BERBYDGN <file 
number> <file 
position> <theme 
number> 

Input: SHORT, 
LONG, LONG

KIN_ERROR 
KIN_INVALID_TH
EME 
KIN_INVALID_PAR
AM KIN_SUCCESS

Set the theme num-
ber of the specified 
DGN element.

Image Manager >  
Utilities > Theme 
Styler

Vectorize Key-ins

IMGVECTORIZE 
AUTOSETERASER-
COLOR GET

Output: SHORT KIN_INVALID_PAR
AM KIN_SUCCESS

Return the current 
status of the “Auto 
Set Eraser Color” tog-
gle (ON/OFF) used 
by the Vectorize 
tools.

Image Manager > 
Tools > Vectorize

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
A-44 MicroStation Descartes User’s Guide



MicroStation Descartes Key-in Tables
Vectorize Key-ins
IMGVECTORIZE 
AUTOSETERASER-
COLOR SETOFF

NONE KIN_SUCCESS Set the current status 
of the “Auto Set 
Eraser Color” toggle 
to OFF.

Image Manager > 
Tools > Vectorize

IMGVECTORIZE 
AUTOSETERASER-
COLOR SETON

NONE KIN_SUCCESS Set the current status 
of the “Auto Set 
Eraser Color” toggle 
to ON.

Image Manager > 
Tools > Vectorize

IMGVECTORIZE 
COL-
ORIMGERASER-
COLOR GET

Ouput: STRING KIN_SUCCESS Gets the Eraser Color 
for a Color Image.. 

Image Manager > 
Tools > Vectorize

IMGVECTORIZE 
COL-
ORIMGERASER-
COLOR SET

Input: STRING KIN_SUCCESS Sets the Eraser Color 
for a Color Image.. 

Image Manager > 
Tools > Vectorize

IMGVECTORIZE 
ERASERASTER 
GET

Output: SHORT KIN_INVALID_PAR
AM KIN_SUCCESS

Return the current 
status of the “Erase 
Raster” toggle (ON/
OFF) used by the 
Vectorize tools.

Image Manager > 
Tools > Vectorize

IMGVECTORIZE 
ERASERASTER 
SETOFF

NONE KIN_SUCCESS Set the current status 
of the “Erase Raster” 
toggle to OFF.

Image Manager > 
Tools > Vectorize

IMGVECTORIZE 
ERASERASTER 
SETON

NONE KIN_SUCCESS Set the current status 
of the “Erase Raster” 
toggle to ON.

Image Manager > 
Tools > Vectorize

IMGVECTORIZE 
GENERATEVEC-
TOR GET

Output: SHORT KIN_INVALID_PAR
AM KIN_SUCCESS

Return the current 
status of the “Gener-
ate Vector” toggle 
(ON/OFF) used by 
the Vectorize tools.

IMGVECTORIZE 
GENERATEVEC-
TOR SETOFF

NONE KIN_SUCCESS Set the current status 
of the “Generate Vec-
tor” toggle to OFF.

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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IMGVECTORIZE 
GENERATEVEC-
TOR SETON

NONE KIN_SUCCESS Set the current status 
of the “Generate Vec-
tor” toggle to ON.

IMGVECTORIZE 
PLACEELMT SET-
AUTORESTORE-
MODE

NONE KIN_SUCCESS Back up current tool 
settings toggles and 
restore them at the 
end of Place Element 
command.

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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MicroStation Descartes Key-ins
MicroStation Descartes Key-ins

Project Key-ins

Key-In Parameters
Returned Error 
Codes

Description
Graphical 
Interface

IMG APPLICATION 
EXIT

NONE KIN_SUCCESS Unloads Descartes. Image Manager> 
File > 
Exit

IMG AUTOSAVE GET Output:
SHORT

KIN_ERROR 
KIN_SUCCESS

Returns the status (ON/
OFF) of the Auto Save 
and Attach feature.

Image Manager> 
Settings > 
Project > 
Auto Save and 
Attach

IMG AUTOSAVE  
SETOFF

NONE KIN_SUCCESS Sets the status of the 
Auto Save and Attach 
feature to OFF.

Image Manager> 
Settings > 
Project > 
Auto Save and 
Attach

IMG AUTOSAVE  
SETON

NONE KIN_SUCCESS Sets the status of the 
Auto Save and Attach 
feature to ON.

Image Manager> 
Settings > 
Project > 
Auto Save and 
Attach

IMG AUTOSAVE  
TOGGLE

NONE KIN_SUCCESS Toggles the status of 
the Auto Save and 
Attach feature.

Image Manager> 
Settings > 
Project > 
Auto Save and 
Attach

IMG DLGABOUT 
OPEN

NONE KIN_SUCCESS
KIN_ERROR

Opens the “About Des-
cartes” dialog.

Image Manager>
Help >
About Decartes…

IMG DLGHELP OPEN NONE KIN_SUCCESS
KIN_ERROR

Opens the Help dialog 
of Descartes.

Image Manager>
Help >
Contents
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IMG DLGPROJECT 
CLOSE

NONE KIN_SUCCESS Closes the Project 
Settings dialog.

Image Manager> 
Settings > Project 

IMG DLGPROJECT 
OPEN

NONE KIN_SUCCESS Opens the Project 
Settings dialog.

Image Manager> 
Settings > Project 

IMG FULLPATH  
SETOFF

NONE KIN_SUCCESS Sets the status of the 
Save Full Path feature to 
OFF.

Image Manager> 
Settings > Project 
> Save Full Path

IMG FULLPATH  
SETON

NONE KIN_SUCCESS Sets the status of the 
Save Full Path feature to 
ON.

Image Manager> 
Settings > Project 
> Save Full Path

IMG FULLPATH  
TOGGLE

NONE KIN_SUCCESS Toggles the status of the 
Save Full Path feature.

Image Manager> 
Settings > Project 
> Save Full Path

IMG FULLPATH GET 
(status)

Output:
SHORT

KIN_ERROR 
KIN_SUCCESS

Returns the status (ON/
OFF) of the Save Full 
Path feature.

Image Manager> 
Settings > Project 
> Save Full Path

IMG LANGUAGE 
GET (language)

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the first letter 
of the currently lan-
guage set.

IMG MAINVERSION 
GET (version) (sub-
version) (revision) 
(subrevision) [(fla-
vor)]

Output:
SHORT
SHORT
SHORT
SHORT
[STRING]

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the current 
Descartes version, sub-
version, revision, subre-
vision and if desired 
the flavor.

IMG METERSPE-
RUOR GET (factor)

Output:
DOUBLE

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the number of 
meters per units of res-
olution.

IMG PROJECT 
ATTACH

NONE KIN_ERROR 
KIN_SUCCESS

Saves and attach the 
current project to the 
Master Design File. 

Image Manager> 
File > 
Project > 
Attach

Key-In Parameters
Returned Error 
Codes

Description
Graphical 
Interface
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IMG PROJECT 
DETACH

NONE KIN_ERROR 
KIN_SUCCESS

Detach any Descartes 
project file from the 
Master Design File.

Image Manager> 
File > 
Project > 
Detach

IMG PROJECT 
EXPORTRASTER-
REF

NONE KIN_ERROR
KIN_SUCCESS

Detach all Images from 
the Image Manager list 
and attach them as raster 
reference to the current 
design file.

Image Manager> 
File > Project > 
Export Raster 
Reference

IMG PROJECT GET 
(name)

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the name of the 
current project. If no 
project is opened the 
answer is “NONE”.

IMG PROJECT 
GETKEEPCURRENT

NONE KIN_SUCCESS Gets the status of the 
option for keeping the 
current project open 
when changing to a 
new design file that 
does not have any 
project attached. 

IMG PROJECT 
IMPORTRASTERREF

NONE KIN_ERROR
KIN_SUCCESS

Detach all raster refer-
ence attachments from 
the current design file 
and attach them to the 
Image Manager list. 

Image Manager> 
File > Project > 
Import Raster 
Reference

IMG PROJECT NEW NONE KIN_SUCCESS Creates a new project 
with default settings.

Image Manager> 
File > 
Project > 
New

IMG PROJECT OPEN 
[filename]

Input:
[STRING]

KIN_FILE_NOT_FOUN
D
KIN_SUCCESS

Opens the specified 
project or open the file 
selector dialog if no file 
name is given.

Image Manager> 
File > 
Project > 
Open

IMG PROJECT SAVE NONE KIN_ERROR
KIN_SUCCESS

Saves the current 
project.

Image Manager> 
File > 
Project > 
Save

Key-In Parameters
Returned Error 
Codes

Description
Graphical 
Interface
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IMG PROJECT 
SAVEAS [filename] 

Input:
[STRING]

KIN_FILE_EXIST
KIN_ERROR
KIN_SUCCESS

Saves the current 
project under the speci-
fied name or opens the 
file creation dialog if no 
file name is given.
Note: Input Parameters 
must be given to get a 
valid returned error 
code.

Image Manager> 
File > 
Project > 
Save As

IMG PROJECT SET-
KEEPCURRENTOFF

NONE KIN_SUCCESS Sets to OFF the option 
of keeping the current 
project open when no 
project is attached to 
the new design file.

IMG PROJECT SET-
KEEPCURRENTON

NONE KIN_SUCCESS Sets to ON the option 
of keeping the current 
project open when no 
project is attached to 
the new design file.

IMG TOOLCNV-
TOVECTOR CLOSE

NONE KIN_SUCCESS Closes the Convert To 
Vector tool frame.

Image Manager> 
Tools >
Convert To Vector

IMG TOOLCNV-
TOVECTOR OPEN

NONE KIN_SUCCESS Opens the Convert To 
Vector tool frame.

Image Manager> 
Tools > 
Convert To Vector

IMG TOOLEDIT 
CLOSE

NONE KIN_SUCCESS Closes the Edit tool 
frame.

Image Manager> 
Tools >
Edit

IMG TOOLEDIT 
OPEN

NONE KIN_SUCCESS Opens the Edit tool 
frame.

Image Manager> 
Tools >
Edit

IMG TOOLMAIN 
CLOSE

NONE KIN_SUCCESS Closes the Image Main 
tool frame.

Image Manager> 
Tools >
Image Main

Key-In Parameters
Returned Error 
Codes

Description
Graphical 
Interface
A-50 MicroStation Descartes User’s Guide



MicroStation Descartes Key-in Tables
Project Key-ins
IMG TOOLMAIN 
OPEN

NONE KIN_SUCCESS Opens the Image Main 
tool frame.

Image Manager> 
Tools >
Image Main

IMG TOOLPREPARE 
CLOSE

NONE KIN_SUCCESS Closes the Prepare tool 
frame.

Image Manager> 
Tools >
Prepare

IMG TOOLPREPARE 
OPEN

NONE KIN_SUCCESS Opens the Prepare tool 
frame.

Image Manager> 
Tools >
Prepare

Key-In Parameters
Returned Error 
Codes

Description
Graphical 
Interface
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Image Edit Key-ins

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface

IMGEDIT CHAN-
NELS APPLY

NONE KIN_NOIMAGE
KIN_FILE_READ_ONLY
KIN_ERROR
KIN_SUCCESS

Saves color table 
changes to the active 
image.

Image Manager> 
Utilities > 
Image Channels>
File > 
Apply

IMGEDIT CHAN-
NELS DEFAULT

NONE KIN_NOIMAGE
KIN_ERROR
KIN_SUCCESS

Resets all settings of 
Image Channels to 
default values.

Image Manager> 
Utilities > 
Image Channels 

IMGEDIT CHAN-
NELS DONE

NONE KIN_NOIMAGE
KIN_FILE_READ_ONLY
KIN_ERROR
KIN_SUCCESS

Save changes to the 
Color table of the active 
image.

Image Manager> 
Utilities > 
Image Channels

IMGEDIT CHAN-
NELS GETBLUE 
(state)

Output:
SHORT

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the Image 
Blue channel status. 

Image Manager> 
Utilities > 
Image Channels

IMGEDIT CHAN-
NELS GETGREEN 
(state)

Output:
SHORT

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the Image 
Green channel status. 

Image Manager> 
Utilities > 
Image Channels

IMGEDIT CHAN-
NELS GETMODE 
(mode)

Output:
STRING

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the current col-
oring mode (COLOR 
or GRAY). 

Image Manager> 
Utilities > 
Image Channels

IMGEDIT CHAN-
NELS GETPOLARITY 
(polarity)

Output:
STRING

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the current col-
oring Polarity (POSI-
TIVE or NEGATIVE).

Image Manager> 
Utilities > 
Image Channels

IMGEDIT CHAN-
NELS GETRED 
(state)

Output:
SHORT

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the Image Red 
channel status. 

Image Manager> 
Utilities > 
Image Channels
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IMGEDIT CHAN-
NELS LOAD 
[filename]

Input:
[STRING]

KIN_NOIMAGE
KIN_FILE_NOT_FOUN
D
KIN_ERROR
KIN_SUCCESS

Loads the specified 
color table. If filename 
is not specified, the 
Load Palette dialog 
opens.
Note: Input parameter 
must be given to get a 
valid returned error 
code.

Image Manager> 
Utilities > 
Image Channels >
File > 
Load Color Table

IMGEDIT CHAN-
NELS SAVEAS 
[filename]

Input:
[STRING]

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_FILE_EXIST
KIN_ERROR
KIN_SUCCESS

Saves the current color 
table in the specified 
file. If filename is not 
specified, the Save Pal-
ette dialog opens.
Note: Input parameter 
must be given to get a 
valid returned error 
code.

Image Manager> 
Utilities > 
Image Channels>
File > 
Save As

IMGEDIT CHAN-
NELS SETCOLOR-
MODE

NONE KIN_NOIMAGE
KIN_ERROR
KIN_SUCCESS

Sets the coloring mode 
to COLOR.

Image Manager> 
Utilities > 
Image Channels

IMGEDIT CHAN-
NELS SETGRAY-
MODE

NONE KIN_NOIMAGE
KIN_ERROR
KIN_SUCCESS

Sets the coloring mode 
to GRAYSCALE.

Image Manager> 
Utilities > 
Image Channels

IMGEDIT CHAN-
NELS SETNEG-
POLARITY 

NONE KIN_NOIMAGE
KIN_ERROR
KIN_SUCCESS

Sets the coloring Polar-
ity to NEGATIVE.

Image Manager> 
Utilities > 
Image Channels

IMGEDIT CHAN-
NELS SETOFFBLUE 

NONE KIN_NOIMAGE
KIN_ERROR
KIN_SUCCESS

Sets the Image Blue 
channel status to OFF.

Image Manager> 
Utilities > 
Image Channels

IMGEDIT CHAN-
NELS SETOFFGREEN

NONE KIN_NOIMAGE
KIN_ERROR
KIN_SUCCESS

Sets the Image Green 
channel status to OFF.

Image Manager> 
Utilities > 
Image Channels

IMGEDIT CHAN-
NELS SETOFFRED

NONE KIN_NOIMAGE
KIN_ERROR
KIN_SUCCESS

Sets the Image Red 
channel status to OFF.

Image Manager> 
Utilities > 
Image Channels

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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IMGEDIT CHAN-
NELS SETONBLUE

NONE KIN_NOIMAGE
KIN_ERROR
KIN_SUCCESS

Sets the Image Blue 
channel status to ON.

Image Manager> 
Utilities > 
Image Channels

IMGEDIT CHAN-
NELS SETONGREEN

NONE KIN_NOIMAGE
KIN_ERROR
KIN_SUCCESS

Sets the Image Green 
channel status to ON.

Image Manager> 
Utilities > 
Image Channels

IMGEDIT CHAN-
NELS SETONRED

NONE KIN_NOIMAGE
KIN_ERROR
KIN_SUCCESS

Sets the Image Red 
channel status to ON.

Image Manager> 
Utilities > 
Image Channels

IMGEDIT CHAN-
NELS SETPOS-
POLARITY 

NONE KIN_NOIMAGE
KIN_ERROR
KIN_SUCCESS

Sets the coloring Polar-
ity to POSITIVE. 

Image Manager> 
Utilities > 
Image Channels

IMGEDIT CLEANUP 
GETAREA

Output:
STRING

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Get the current area 
type for Clean Up. 

Image Manager> 
Tools > 
Clean Up 

IMGEDIT CLEANUP 
GETAREAOBJFILTER

Output:
STRING

KIN_ERROR
KIN_SUCCESS

Returns the Raster 
Object filter name. 
If the image is 1bit, 
possible filter names 
are foreground and 
background.

Image Manager> 
Tools > 
Clean Up

IMGEDIT CLEANUP 
GETCOLOR

Output:
LONG

KIN_ERROR
KIN_SUCCESS

Returns the current 
color.
Color indexes range 
from 0 to 255, 
Only available with 8 
bit image.

Image Manager> 
Tools > 
Clean Up

IMGEDIT CLEANUP 
GETFILTER

Output:
STRING

KIN_ERROR
KIN_SUCCESS

Returns the current fil-
ter name.

Image Manager> 
Tools > 
Clean Up

IMGEDIT CLEANUP 
GETPIXELSIZE 
(pixels)

Output:
LONG

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the current 
speckle size in pixels. 

Image Manager> 
Tools > 
Clean Up
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IMGEDIT CLEANUP 
HOLE

NONE KIN_NOIMAGE
KIN_INVALID_SETTIN
GS
KIN_ERROR
KIN_SUCCESS

Apply hole removal to 
the selected area.

Image Manager> 
Tools > 
Clean Up

IMGEDIT CLEANUP 
SETAREA 
<BLOCK|ELEMENT|
FENCE|IMAGE|>

Input:
STRING

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Sets the area to the 
specified one Block.

Image Manager> 
Tools > 
Clean Up

IMGEDIT CLEANUP 
SETAREAOBJFILTER
<filterName>

Input:
STRING

KIN_INVALID_PARAM 
KIN_ERROR
KIN_SUCCESS

Sets the Raster Object 
filter. If the image is 
1bit, possible filter 
names are foreground 
and background.

Image Manager> 
Tools > 
Clean Up

IMGEDIT CLEANUP 
SETCOLOR
<colorIndex>

Input:
LONG

KIN_INVALID_PARAM 
KIN_ERROR
KIN_SUCCESS

Set the current color 
index used for erasing. 
Value ranges from 0 to 
255. 

Image Manager> 
Tools > 
Clean Up

IMGEDIT CLEANUP 
SETFILTER
<filterName>

Input:
STRING

KIN_INVALID_PARAM 
KIN_ERROR
KIN_SUCCESS

Set the filter name used 
by the Clean Up tools.

Image Manager> 
Tools > 
Clean Up

IMGEDIT CLEANUP 
SETPIXELSIZE 
<pixels>

Input:
LONG

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Sets the speckle size in 
pixels. 

Image Manager> 
Tools > 
Clean Up

IMGEDIT CLEANUP 
SPECKLE

NONE KIN_NOIMAGE
KIN_INVALID_SETTIN
GS
KIN_ERROR
KIN_SUCCESS

Removes speckles in 
the selected area.

Image Manager> 
Tools > 
Clean Up

IMGEDIT COMPRES-
SION GETBLUE 
(filename)

Output:
STRING

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the Blue Chan-
nel Input file name. If 
no filename was set, 
the returned value is 
“NONE”.

Image Manager> 
Utilities > 
Color Compres-
sion
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IMGEDIT COMPRES-
SION GETCOLORS 
(count)

Output:
SHORT

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the current 
number of colors for 
the compression setup.

Image Manager> 
Utilities > 
Color Compres-
sion

IMGEDIT COMPRES-
SION GETCOL-
WEIGHT 
(state)

Output:
SHORT

KIN_INVALID_SETTIN
GS
KIN_ERROR
KIN_SUCCESS

Returns the status of 
the Use Color as Weight 
option. The status is 
ON or OFF.

Image Manager> 
Utilities > 
Color Compres-
sion

IMGEDIT COMPRES-
SION GETCOMPFILE 
(filename)

Output:
STRING

KIN_INVALID_PARAM
KIN_ERRROR
KIN_SUCCEE

Returns the current 
color compression file 
name. If no filename 
was set, the returned 
value is “NONE”.

Image Manager> 
Utilities > 
Color Compres-
sion

IMGEDIT COMPRES-
SION GETCURRENT-
SEL 
(state)

Output:
SHORT

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the status of 
the Use Current Selec-
tion option. The status 
is ON or OFF.

Image Manager> 
Utilities > 
Color Compres-
sion

IMGEDIT COMPRES-
SION GETDATA-
COMP 
(mode)

Output:
STRING

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the output Data 
Compression mode. 
Modes are NONE or 
DEFLATE.

Image Manager> 
Utilities > 
Color Compres-
sion

IMGEDIT COMPRES-
SION GETGREEN 
(filename)

Output:
STRING

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the Green 
Channel Input file 
name. If no file name 
was set, the returned 
value is “NONE”.

Image Manager> 
Utilities > 
Color Compres-
sion

IMGEDIT COMPRES-
SION GETINFILE 
(filename)

Output:
STRING

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the Palette 
Input file name. If no 
file name was set the 
returned value, is 
“NONE”.

Image Manager> 
Utilities > 
Color Compres-
sion

IMGEDIT COMPRES-
SION GETMODE 
(mode)

Output:
STRING

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the current 
compression mode for 
the compression setup. 
Modes are CUSTOM, 
USESTD (Use Standard) 
or CREATESTD (Create 
standard).

Image Manager> 
Utilities > 
Color Compres-
sion
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IMGEDIT COMPRES-
SION GETOUTFILE 
(filename)

Output:
STRING

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the Output file 
name. If no file name 
was set, the returned 
value is “NONE”.

Image Manager> 
Utilities > 
Color Compres-
sion

IMGEDIT COMPRES-
SION GETRED 
(filename)

Output:
STRING

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the Red Chan-
nel Input file name. If 
no file name was set, 
the returned value is 
“NONE”.

Image Manager> 
Utilities > 
Color Compres-
sion

IMGEDIT COMPRES-
SION GETTYPE 
(typename)

Output:
STRING

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the current 
Input Type (RGB or 
PALETTE).

Image Manager> 
Utilities > 
Color Compres-
sion

IMGEDIT COMPRES-
SION RESET

NONE KIN_ERROR
KIN_SUCCESS

Reset color compres-
sion settings to default 
values.

Image Manager> 
Utilities > 
Color Compres-
sion

IMGEDIT COMPRES-
SION RUN

NONE KIN_MISSING_SETTIN
GS
KIN_NEED_INTERACTI
ON
KIN_ERROR
KIN_SUCCESS

Executes the color 
compression with the 
current settings. 

Image Manager> 
Utilities > 
Color Compres-
sion

IMGEDIT COMPRES-
SION SETBLUE 
<filename>

Input:
STRING

KIN_INVALID_PARAM
KIN_INVALID_SETTIN
GS
KIN_FILE_NOT_FOUN
D
KIN_INVALID_FILE_NA
ME
KIN_ERROR
KIN_SUCCESS

Sets the Blue Channel 
Input file when Input 
Type is RGB. If Input 
Type is Palette, 
KIN_INVALID_SETTIN
GS is returned.

Image Manager> 
Utilities > 
Color Compres-
sion

IMGEDIT COMPRES-
SION SETCOLORS 
<count>

Input:
SHORT

KIN_INVALID_PARAM
KIN_INVALID_SETTIN
GS
KIN_ERROR
KIN_SUCCESS

Sets the number of col-
ors for the compression 
setup. Available only if 
the compression mode 
is CUSTOM or CREAT-
ESTD. Default: CUS-
TOM.

Image Manager> 
Utilities > 
Color Compres-
sion
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IMGEDIT COMPRES-
SION SETCOMPFILE 
<filename>

Input:
STRING

KIN_INVALID_PARAM
KIN_INVALID_SETTIN
GS
KIN_ERRROR
KIN_SUCCEE

Sets the color compres-
sion file name. Avail-
able if the compression 
mode is USESTD or 
CREATESTD. Default: 
USESTD.

Image Manager> 
Utilities > 
Color Compres-
sion

IMGEDIT COMPRES-
SION SETDATACOMP 
<NONE | DEFLATE>

Input:
STRING

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Sets the output Data 
Compression option to 
NONE or DEFLATE.

Image Manager> 
Utilities > 
Color Compres-
sion 

IMGEDIT COMPRES-
SION SETGREEN 
<filename>

Input:
STRING

KIN_INVALID_PARAM
KIN_INVALID_SETTIN
GS
KIN_FILE_NOT_FOUN
D
KIN_INVALID_FILE_NA
ME
KIN_ERROR
KIN_SUCCESS

Sets the Green Chan-
nel Input file name 
when Input Type is 
RGB. If Input Type is 
Palette, 
KIN_INVALID_SETTIN
GS is returned.

Image Manager> 
Utilities > 
Color Compres-
sion Green:

IMGEDIT COMPRES-
SION SETINFILE 
<filename>

Input:
STRING

KIN_INVALID_PARAM
KIN_INVALID_SETTIN
GS
KIN_FILE_NOT_FOUN
D
KIN_INVALID_FILE_NA
ME
KIN_ERROR
KIN_SUCCESS

Sets the Input file name 
when Input Type is 
Palette. If Input Type 
is RGB, 
KIN_INVALID_SETTIN
GS is returned.

Image Manager> 
Utilities > 
Color Compres-
sion

IMGEDIT COMPRES-
SION SETMODE 
<CUSTOM | 
USESTD | CREAT-
ESTD>

Input:
STRING

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Sets the color compres-
sion mode for the com-
pression setup. Modes 
are CUSTOM, USESTD 
(Use Standard) or CRE-
ATESTD (Create stan-
dard).

Image Manager> 
Utilities > 
Color Compres-
sion

IMGEDIT COMPRES-
SION SETOFFCOL-
WEIGHT

NONE KIN_INVALID_SETTIN
GS
KIN_ERROR
KIN_SUCCESS

Sets the Use Color as 
Weight to OFF. If Use 
Current Selection is Off, 
KIN_INVALID_SETTIN
GS is returned.

Image Manager> 
Utilities > 
Color Compres-
sion
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IMGEDIT COMPRES-
SION SETOFFCUR-
RENTSEL

NONE KIN_ERROR
KIN_SUCCESS

Sets the Use Current 
Selection to OFF.

Image Manager> 
Utilities > 
Color Compres-
sion

IMGEDIT COMPRES-
SION SETONCOL-
WEIGHT

NONE KIN_INVALID_SET-
TINGS
KIN_ERROR
KIN_SUCCESS

Sets the Use Color as 
Weight to ON. If Use 
Current Selection is Off, 
KIN_INVALID_SET-
TINGS is returned.

Image Manager> 
Utilities > 
Color Compres-
sion

IMGEDIT COMPRES-
SION SETON-
CURRENTSEL

NONE KIN_ERROR
KIN_SUCCESS

Sets the Use Current 
Selection to ON.

Image Manager> 
Utilities > 
Color Compres-
sion

IMGEDIT COMPRES-
SION SETOUTFILE 
<filename>

Input:
STRING

KIN_INVALID_PARAM
KIN_FILE_EXIST
KIN_ERROR
KIN_SUCCESS

Sets the Output File-
name.

Image Manager> 
Utilities > 
Color Compres-
sion

IMGEDIT COMPRES-
SION SETPALETTE-
TYPE

NONE KIN_ERROR
KIN_SUCCESS

Sets the Input Type to 
Palette. 

Image Manager> 
Utilities > 
Color Compres-
sion

IMGEDIT COMPRES-
SION SETRED 
<filename>

Input:
STRING

KIN_INVALID_PARAM
KIN_INVALID_SET-
TINGS
KIN_FILE_NOT_
FOUN
KIN_INVALID_FILE_
NAME
KIN_ERROR
KIN_SUCCESS

Sets the Red Channel 
Input Filename. If Input 
Type is Palette,  
KIN_INVALID_SET-
TINGS is returned.

Image Manager> 
Utilities > 
Color Compres-
sion

IMGEDIT COMPRES-
SION SETRGBTYPE

NONE KIN_ERROR
KIN_SUCCESS

Sets the Input Type 
option to RGB. 

Image Manager> 
Utilities > 
Color Compres-
sion

IMGEDIT CON-
TRAST APPLY

NONE KIN_NOIMAGE
KIN_FILE_READ_ONLY
KIN_ERROR
KIN_SUCCESS

Saves color table 
changes to the active 
image.

Image Manager> 
Utilities > 
Contrast Stretch>
File > Apply
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IMGEDIT CON-
TRAST SAVEAS 
[filename]

Input:
[STRING]

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_FILE_EXIST
KIN_ERROR
KIN_SUCCESS

Saves the current color 
table in the specified 
file. If filename is not 
specified, the Save Pal-
ette dialog opens.
Note: Input parameter 
must be given to get a 
valid returned error 
code.

Image Manager> 
Utilities > 
Contrast Stretch>
File > Save As

IMGEDIT CONT-
STRETCH DONE

NONE KIN_NOIMAGE
KIN_FILE_READ_ONLY
KIN_ERROR
KIN_SUCCESS

Saves changes made 
with the contrast stretch 
to the color table of the 
active image.

Image Manager> 
Utilities >
Contrast Stretch

IMGEDIT CONT-
STRETCH GET-
EXPONENT 
(exponent)

Output:
DOUBLE

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the exponent 
of the Contrast Stretch 
curve.

Image Manager> 
Utilities >
Contrast Stretch

IMGEDIT CONT-
STRETCH GETHIGH-
SCALELIMIT 
(value)

Output:
DOUBLE

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the current 
maximum vertical 
scale limit.

Image Manager> 
Utilities >
Contrast Stretch>
View > 
Vertical Scale

IMGEDIT CONT-
STRETCH GETLOWS-
CALELIMIT
(value)

Output:
DOUBLE

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the current 
minimum vertical scale 
limit.

Image Manager> 
Utilities >
Contrast Stretch> 
View > 
Vertical Scale

IMGEDIT CONT-
STRETCH GETMAX 
(index)

Output:
SHORT

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the current 
maximum index.

Image Manager> 
Utilities >
Contrast Stretch

IMGEDIT CONT-
STRETCH GETMIN 
(index)

Output:
SHORT

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the current 
minimum index.

Image Manager> 
Utilities >
Contrast Stretch
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IMGEDIT CONT-
STRETCH GET-
NEGATIVE 
(state)

Output:
SHORT

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the status of 
the Negative function 
(ON or OFF).

Image Manager> 
Utilities >
Contrast Stretch

IMGEDIT CONT-
STRETCH RESET

NONE KIN_NOIMAGE
KIN_ERROR
KIN_SUCCESS

Resets the default set-
tings of the Contrast 
Stretch function.

Image Manager> 
Utilities >
Contrast Stretch

IMGEDIT CONT-
STRETCH SETEXPO-
NENT
<exponent>

Input:
DOUBLE

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Sets the exponent of 
the Contrast Stretch 
curve. Exponent value 
ranges from 0 to 9.99.

Image Manager> 
Utilities >
Contrast Stretch

IMGEDIT CONT-
STRETCH SETHIGH-
SCALELIMIT
<value>

Input:
DOUBLE

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Sets the maximum ver-
tical scale limit. Value 
ranges from 0 to 99.9.

Image Manager> 
Utilities >
Contrast Stretch>
View > 
Vertical Scale

IMGEDIT CONT-
STRETCH SETLOWS-
CALELIMIT <value>

Input:
DOUBLE

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Sets the minimum verti-
cal scale limit. Value 
ranges from 0 to 99.9.

Image Manager> 
Utilities >
Contrast Stretch>
View > 
Vertical Scale

IMGEDIT CONT-
STRETCH SETMAX 
<index>

Input:
SHORT

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Sets the maximum 
index for the Contrast 
Stretch. 

Image Manager> 
Utilities >
Contrast Stretch

IMGEDIT CONT-
STRETCH SETMIN 
<index>

Input:
SHORT

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Sets the minimum 
index for the Contrast 
Stretch.

Image Manager> 
Utilities >
Contrast Stretch

IMGEDIT CONT-
STRETCH SETOFF-
NEGATIVE

NONE KIN_NOIMAGE
KIN_ERROR
KIN_SUCCESS

Sets the status of the 
Negative function to 
OFF.

Image Manager> 
Utilities >
Contrast Stretch

IMGEDIT CONT-
STRETCH SETON-
NEGATIVE

NONE KIN_NOIMAGE
KIN_ERROR
KIN_SUCCESS

Sets the status of the 
Negative function to 
ON.

Image Manager> 
Utilities >
Contrast Stretch
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IMGEDIT COPY 
AREA

NONE KIN_INVALID_SET-
TINGS
KIN_ERROR
KIN_SUCCESS

Starts the Copy Area 
tool.

Image Manager> 
Tools >
Copy/Paste

IMGEDIT COPY 
GETAREA
(area)

Output:
STRING

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Get the current area 
selected in the tool 
settings dialog. 

Raster Transform 
(Tool Setting)

IMGEDIT COPY 
GETAREAOBJFILTER

Output:
STRING

KIN_ERROR
KIN_SUCCESS

Get the filter name used 
by the Raster Object 
option for the current 
area. 
Note: For 2 color 
images, foreground and 
background are offered.

Image Manager >
Tools >
Copy/Paste >
Copy >
Tool Settings

IMGEDIT COPY 
GETFILTER

Output:
STRING

KIN_ERROR
KIN_SUCCESS

Get the current filter for 
the Copy/Paste tools.

Image Manager >
Tools >
Copy/Paste >
Tool Settings

IMGEDIT COPY 
GETRESOLUTION 
(resolution)

Output:
DOUBLE

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the copy/paste 
resolution value. 

Image Manager> 
Settings >
Copy/Paste

IMGEDIT COPY GET-
TYPERESOLUTION 
(type)

Output:
STRING

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the current 
copy/paste resolution 
type (FILE or SCREEN).

Image Manager> 
Settings >
Copy/Paste

IMGEDIT COPY 
SETAREA
< BLOCK | FENCE | 
ELEMENT | IMAGE | 
RASTEROBJECT>

Input:
STRING

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Set the area in the tool 
setting.

Image Manager >
Tools >
Copy/Paste >
Tool Settings

IMGEDIT COPY 
SETAREAOBJFILTER
<filterName>

Input:
STRING

KIN_INVALID_PARAM 
KIN_ERROR
KIN_SUCCESS

Set the filter name used 
by the Raster Object 
option for the current 
area. 
Note: For 2 color 
images, foreground and 
background are offered.

Image Manager >
Tools >
Copy/Paste >
Tool Settings
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IMGEDIT COPY SET-
FILERESOLUTION

NONE KIN_ERROR
KIN_SUCCESS

Sets the copy/paste res-
olution type to File. 

Image Manager> 
Settings >
Copy/Paste

IMGEDIT COPY 
SETFILTER
<filterName>

Input:
STRING

KIN_INVALID_PARAM 
KIN_ERROR
KIN_SUCCESS

Set the filter name used 
by the Copy/Paste tools. 

Image Manager >
Tools >
Copy/Paste >
Tool Settings

IMGEDIT COPY SET-
RESOLUTION 
<Resolution>

Input:
LONG

KIN_INVALID_PARAM
KIN_INVALID_SETTIN
GS
KIN_ERROR
KIN_SUCCESS

Sets the copy/paste res-
olution to the specified 
value. 

Image Manager> 
Settings >
Copy/Paste

IMGEDIT COPY SET-
SCREENRESOLU-
TION

NONE KIN_ERROR
KIN_SUCCESS

Sets the copy/paste res-
olution type to Screen. 

Image Manager> 
Settings >
Copy/Paste

IMGEDIT DENSITY 
DONE

NONE KIN_NOIMAGE
KIN_FILE_READ_ONLY
KIN_ERROR
KIN_SUCCESS

Saves changes made 
with the density slicing 
function to the color 
table of the active 
image.

Image Manager> 
Utilities >
Density Slicing

IMGEDIT DENSITY 
GETHIGHSCALE-
LIMIT 
(value)

Output:
DOUBLE

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the maximum 
vertical scale limit.

Image Manager> 
Utilities >
Density Slicing >
View > 
Vertical Scale

IMGEDIT DENSITY 
GETLOWSCALELIMIT 
(value)

Output:
DOUBLE

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the current 
minimum vertical scale 
limit.

Image Manager> 
Utilities >
Density Slicing >
View > 
Vertical Scale

IMGEDIT DENSITY 
GETMAX 
(index)

Output:
SHORT

KIN_INVALID_PARAM
KIN_NOIMAGE
KIN_ERROR
KIN_SUCCESS

Returns the maximum 
index.

Image Manager> 
Utilities >
Density Slicing
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IMGEDIT DENSITY 
GETMIN 
(index)

Output:
SHORT

KIN_INVALID_PARAM
KIN_NOIMAGE
KIN_ERROR
KIN_SUCCESS

Returns the minimum 
index.

Image Manager> 
Utilities >
Density Slicing

IMGEDIT DENSITY 
GETWIDTH 
(width)

Output:
SHORT

KIN_INVALID_PARAM
KIN_NOIMAGE
KIN_ERROR
KIN_SUCCESS

Returns the width of 
the slice.

Image Manager> 
Utilities >
Density Slicing

IMGEDIT DENSITY 
RESET

NONE KIN_NOIMAGE
KIN_ERROR
KIN_SUCCESS

Resets the default set-
tings of the Density 
Slicing function.

Image Manager> 
Utilities >
Density Slicing

IMGEDIT DENSITY 
SETHIGHSCALE-
LIMIT <value>

Input:
DOUBLE

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Sets the maximum ver-
tical scale limit 

Image Manager> 
Utilities >
Density Slicing >
View > 
Vertical Scale

IMGEDIT DENSITY 
SETLOWSCALELIMIT 
<value>

Input:
DOUBLE

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Sets the minimum verti-
cal scale limit.

Image Manager> 
Utilities >
Density Slicing >
View > 
Vertical Scale

IMGEDIT DENSITY 
SETMAX 
<index>

Input:
SHORT

KIN_INVALID_PARAM
KIN_NOIMAGE
KIN+ERROR
KIN_SUCCESS

Sets the maximum 
index. Value ranges 
from 0 to 255.

Image Manager> 
Utilities >
Density Slicing

IMGEDIT DENSITY 
SETMIN 
<index>

Input:
SHORT

KIN_INVALID_PARAM
KIN_NOIMAGE
KIN+ERROR
KIN_SUCCESS

Sets the minimum 
index. Value ranges 
from 0 to 255.

Image Manager> 
Utilities >
Density Slicing

IMGEDIT DENSITY 
SETWIDTH
<width>

Input:
SHORT

KIN_INVALID_PARAM
KIN_NOIMAGE
KIN+ERROR
KIN_SUCCESS

Sets the width of the 
slice. Width value 
ranges from 1 to 255.

Image Manager> 
Utilities >
Density Slicing

IMGEDIT DLGCHAN-
NELS OPEN

NONE KIN_NOIMAGE
KIN_ERROR
KIN_SUCCESS

Opens the Image Chan-
nels dialog.

Image Manager> 
Utilities > 
Image Channels
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IMGEDIT DLGCOM-
PRESSION OPEN

NONE KIN_ERROR
KIN_SUCCESS

Opens the Color Com-
pression dialog.

Image Manager> 
Utilities > 
Color Compres-
sion

IMGEDIT DLGCON-
TRAST OPEN

NONE KIN_NOIMAGE
KIN_ERROR
KIN_SUCCESS

Opens the Contrast 
Stretch dialog.

Image Manager> 
Utilities > Con-
trast Stretch

IMGEDIT DLGCOPY-
SETTINGS OPEN

NONE KIN_ERROR
KIN_SUCCESS

Opens the copy/paste 
settings dialog.

Image Manager> 
Settings >
Copy/Paste

IMGEDIT DLGDEN-
SITY OPEN

NONE KIN_NOIMAGE
KIN_ERROR
KIN_SUCCESS

Opens the Density Slic-
ing dialog.

Image Manager> 
Utilities > 
Density Slicing

IMGEDIT DLGDRAW-
SETTING OPEN

NONE KIN_ERROR
KIN_SUCCES

Opens the Draw Set-
tings dialog.

Image Manager> 
Settings >
Draw 

IMGEDIT DLGFIL-
TER CLOSE

NONE KIN_SUCCESS Closes the Color Filter 
dialog.

Image Manager> 
Utilities >
Color Filter

IMGEDIT DLGFIL-
TER OPEN

NONE PERM_ERROR
KIN_NOIMAGE
KIN_INVALID_IMAGE_
TYPE
KIN_SUCCESS

Opens the Color Filter 
dialog. 

Image Manager> 
Utilities >
Color Filter

IMGEDIT DLGHIS-
TOGRAM OPEN

NONE KIN_NOIMAGE
KIN_ERROR
KIN_SUCCESS

Opens the Histogram 
dialog.

Image Manager > 
File > 
Properties > 
Histogram

IMGEDIT DLG-
PALEDIT OPEN

NONE KIN_NOIMAGE
KIN_ERROR
KIN_SUCCESS

Opens the Color Table 
Editor dialog.

Image Manager > 
File > 
Properties > 
Color Table
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IMGEDIT 
DLGDRAWSETTING 
CLOSE

NONE KIN_SUCCES Closes the Raster Snap 
on Tentative dialog.

Image Manager > 
Settings >
Raster Snap on 
Tentative

IMGEDIT DLGTRSLU-
CENT CLOSE

NONE KIN_SUCCESS Closes the Translucent 
Colors dialog.

Image Manager> 
Utilities >
Translucent 
Colors 

IMGEDIT DLGTRSLU-
CENT OPEN

NONE KIN_NOIMAGE
KIN_ERROR
KIN_SUCCESS

Opens the Translucent 
Colors dialog.

Image Manager> 
Utilities >
Translucent 
Colors

IMGEDIT DLGTRS-
PARENT CLOSE

NONE KIN_SUCCESS Closes the Transparent 
Colors dialog.

Image Manager> 
Utilities >
Transparent Col-
ors

IMGEDIT DLGTRS-
PARENT OPEN

NONE KIN_NOIMAGE
KIN_ERROR
KIN_SUCCESS

Opens the Transparent 
Colors dialog.

Image Manager> 
Utilities >
Transparent Col-
ors

IMGEDIT DLGUN-
DOSETTINGS OPEN

NONE KIN+ERROR
KIN_SUCCESS

Opens the Undo/Redo 
settings dialog.

Image Manager> 
Settings >
Undo/Redo

IMGEDIT 
DRAWSETTING 
GETFILTER
(FilterName)

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the name of the 
selected filter.

Image Manager > 
Settings >
Raster Snap on 
Tentative

IMGEDIT 
DRAWSETTING 
GETRASTERSNAP
(Status)

Output:
SHORT

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the status (ON/
OFF) of the Raster Snap 
toggle.

Image Manager > 
Settings >
Raster Snap on 
Tentative

IMGEDIT 
DRAWSETTING 
SETFILTER
<FilterName>

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Sets the filter name. Image Manager > 
Settings >
Raster Snap on 
Tentative
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IMGEDIT 
DRAWSETTING 
SETRASTERSNAPOFF

NONE KIN_ERROR
KIN_SUCCESS

Sets the Raster Snap 
toggle to OFF.

Image Manager > 
Settings >
Raster Snap on 
Tentative

IMGEDIT 
DRAWSETTING 
SETRASTERSNAPON

NONE KIN_ERROR
KIN_SUCCESS

Sets the Raster Snap 
toggle to ON.

Image Manager > 
Settings >
Raster Snap on 
Tentative

IMGEDIT ERASE 
AREA

NONE KIN_NOIMAGE
KIN_FILE_READ_ONLY
KIN_INVALID_SETTIN
GS
KIN_ERROR
KIN_SUCCESS

Erases the current area 
of the active image.

Image Manager >
Tools >
Erase >
Erase Area

IMGEDIT ERASE CIR-
CULAR

NONE KIN_NOIMAGE
KIN_FILE_READ_ONLY
KIN_INVALID_SETTIN
GS
KIN_ERROR
KIN_SUCCESS

Erases the image with a 
circular brush. Two 
data points are required 
to define the circle.

Image Manager >
Tools >
Erase > 
Erase with Circu-
lar Brush

IMGEDIT ERASE 
GETAREA (area)

Output:
STRING

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Get the current area 
selected for the Erase 
Area command.

Image Manager >
Tools >
Erase >
Tool Settings

IMGEDIT ERASE 
GETAREAOBJFILTER

Output:
STRING

KIN_ERROR
KIN_SUCCESS

Get the filter name 
used by the Raster 
Object option for the 
current area. 
Note: For 2 color 
images, foreground and 
background are 
offered.

Image Manager >
Tools >
Erase >
Tool Settings

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
MicroStation Descartes User’s Guide A-67



MicroStation Descartes Key-in Tables
Image Edit Key-ins
IMGEDIT ERASE 
GETCOLOR

Output:
LONG

KIN_ERROR
KIN_SUCCESS

Get the current color 
index used for erasing. 
Value ranges from 0 to 
255. 
Note: For 2 color 
images, the background 
color is used.

Image Manager >
Tools >
Erase >
Tool Settings

IMGEDIT ERASE 
OBLIQUE

NONE KIN_NOIMAGE
KIN_FILE_READ_ONLY
KIN_INVALID_SET-
TINGS
KIN_ERROR
KIN_SUCCESS

Erases the image with 
an oblique rectangular 
brush. Three data 
points are required to 
define the oriented 
rectangle.

Image Manager >
Tools >
Erase > 
Erase with 
Oblique Brush

IMGEDIT ERASE 
RECTANGLE

NONE KIN_NOIMAGE
KIN_FILE_READ_ONLY
KIN_INVALID_SET-
TINGS
KIN_ERROR
KIN_SUCCESS

Erases the image using 
a rectangular brush. 
Two data points are 
required to define the 
rectangle.

Image Manager >
Tools >
Erase > 
Erase with Rect-
angular Brush

IMGEDIT ERASE 
SETAREA < BLOCK | 
ELEMENT | FENCE 
| IMAGE | RASTER-
OBJECT >

Input: 
STRING

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Set the area for the 
Erase Area command.

Image Manager >
Tools >
Erase >
Erase Area >
Tool Settings

IMGEDIT ERASE 
SETAREAOBJFILTER
<filterName>

Input:
STRING

KIN_INVALID_PARAM 
KIN_ERROR
KIN_SUCCESS

Set the filter name used 
by the Raster Object 
option for the current 
area. 
Note: For 2 color 
images, foreground and 
background are 
offered.

Image Manager >
Tools >
Erase >
Erase Area >
Tool Settings

IMGEDIT ERASE SET-
COLOR
<colorIndex>

Input:
LONG

KIN_INVALID_PARAM 
KIN_ERROR
KIN_SUCCESS

Set the current color 
index used for erasing. 
Value ranges from 0 to 
255. 

Image Manager >
Tools >
Erase >
Erase Area >
Tool Settings
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IMGEDIT FILTER 
ADD 
<filtername>

Input:
STRING

INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Adds a new filter name 
to the current filter file 
using the current filter 
settings. 

Image Manager> 
Utilities >
Color Filter

IMGEDIT FILTER 
ADDCOLORS

NONE KIN_NOIMAGE
KIN_INVALID_IMAGE_
TYPE
KIN_PERM_DENIED
KIN_ERROR
KIN_SUCCESS

Starts the “Add to Filter” 
command that adds to 
the selected filter the 
colors sampled within 
the selected area. 

Image Manager> 
Tools >
Color Filter >
Add to Filter

IMGEDIT FILTER ALL 
<filtername>

Input:
STRING

INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Selects all colors of the 
color palette for the 
selected filter. 

Image Manager> 
Utilities >
Color Filter

IMGEDIT FILTER 
DELETE 
<filtername>

Input:
STRING

INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Deletes the specified 
filter from the opened 
filter file. 

Image Manager> 
Utilities >
Color Filter

IMGEDIT FILTER 
GETAREA
(area)

Output:
STRING

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the selected 
area for the filter 
commands.

Image Manager > 
Tools >
Color Filter

IMGEDIT FILTER 
GETHIGHLIGHT
(highlight)

Output:
STRING

KIN_INVALID_PARAM
KIN_ERROR 
KIN_SUCCESS

Returns the selected 
highlight type for the 
filter commands 
(NONE, COLOR, 
MONOCHROME).

Image Manager> 
Tools >
Color Filter

IMGEDIT FILTER 
SETHIGHLIGHT
< NONE | COLOR | 
MONOCHROME >

Input 
param:
STRING

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Set the highlight type 
for the Filter com-
mands.

Image Manager> 
Tools >
Color Filter

IMGEDIT FILTER 
HIGHLIGHT

NONE KIN_NOIMAGE
KIN_INVALID_IMAGE_
TYPE
KIN_ERROR
KIN_SUCCESS

Starts the “Highlight 
from Filter” command 
that highlights the 
selected filter on the 
active image.

Image Manager> 
Tools >
Color Filter >
Highlight 

IMGEDIT FILTER 
GETDLGFILTER

Output:
STRING

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the filter name 
selected in the color 
filter dialog.

Image Manager > 
Utilities >
Color Filter
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IMGEDIT FILTER 
GETTOOLFILTER

Output:
STRING

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the filter name 
selected in the tool 
settings of the Filter 
tools.

Image Manager > 
Tools >
Color Filter

IMGEDIT FILTER 
INVERT 
<filtername>

Input:
STRING

INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Selects the unselected 
colors and deselects the 
selected ones from the 
color palette for the 
selected filter. 

Image Manager> 
Utilities >
Color Filter

IMGEDIT FILTER 
NONE 
<filtername>

Input:
STRING

INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Deselects all colors 
from the color palette 
for the selected filter. 

Image Manager> 
Utilities >
Color Filter

IMGEDIT FILTER 
RESET 
<filtername>

Input:
STRING

INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Brings back original 
settings (before the last 
save) for the specified 
filter. 

Image Manager> 
Utilities >
Color Filter

IMGEDIT FILTER 
SETAREA < BLOCK | 
ELEMENT | FENCE 
| IMAGE >

Input:
STRING

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Set the area for the Fil-
ter commands.

Image Manager> 
Tools >
Color Filter

IMGEDIT FILTER 
SETDLGFILTER
<filtername>

Input:
STRING

INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Sets the filter name in 
the color filter dialog.

Image Manager> 
Utilities >
Color Filter

IMGEDIT FILTER 
SETTOOLFILTER 
<filtername>

Input:
STRING

INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Sets the filter name in 
the tool settings of the 
Filter tools.

Image Manager > 
Tools >
Color Filter

IMGEDIT FILTER 
SUBTRACTCOLORS

NONE KIN_NOIMAGE
KIN_INVALID_IMAGE_
TYPE
KIN_PERM_DENIED
KIN_ERROR
KIN_SUCCESS

Starts the “Subtract 
from Filter” command 
that removes from the 
selected filter the colors 
sampled within the 
selected area.

Image Manager> 
Tools >
Color Filter >
Subtract from Fil-
ter

IMGEDIT FILTER-
FILE NEW

NONE KIN_ERROR
KIN_SUCCESS

Create a new filter file. Image Manager> 
Utilities >
Color Filter >
File
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IMGEDIT FILTER-
FILE OPEN 
[filename]

Input:
[STRING]

KIN_FILE_NOT_
FOUND
KIN_ERROR
KIN_NEED_INTERACTI
ON
KIN_SUCCESS

Opens the specified fil-
ter file. If filename is 
not specified, the Select 
Filter File dialog is 
opened.
Note: Input parameter 
must be given to get a 
valid returned error 
code.

Image Manager> 
Utilities >
Color Filter >
File

IMGEDIT FILTER-
FILE SAVE

NONE KIN_ERROR
KIN_SUCCESS

Save changes to the 
current filter file.

Image Manager> 
Utilities >
Color Filter >
File

IMGEDIT FILTER-
FILE SAVEAS
[filename]

Input:
[STRING]

KIN_FILE_AL-
READY_EXIST
KIN_ERROR
KIN_NEED_INTERACTI
ON
KIN_SUCCESS

Saves the current filter 
file under the specified 
filename. If filename is 
not specified, the Select 
Filter File dialog is 
opened.
Note: Input parameter 
must be given to get a 
valid returned error 
code.

Image Manager> 
Utilities >
Color Filter >
File

IMGEDIT HISTO-
GRAM GETHIGH-
SCALELIMIT (value)

Output:
DOUBLE

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the current 
maximum vertical 
scale limit.

Image Manager > 
File >
Properties >
Histogram >
View > 
Vertical Scale

IMGEDIT HISTO-
GRAM GETLOWS-
CALELIMIT (value)

Output:
DOUBLE

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the current 
minimum vertical scale 
limit.

Image Manager> 
File >
Properties >
Histogram > 
View > 
Vertical Scale

IMGEDIT HISTO-
GRAM GETMAX 
(value)

Output:
SHORT

KIN_INVALID_PARAM
KIN_NOIMAGE
KIN+ERROR
KIN_SUCCESS

Returns the current 
maximum index.

Image Manager > 
File >
Properties >
Histogram
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IMGEDIT HISTO-
GRAM GETMIN 
(value)

Output:
SHORT

KIN_INVALID_PARAM
KIN_NOIMAGE
KIN+ERROR
KIN_SUCCESS

Returns the current 
minimum index.

Image Manager > 
File >
Properties >
Histogram

IMGEDIT HISTO-
GRAM RESET

NONE KIN_NOIMAGE
KIN_ERROR
KIN_SUCCESS

Resets the default set-
tings of the Histogram 
function.

Image Manager > 
File >
Properties >
Histogram

IMGEDIT HISTO-
GRAM SETHIGH-
SCALELIMIT <value>

Input:
DOUBLE

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Sets the maximum ver-
tical scale limit. Value 
ranges from 0 to 99.9.

Image Manager > 
File >
Properties >
Histogram >
View > 
Vertical Scale

IMGEDIT HISTO-
GRAM SETLOWS-
CALELIMIT <value>

Input:
DOUBLE

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Sets the minimum verti-
cal scale limit. Value 
ranges from 0 to 99.9.

Image Manager > 
File >
Properties >
Histogram >
View >
Vertical Scale

IMGEDIT HISTO-
GRAM SETMAX 
<value>

Input:
SHORT

KIN_INVALID_PARAM
KIN_NOIMAGE
KIN+ERROR
KIN_SUCCESS

Sets the maximum 
index. Value ranges 
from 0 to 255.

Image Manager >
File >
Properties >
Histogram

IMGEDIT HISTO-
GRAM SETMIN 
<value>

Input:
SHORT

KIN_INVALID_PARAM
KIN_NOIMAGE
KIN_MISSING_SETTIN
GS
KIN+ERROR
KIN_SUCCESS

Sets the minimum 
index. Value ranges 
from 0 to 255.

Image Manager >
File >
Properties >
Histogram

IMGEDIT IMGVER-
SION GET
(version) (subver-
sion) (revision) (sub-
revision)

Output:
SHORT
SHORT
SHORT
SHORT

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the current ver-
sion, subversion, revi-
sion and subrevision of 
the minimal required 
Descartes main mod-
ule. 
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IMGEDIT PAINT 
AREA

NONE KIN_NOIMAGE
KIN_FILE_READ_ONLY
KIN_INVALID_SET-
TINGS
KIN_ERROR
KIN_SUCCESS

Paints the current area 
of the active image.

Image Manager >
Tools >
Paint >
Paint Area

IMGEDIT PAINT CIR-
CULAR

NONE KIN_NOIMAGE
KIN_FILE_READ_ONLY
KIN_INVALID_SET-
TINGS
KIN_ERROR
KIN_SUCCESS

Paints the image with a 
circular brush. Two 
data points are required 
to define the circle.

Image Manager >
Tools >
Paint >
Paint with Circu-
lar Brush

IMGEDIT PAINT 
GETAREA (area)

Output:
STRING

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Get the current area 
selected for the Paint 
Area command.

Image Manager >
Tools >
Paint >
Paint Area >
Tool Settings

IMGEDIT PAINT 
GETAREAOBJFILTER

Output:
STRING

KIN_ERROR
KIN_SUCCESS

Get the filter name 
used by the Raster 
Object option for the 
current area. 
Note: For 2 color 
images, foreground and 
background are 
offered.

Image Manager >
Tools >
Paint >
Paint Area >
Tool Settings

IMGEDIT PAINT 
GETCOLOR

Output:
LONG

KIN_ERROR
KIN_SUCCESS

Get the current color 
index used for painting. 
Value ranges from 0 to 
255. 
Note: For 2 color 
images, the foreground 
color is used.

Image Manager >
Tools >
Paint >
Tool Settings

IMGEDIT PAINT 
GETFILTER

Output:
STRING

KIN_ERROR
KIN_SUCCESS

Get the current filter for 
the Paint tools.

Image Manager >
Tools >
Paint >
Tool Settings
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IMGEDIT PAINT 
OBLIQUE

NONE KIN_NOIMAGE
KIN_FILE_READ_ONLY
KIN_INVALID_SET-
TINGS
KIN_ERROR
KIN_SUCCESS

Paints the image with 
an oblique rectangle 
brush. Three data 
points are required to 
define the size of the 
oriented rectangle.

Image Manager >
Tools >
Paint > 
Paint with 
Oblique Brush

IMGEDIT PAINT 
RECTANGLE

NONE KIN_NOIMAGE
KIN_FILE_READ_ONLY
KIN_INVALID_SET-
TINGS
KIN_ERROR
KIN_SUCCESS

Paints the image using 
a rectangular brush. 
Two data points are 
required to define the 
size of the rectangle.

Image Manager >
Tools >
Paint > 
Paint with Rect-
angular Brush

IMGEDIT PAINT 
SETAREA < BLOCK | 
ELEMENT | FENCE 
| IMAGE | RASTER-
OBJECT >

Input:
STRING

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Set the area for the 
Paint Area command.

Image Manager >
Tools >
Paint >
Paint Area >
Tool Settings

IMGEDIT PAINT 
SETAREAOBJFILTER
<filterName>

Input:
STRING

KIN_INVALID_PARAM 
KIN_ERROR
KIN_SUCCESS

Set the filter name used 
by the Raster Object 
option for the current 
area. 
Note: For 2 color 
images, foreground and 
background are 
offered.

Image Manager >
Tools >
Paint >
Paint Area >
Tool Settings

IMGEDIT PAINT SET-
COLOR
<colorIndex>

Input:
LONG

KIN_INVALID_PARAM 
KIN_ERROR
KIN_SUCCESS

Set the current color 
index used for painting. 
Value ranges from 0 to 
255. 

Image Manager >
Tools >
Paint >
Tool Settings

IMGEDIT PAINT SET-
FILTER
<filterName>

Input:
STRING

KIN_INVALID_PARAM 
KIN_ERROR
KIN_SUCCESS

Set the filter name used 
by the Paint tools. 

Image Manager >
Tools >
Paint >
Paint Area >
Tool Settings

IMGEDIT PALEDIT 
APPLY

NONE KIN_NOIMAGE
KIN_FILE_READ_ONLY
KIN_ERROR
KIN_SUCCESS

Saves color table 
changes to the active 
image.

Image Manager> 
Properties > 
Color Table > 
File > 
Apply
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IMGEDIT PALEDIT 
GETCMY 
<index> (Cyan) 
(Magenta) (Yellow)

Input:
SHORT
Output:
DOUBLE
DOUBLE
DOUBLE

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns for the speci-
fied color index num-
ber its composition of 
Cyan Magenta and Yel-
low. Index number 
range from 0 to 255.

Image Manager >
File >
Properties >
Color Table

IMGEDIT PALEDIT 
GETHSV 
<index> (Hue) (Satu-
ration) (Value)

Input:
SHORT
Output:
SHORT
SHORT
SHORT

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns for the speci-
fied color index num-
ber its composition of 
Hue, Saturation and 
Value. Index number 
range from 0 to 255.

Image Manager >
File >
Properties >
Color Table

IMGEDIT PALEDIT 
GETRGB 
<index> (Red) 
(Green) (Blue)

Input:
SHORT
Output:
SHORT
SHORT
SHORT

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns for the speci-
fied color index num-
ber its composition of 
Red Green and Blue. 
Index number range 
from 0 to 255.

Image Manager >
File >
Properties >
Color Table

IMGEDIT PALEDIT 
GETRGBPORTION 
<index> (RedP) 
(GreenP) (BlueP)

Input:
SHORT
Output:
DOUBLE
DOUBLE
DOUBLE

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns for the speci-
fied color index its 
composition of Red 
Green and Blue. Index 
number range from 0 to 
255.

Image Manager >
File >
Properties >
Color Table

IMGEDIT PALEDIT 
LOAD 
[filename]

Input:
[STRING]

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_FILE_NOT_FOUN
D
KIN_ERROR
KIN_SUCCESS

Loads the specified 
color table. If filename 
is not specified, the 
Load Palette dialog 
opens.
Note: Input parameter 
must be given to get a 
valid returned error 
code.

Image Manager> 
Properties > 
Color Table > 
File > 
Load Color Table
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IMGEDIT PALEDIT 
SAVEAS 
[filename]

Input:
[STRING]

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_FILE_EXIST
KIN_ERROR
KIN_SUCCESS

Saves the current color 
table in the specified 
file. If filename is not 
specified, the Save Pal-
ette dialog opens.
Note: Input parameter 
must be given to get a 
valid returned error 
code.

Image Manager> 
Properties > 
Color Table > 
File > 
Save As

IMGEDIT PALEDIT 
SETCMY 
<index> <Cyan> 
<Magenta> <Yellow>

Input:
SHORT
DOUBLE
DOUBLE
DOUBLE

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Sets the specified color 
index with the compo-
sition of Cyan, 
Magenta and Yellow. 
Index number values 
range from 0 to 255. 
Cyan, Magenta and Yel-
low value range from 0 
to 1.

Image Manager >
File >
Properties >
Color Table

IMGEDIT PALEDIT 
SETHSV 
<index> <Hue> <Sat-
uration> <Value>

Input:
SHORT
SHORT
SHORT
SHORT

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Sets the specified color 
index with the compo-
sition of Hue, Satura-
tion and Value. Index 
number values range 
from 0 to 255. Hue 
range from 0 to 359. 
Saturation and Value 
range from 0 to 100.

Image Manager >
File >
Properties >
Color Table

IMGEDIT PALEDIT 
SETRGB 
<index> <Red> 
<Green> <Blue>

Input:
SHORT
SHORT
SHORT
SHORT

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Sets the specified color 
index with the compo-
sition of Red Green and 
Blue. Index number 
and color values range 
from 0 to 255.

Image Manager >
File >
Properties >
Color Table

IMGEDIT PALEDIT 
SETRGBPORTION 
<index> <RedP> 
<GreenP> <BlueP>

Input:
SHORT
DOUBLE
DOUBLE
DOUBLE

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Sets the specified color 
index with the compo-
sition of Red, Green 
and Blue. Index num-
ber values range from 0 
to 255. RedP GreenP 
and BlueP value range 
from 0 to 1.

Image Manager >
File >
Properties >
Color Table
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IMGEDIT PASTE 
DGN

NONE KIN_INVALID_SET-
TINGS
KIN_ERROR
KIN_SUCCESS

Activates the Paste 
Image Area as Design 
Element command.

Image Manager >
Tools >
Copy/Paste >
Paste Image Area 
As Design Ele-
ment

IMGEDIT PASTE 
HMR

NONE KIN_INVALID_SET-
TINGS
KIN_ERROR
KIN_SUCCESS

Activates the Paste 
Image Area command.

Image Manager >
Tools >
Copy/Paste >
Paste Image Area

IMGEDIT SLICE-
COLOR APPLY

NONE KIN_NOIMAGE
KIN_FILE_READ_ONLY
KIN_ERROR
KIN_SUCCESS

Save changes to the 
color table of the active 
image.

Image Manager >
Utilities >
Density Slicing > 
File > 
Apply

IMGEDIT SLICE-
COLOR GETMAX
(red) (green) (blue)

Output:
SHORT
SHORT
SHORT

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the current 
maximum color value 
composition (Red 
Green and Blue) for the 
current slice.

Image Manager >
Utilities >
Density Slicing

IMGEDIT SLICE-
COLOR GETMIN
(red) (green) (blue)

Output:
SHORT
SHORT
SHORT

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the current 
minimum color value 
composition (Red, 
Green and Blue) for the 
current slice.

Image Manager >
Utilities >
Density Slicing

IMGEDIT SLICE-
COLOR LOAD
[filename]

Input:
[STRING]

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_FILE_NOT_
FOUND
KIN_ERROR
KIN_SUCCESS

Loads the specified 
color table. If filename 
is not specified, the File 
Selection dialog opens.
Note: Input parameter 
must be given to get a 
valid returned error 
code.

Image Manager >
Utilities >
Density Slicing > 
File > 
Load Color Table
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IMGEDIT SLICE-
COLOR SAVEAS
[filename]

Input:
[STRING]

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_FILE_EXIST
KIN_ERROR
KIN_SUCCESS

Saves the current color 
table in the specified 
file. If filename is not 
specified, the Save Pal-
ette dialog opens.
Note: Input parameter 
must be given to get a 
valid returned error 
code.

Image Manager >
Utilities >
Density Slicing > 
File > 
Save As…

IMGEDIT SLICE-
COLOR SETMAX
<Red> <Green> 
<Blue>

Input:
SHORT
SHORT
SHORT

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Sets the maximum 
color value composi-
tion (Red, Green and 
Blue) for the current 
slice. 
Red, Green and Blue 
value range from 0 to 
255.

Image Manager >
Utilities >
Density Slicing > 
Functions > 
Slice Coloring 

IMGEDIT SLICE-
COLOR SETMIN 
<Red> <Green> 
<Blue>

Input:
SHORT
SHORT
SHORT

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Sets the minimum color 
value composition 
(Red, Green and Blue) 
for the current slice. 
Red, Green and Blue 
value range from 0 to 
255.

Image Manager >
Utilities >
Density Slicing > 
Functions > 
Slice Coloring

IMGEDIT STAMP 
GET1BITMODE
(Mode)

Output:
STRING

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the mode for 1 
bit stamping.
Modes are: FORE-
GROUND, BACK-
GROUND and 
REVERSE.

Image Manager >
Settings >
Stamp Vector

IMGEDIT STAMP 
GETLINESTYLE 
<LineNumber> (dash) 
[(Gap)] [(dash)] 
[(Gap)] [(dash)] 
[(Gap)] [(dash)] 
[(Gap)]

Input:
SHORT
Output:
STRING
[STRING]
[STRING]
[STRING]
[STRING]
[STRING]
[STRING]
[STRING]

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the line style 
for the specified line 
number. Line number 
range from 0 to 15. 
Dashes and gaps are 
returned in working 
units ex: 10:50.000.

Image Manager >
Settings >
Stamp Vector
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IMGEDIT STAMP 
GETLINESTYLEPIXEL 
<LineNumber> (dash) 
[(Gap)] [(dash)] 
[(Gap)] [(dash)] 
[(Gap)] [(dash)] 
[(Gap)]

Input:
SHORT
Output:
SHORT
[SHORT]
[SHORT]
[SHORT]
[SHORT]
[SHORT]
[SHORT]
[SHORT]

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the line style 
for the specified line 
number. Line number 
range from 0 to 15. 
Dashes and gaps are 
returned in pixel units. 
ex: 1.5.
Units mode must be set 
to PIXELS.

Image Manager >
Settings >
Stamp Vector

IMGEDIT STAMP 
GETLINEWEIGHT 
<LineNumber> 
(weight)

Input:
SHORT
Output:
STRING

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the line weight 
for the specified line 
number. Line number 
range from 0 to 15. Line 
weight are returned in 
working units ex: 
10:50.000.

Image Manager >
Settings >
Stamp Vector

IMGEDIT STAMP 
GETLINEWEIGHT-
PIXEL 
<LineNumber> 
(weight)

Input:
SHORT
Output:
SHORT

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the line weight 
for the specified line 
number. Line number 
range from 0 to 15. Line 
weight are returned in 
pixel units ex: 1.5.
Units mode must be set 
to PIXELS.

Image Manager >
Settings >
Stamp Vector

IMGEDIT STAMP 
GETSCALEFACTOR 
(value)

Output:
DOUBLE

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the current 
Scale Factor value.

Image Manager >
Settings >
Stamp Vector

IMGEDIT STAMP 
GETUNITS
(UnitsMode)

Output:
STRING

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the units used 
by the stamp process.
Units mode are: PIXELS 
and WORKINGUNITS.

Image Manager >
Settings >
Stamp Vector

IMGEDIT STAMP 
GETVIEW 
(viewNumber)

Output:
SHORT

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the current 
view number for 
stamping.

Image Manager >
Tools >
Stamp >
Tool Settings

Key-In Parameters Returned Error 
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IMGEDIT STAMP 
SET1BITMODE
< FOREGROUND | 
BACKGROUND | 
REVERSE >

Input:
STRING

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Sets the mode for 1 bit 
stamping.
Modes are: FORE-
GROUND, BACK-
GROUND and 
REVERSE.

Image Manager >
Settings >
Stamp Vector

IMGEDIT STAMP 
SETLINESTYLE 
<LineNumber> 
<Dash> [Gap] [Dash] 
[Gap] [Dash] [Gap] 
[Dash] [Gap]

Input:
SHORT
STRING
[STRING]
[STRING]
[STRING]
[STRING]
[STRING]
[STRING]
[STRING]

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Sets the line style for 
the specified line num-
ber. Line number 
range from 0 to 15. 
Dashes and gaps are in 
working units ex: 
10:50.000. 

Image Manager >
Settings >
Stamp Vector

IMGEDIT STAMP 
SETLINESTYLEPIXEL 
<LineNumber> 
<Dash> [Gap] [Dash] 
[Gap] [Dash] [Gap] 
[Dash] [Gap]

Input:
SHORT
SHORT
[SHORT]
[SHORT]
[SHORT]
[SHORT]
[SHORT]
[SHORT]
[SHORT]

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Sets the line style for 
the specified line num-
ber. Line number 
range from 0 to 15. 
Dashes and gaps are in 
pixel units
ex: 1.5.
Units mode must be set 
to PIXELS. 

Image Manager >
Settings >
Stamp Vector

IMGEDIT STAMP 
SETLINEWEIGHT 
<LineNumber> 
<Weight>

Input:
SHORT
STRING

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Sets the line weight for 
the specified line num-
ber. Line number 
range from 0 to 15. Line 
weight are in working 
units ex: 10:50.000.

Image Manager >
Settings >
Stamp Vector

IMGEDIT STAMP 
SETLINEWEIGHT-
PIXEL 
<LineNumber> 
<Weight>

Input:
SHORT
SHORT

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Sets the line weight for 
the specified line num-
ber. Line number 
range from 0 to 15. Line 
weight are in pixel 
units; ex: 1.5.
Units mode must be set 
to PIXELS.

Image Manager >
Settings >
Stamp Vector
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IMGEDIT STAMP 
SETSCALEFACTOR 
<value>

Input:
DOUBLE

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Sets the Scale Factor. Image Manager >
Settings >
Stamp Vector

IMGEDIT STAMP 
SETUNITS
< PIXELS | WORKIN-
GUNITS >

Input:
STRING

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Sets the units mode for 
the stamp settings.
Units mode are: PIXELS 
and WORKINGUNITS.

Image Manager >
Settings >
Stamp Vector

IMGEDIT STAMP 
SETVIEW 
<viewNumber>

Input:
SHORT

KIN_INVALID_VIEW
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Set the view number 
for stamping.

Image Manager >
Tools >
Stamp >
Tool Settings

IMGEDIT STAMP 
VECTOR

NONE KIN_ERROR
KIN_SUCCESS

Activates the Stamp 
Vector command. 

Image Manager >
Tools >
Stamp > 
Stamp Vector 

IMGEDIT STAM-
PAUTO GET
(status)

Output 
param.:
SHORT

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Return the status (ON/
OFF) of Automatic Vec-
tor Stamping.

Image Manager >
Settings >
Stamp Vector

IMGEDIT STAM-
PAUTO SETOFF

NONE KIN_ERROR
KIN_SUCCESS

Set the status of Auto-
matic Vector Stamping 
to OFF.

Image Manager >
Settings >
Stamp Vector

IMGEDIT STAM-
PAUTO SETON

NONE KIN_ERROR
KIN_SUCCESS

Set the status of Auto-
matic Vector Stamping 
to ON.

Image Manager >
Settings >
Stamp Vector

IMGEDIT STAMP-
CONFIRM SETOFF

NONE KIN_ERROR
KIN_SUCCESS

Disable the confirming 
message to appear 
when a stamping oper-
ation will be done.

IMGEDIT STAMP-
CONFIRM SETON

NONE KIN_ERROR
KIN_SUCCESS

Enables the confirming 
message to appear 
when a stamping oper-
ation will be done.

IMGEDIT 
STAMPCVT1TO8 SET-
OFF

NONE KIN_ERROR
KIN_SUCCESS

Sets the conversion of 1 
bit images in 8 bit 
images to OFF for 
stamping operations. 
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IMGEDIT 
STAMPCVT1TO8 
SETON

NONE KIN_ERROR
KIN_SUCCESS

Sets the conversion of 1 
bit images in 8 bit 
images ON for stamp-
ing operations. 

IMGEDIT 
STAMPCVTCONF 
SETON

NONE KIN_ERROR
KIN_SUCCESS

Enables the confirming 
message to appear 
when an image conver-
sion should be done 
while stamping.

IMGEDIT 
STAMPCVTCONFSET-
OFF

NONE KIN_ERROR
KIN_SUCCESS

Disables the confirming 
message to appear 
when an image conver-
sion should be done 
while stamping.

IMGEDIT STAMPNO-
TOUCHIMAGE SET-
OFF

NONE KIN_ERROR
KIN_SUCCESS

Disables the No 
Touched Image mes-
sage box to appear 
when a stamping oper-
ation is done.

IMGEDIT STAMPNO-
TOUCHIMAGE 
SETON

NONE KIN_ERROR
KIN_SUCCESS

Enables the No 
Touched Image mes-
sage box to appear 
when a stamping oper-
ation is done.

IMGEDIT TOOL-
CLEANUP CLOSE

NONE KIN_SUCCESS Closes the Cleanup tool 
box.

Image Manager> 
Tools >
Clean Up

IMGEDIT TOOL-
CLEANUP OPEN

NONE KIN_ERROR
KIN_SUCCESS

Opens the Cleanup tool 
box.

Image Manager> 
Tools >
Clean Up

IMGEDIT TOOL-
COPYPASTE CLOSE

NONE KIN_SUCCESS Closes the Copy/Paste 
tool box.

Image Manager> 
Tools >
Copy/Paste

IMGEDIT TOOL-
COPYPASTE OPEN

NONE KIN_ERROR
KIN_SUCCESS

Opens the Copy/Paste 
tool box.

Image Manager> 
Tools >
Copy/Paste
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IMGEDIT TOOL-
STAMP CLOSE

NONE KIN_SUCCESS Closes the Draw tool 
box.

Image Manager> 
Tools >
Draw

IMGEDIT TOOL-
STAMP OPEN

NONE KIN_ERROR
KIN_SUCCESS

Opens the Draw tool 
box.

Image Manager> 
Tools >
Draw

IMGEDIT TOOL-
ERASE CLOSE

NONE KIN_SUCCESS Closes the Erase tool 
box.

Image Manager> 
Tools >
Erase

IMGEDIT TOOL-
ERASE OPEN

NONE KIN_ERROR
KIN_SUCCESS

Opens the Erase tool 
box.

Image Manager> 
Tools >
Erase

IMGEDIT TOOL-
FILTER CLOSE

NONE KIN_SUCCESS Closes the Filter tool 
box.

Image Manager> 
Tools >
Color Filter

IMGEDIT TOOL-
FILTER OPEN

NONE KIN_ERROR
KIN_SUCCESS

Opens the Filter tool 
box.

Image Manager> 
Tools >
Color Filter

IMGEDIT 
TOOLFILTERFILE 
CLOSE

NONE KIN_SUCCESS Closes the Filter File tool 
box.

Image Manager > 
Tools >
Color Filter File

IMGEDIT 
TOOLFILTERFILE 
OPEN

NONE KIN_ERROR
KIN_SUCCESS

Opens the Filter File tool 
box.

Image Manager > 
Tools >
Color Filter File

IMGEDIT TOOL-
PAINT CLOSE

NONE KIN_SUCCESS Closes the Paint tool 
box.

Image Manager> 
Tools >
Paint

IMGEDIT TOOL-
PAINT OPEN

NONE KIN_ERROR
KIN_SUCCESS

Opens the Paint tool 
box.

Image Manager> 
Tools >
Paint

IMGEDIT TOOL-
TRANSFORM CLOSE

NONE KIN_SUCCESS Closes the Local Trans-
form tool box.

Image Manager> 
Tools >
Local Transform
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IMGEDIT TOOL-
TRANSFORM OPEN

NONE KIN_ERROR
KIN_SUCCESS

Opens the Local Trans-
form tool box.

Image Manager> 
Tools >
Local Transform

IMGEDIT TOOL-
UNDOREDO CLOSE

KIN_SUCCESS Closes the Undo/Redo 
tool box.

Image Manager> 
Tools >
Undo/Redo

IMGEDIT TOOL-
UNDOREDO OPEN

KIN_ERROR
KIN_SUCCESS

Opens the Undo/Redo 
tool box.

Image Manager> 
Tools >
Undo/Redo

IMGEDIT TRANSLU-
CENCY GETONOFF 
<view number> 
(state)

Output:
SHORT

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the current 
translucency status 
(ON/OFF) for the 
active image in the 
specified view.

Image Manager >
Utilities >
Translucent Col-
ors

IMGEDIT TRANS-
FORM GETAREA 
(area)

Output:
STRING

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Get the current area 
type for Local Trans-
form tools.

Image Manager> 
Tools > 
Local Transform 

IMGEDIT TRANS-
FORM GETAREAOBJ-
FILTER

Output:
STRING

KIN_ERROR
KIN_SUCCESS

Returns the Raster 
Object filter name. 
If the image is 2 colors, 
possible filter names 
are foreground and 
background.

Image Manager> 
Tools > 
Local Transform

IMGEDIT TRANS-
FORM GETCOLOR

Output:
LONG

KIN_ERROR
KIN_SUCCESS

Returns the current 
color used by Local 
Transform tools.
Color indexes range 
from 0 to 255.

Image Manager> 
Tools > 
Local Transform

IMGEDIT TRANS-
FORM GETFILTER

Output:
STRING

KIN_ERROR
KIN_SUCCESS

Returns the current fil-
ter name used by Local 
Transform tools.

Image Manager> 
Tools > 
Local Transform

IMGEDIT TRANS-
FORM MIRRORHORI-
ZONTAL

NONE KIN_INVALID_SETTIN
GS
KIN_ERROR
KIN_SUCCESS

Starts the Horizontal 
Mirror Image Area com-
mand.

Image Manager> 
Tools > 
Local Transform
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IMGEDIT TRANS-
FORM MIRRORVER-
TICAL

NONE KIN_INVALID_SET-
TINGS
KIN_ERROR
KIN_SUCCESS

Starts the Vertical Mirror 
Image Area command.

Image Manager> 
Tools > 
Local Transform

IMGEDIT TRANS-
FORM MOVE

NONE KIN_INVALID_SET-
TINGS
KIN_ERROR
KIN_SUCCESS

Starts the Move Image 
Area command.

Image Manager> 
Tools > 
Local Transform

IMGEDIT TRANS-
FORM PLACE

NONE KIN_INVALID_SET-
TINGS
KIN_ERROR
KIN_SUCCESS

Starts the Place Image 
Area command.

Image Manager> 
Tools > 
Local Transform

IMGEDIT TRANS-
FORM ROTATE

NONE KIN_INVALID_SET-
TINGS
KIN_ERROR
KIN_SUCCESS

Starts the Rotate Image 
Area command.

Image Manager> 
Tools > 
Local Transform

IMGEDIT TRANS-
FORM SCALE

NONE KIN_INVALID_SET-
TINGS
KIN_ERROR
KIN_SUCCESS

Starts the Scale Image 
Area command.

Image Manager> 
Tools > 
Local Transform

IMGEDIT TRANS-
FORM SETAREA 
<BLOCK | ELEMENT 
| FENCE | RASTER-
OBJECT>

Input: 
STRING

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Sets the area for local 
transformations.

Image Manager> 
Tools > 
Local Transform

IMGEDIT TRANS-
FORM SETAREAOBJ-
FILTER
<filterName>

Input:
STRING

KIN_INVALID_PARAM 
KIN_ERROR
KIN_SUCCESS

Sets the Raster Object 
filter. If the image is 
1bit, possible filter 
names are foreground 
and background.

Image Manager> 
Tools > 
Local Transform

IMGEDIT TRANS-
FORM SETCOLOR
<colorIndex>

Input:
LONG

KIN_INVALID_PARAM 
KIN_ERROR
KIN_SUCCESS

Set the current color 
index used for erasing. 
Value ranges from 0 to 
255. 

Image Manager> 
Tools > 
Local Transform

IMGEDIT TRANS-
FORM SETFILTER
<filterName>

Input:
STRING

KIN_INVALID_PARAM 
KIN_ERROR
KIN_SUCCESS

Set the filter name used 
by the Local Transform 
tools.

Image Manager> 
Tools > 
Local Transform
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IMGEDIT TRANSF-
PLACE GETMODE 
(mode)

Output:
STRING

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the selected 
mode for transforming 
the geometry. Modes 
are INTERACTIVE or 
SOURCEDEST.

Image Manager> 
Tools > 
Local Transform 
> 
Place Image Area

IMGEDIT TRANSF-
PLACE GETUSE 
(NumberOfpoints)

Output:
SHORT

KIN_ERROR
KIN_SUCCESS

Returns the number of 
points selected for 
transforming the geom-
etry. 

Image Manager> 
Tools > 
Local Transform 
> Place Image 
Area

IMGEDIT TRANSF-
PLACE SETUSE 
<3PTS | 4PTS>

Input:
STRING

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Sets the number of 
points for transforming 
the geometry.

Image Manager> 
Tools > 
Local Transform>
Place Image Area

IMGEDIT TRANSF-
PLACE SETMODE 
<INTERACTIVE | 
SOURCEDEST>

Input:
STRING

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Sets the mode for trans-
forming the geometry.

Image Manager> 
Tools > 
Local Transform> 
Place Image Area

IMGEDIT TRANS-
FROTATE GETANGLE 
(angle)

Output:
DOUBLE

KIN_INVALID_PARAM 
KIN_ERROR
KIN_SUCCESS

Returns the selected 
value for specifying 
the angle of rotation.

Image Manager> 
Tools > 
Local Transform> 
Rotate Image 
Area

IMGEDIT TRANS-
FROTATE GETMODE 
(mode)

Output:
STRING

KIN_INVALID_PARAM 
KIN_ERROR
KIN_SUCCESS

Returns the selected 
mode for specifying the 
rotation. Modes are 
INTERACTIVE or 
FIXED.

Image Manager> 
Tools > 
Local Transform> 
Rotate Image 
Area

IMGEDIT TRANS-
FROTATE SETANGLE 
<angle>

Input:
DOUBLE

KIN_INVALID_PARAM 
KIN_ERROR
KIN_SUCCESS

Sets the angle of rota-
tion.

Image Manager> 
Tools > 
Local Transform> 
Rotate Image 
Area

IMGEDIT TRANS-
FROTATE SETMODE
<FIXED | INTERAC-
TIVE>

Input:
STRING

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Sets the mode for spec-
ifying the rotation.

Image Manager> 
Tools > 
Local Transform> 
Rotate Image 
Area
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IMGEDIT TRANSFS-
CALE GETMODE
(mode)

Output:
STRING

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the current 
scaling mode. Modes 
are INTERACTIVE, 
SCALE or DISTANCE.

Image Manager> 
Tools > 
Local Transform> 
Scale Image Area

IMGEDIT TRANSFS-
CALE GETVALUE 
(value)

Output:
DOUBLE

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the current 
scaling value.

Image Manager> 
Tools > 
Local Transform> 
Scale Image Area

IMGEDIT TRANSFS-
CALE SETMODE
<FIXEDDIATANCE | 
FIXEDSCALE | 
INTERACTIVE>

Input:
STRING

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Sets the current scaling 
mode.

Image Manager> 
Tools > 
Local Transform> 
Scale Image Area

IMGEDIT TRANSFS-
CALE SETVALUE 
<value>

Input:
DOUBLE

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Sets the current scaling 
value.

Image Manager> 
Tools > 
Local Transform> 
Scale Image Area

IMGEDIT TRANSLU-
CENCY ADDSAMPLE

NONE KIN_NOIMAGE
KIN_ERROR
KIN_SUCCESS

Starts the command 
that adds the colors 
sampled in the 
selected rectangle.

Image Manager >
Utilities >
Translucent 
Colors

IMGEDIT TRANSLU-
CENCY ALL 
<view number>

NONE KIN_NOIMAGE
KIN_ERROR
KIN_SUCCESS

Selects all colors as 
translucent.

Image Manager >
Utilities >
Translucent 
Colors

IMGEDIT TRANSLU-
CENCY APPLY

NONE KIN_NOIMAGE
KIN_ERROR
KIN_SUCCESS

Apply the translucency 
to selected colors for 
the active image.

Image Manager >
Utilities >
Translucent 
Colors

IMGEDIT TRANSLU-
CENCY GETMODE 
(mode)

Output:
STRING

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the current 
mode for sampling col-
ors. Modes are DIMEN-
SIONS or 
TWOCORNERS.

Image Manager >
Utilities >
Translucent 
Colors
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IMGEDIT TRANSLU-
CENCY 
GETPERCENT 
(percent)

Output:
SHORT

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the current per-
centage of translu-
cency.

Image Manager >
Utilities >
Translucent 
Colors

IMGEDIT TRANSLU-
CENCY GETXSIZE 
(size)

Output:
SHORT

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the current 
size (X axis) of the 
color capturing rectan-
gle. 

Image Manager >
Utilities >
Translucent 
Colors

IMGEDIT TRANSLU-
CENCY GETYSIZE 
(size)

Output:
SHORT

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the current 
size (Y axis) of the 
color capturing rectan-
gle.

Image Manager >
Utilities >
Translucent 
Colors

IMGEDIT TRANSLU-
CENCY INVERT 
<view number>

NONE KIN_NOIMAGE
KIN_ERROR
KIN_SUCCESS

Invert the status of each 
color for translucency.

Image Manager >
Utilities >
Translucent 
Colors

IMGEDIT TRANSLU-
CENCY NONE 
<view number>

NONE KIN_NOIMAGE
KIN_ERROR
KIN_SUCCESS

Deselect all colors for 
translucency.

Image Manager >
Utilities >
Translucent 
Colors

IMGEDIT TRANSLU-
CENCY RESET 
<view number>

NONE KIN_NOIMAGE
KIN_ERROR
KIN_SUCCESS

Reset translucency set-
tings as it was before 
the last change. 

Image Manager >
Utilities >
Translucent 
Colors

IMGEDIT TRANSLU-
CENCY SETMODE 
<DIMENSIONS | 
TWOCORNERS>

Input:
STRING

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Sets the mode for sam-
pling translucent colors. 
Modes are DIMEN-
SIONS or TWOCOR-
NERS.

Image Manager >
Utilities >
Translucent 
Colors:

IMGEDIT TRANSLU-
CENCY SETOFF 
<view number> 

NONE KIN_NOIMAGE
KIN_ERROR
KIN_SUCCESS

Sets the translucency 
to OFF for the active 
image in the specified 
view. 

Image Manager >
Utilities >
Translucent 
Colors

IMGEDIT TRANSLU-
CENCY SETON 
<view number> 

NONE KIN_NOIMAGE
KIN_ERROR
KIN_SUCCESS

Sets the translucency 
to ON for the active 
image in the specified 
view.

Image Manager >
Utilities >
Translucent 
Colors
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IMGEDIT TRANSLU-
CENCY SETPERCENT 
<25 | 50 | 75>

Input:
SHORT

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Sets the percentage of 
translucency for the 
selected colors. 

Image Manager >
Utilities >
Translucent 
Colors

IMGEDIT TRANSLU-
CENCY SETXSIZE 
<size>

Input:
SHORT

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_INVALID_SET-
TINGS
KIN_ERROR
KIN_SUCCESS

Sets the current size (X 
axis) of the color cap-
turing rectangle. Only 
available when capture 
mode is DIMENSIONS. 

Image Manager >
Utilities >
Translucent 
Colors

IMGEDIT TRANSLU-
CENCY SETYSIZE 
<size>

Input:
SHORT

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_INVALID_SET-
TINGS
KIN_ERROR
KIN_SUCCESS

Sets the current size (Y 
axis) of the color cap-
turing rectangle. Only 
available when capture 
mode is DIMENSIONS. 

Image Manager >
Utilities >
Translucent 
Colors

IMGEDIT TRANSLU-
CENCY SUBSAMPLE 

NONE KIN_NOIMAGE
KIN_ERROR
KIN_SUCCESS

Starts the command 
that deselect the colors 
sampled in the 
selected rectangle.

Image Manager >
Utilities >
Translucent 
Colors

IMGEDIT TRANSPAR-
ENCY ADDSAMPLE

NONE KIN_NOIMAGE
KIN_ERROR
KIN_SUCCESS

Starts the command 
that adds the colors 
sampled in the 
selected rectangle.

Image Manager >
Utilities >
Transparent 
Colors

IMGEDIT TRANSPAR-
ENCY ALL 

NONE KIN_NOIMAGE
KIN_ERROR
KIN_SUCCESS

Selects all colors as 
transparent.

Image Manager >
Utilities >
Transparent 
Colors

IMGEDIT TRANSPAR-
ENCY APPLY

NONE KIN_NOIMAGE
KIN_ERROR
KIN_SUCCESS

Apply the transparency 
to selected colors for 
the active image.

Image Manager >
Utilities >
Transparent 
Colors

IMGEDIT TRANSPAR-
ENCY GETMODE 
(mode)

Output:
STRING

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the current 
mode for sampling col-
ors. Modes are DIMEN-
SIONS or 
TWOCORNERS.

Image Manager >
Utilities >
Transparent 
Colors

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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IMGEDIT TRANSPAR-
ENCY GETONOFF 
(state)

Output:
SHORT

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the current 
transparency status 
(ON/OFF) for the 
active image in the 
specified view.

Image Manager >
Utilities >
Transparent 
Colors

IMGEDIT TRANSPAR-
ENCY GETXSIZE 
(size)

Output:
SHORT

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the current 
size (X axis) of the 
color capturing rectan-
gle.

Image Manager >
Utilities >
Transparent 
Colors

IMGEDIT TRANSPAR-
ENCY GETYSIZE 
(size)

Output:
SHORT

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the current 
size (Y axis) of the 
color capturing rectan-
gle.

Image Manager >
Utilities >
Transparent 
Colors

IMGEDIT TRANSPAR-
ENCY INVERT 

NONE KIN_NOIMAGE
KIN_ERROR
KIN_SUCCESS

Invert the status of each 
color for transparency.

Image Manager >
Utilities >
Transparent 
Colors

IMGEDIT TRANSPAR-
ENCY NONE 

NONE KIN_NOIMAGE
KIN_ERROR
KIN_SUCCESS

Deselect all colors for 
transparency.

Image Manager >
Utilities >
Transparent 
Colors

IMGEDIT TRANSPAR-
ENCY RESET 

NONE KIN_NOIMAGE
KIN_ERROR
KIN_SUCCESS

Reset transparency set-
tings as it was before 
the last change.

Image Manager >
Utilities >
Transparent 
Colors

IMGEDIT TRANSPAR-
ENCY SETMODE 
<DIMENSIONS | 
TWOCORNERS>

Input:
STRING

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Sets the mode for sam-
pling transparent col-
ors. Modes are 
DIMENSIONS or TWO-
CORNERS.

Image Manager >
Utilities >
Transparent 
Colors:

IMGEDIT TRANSPAR-
ENCY SETOFF 

NONE KIN_NOIMAGE
KIN_ERROR
KIN_SUCCESS

Sets the transparency to 
OFF for the active 
image in the specified 
view.

Image Manager >
Utilities >
Transparent 
Colors

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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IMGEDIT TRANSPAR-
ENCY SETON 

NONE KIN_NOIMAGE
KIN_ERROR
KIN_SUCCESS

Sets the transparency to 
ON for the active image 
in the specified view.

Image Manager >
Utilities >
Transparent 
Colors

IMGEDIT TRANSPAR-
ENCY SETXSIZE 
<size>

Input:
SHORT

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_INVALID_SET-
TINGS
KIN_ERROR
KIN_SUCCESS

Sets the current size (X 
axis) of the color cap-
turing rectangle. Only 
available when capture 
mode is DIMENSIONS.

Image Manager >
Utilities >
Transparent 
Colors

IMGEDIT TRANSPAR-
ENCY SETYSIZE 
<size>

Input:
SHORT

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_INVALID_SET-
TINGS
KIN_ERROR
KIN_SUCCESS

Sets the current size (Y 
axis) of the color cap-
turing rectangle. Only 
available when capture 
mode is DIMENSIONS.

Image Manager >
Utilities >
Transparent Col-
ors

IMGEDIT TRANSPAR-
ENCY SUBSAMPLE

NONE KIN_NOIMAGE
KIN_ERROR
KIN_SUCCESS

Starts the command 
that deselect the colors 
sampled in the 
selected rectangle.

Image Manager >
Utilities >
Transparent Col-
ors

IMGEDIT 
UNDOREDO 
GETENABLE 
(state)

Output:
SHORT

KIN_INVALID_PARAM
KIN+ERROR
KIN_SUCCESS

Returns the Undo/
Redo enable state (ON 
or OFF).

Image Manager >
Settings >
Undo/Redo

IMGEDIT 
UNDOREDO 
GETFILE 
(filename)

Output:
STRING

KIN_INVALID_PARAM
KIN+ERROR
KIN_SUCCESS

Returns the file name 
used for undo opera-
tions. If no file name is 
defined, “NONE” is 
returned.

Image Manager >
Settings >
Undo/Redo

IMGEDIT 
UNDOREDO GET-
MEMORYSIZE 
(memsize)

Output:
LONG

KIN_INVALID_PARAM
KIN+ERROR
KIN_SUCCESS

Returns the current 
memory size used for 
undo operations (Kb). 

Image Manager >
Settings >
Undo/Redo

IMGEDIT 
UNDOREDO GET-
SIZEFILE 
(filesize)

Output:
LONG

KIN_INVALID_PARAM
KIN+ERROR
KIN_SUCCESS

Returns the maximum 
file size of the file used 
for undo operations 
(Kb).

Image Manager >
Settings >
Undo/Redo

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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IMGEDIT 
UNDOREDO REDO

NONE KIN_NOIMAGE
KIN+ERROR
KIN_SUCCESS

Activates the Redo 
Image command.

Image Manager >
Tools >
Undo/Redo

IMGEDIT 
UNDOREDO SETFILE 
<filename>

Input:
STRING

KIN_INVALID_PARAM
KIN_FILE_EXIST
KIN+ERROR
KIN_SUCCESS

Sets the file used for 
undo operations. The 
file must not exist.

Image Manager >
Settings >
Undo/Redo

IMGEDIT 
UNDOREDO SET-
MEMORYSIZE 
<size>

Input:
LONG

KIN_INVALID_PARAM
KIN+ERROR
KIN_SUCCESS

Sets the size of memory 
for undo operations. 
Value range from 0 to 9 
999 999 999 (Kb).

Image Manager >
Settings >
Undo/Redo

IMGEDIT 
UNDOREDO SETOF-
FENABLE

NONE KIN+ERROR
KIN_SUCCESS

Sets the Undo/Redo 
Enable status to OFF.

Image Manager >
Settings >
Undo/Redo

IMGEDIT 
UNDOREDO SET-
ONENABLE

NONE KIN+ERROR
KIN_SUCCESS

Sets the Undo/Redo 
Enable status to ON.

Image Manager >
Settings >
Undo/Redo

IMGEDIT 
UNDOREDO SET-
SIZEFILE 
<size>

Input:
LONG

KIN_INVALID_PARAM
KIN+ERROR
KIN_SUCCESS

Sets the maximum file 
size of the file used for 
undo operations. Value 
range from 0 to 9 999 
999 999. (Kb).

Image Manager >
Settings >
Undo/Redo

IMGEDIT 
UNDOREDO UNDO

NONE KIN_NOIMAGE
KIN+ERROR
KIN_SUCCESS

Activates the Undo 
Image command.

Image Manager >
Tools >
Undo/Redo

IMGEDIT VERSION 
GET 
(version) (subver-
sion) (revision) (sub-
revision)

Output:
SHORT
SHORT
SHORT
SHORT

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the current ver-
sion, subversion, revi-
sion and sub revision of 
the Image Edit module. 

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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Image Manager Key-ins

Key-In Parameters
Returned Error 
Codes

Description
Graphical 
Interface

IMGMANAGER 
ACTIVEIMAGE GET

Output:
STRING

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the name of the 
active image.

IMGMANAGER 
ACTIVEIMAGE NONE

NONE KIN_SUCCESS De-activates any active 
image. 

IMGMANAGER 
ACTIVEIMAGE SET
[view number] 
[filename]

Input:
SHORT,
[STRING]

KIN_INVALID_VIEW
KIN_FILE_NOT_
FOUND
KIN_NOIMAGE
KIN_ERROR
KIN_SUCCESS

Sets the specified image 
active. If filename is not 
specified, applies to the 
selected image of the 
specified view If none 
or more than one image 
is selected in the 
specified view, a data 
point is required to 
identify the desired 
image If view is not 
specified, a data point is 
required to identify the 
desired view and the 
image
Note: The first Input 
parameter must be 
given to return a valid 
error code.

Image Manager >
Edit >
Set Active Image

IMGMANAGER 
ACTIVEIMAGE SET-
BYINDEX
< View> < Index 
number>

Input:
SHORT,
SHORT

KIN_INVALID_VIEW
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Sets active image to the 
specified index num-
ber in the list of 
images. Index starts at 
1.

IMGMANAGER 
BATCHCONVER 
COLORCOMPGETFIL
E (filename)

Output:
STRING

KIN_SUCCESS
KIN_INVALID_PARAM
KIN_ERROR

Returns the name of the 
color cube file created 
or used in the color 
compression process.

Image Manager >
File>
Batch Conversion
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IMGMANAGER 
BATCHCONVER 
COLORCOMPGET-
MODE (mode)

Output:
STRING

KIN_SUCCESS
KIN_INVALID_PARAM
KIN_ERROR

Returns the color 
compression mode. 
Modes are STANDARD, 
CUSTOM and CREATE.

Image Manager >
File>
Batch Conversion

IMGMANAGER 
BATCHCONVER 
COLORCOMPGETNB
COLOR (nb colors)

Output:
SHORT

KIN_SUCCESS
KIN_INVALID_PARAM
KIN_ERROR

Returns the number of 
colors used in the color 
compression.

Image Manager >
File>
Batch Conversion

IMGMANAGER 
BATCHCONVER 
COLORCOMPSET-
FILE <filename>

Input:
STRING

KIN_SUCCESS
KIN_INVALID_PARAM
KIN_FILE_EXIST
KIN_ERROR

Sets the name of the 
color cube file created 
or used in the color 
compression process.

Image Manager >
File>
Batch Conversion

IMGMANAGER 
BATCHCONVER 
COLORCOMPSETMO
DE <STANDARD | 
CUSTOM | CREATE>

Input:
STRING

KIN_SUCCESS
KIN_INVALID_PARAM
KIN_ERROR

Sets the color 
compression mode.

Image Manager >
File>
Batch Conversion

IMGMANAGER 
BATCHCONVER 
COLORCOMPSETNB
COLOR <nb colors>

Input:
SHORT

KIN_SUCCESS
KIN_INVALID_COLOR
KIN_ERROR

Sets the number of 
colors used in the color 
compression.

Image Manager >
File>
Batch Conversion

IMGMANAGER 
BATCHCONVER 
GETRESULT (status)

Output:
SHORT

KIN_SUCCESS Gets the status (ON/
OFF) of the option for 
displaying result dur-
ing a batch conversion 
process.

Image Manager 
>File> Batch Con-
version

IMGMANAGER 
BATCHCONVER 
SETOUTPUTSETTIN
G <Extension> 
<Pixel Type> 
<Compression> 
<Directory>

Input:
STRING
STRING
STRING
STRING

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Sets the options 
(Extension, Pixel Type, 
Compression and 
Directory) for the output 
file (see “Image File 
Formats” on page A-120 
for available options).

Image Manager >
File > 
Batch Conversion

Key-In Parameters
Returned Error 
Codes

Description
Graphical 
Interface
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IMGMANAGER 
BATCHCONVER SET-
RESULTOFF

NONE KIN_SUCCESS Sets the status to OFF 
for the option of dis-
playing result during a 
batch conversion pro-
cess.

Image Manager 
>File> Batch Con-
version

IMGMANAGER 
BATCHCONVER SET-
RESULTON

NONE KIN_SUCCESS Sets the status to ON 
for the option of dis-
playing result during a 
batch conversion pro-
cess.

Image Manager 
>File> Batch Con-
version

IMGMANAGER 
BATCHCOT  
GETTILED
(status)

Output:
SHORT

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the tiling status 
for the creation of a COT 
file.

Image Manager >
File > 
Batch Conversion

IMGMANAGER 
BATCHCOT 
SETTILEDOFF

NONE KIN_SUCCESS Sets the tiling to OFF for 
the creation of a COT 
file.

Image Manager >
File > 
Batch Conversion

IMGMANAGER 
BATCHCOT 
SETTILEDON

NONE KIN_SUCCESS Sets the tiling to ON for 
the creation of a COT 
file.

Image Manager >
File > 
Batch Conversion

IMGMANAGER 
BATCHTIF  
GETTILED (status)

Output:
SHORT

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the tiling status 
for the creation of a TIFF 
file.

Image Manager >
File > 
Batch Conversion

IMGMANAGER 
BATCHTIF 
SETTILEDOFF

NONE KIN_SUCCESS Sets the tiling to OFF for 
the creation of a TIFF 
file.

Image Manager >
File > 
Batch Conversion

IMGMANAGER 
BATCHTIF 
SETTILEDON

NONE KIN_SUCCESS Sets the tiling to ON for 
the creation of a TIFF 
file.

Image Manager >
File > 
Batch Conversion

IMGMANAGER 
COLORDIST 
GET24BITS (status)

Output:
SHORT

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the 24 bits 
display status.

Image Manager >
Setting > 
Preferences> 
Colors

Key-In Parameters
Returned Error 
Codes

Description
Graphical 
Interface
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IMGMANAGER 
COLORDIST 
GETEXACTDGN-
COLORS (nb colors)

Output:
SHORT

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the Number of 
Exact DGN Colors.

Image Manager >
Settings > 
Preferences> 
Colors

IMGMANAGER 
COLORDIST 
GETEXACTIMAGE-
COLORS (nb colors)

Output:
SHORT

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the Number of 
Exact Image Colors.

Image Manager >
Setting > 
Preferences> 
Colors

IMGMANAGER 
COLORDIST 
GETEXACTMS-
COLORS (nb colors)

Output:
SHORT

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the Number of 
Exact MicroStation 
Colors.

Image Manager >
Setting > 
Preferences> 
Colors

IMGMANAGER 
COLORDIST 
SET24BITSOFF

NONE KIN_SUCCESS Sets 24 bits display 
option to OFF.

Image Manager >
Setting > 
Preferences> 
Colors

IMGMANAGER 
COLORDIST 
SET24BITSON 

NONE KIN_SUCCESS Sets 24 bits display 
option to ON.

Image Manager >
Setting > 
Preferences> 
Colors

IMGMANAGER 
COLORDIST 
SETEXACTDGN-
COLORS <nb colors>

Input:
SHORT

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Sets the Number of 
Exact DGN Colors.

Image Manager >
Settings > 
Preferences> 
Colors

IMGMANAGER 
COLORDIST 
SETEXACTIMAGE-
COLORS <nb colors>

Input:
SHORT

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Sets the Number of 
Exact Image Colors.

Image Manager >
Setting > 
Preferences> 
Colors

IMGMANAGER 
COLORDIST 
SETEXACTMS-
COLORS <nb colors>

Input:
SHORT

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Sets the Number of 
Exact MicroStation 
Colors.

Image Manager >
Setting > 
Preferences> 
Colors

Key-In Parameters
Returned Error 
Codes

Description
Graphical 
Interface
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IMGMANAGER 
DIALOG CLOSE

NONE KIN_SUCCESS Closes the main dialog 
of Descartes -  Image 
Manager

IMGMANAGER 
DIALOG OPEN

NONE KIN_ERROR
KIN_SUCCESS

Opens the main dialog 
of Descartes -  Image 
Manager

IMGMANAGER 
DISPLAY 1FOR1 
[view number]  
[filename]

Input:
[SHORT],
[STRING]

KIN_INVALID_VIEW
KIN_FILE_NOT_
FOUND
KIN_NOIMAGE
KIN_ERROR
KIN_SUCCESS

Sets the specified image 
to actual resolution (1:1) 
for the selected view. If 
filename is not 
specified, applies to the 
selected image in the 
specified view If none 
or more than one image 
is selected in the 
specified view, a data 
point is required to 
identify the desired 
image. If view is not 
specified, a data point is 
required to identify the 
desired view and image
Note: The first Input 
parameter must be 
given to return a valid 
error code.

Image Manager > 
Display > 
Actual Resolution 
(1:1)

IMGMANAGER 
DISPLAY APPLYALL
[source view] 

Input:
SHORT,

KIN_INVALID_VIEW
KIN_SUCCESS
KIN_ERROR

Copies the list of images 
of the source view in all 
others opened views. If 
no source view is 
specified, a data point is 
required to identify the 
desired source view.

Image Manager >
Display >
Apply To All

Key-In Parameters
Returned Error 
Codes

Description
Graphical 
Interface
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IMGMANAGER 
DISPLAY APPLYTO
[source view] 
[destination view]

Input:
SHORT,
SHORT

KIN_INVALID_VIEW
KIN_SUCCESS
KIN_ERROR

Copies the list of images 
of the source view in the 
specified destination 
view. If destination view 
is not specified, the 
dialog “Apply To” will 
be opened. If source 
view is not specified, a 
data point is required to 
identify the desired 
source view.

Image Manager >
Display > 
Apply To

IMGMANAGER 
DISPLAY BACK 
[view number]  
[filename]

Input:
[SHORT],
[STRING]

KIN_INVALID_VIEW
KIN_FILE_NOT_
FOUND
KIN_NOIMAGE
KIN_ERROR
KIN_SUCCESS

Sends the specified 
image to the back in the 
selected view. If 
filename is not 
specified, applies to the 
selected images of the 
specified view. If view is 
not specified, a data 
point is required to 
identify the desired 
view. If no images are 
selected in this view, a 
data point is required to 
identify the desired 
image.
Note: The first Input 
parameter must be 
given to get a valid 
returned error code.

Image Manager > 
Display > 
Send to Back

Key-In Parameters
Returned Error 
Codes

Description
Graphical 
Interface
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IMGMANAGER 
DISPLAY FIT 
[view number]  
[filename]

Input:
[SHORT],
[STRING]

KIN_INVALID_VIEW
KIN_NOIMAGE
KIN_FILE_NOT_
FOUND
KIN_ERROR
KIN_SUCCESS

Fits the specified image 
to the view. If filename 
is not specified, the 
selected images of the 
specified view will be 
used. If view is absent, 
a data point is required 
to identify the desired 
view. If no images are 
selected in this view, a 
data point is required to 
identify the desired 
image.
Note: The first Input 
parameter must be 
given to get a valid 
returned error code.

Image Manager > 
Display> 
Fit Image (s) to 
View

IMGMANAGER 
DISPLAY FITALL 
[view number]

Input:
[SHORT]

KIN_INVALID_VIEW
KIN_ERROR
KIN_SUCCESS

Fits all visible image to 
a view. If view is not 
specified, a data point is 
required to identify the 
desired view.
Note: Input parameter 
must be given to get a 
valid returned error 
code.

Image Manager > 
Display> 
Fit All Images to 
View

Key-In Parameters
Returned Error 
Codes

Description
Graphical 
Interface
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IMGMANAGER 
DISPLAY FRONT 
[view number]  
[filename]

Input:
[SHORT],
[STRING]

KIN_INVALID_VIEW
KIN_FILE_NOT_
FOUND
KIN_NOIMAGE
KIN_ERROR
KIN_SUCCESS

Brings the specified 
image to the front in the 
selected view. If 
filename is not 
specified, applies to the 
selected images of the 
specified view. If view is 
not specified, a data 
point is required to 
identify the desired 
view. If no images are 
selected in this view, a 
data point is required to 
identify the desired 
image.
Note: The first Input 
parameter must be 
given to get a valid 
returned error code.

Image Manager > 
Display> 
Bring to Front

IMGMANAGER 
DISPLAY GETONOFF 
<view number> 
[filename] (status)

Input:
SHORT,
[STRING]
Output:
SHORT

KIN_INVALID_PARAM
KIN_INVALID_VIEW
KIN_FILE_NOT_
FOUND
KIN_SUCCESS
KIN_ERROR

Returns the status (ON/
OFF) of the specified 
image in the selected 
view. Applies to the first 
selected images if no 
filename is specified.

IMGMANAGER 
DISPLAY SETOFF 
 [view number] 
[filename]

Input:
SHORT,
[STRING]

KIN_INVALID_VIEW
KIN_FILE_NOT_
FOUND
KIN_INVALID_PARAM
KIN_SUCCESS
KIN_ERROR

Sets OFF the specified 
image in the selected 
view. Applies to the 
selected images of the 
specified view if no 
filename is specified. If 
no view is specified, a 
data point is required to 
identify the desired 
view.

Image Manager > 
Display> 
Image(s) Off

Key-In Parameters
Returned Error 
Codes

Description
Graphical 
Interface
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IMGMANAGER 
DISPLAY SETON 
 [view number] 
[filename]

Input:
SHORT,
[STRING]

KIN_INVALID_VIEW
KIN_FILE_NOT_
FOUND
KIN_INVALID_PARAM
KIN_SUCCESS
KIN_ERROR

Sets ON the specified 
image in the selected 
view. Applies to the 
selected images of the 
specified view if no 
filename is specified. If 
no view is specified, a 
data point is required to 
identify the desired view 
and images.

Image Manager > 
Display> 
Image(s) On

IMGMANAGER 
DLGCOLORDIST 
OPEN

NONE KIN_ERROR
KIN_SUCCESS

Opens the Color 
Distribution dialog.

Image Manager >
Settings >
Preferences >
Colors…

IMGMANAGER 
DLGGENERAL OPEN

NONE KIN_ERROR
KIN_SUCCESS

Opens the Properties 
General dialog.

Image Manager >
File >
Properties >
General

IMGMANAGER 
DLGLOCATION 
OPEN

NONE KIN_NOIMAGE
KIN_ERROR
KIN_SUCCESS

Opens the Image 
Location Editor dialog.

Image Manager > 
File> Properties > 
Location

IMGMANAGER 
DLGMEMORY OPEN

NONE KIN_ERROR
KIN_SUCCESS

Opens the Memory 
Allocation dialog.

Image Manager >
Settings > 
Preferences > 
Memory

IMGMANAGER 
DLGPLOT OPEN

NONE KIN_ERROR
KIN_SUCCESS

Opens the Plot dialog. Image Manager >
File >
Plot

IMGMANAGER 
DLGVIEW CLOSE

NONE KIN_ERROR
KIN_SUCCESS

Closes the View Image 
Attributes dialog.

Image Manager >
Settings > 
View Image 
Attributes

Key-In Parameters
Returned Error 
Codes

Description
Graphical 
Interface
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IMGMANAGER 
DLGVIEW OPEN

NONE KIN_ERROR
KIN_SUCCESS

Opens the View Image 
Attributes dialog.

Image Manager >
Settings > 
View Image 
Attributes

IMGMANAGER FILE 
BATCHCONVER
<filename>

Input:
STRING

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Convert the given file to 
a new file format. If no 
filename is specified, 
the Batch Conversion 
dialog is opened.

Image Manager >
File > 
Batch Conversion

IMGMANAGER FILE 
CLOSE 
 [view number] 
[filename]

Input:
SHORT,
[STRING]

KIN_INVALID_VIEW
KIN_FILE_NOT_
FOUND
KIN_NO_ACTIVE_FILE
KIN_SUCCESS
KIN_ERROR

Closes the specified 
image in the specified 
view. If no filename is 
specified, closes the 
selected images in the 
specified view. If no 
view is specified, a data 
point is required to 
identify the desired view

Image Manager > 
File> 
Close

IMGMANAGER FILE 
CLOSEALL 

NONE KIN_SUCCESS Closes all images in all 
views.

Image Manager > 
File> 
Closeall

IMGMANAGER FILE 
NEW

NONE KIN_SUCCESS
KIN_ERROR

Opens the New Image 
dialog.

Image Manager > 
File> 
New…

IMGMANAGER FILE 
OPEN [filename]

Input:
,
STRING

KIN_INVALID_FILE_
NAME
KIN_SUCCESS
KIN_ERROR

Opens the specified 
image in the specified 
view. If no filename is 
specified, opens the 
Image File Selection 
dialog.
Note: Input parameter 
must be given to get a 
valid returned error 
code.

Image Manager > 
File> 
Open…

Key-In Parameters
Returned Error 
Codes

Description
Graphical 
Interface
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IMGMANAGER FILE 
SAVE 

NONE KIN_FILE_READ_ONLY
KIN_NO_ACTIVE_FILE
KIN_ERROR
KIN_SUCCESS

Saves the active image. Image Manager > 
File> 
Save

IMGMANAGER FILE 
SAVEAS 
<filename>

Input:
STRING

KIN_FILE_EXIST
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS
KIN_NO_ACTIVE_FILE

Saves the active image 
under the specified 
name. If no filename is 
specified, opens the 
Image File Creation 
dialog.

Image Manager > 
File > 
Save as

IMGMANAGER 
IMAGE 
GETCOLORCOUNT
<ColorIndex> (Count)

Input:
SHORT
Output:
LONG

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the number of 
pixels count of the 
specified color index in 
the active image.

Image Manager >
File >
Properties >
Histogram

IMGMANAGER 
IMAGE GETCOUNT
< View> (Count)

Input:
SHORT
Output:
LONG

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the number of 
images opened in the 
specified view.

IMGMANAGER 
IMAGE 
GETFILENAME
(FileName)

Output:
STRING

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_INVALID_VIEW
KIN_SUCCESS

Returns the file name of 
the active image.

Image Manager >
File >
Properties >
General

IMGMANAGER 
IMAGE GETFORMAT
(Format)

Output:
STRING

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the file format of 
the active image.

Image Manager >
File >
Properties >
General

IMGMANAGER 
IMAGE GETONOFF
<view> (Status)

Input:
SHORT
Output:
SHORT

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_INVALID_VIEW
KIN_SUCCESS

Returns the status (ON/
OFF).of the active image 

Image Manager 
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IMGMANAGER 
IMAGE 
GETPALETTECOLOR
<ColorIndex> (Red) 
(Green) (Blue) 

Input:
SHORT
Output:
SHORT
SHORT
SHORT

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the red, green 
and blue values for the 
specified color index in 
the color palette of the 
active image.

Image Manager >
File >
Properties >
Color Table

IMGMANAGER 
IMAGE 
GETPALETTESIZE
(PaletteSize)

Output:
SHORT

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the color palette 
size of the active image.

IMGMANAGER 
IMAGE 
GETPIXELTYPE
(PixelType)

Output:
STRING

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the pixel type of 
the active image.

Image Manager >
File >
Properties >
General

IMGMANAGER 
IMAGE 
GETTRANSLUCENCE
<View> <ColorIndex> 
(State)

Input:
SHORT
SHORT
Output:
SHORT

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the 
translucence state for 
the specified color 
index in palette of the 
active image for the 
specified view.

Image Manager >
Utilities >
Translucent 
Colors

IMGMANAGER 
IMAGE 
GETTRANSLUCENCE
PERCENT
<View> (Percent)

Input:
SHORT
Output:
DOUBLE

KIN_NOIMAGE
KIN_INVALID_VIEW
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the 
translucence percent 
value for the active 
image in the specified 
view.

Image Manager >
Utilities >
Translucent 
Colors

IMGMANAGER 
IMAGE 
GETTRANSPARENCE
<View> <ColorIndex> 
(State)

Input:
SHORT
SHORT
Output:
SHORT

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the 
transparence state for 
the specified color 
index in palette of the 
active image for the 
specified view.

Image Manager >
Utilities >
Transparent 
Colors

IMGMANAGER 
IMAGE 
GETXNBPIXELS
(NbPixels)

Output:
LONG

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the width of the 
active image in pixels.

Image Manager >
File >
Properties >
Location

Key-In Parameters
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IMGMANAGER 
IMAGE GETYNB-
PIXELS
(NbPixels)

Output:
LONG

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the height of 
the active image in pix-
els.

Image Manager >
File >
Properties >
Location

IMGMANAGER 
IMAGE QUERY
<View> (ImgList)

Input:
SHORT
Output:
STRUCT

KIN_INVALID_VIEW
KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns all the informa-
tion related to the list of 
images opened in the 
specified view. The 
ImgList is defined in the 
imgquery.h file. See 
mdl\exam-
ples\imgquery for an 
example.
NB: Available for MDL 
programming only.

IMGMANAGER 
IMAGE QUERYFREE
< ImgList >

Input:
STRUCT

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Free the memory allo-
cated for the specified 
ImgList by the key-in 
IMGMANAGER IMAGE 
QUERY.
NB: Available for MDL 
programming only.

IMGMANAGER 
IMAGE SELECT 
[view number]  
[filename]

Input:
[SHORT],
[STRING]

KIN_INVALID_VIEW
KIN_FILE_NOT_
FOUND
KIN_NOIMAGE
KIN_ERROR
KIN_SUCCESS

Selects the specified 
image in the specified 
view. If filename is not 
specified, selects all 
images of the specified 
view. If view is not 
specified, a data point is 
required to identify the 
desired view and image.
Note: The first Input 
parameter must be 
given to get a valid 
returned error code.

Image Manager >
Tools >
Image Control >
Select Images / 
Active Image

IMGMANAGER 
IMAGE SETOFF
<view>

Input:
SHORT

KIN_NOIMAGE
KIN_INVALID_VIEW
KIN_SUCCESS

Sets the status of the 
active image to OFF.

Image Manager
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IMGMANAGER 
IMAGE SETON
<view>

Input:
SHORT

KIN_NOIMAGE
KIN_INVALID_VIEW
KIN_SUCCESS

Sets the status of the 
active image to ON.

Image Manager

IMGMANAGER 
IMAGE UNSELECT
 [view number] 
[filename]

Input:
SHORT,
STRING

KIN_INVALID_VIEW
KIN_FILE_NOT_
FOUND
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Deselects the specified 
image in the specified 
view. If filename is not 
specified, applies to the 
selected images of the 
specified view. If view is 
not specified, all the 
selected images of all 
views are deselected. 

IMGMANAGER 
LOCATION GETDESC 
(description)

Output:
STRING

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the Location 
Description for the 
active image.

Image Manager > 
File > Properties > 
Location

IMGMANAGER 
LOCATION 
GETPIXSIZE (size)

Output:
STRING

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the Pixel Size 
value for the active 
image.

Image Manager > 
File> 
Properties > 
Location

IMGMANAGER 
LOCATION 
GETXORIGIN 
(originX)

Output:
STRING

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the X Origin 
value for the active 
image.

Image Manager > 
File> 
Properties > 
Location

IMGMANAGER 
LOCATION 
GETYORIGIN 
(OriginY)

Output:
STRING

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the Y Origin 
value for the active 
image.

Image Manager > 
File> 
Properties > 
Location

IMGMANAGER 
LOCATION SETDESC 
<description>

Input:
STRING

KIN_NOIMAGE
KIN_FILE_READ_ONLY
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Sets the Location 
Description for the 
active image. (e.g.: 
1:50.000) 

Image Manager > 
File> 
Properties > 
Location
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IMGMANAGER 
LOCATION 
SETPIXSIZE <size>

Input:
STRING

KIN_NOIMAGE
KIN_FILE_READ_ONLY
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Sets the Pixel Size value 
for the active image. 
(e.g.: 1:50.000) 

Image Manager > 
File> 
Properties > 
Location

IMGMANAGER 
LOCATION 
SETXORIGIN 
<originX>

Input:
STRING

KIN_NOIMAGE
KIN_FILE_READ_ONLY
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Sets the X Origin value 
for the active image. 
(e.g.: 100:10.000) 

Image Manager > 
File> 
Properties > 
Location

IMGMANAGER 
LOCATION 
SETYORIGIN 
<originY>

Input:
STRING

KIN_NOIMAGE
KIN_FILE_READ_ONLY
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Sets the Y Origin value 
for the active image. 
(e.g.: 100:10.000) 

Image Manager > 
File> 
Properties > 
Location

IMGMANAGER 
MEMORY 
GETNUMFILETILES 
(count)

Output:
SHORT

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the number of 
Image File buffers.

Image Manager >
Settings > 
Preferences > 
Memory

IMGMANAGER 
MEMORY 
GETNUMSCREENTIL
ES (count)

Output:
SHORT

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the number of 
Screen Tile buffers.

Image Manager >
Settings > 
Preferences > 
Memory

IMGMANAGER 
MEMORY 
GETXSIZESCREEN-
TILED (X size)

Output:
SHORT

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the Size in the X 
axis of Screen Tile 
buffers. (e.g.: 256) 

Image Manager >
Settings > 
Preferences > 
Memory

IMGMANAGER 
MEMORY 
GETYSIZESCREEN-
TILED (Y size)

Output:
SHORT

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the Size in the Y 
axis of Screen Tile 
buffers. (e.g.: 256)

Image Manager >
Settings > 
Preferences > 
Memory

IMGMANAGER 
MEMORY 
SETNUMFILETILES 
<count>

Input:
SHORT

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Sets the Number of file 
buffers for the active 
image. (e.g.: 20) 

Image Manager >
Settings > 
Preferences > 
Memory
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IMGMANAGER 
MEMORY 
SETNUMSCREEN-
TILES <count>

Input:
SHORT

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Sets the Number of 
Screen Tile buffers. 
(e.g.: 20)

Image Manager >
Settings > 
Preferences > 
Memory

IMGMANAGER 
MEMORY 
SETXSIZESCREEN-
TILED <X size>

Input:
SHORT

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Sets the Size in the X 
axis of Screen Tile 
buffers. (e.g.: 256) 

Image Manager >
Settings > 
Preferences > 
Memory

IMGMANAGER 
MEMORY 
SETYSIZESCREEN-
TILED <Y size>

Input:
SHORT

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Sets the Size in the Y 
axis of Screen Tile 
buffers. (e.g.: 256)

Image Manager >
Settings > 
Preferences > 
Memory

IMGMANAGER 
NEWIMAGE 
GETBACKCOLOR
(Red) (Green) (Blue)

Output:
SHORT
SHORT
SHORT

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the background 
color of the new image.

Idem

IMGMANAGER 
NEWIMAGE 
GETCOLUMNS
(columns)

Output:
LONG

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the number of 
columns of the new 
image.

Idem

IMGMANAGER 
NEWIMAGE 
GETCOMPRESSION
(Compression Type)

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the 
compression mode of 
the new image.

Idem

IMGMANAGER 
NEWIMAGE 
GETDESCRIPTION
(Description)

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the description 
of the new image.

Idem

IMGMANAGER 
NEWIMAGE 
GETLOCKCOLROW
(State)

Output:
SHORT

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the status of the 
locking option for 
columns and rows when 
in interactive place 
mode (ON/OFF).

Idem
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IMGMANAGER 
NEWIMAGE 
GETLOCKPIXELSIZE
(State)

Output:
SHORT

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the status of the 
locking option for the 
pixel size when in 
interactive place mode 
(ON/OFF).

Idem

IMGMANAGER 
NEWIMAGE 
GETPIXELSIZE
(PixelSize)

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the pixel size of 
the new image in 
Working units. 
(ex: 1:150.000)

Idem

IMGMANAGER 
NEWIMAGE 
GETPLACEMODE
(Place Mode)

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the place mode 
of the new image.

Idem

IMGMANAGER 
NEWIMAGE 
GETROW
(rows)

Output:
LONG

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the number of 
rows of the new image.

Idem

IMGMANAGER 
NEWIMAGE 
GETSAMEAS
(FileName)

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the file name of 
the image used as a 
template (“same as”) for 
the new image.

Idem

IMGMANAGER 
NEWIMAGE 
GETTYPE
(Type)

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the type of the 
new image.

Idem

IMGMANAGER 

NEWIMAGE 

GETXORIGIN

(Origin X)

Output:

STRING

KIN_INVALID_PARAM

KIN_SUCCESS

Returns X the origin of 

the new image in 

Working units. 

(ex: 1:150.000)

Idem

IMGMANAGER 

NEWIMAGE 

GETYORIGIN

(Origin Y)

Output:

STRING

KIN_INVALID_PARAM

KIN_SUCCESS

Returns the Y origin of 

the new image in 

Working units 

(ex: 1:150.000).

Idem
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IMGMANAGER 
NEWIMAGE RESET

NONE KIN_NOIMAGE
KIN_SUCCESS

Resets the options of the 
new image to the value 
of the template (“same 
as”) image.

Idem

IMGMANAGER 
NEWIMAGE 
SETBACKCOLOR
< Red> < Green > < 
Blue >

Input:
SHORT
SHORT
SHORT

KIN_INVALID_PARAM
KIN_SUCCESS

Sets the background 
color of the new image.

Idem

IMGMANAGER 
NEWIMAGE 
SETCOLUMNS
<columns>

Input:
LONG

KIN_INVALID_PARAM
KIN_SUCCESS

Sets the number of 
columns of the new 
image.

Idem

IMGMANAGER 
NEWIMAGE 
SETCOMPRESSION
< NONE | DEFLATE | 
PACKBITS | CCITT3 | 
CCITT4 >

Input:
STRING

KIN_INVALID_PARAM
KIN_PERM_DENIED
KIN_SUCCESS

Sets the compression 
mode of the new image. 
If the type is 
“2COLORS”, NONE, 
PACKBITS, CCITT3 and 
CCITT4 are available. If 
the type is 
“CONTINUOUSTONE”, 
NONE and DEFLATE 
are available.

Idem

IMGMANAGER 
NEWIMAGE 
SETDESCRIPTION
< Description >

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Sets the description of 
the new image.

Image Manager >
File > 
New

IMGMANAGER 
NEWIMAGE 
SETLOCKCOLROW-
OFF

NONE KIN_ERROR
KIN_SUCCESS

Sets the locking option 
of columns and rows to 
OFF when in interactive 
place mode.

Idem

IMGMANAGER 
NEWIMAGE 
SETLOCKCOLROW-
ON

NONE KIN_ERROR
KIN_SUCCESS

Sets the locking option 
of columns and rows to 
ON when in interactive 
place mode.

Idem
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IMGMANAGER 
NEWIMAGE 
SETLOCKPIXELSIZE
OFF

NONE KIN_ERROR
KIN_SUCCESS

Sets the locking option 
of pixel size to OFF 
when in interactive 
place mode.

Idem

IMGMANAGER 
NEWIMAGE 
SETLOCKPIXELSIZE
ON

NONE KIN_ERROR
KIN_SUCCESS

Sets the locking option 
of pixel size to ON when 
in interactive place 
mode.

Idem

IMGMANAGER 
NEWIMAGE SET-
PIXELSIZE
<PixelSize>

Input
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Sets the pixel size of 
the new image in 
Working units. (ex: 
1:150.000)

Idem

IMGMANAGER 
NEWIMAGE 
SETPLACEMODE
<LOCATION | 
INTERACTIVE>

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Sets the place mode of 
the new image.

Idem

IMGMANAGER 
NEWIMAGE SETROW
<rows>

Input:
LONG

KIN_INVALID_PARAM
KIN_SUCCESS

Sets the number of rows 
of the new image.

Idem

IMGMANAGER 
NEWIMAGE 
SETSAMEAS
[FileName]

Input:
STRING

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Sets the file name of the 
image used as a 
template (“same as”) for 
the new image. If no 
parameters are given, 
the file selection dialog 
is opened.

Idem

IMGMANAGER 
NEWIMAGE SETTYPE
< 2COLORS | 
CONTINUOUS-
TONE >

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Sets the type of the new 
image.

Idem
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IMGMANAGER 
NEWIMAGE SETX-
ORIGIN
<Origin X>

Input:
STRING

KIN_PERM_DENIED
KIN_INVALID_PARAM
KIN_SUCCESS

Sets the X origin of the 
new image when the 
place mode is LOCA-
TION. OriginX is in 
Working units (ex: 
1:150.000).

Idem

IMGMANAGER 
NEWIMAGE SETY-
ORIGIN
<OriginY>

Input:
STRING

KIN_PERM_DENIED
KIN_INVALID_PARAM
KIN_SUCCESS

Sets the Y origin of the 
new image when the 
place mode is LOCA-
TION. OriginY is in 
Working units (ex: 
1:150.000).

Idem

IMGMANAGER OPEN 
GETVIEW
(view list) 

Output:
STRING

KIN_ERROR
KIN_SUCCESS

Returns the views in 
which the image will be 
opened.

Image Manager > 
File> 
Open

IMGMANAGER OPEN 
SETVIEWOFF
<view list> 

Input:
SHORT list

KIN_INVALID_VIEW
KIN_ERROR
KIN_SUCCESS

Sets the views to OFF in 
which the image will be 
opened (ex: 1,2-4,8 for 
1,2,3,4,8).

Image Manager > 
File> 
Open

IMGMANAGER OPEN 
SETVIEWON
<view list> 

Input:
SHORT list

KIN_INVALID_VIEW
KIN_ERROR
KIN_SUCCESS

Sets the views to ON in 
which the image will be 
opened (ex: 1,2-4,8 for 
1,2,3,4,8).

Image Manager > 
File> 
Open

IMGMANAGER 
OPENCONFEXPORT 
GET

Output:
SHORT

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the state (ON/
OFF) of the opening 
warning dialog when 
the file can be opened 
but can not be modified.

Image Manager >
File > 
Open

IMGMANAGER 
OPENCONFEXPORT 
SETOFF

NONE KIN_ERROR
KIN_SUCCESS

Disables the opening of 
a warning dialog when 
the file can be opened 
but can not be modified.

Image Manager >
File > 
Open

IMGMANAGER 
OPENCONFEXPORT 
SETON

NONE KIN_ERROR
KIN_SUCCESS

Enables the opening of 
a warning dialog when 
the file can be opened 
but can not be modified. 

Image Manager >
File > 
Open
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IMGMANAGER 
OPENCONFINVALID
FILE GET

Output:
SHORT

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the status (ON/
OFF) of the opening 
warning dialog when 
the file is invalid.

Image Manager >
File > 
Open

IMGMANAGER 
OPENCONFINVALID
FILE SETOFF

NONE KIN_ERROR
KIN_SUCCESS

Disables the opening of 
a warning dialog when 
the file is invalid.

Image Manager >
File > 
Open

IMGMANAGER 
OPENCONFINVALID
FILE SETON

NONE KIN_ERROR
KIN_SUCCESS

Enables the opening of 
a warning dialog when 
the file is invalid. 

Image Manager >
File > 
Open

IMGMANAGER 
OPENCONFMORE32 
GETONOFF

Output:
SHORT

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the status (ON/
OFF) of the opening of 
a warning dialog when 
the image uses more 
than 32 colors.

Image Manager >
File > 
Open

IMGMANAGER 
OPENCONFMORE32 
GETYESNO

Output:
SHORT

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the default 
response for the image 
compression to 32 
colors.

Image Manager >
File > 
Open

IMGMANAGER 
OPENCONFMORE32 
SETNO

NONE KIN_ERROR
KIN_SUCCESS

Disables the color 
compression of the 
image when it uses 
more than 32 colors. 

Image Manager >
File > 
Open

IMGMANAGER 
OPENCONFMORE32 
SETOFF

NONE KIN_ERROR
KIN_SUCCESS

Disables the opening of 
a warning dialog when 
the image uses more 
than 32 colors.

Image Manager >
File > 
Open

IMGMANAGER 
OPENCONFMORE32 
SETON

NONE KIN_ERROR
KIN_SUCCESS

Enables the opening of 
a warning dialog when 
the image uses more 
than 32 colors.

Image Manager >
File > 
Open
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IMGMANAGER 
OPENCONFMORE32 
SETYES

NONE KIN_ERROR
KIN_SUCCESS

Enables the color 
compression of the 
image when it uses 
more than 32 colors. 

Image Manager >
File > 
Open

IMGMANAGER 
OPENCONFNOGEOR
EF GETONOFF

Output:
SHORT

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the status (ON/
OFF) of the opening 
dialog when the file is 
not georeferenced.

Image Manager >
File > 
Open

IMGMANAGER 
OPENCONFNOGEOR
EF GETYESNO

Output:
SHORT

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the default 
response for the 
interactive placing 
images when the file has 
no goereference.

Image Manager >
File > 
Open

IMGMANAGER 
OPENCONFNOGEOR
EF SETNO

NONE KIN_ERROR
KIN_SUCCESS

Indicates that the image 
should not be placed 
interactively when not 
georeferenced. Same as 
selecting NO in the 
dialog.

Image Manager >
File > 
Open

IMGMANAGER 
OPENCONFNOGEOR
EF SETOFF

NONE KIN_ERROR
KIN_SUCCESS

Disables the opening of 
a dialog when the file is 
not georeferenced.

Image Manager >
File > 
Open

IMGMANAGER 
OPENCONFNOGEOR
EF SETON

NONE KIN_ERROR
KIN_SUCCESS

Enables the opening of 
a dialog when the file is 
not georeferenced.

Image Manager >
File > 
Open

IMGMANAGER 
OPENCONFNOGEOR
EF SETYES

NONE KIN_ERROR
KIN_SUCCESS

Indicates that the image 
must be placed 
interactively when not 
georeferenced. Same as 
selecting YES in the 
dialog.

Image Manager >
File > 
Open

IMGMANAGER 
OPENCONFNOTSUP
PORTED SETOFF

NONE KIN_ERROR
KIN_SUCCESS

Disables the opening of 
a warning dialog when 
the file format is not 
supported.

Image Manager >
File > 
Open
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IMGMANAGER 
OPENCONFNOTSUP
PORTED SETON

NONE KIN_ERROR
KIN_SUCCESS

Enables the opening of 
a warning dialog when 
the file format is not 
supported.

Image Manager >
File > 
Open

IMGMANAGER 
OPENCONFREAD-
ONLY GET

Output:
SHORT

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the state (ON/
OFF) of the opening 
warning dialog when 
the file is read only.

Image Manager >
File > 
Open

IMGMANAGER 
OPENCONFREAD-
ONLY SETOFF

NONE KIN_ERROR
KIN_SUCCESS

Disables the opening of 
a warning dialog when 
the file is read only.

Image Manager >
File > 
Open

IMGMANAGER 
OPENCONFREAD-
ONLY SETON

NONE KIN_ERROR
KIN_SUCCESS

Enables the opening of 
a warning dialog when 
the file is read only.

Image Manager >
File > 
Open

IMGMANAGER 
OPENCONFSUPPOR
TED GET

Output:
SHORT

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the status (ON/
OFF) of the opening 
warning dialog when 
the file format is not 
supported.

Image Manager >
File > 
Open

IMGMANAGER 
PLOT8788 GET 
(status)

Output:
SHORT

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the status of 
plotting for Design 
elements of type 87 and 
88. 

IMGMANAGER 
PLOT8788 SETOFF

NONE KIN_ERROR
KIN_SUCCESS

Disables the plotting of 
Design elements of type 
87 and 88.

IMGMANAGER 
PLOT8788 SETON

NONE KIN_ERROR
KIN_SUCCESS

Enables the plotting of 
Design elements of type 
87 and 88.

IMGMANAGER 
SAVEAS 
COLORCOMPGET-
FILE (filename)

Output:
STRING

KIN_SUCCESS
KIN_INVALID_PARAM
KIN_ERROR

Returns the name of the 
color cube file created 
or used in the color 
compression process.

Image Manager >
File> 
Save As

Key-In Parameters
Returned Error 
Codes

Description
Graphical 
Interface
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IMGMANAGER 
SAVEAS 
COLORCOMPGET-
MODE (mode)

Output:
STRING

KIN_SUCCESS
KIN_INVALID_PARAM
KIN_ERROR

Returns the color 
compression mode. 
Modes are STANDARD, 
CUSTOM and CREATE.

Image Manager >
File> 
Save As

IMGMANAGER 
SAVEAS 
COLORCOMPGETNB
COLOR (nb colors)

Output:
SHORT

KIN_SUCCESS
KIN_INVALID_PARAM
KIN_ERROR

Returns the number of 
colors used in the color 
compression.

Image Manager >
File> 
Save As

IMGMANAGER 
SAVEAS 
COLORCOMPSET-
FILE <filename>

Input:
STRING

KIN_SUCCESS
KIN_INVALID_PARAM
KIN_FILE_EXIST
KIN_ERROR

Sets the name of the 
color cube file created 
or used in the color 
compression process.

Image Manager >
File> 
Save As

IMGMANAGER 
SAVEAS 
COLORCOMPSETMO
DE <STANDARD | 
CUSTOM | CREATE>

Input:
STRING

KIN_SUCCESS
KIN_INVALID_PARAM
KIN_ERROR

Sets the color 
compression mode. 

Image Manager >
File> 
Save As

IMGMANAGER 
SAVEAS 
COLORCOMPSETNB
COLOR <nb colors>

Input:
SHORT

KIN_SUCCESS
KIN_INVALID_COLOR
KIN_ERROR

Sets the number of 
colors used in the color 
compression.

Image Manager >
File>
Save As

IMGMANAGER 
SAVEAS 
SETOUTPUTSET-
TING <Extension> 
<Pixel Type> 
<Compression> 

Input:
STRING
STRING
STRING

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Sets the setting 
(Extension, Pixel Type 
and Compression) for 
the output file (see 
“Image File Formats” on 
page A-120 for available 
options).

Image Manager >
File > 
Save As

IMGMANAGER 
SAVEASCOT 
GETTILED (status)

Output:
SHORT

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the tiling status 
for the creation of a COT 
file.

Image Manager >
File > 
Save As

IMGMANAGER 
SAVEASCOT 
SETTILEDOFF

NONE KIN_SUCCESS Sets the tiling to OFF for 
the creation of a COT 
file.

Image Manager >
File > 
Save As

Key-In Parameters
Returned Error 
Codes

Description
Graphical 
Interface
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IMGMANAGER 
SAVEASCOT 
SETTILEDON

NONE KIN_SUCCESS Sets the tiling to ON for 
the creation of a COT 
file.

Image Manager >
File > 
Save As

IMGMANAGER 
SAVEASTIF  
GETTILED (status)

Output:
SHORT

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the tiling status 
for the creation of a TIFF 
file.

Image Manager >
File > 
Save As

IMGMANAGER 
SAVEASTIF 
SETTILEDOFF

NONE KIN_SUCCESS Sets the tiling to OFF for 
the creation of a TIFF 
file.

Image Manager >
File > 
Save As

IMGMANAGER 
SAVEASTIF 
SETTILEDON

NONE KIN_SUCCESS Sets the tiling to ON for 
the creation of a TIFF 
file.

Image Manager >
File > 
Save As

IMGMANAGER 
TOOLCONTROL 
CLOSE

NONE KIN_SUCCESS Closes the Image 
Control tool box. 

Image Manager > 
Tool >
Image Control

IMGMANAGER 
TOOLCONTROL 
OPEN

NONE KIN_SUCCESS Opens the Image 
Control tool box.

Image Manager > 
Tool >
Image Control

IMGMANAGER 
TOOLFILE CLOSE

NONE KIN_SUCCESS Closes the Image File 
tool box.

Image Manager > 
Tool> 
Image File

IMGMANAGER 
TOOLFILE OPEN

NONE KIN_ERROR
KIN_SUCCESS

Opens the Image File 
tool box.

Image Manager > 
Tool> 
Image File

IMGMANAGER 
VIEWBORDER GET 
<view> (status)

Input:
SHORT
Output:
SHORT

KIN_INVALID_PARAM
KIN_INVALID_VIEW
KIN_ERROR
KIN_SUCCESS

Returns the border 
status of images (ON/
OFF) in the specified 
view.

Image Manager > 
Settings > 
View Image 
Attributes

IMGMANAGER 
VIEWBORDER 
SETOFF
<view list> 

Input:
SHORT list

KIN_INVALID_VIEW
KIN_ERROR
KIN_SUCCESS

Sets the border of 
images to OFF in the 
specified views (ex: 1,2-
4,8 for 1,2,3,4,8).

Image Manager > 
Settings > 
View Image 
Attributes

Key-In Parameters
Returned Error 
Codes

Description
Graphical 
Interface
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IMGMANAGER 
VIEWBORDER 
SETON 
<view list>

Input:
SHORT list

KIN_INVALID_VIEW
KIN_ERROR
KIN_SUCCESS

Sets the border of 
images to ON in the 
specified views (ex: 1,2-
4,8 for 1,2,3,4,8).

Image Manager > 
Settings > 
View Image 
Attributes

IMGMANAGER 
VIEWROTATION 
GET <view> (status)

Input:
SHORT
Output:
SHORT

KIN_INVALID_VIEW
KIN_ERROR
KIN_SUCCESS

Returns the status of 
Rotation of images (ON/
OFF) in the specified 
view.

Image Manager > 
Settings > 
View Image 
Attributes

IMGMANAGER 
VIEWROTATION 
SETOFF 
<view list>

Input:
SHORT list

KIN_INVALID_VIEW
KIN_ERROR
KIN_SUCCESS

Sets the Rotation of 
images to OFF in the 
specified views (ex: 1,2-
4,8 for 1,2,3,4,8).

Image Manager > 
Settings > 
View Image 
Attributes

IMGMANAGER 
VIEWROTATION 
SETON <view list>

Input:
SHORT list

KIN_INVALID_VIEW
KIN_ERROR
KIN_SUCCESS

Sets the Rotation of 
images to ON in the 
specified views (ex: 1,2-
4,8 for 1,2,3,4,8).

Image Manager > 
Settings > 
View Image 
Attributes

IMGMANAGER 
VIEWTRSLUCENCY 
GET <view> (status)

Input:
SHORT
Output:
SHORT

KIN_INVALID_VIEW
KIN_ERROR
KIN_SUCCESS

Returns the 
Translucency status of 
images (ON/OFF) in the 
specified view.

Image Manager > 
Settings > 
View Image 
Attributes

IMGMANAGER 
VIEWTRSLUCENCY 
SETOFF <view list>

Input:
SHORT list

KIN_INVALID_VIEW
KIN_ERROR
KIN_SUCCESS

Sets the Translucency of 
images to OFF in the 
specified views (ex: 1,2-
4,8 for 1,2,3,4,8).

Image Manager > 
Settings > 
View Image 
Attributes

IMGMANAGER 
VIEWTRSLUCENCY 
SETON <view list>

Input:
SHORT list

KIN_INVALID_VIEW
KIN_ERROR
KIN_SUCCESS

Sets the Translucency of 
images to ON in the 
specified views (ex: 1,2-
4,8 for 1,2,3,4,8).

Image Manager > 
Settings > 
View Image 
Attributes

IMGMANAGER 
VIEWTRSPARENCY 
GET <view> (status)

Input:
SHORT
Output:
SHORT

KIN_INVALID_VIEW
KIN_ERROR
KIN_SUCCESS

Returns the 
Transparency status of 
images (ON/OFF) in the 
specified view.

Image Manager > 
Settings > 
View Image 
Attributes

Key-In Parameters
Returned Error 
Codes

Description
Graphical 
Interface
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IMGMANAGER 
VIEWTRSPARENCY 
SETOFF <view list>

Input:
SHORT list

KIN_INVALID_VIEW
KIN_ERROR
KIN_SUCCESS

Sets the Transparency of 
images to OFF in the 
specified views (ex: 1,2-
4,8 for 1,2,3,4,8).

Image Manager > 
Settings > 
View Image 
Attributes

IMGMANAGER 
VIEWTRSPARENCY 
SETON <view list>

Input:
SHORT list

KIN_INVALID_VIEW
KIN_ERROR
KIN_SUCCESS

Sets the Transparency of 
images to ON in the 
specified views (ex: 1,2-
4,8 for 1,2,3,4,8).

Image Manager > 
Settings > 
View Image 
Attributes

IMGMANAGER 
VIEWVISIBLE GET 
<view> (status)

Input:
SHORT
Output:
SHORT

KIN_INVALID_PARAM
KIN_INVALID_VIEW
KIN_ERROR
KIN_SUCCESS

Returns the status of 
Visibility of images 
(ON/OFF) in the 
specified view.

Image Manager > 
Settings > 
View Image 
Attributes

IMGMANAGER 
VIEWVISIBLE 
SETOFF
<view list> 

Input:
SHORT list

KIN_INVALID_VIEW
KIN_ERROR
KIN_SUCCESS

Sets the Visibility of 
images to OFF in the 
specified views (ex: 1,2-
4,8 for 1,2,3,4,8).

Image Manager > 
Settings > 
View Image 
Attributes

IMGMANAGER 
VIEWVISIBLE SETON 
<view list>

Input:
SHORT list

KIN_INVALID_VIEW
KIN_ERROR
KIN_SUCCESS

Sets the Visibility of 
images to ON in the 
specified views (ex: 1,2-
4,8 for 1,2,3,4,8).

Image Manager > 
Settings > 
View Image 
Attributes

Key-In Parameters
Returned Error 
Codes

Description
Graphical 
Interface
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File Format Name  File Extension Pixel Type Data Compression

HMR HMR 2COLORS NONE
PACKBITS
CCITT3
CCITT4

HMR HMR 256COLORS NONE
DEFLATE

HMR HMR GRAYSCALE NONE
DEFLATE

Img (24 bit) A 24BITCOLOR DEFAULT

Img File P 16COLORS 256COLORS
GRAYSCALE

DEFAULT

Intergraph CIT CIT 2COLORS CCITT4

Intergraph COT COT 256 Colors NONE

Intergraph COT COT GRAYSCALE NONE

Intergraph RGB RGB 24BITCOLOR DEFAULT

Intergraph RLE RLE 2COLORS RLE

JPEG JPG 24BITCOLOR
GRAYSCALE

JPEG

PCX PCX 16COLORS 256COLORS
GRAYSCALE

DEFAULT

SUN Raster file RS 256COLORS
GRAYSCALE

DEFAULT

TARGA TGA 24BITCOLOR DEFAULT

TIF TIF 24BITCOLOR NONE
DEFLATE

TIF TIF 256COLORS NONE
DEFLATE

TIF  TIF GRAYSCALE NONE
DEFLATE

TIF TIF 2COLORS NONE
PACKBITS
CCITT3
CCITT4
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Windows BMP BMP 16COLORS 256COLORS 
24BITCOLOR
GRAYSCALE

DEFAULT
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Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface

IMGREGISTER COL-
ORCTLPTS GETBASE
(ColorNumber)

Output:
SHORT

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the Base Con-
trol Point color index.

Image Manager >
Utilities >
Register >
Settings >
Color for Control 
Points

IMGREGISTER COL-
ORCTLPTS GETUN-
CORRECT
(ColorNumber)

Output:
SHORT

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the Uncor-
rected Control Point 
color index.

Image Manager >
Utilities >
Register >
Settings >
Color for Control 
Points

IMGREGISTER COL-
ORCTLPTS SETBASE
<ColorNumber>

Input:
SHORT

KIN_INVALID_PARAM
KIN_SUCCESS

Sets the Base Control 
Point color index. 

Image Manager >
Utilities >
Register >
Settings >
Color for Control 
Points

IMGREGISTER COL-
ORCTLPTS SETUN-
CORRECT
<ColorNumber>

Input:
SHORT

KIN_INVALID_PARAM
KIN_SUCCESS

Sets the Uncorrected 
Control Point color 
index.

Image Manager >
Utilities >
Register >
Settings >
Color for Control 
Points

IMGREGISTER 
CONTPT ADD
[<State> <BaseX> 
<BaseY> <UncorX> 
<UncorY>]

Input:
STRING
STRING
STRING
STRING
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Add a new control 
point to the current 
transformation model. 
If no parameters are 
specified, the “Add 
Control Points” dialog 
is opened. 
State can have the 
value “ON” or “OFF”.
Coordinates are in 
working units
(ex: 1:150.000).

Image Manager >
Utilities >
Register >
Edit > Add Con-
trol Points
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IMGREGISTER 
CONTPT DELETE

NONE KIN_SUCCESS Starts the Delete Con-
trol Points command. 

Image Manager >
Tools >
Register

IMGREGISTER 
CONTPT DELETE-
CURRENT

NONE KIN_SUCCESS Delete the current con-
trol point pair in the 
Register dialog.

Image Manager >
Utilities >
Register >
Edit > 
Delete Control 
Points

IMGREGISTER 
CONTPT GETCO-
ORDS
(BaseX) (BaseY) 
(UncorX) (UncorY)

Output:
STRING
STRING
STRING
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the coordi-
nates of the current 
control point in the 
Register dialog.
Coordinates are in 
working units
(ex: 1:150.000).

Image Manager >
Utilities >
Register

IMGREGISTER 
CONTPT GETCUR-
RENT
(PointNumber)

Output:
LONG

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the number of 
the current control 
point. Numbers start at 
1.

Image Manager >
Utilities >
Register

IMGREGISTER 
CONTPT GETONOFF
(Status)

Output:
SHORT

KIN_ERROR
KIN_INVALID_PARAM
KIN_SUCCESS

Returns the Status of 
the current control 
point. (ON/OFF).

Image Manager >
Utilities >
Register

IMGREGISTER 
CONTPT HIGH-
LIGHT

NONE KIN_SUCCESS Highlight the current 
control point.

Image Manager >
Utilities >
Register >
Edit > 
Highlight Control 
Points

IMGREGISTER 
CONTPT LOCATE

NONE KIN_SUCCESS Locate the current con-
trol point in the views 
used to locate control 
points.

Image Manager >
Utilities >
Register >
Edit >
Locate Control 
Points

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
MicroStation Descartes User’s Guide A-123



MicroStation Descartes Key-in Tables
Register Key-ins
IMGREGISTER 
CONTPT MODIFY
<BaseX> <BaseY> 
<UncorX> <UncorY>

Input:
STRING
STRING
STRING
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Modify the coordinates 
of the current control 
point. If no parameters 
are specified, the “Mod-
ify Control Points” dia-
log is opened. 
Coordinates are in 
Working units
(ex: 1:150.000).

Image Manager >
Utilities >
Register >
Edit > Modify 
Control Points

IMGREGISTER 
CONTPT MOVE

NONE KIN_SUCCESS Starts the Move Control 
Point command.

Image Manager >
Tools >
Register > 
Move Control 
Point

IMGREGISTER 
CONTPT PLACE

NONE KIN_SUCCESS Starts the Place Control 
Points command. 

Image Manager >
Tools >
Register > 
Place Control 
Point

IMGREGISTER 
CONTPT SETCUR-
RENT
<PointNumber>

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Set the current control 
point to the specified 
number. Numbers start 
at 1.

Image Manager >
Utilities >
Register

IMGREGISTER 
CONTPT SETOFF

NONE KIN_ERROR
KIN_SUCCESS

Set the current control 
point to OFF.

Image Manager >
Utilities >
Register

IMGREGISTER 
CONTPT SETON

NONE KIN_ERROR
KIN_SUCCESS

Set the current control 
point to ON.

Image Manager >
Utilities >
Register

IMGREGISTER DIA-
LOG CLOSE

NONE KIN_ERROR
KIN_SUCCESS

Closes the Register dia-
log.

Image Manager >
Utilities >
Register

IMGREGISTER DIA-
LOG OPEN

NONE KIN_ERRORKIN_SUCC
ESS

Opens the Register dia-
log.

Image Manager >
Utilities >
Register

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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IMGREGISTER DIS-
PLOCPTS GET
(ViewNumber) 

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Returns a list of view 
numbers (separated 
with comma) that are 
enabled for the locate 
function.

Image Manager >
Utilities >
Register > 
View>
Views Used to 
Locate Control 
Points

IMGREGISTER DIS-
PLOCPTS SETOFF
<ViewList>

Input:
STRING

KIN_INVALLID_PARAM
KIN_SUCCESS

Set the specified views 
to OFF for the locate 
function. The view list 
is a string containing a 
list of numbers sepa-
rated with commas. 

Image Manager >
Utilities >
Register > 
View>
Views Used to 
Locate Control 
Points

IMGREGISTER DIS-
PLOCPTS SETON
<ViewList>

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Set the specified views 
to ON for the locate 
function. The view list 
is a string containing a 
list of numbers sepa-
rated with commas.

Image Manager >
Utilities >
Register > 
View>
Views Used to 
Locate …

IMGREGISTER DISP-
NONWARP GET
(Status)

Output:
SHORT

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the status of 
“Also Display Non 
Warped Elements” 
(ON/OFF).

Image Manager >
Utilities >
Register > 
View>
Views Displaying 
Uncorrected Data

IMGREGISTER DISP-
NONWARP SETOFF

NONE KIN_SUCCESS Sets the status of “Also 
Display Non Warped 
Elements” to Off.

Image Manager >
Utilities >
Register > 
View>
Views Displaying 
Uncorrected Data

IMGREGISTER DISP-
NONWARP SETON

NONE KIN_SUCCESS Sets the status of “Also 
Display Non Warped 
Elements” to On.

Image Manager >
Utilities >
Register > 
View>
Views Displaying 
Uncorrected Data

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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IMGREGISTER DIS-
PUNCORPTS GET
(ViewList)

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Returns a list of view 
numbers (separated 
with comma) that are 
enabled for.displaying 
uncorrected data. 

Image Manager >
Utilities >
Register > 
View>
Views Displaying 
Uncorrected Data

IMGREGISTER DIS-
PUNCORPTS SETOFF
<ViewList>

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Set the specified views 
to ON for the display-
ing of uncorrected data. 
The view list is a string 
containing a list of 
numbers separated 
with commas.

Image Manager >
Utilities >
Register > 
View>
Views Displaying 
Uncorrected Data

IMGREGISTER DIS-
PUNCORPTS SETON
<ViewList>

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Set the specified views 
to OFF for the display-
ing of uncorrected data. 
The view list is a string 
containing a list of 
numbers separated 
with commas.

Image Manager >
Utilities >
Register > 
View>
Views Displaying 
Uncorrected Data

IMGREGISTER DLG-
COLORPTS OPEN

NONE KIN_SUCCESS Open the “Colors for 
Control Points” dialog.

Image Manager >
Utilities >
Register > 
Settings >
Colors for Control 
Points

IMGREGISTER 
DLGELSELECT OPEN

NONE KIN_SUCCESS Open the “Elements 
Transformation” dialog. 

Image Manager >
Utilities >
Register > 
Settings >
Elements Trans-
formation

IMGREGISTER 
DLGLOCPTS OPEN

NONE KIN_ERROR
KIN_SUCCESS

Open the “Views Used 
to Locate Control 
Points” dialog.

Image Manager >
Utilities >
Register > 
View>
Views Used to 
Locate …

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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IMGREGISTER 
DLGRSP CLOSE

NONE KIN_ERROR
KIN_SUCCESS

Close the “Resampling” 
dialog.

Image Manager >
Utilities >
Register >   
Apply> 
To Image

IMGREGISTER 
DLGRSP OPEN

NONE KIN_ERROR
KIN_SUCCESS

Open the “Resam-
pling” dialog.

Image Manager >
Utilities >
Register >   
Apply> 
To Image

IMGREGISTER 
DLGUNCORPTS 
OPEN

NONE KIN_ERROR
KIN_SUCCESS

Open the “Views Dis-
playing Uncorrected 
Data” dialog.

Image Manager >
Utilities >
Register > 
View>
Views Displaying 
Uncorrected Data

IMGREGISTER DLG-
WARPING OPEN

NONE KIN_ERROR
KIN_SUCCESS

Open the “Warping 
Window” dialog.

Image Manager >
Utilities >
Register > 
View>
Warping Window

IMGREGISTER DYN-
WARPING GET
(Status)

Output:
SHORT

KIN_INVALID_PARAM
KIN_SUCCESS

Returns status of 
Dynamic Warping. 
(ON/OFF)

Image Manager >
Utilities >
Register > 
View>
Dynamic Warping

IMGREGISTER DYN-
WARPING SETOFF

NONE KIN_SUCCESS Sets the Dynamic Warp-
ing status to OFF.

Image Manager >
Utilities >
Register > 
View>
Dynamic Warping

IMGREGISTER DYN-
WARPING SETON

NONE KIN_SUCCESS Sets the Dynamic Warp-
ing status to ON.

Image Manager >
Utilities >
Register > 
View>
Dynamic Warping

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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IMGREGISTER ELSE-
LECT GETARCMODE
(Mode)

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the ARC trans-
formation mode.

Image Manager >
Utilities >
Register > 
Settings >
Elements Trans-
formation

IMGREGISTER ELSE-
LECT GETARCTOL
(Tolerance)

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the tolerance 
used when stroking 
ARC elements. Toler-
ance is in Working units 
(ex: 1:150.000).

Idem

IMGREGISTER ELSE-
LECT GETBSPLINE
(Mode)

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the B-SPLINE 
transformation mode.

Idem

IMGREGISTER ELSE-
LECT GETCCHAIN
(Mode)

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the COMPLEX 
CHAIN transformation 
mode.

Idem

IMGREGISTER ELSE-
LECT GETCELL
(Mode)

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the CELL trans-
formation mode.

Idem 

IMGREGISTER ELSE-
LECT GETCSHAPE
(Mode)

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the COMPLEX 
SHAPE transformation 
mode.

Idem

IMGREGISTER ELSE-
LECT GETCURVE
(Mode)

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the CURVE 
transformation mode.

Idem

IMGREGISTER ELSE-
LECT GETELLMODE
(Mode)

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the ELLIPSE 
transformation mode.

Idem

IMGREGISTER ELSE-
LECT GETELLTOL
(Tolerance)

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the tolerance 
used when stroking 
ELLIPSE elements in 
Working units (ex: 
1:150.000).

Idem

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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IMGREGISTER ELSE-
LECT GETLINE
(Mode)

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the LINE trans-
formation mode.

Idem

IMGREGISTER ELSE-
LECT GETNODE-
TEXT
(Mode)

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the NODE 
TEXT transformation 
mode.

Idem

IMGREGISTER ELSE-
LECT GETSCELL
(Mode)

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the SHARED 
CELL transformation 
mode.

Idem

IMGREGISTER ELSE-
LECT GETSHAPE
(Mode)

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the SHAPE 
transformation mode.

Idem

IMGREGISTER ELSE-
LECT GETSTRING
(Mode)

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the STRING 
transformation mode.

Idem

IMGREGISTER ELSE-
LECT GETTEXT
(Mode)

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the TEXT trans-
formation mode.

Idem

IMGREGISTER ELSE-
LECT SETARCMODE
< STROKALLCOORD 
| NONE >

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Sets the transformation 
mode for ARC ele-
ments.

Idem

IMGREGISTER ELSE-
LECT SETARCTOL
<Tolerance >

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Sets the tolerance for 
ARC elements.
Tolerance is in Working 
Units.
(ex: 1:150:000)

Idem

IMGREGISTER ELSE-
LECT SETBSPLINE
< ALLCOORD | 
NONE >

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Sets the transformation 
mode for B-SPLINE ele-
ments.

Idem

IMGREGISTER ELSE-
LECT SETCCHAIN
< ALLCOORD | 
NONE >

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Sets the transformation 
mode for COMPLEX 
CHAIN elements.

Idem

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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IMGREGISTER ELSE-
LECT SETCELL
< ALLCOORD | 
NONE >

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Sets the transformation 
mode for CELL ele-
ments.

Idem

IMGREGISTER ELSE-
LECT SETCSHAPE
< ALLCOORD | 
NONE >

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Sets the transformation 
mode for COMPLEX 
SHAPE elements.

Idem

IMGREGISTER ELSE-
LECT SETCURVE
< ALLCOORD | 
NONE >

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Sets the transformation 
mode for CURVE ele-
ments.

Idem

IMGREGISTER ELSE-
LECT SETELLMODE
< STROKALLCOORD 
| NONE >

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Sets the transformation 
mode for ELLIPSE ele-
ments.

Idem

IMGREGISTER ELSE-
LECT SETELLTOL
<Tolerance >

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Sets the transformation 
mode for ELLIPSE ele-
ments.
Tolerance is in Working 
Units
(ex: 1:150:000).

Idem

IMGREGISTER ELSE-
LECT SETLINE
< ALLCOORD | 
NONE >

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Sets the transformation 
mode for LINE ele-
ments.

Idem

IMGREGISTER ELSE-
LECT SETNODETEXT
< ORIGINONLY | 
NONE >

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Sets the transformation 
mode for NODE TEXT 
elements.

Idem

IMGREGISTER ELSE-
LECT SETSCELL
< ORIGINONLY | 
NONE >

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Sets the transformation 
mode for SHARED 
CELL elements.

Idem
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IMGREGISTER ELSE-
LECT SETSHAPE
< ALLCOORD | 
NONE >

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Sets the transformation 
mode for SHAPE ele-
ments.

Idem

IMGREGISTER ELSE-
LECT SETSTRING
< ALLCOORD | 
NONE >

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Sets the transformation 
mode for STRING ele-
ments.

Idem

IMGREGISTER ELSE-
LECT SETTEXT
< ORIGINONLY | 
NONE >

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Sets the transformation 
mode for TEXT ele-
ments.

Idem

IMGREGISTER FILE 
GET
(FileName)

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the current 
Register file. Returns 
UNTITLED if none is 
opened.

Image Manager >
Utilities >
Register >
File

IMGREGISTER FILE 
NEW

NONE KIN_SUCCESS Create a new Register 
file.

Image Manager >
Utilities >
Register >
File

IMGREGISTER FILE 
OPEN
[FileName]

Input:
STRING

KIN_ERROR
KIN_SUCCESS

Open the specified 
existing Register file.
If FileName is not spec-
ified, opens a File 
Selection dialog.

Image Manager >
Utilities >
Register >
File

IMGREGISTER FILE 
SAVE

NONE KIN_SUCCESS Save changes to the 
current Register file.

Image Manager >
Utilities >
Register >
File

IMGREGISTER FILE 
SAVEAS
[FileName]

Input:
STRING

KIN_ERROR
KIN_SUCCESS

Save the current Regis-
ter file in the specified 
file. If FileName is not 
specified, opens a File 
Creation dialog.

Image Manager >
Utilities >
Register >
File
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IMGREGISTER IMG-
VERSION GET
(version) (subver-
sion) (revision) (sub-
revision)

Output:
SHORT
SHORT
SHORT
SHORT

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the version, 
subversion, revision 
and subrevision of the 
minimal Descartes 
required to run this ver-
sion of Register. 

IMGREGISTER 
MODEL GET
(ModelName)

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the name of the 
current transformation 
model.

Image Manager >
Utilities >
Register

IMGREGISTER 
MODEL SETAFFINE1

NONE KIN_SUCCESS Set the current transfor-
mation model to 
AFFINE-1.

Image Manager >
Utilities >
Register

IMGREGISTER 
MODEL SETHELMET

NONE KIN_SUCCESS Set the current transfor-
mation model to HELM-
ERT.

Image Manager >
Utilities >
Register

IMGREGISTER 
MODEL SETPOLY2

NONE KIN_SUCCESS Set the current transfor-
mation model to POLY-
NOMIAL-2.

Image Manager >
Utilities >
Register

IMGREGISTER 
MODEL SETPOLY3

NONE KIN_SUCCESS Set the current transfor-
mation model to POLY-
NOMIAL-3.

Image Manager >
Utilities >
Register

IMGREGISTER 
MODEL SETPROJEC-
TIVE

NONE KIN_SUCCESS Set the current transfor-
mation model to PRO-
JECTIVE.

Image Manager >
Utilities >
Register

IMGREGISTER 
MODEL SETSIMILI-
TUDE

NONE KIN_SUCCESS Set the current transfor-
mation model to SIMIL-
ITUDE.

Image Manager >
Utilities >
Register

IMGREGISTER RESA-
MPLE IMAGE

NONE KIN_ERROR
KIN_SUCCESS

Prepares a resampling 
page with the active 
image and the current 
transformation model.

Image Manager >
Tools > 
Register >
Resample Image

IMGREGISTER RSPB-
GCOLOR GET 
(Color)

Output:
SHORT

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the background 
color used when resa-
mpling. 

Image Manager >
Utilities >
Register >   
Apply> To Image
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IMGREGISTER RSPB-
GCOLOR SET 
<Color>

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Sets the background 
color used when resa-
mpling.

Idem

IMGREGISTER RSP-
COLORMAX GET 
(Color)

Output:
SHORT

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the maximum 
limit for colors when 
resampling.

Idem

IMGREGISTER RSP-
COLORMAX SET 
<Color>

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Sets the maximum 
limit for colors when 
resampling.

Idem

IMGREGISTER RSP-
COLORMIN GET 
(Color)

Output:
SHORT

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the minimum 
limit for colors when 
resampling.

Idem

IMGREGISTER RSP-
COLORMIN SET 
<Color>

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Sets the minimum limit 
for colors when resam-
pling.

Idem

IMGREGISTER RSP-
COMPRESSION GET
(Compression)

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the file com-
pression type for the 
output image.

Idem

IMGREGISTER RSP-
COMPRESSION SET
<NONE | PACKBITS 
| DEFLATE | 
CCITT3 | CCITT4>

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Sets the file compres-
sion type for the output 
image.

Idem

IMGREGISTER 
RSPCONFIRM GET
(State)

Output:
SHORT

KIN_INVALID_PARAM
KIN_SUCCESS

Return the status (ON/
OFF) of the opening of 
warning dialogs for the 
resampling process.

Image Manager >
Register >
Apply >
To Image

IMGREGISTER 
RSPCONFIRM 
SETOFF

NONE KIN_ERROR
KIN_SUCCESS

Disable the opening of 
warning dialogs for the 
resampling process.

Idem

IMGREGISTER 
RSPCONFIRM SETON

NONE KIN_ERROR
KIN_SUCCESS

Enable the opening of 
warning dialogs for the 
resampling process.

Idem
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IMGREGISTER RSP-
FILE CLOSE

NONE KIN_ERROR
KIN_SUCCESS

Close the file. Image Manager >
Utilities >
Register >   
Apply> 
To Image > File 

IMGREGISTER RSP-
FILE NEW

NONE KIN_ERROR
KIN_SUCCESS

Create a new Resam-
pling file.

Image Manager >
Utilities >
Register >   
Apply> 
To Image > File

IMGREGISTER RSP-
FILE OPEN
[FileName]

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Open an existing Resa-
mpling file.

Image Manager >
Utilities >
Register >   
Apply> 
To Image > File

IMGREGISTER RSP-
FILE SAVE

NONE KIN_ERROR
KIN_SUCCESS

Save changes to the 
current Resampling file.

Image Manager >
Utilities >
Register >   
Apply> 
To Image > File

IMGREGISTER RSP-
FILE SAVEAS
[FileName]

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Save the current Resa-
mpling file in the speci-
fied file. If FileName is 
not specified, the File 
Creation dialog is 
opened.

Image Manager >
Utilities >
Register >   
Apply> 
To Image > File

IMGREGISTER 
RSPINDIMX SET     
<DimensionX>

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Sets the X dimension of 
the input window.
DimensionX is in Work-
ing Units (ex: 
1:500.000).

Idem

IMGREGISTER 
RSPINDIMY GET 
(DimensionY)

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the Y dimen-
sion of the input win-
dow.
DimensionY is in Work-
ing Units (ex: 
1:500.000).

Idem
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IMGREGISTER 
RSPINDIMY SET 
<DimensionY>

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Sets the Y dimension of 
the input window.
DimensionY is in Work-
ing Units (ex: 
1:500.000).

Idem

IMGREGISTER 
RSPINORIGINX GET 
(OriginX)

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the X origin of 
the input window.
OriginX is in Working 
Units (ex: 1:500.000).

Idem

IMGREGISTER 
RSPINORIGINX SET 
<OriginX>

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Sets the X origin of the 
input window.
OriginX is in Working 
Units (ex: 1:500.000).

Idem

IMGREGISTER 
RSPINORIGINY GET 
(OriginY)

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the Y origin of 
the input window.
OriginY is in Working 
Units (ex: 1:500.000).

Idem

IMGREGISTER 
RSPINORIGINY SET 
<OriginY>

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Sets the Y origin of the 
input window.
OriginY is in Working 
Units (ex: 1:500.000).

Idem

IMGREGISTER 
RSPINPUT SET [File-
Name]

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Sets the input image 
with the specified file. 
If FileName is not spec-
ified, the File Selection 
dialog is opened.

Idem

IMGREGISTER RSP-
MODEL GET (File-
Name)

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the file name of 
the model.

Idem

IMGREGISTER RSP-
MODEL SET [File-
Name]

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Sets the model with the 
specified file. If File-
Name is not specified, 
the File Selection dialog 
is opened.

Idem
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IMGREGISTER 
RSPOUTDIMX GET 
(DimensionX)

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the X dimen-
sion of the output win-
dow.
DimensionX is in Work-
ing Units
(ex: 1:500.000).

Image Manager >
Utilities >
Register >   
Apply> 
To Image >
Window Input

IMGREGISTER 
RSPOUTDIMX SET 
<DimensionX>

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Sets the X dimension of 
the output window.
DimensionX is in Work-
ing Units
(ex: 1:500.000).

Idem

IMGREGISTER 
RSPOUTDIMY GET 
(DimensionY)

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the Y dimen-
sion of the output win-
dow.
DimensionY is in Work-
ing Units
(ex: 1:500.000).

Idem

IMGREGISTER 
RSPOUTDIMY SET 
<DimensionY>

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Sets the Y dimension of 
the output window.
DimensionY is in Work-
ing Units
(ex: 1:500.000).

Idem

IMGREGISTER RSPO-
UTORIGINX GET 
(OriginX)

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the X origin of 
the output window.
OriginX is in Working 
Units
(ex: 1:500.000).

Idem

IMGREGISTER RSPO-
UTORIGINX SET 
<OriginX>

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Sets the X origin of the 
output window.
OriginX is in Working 
Units
(ex: 1:500.000)

Idem

IMGREGISTER RSPO-
UTORIGINY GET 
(OriginY)

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the Y origin of 
the output window.
OriginY is in Working 
Units
(ex: 1:500.000)

Idem
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IMGREGISTER RSPO-
UTORIGINY SET 
<OriginY>

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Sets the Y origin of the 
output window.
OriginY is in Working 
Units
(ex: 1:500.000)

Idem

IMGREGISTER 
RSPOUTPUT GET 
(FileName)

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the file name of 
the output image.

Image Manager >
Utilities >
Register >   
Apply> 
To Image >

IMGREGISTER 
RSPOUTPUT SET 
[FileName]

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Sets the output image 
with the specified file. 
If FileName is not spec-
ified, the File Selection 
dialog is opened.

Idem

IMGREGISTER RSP-
PAGE DELETE

NONE KIN_INVALID_PARAM
KIN_SUCCESS

Delete the current resa-
mpling page.

Image Manager >
Utilities >
Register >   
Apply> 
To Image >
Job manager

IMGREGISTER RSP-
PAGE DELETEALL

NONE KIN_INVALID_PARAM
KIN_SUCCESS

Delete all resampling 
pages.

Idem

IMGREGISTER RSP-
PAGE DOWN

NONE KIN_INVALID_PARAM
KIN_SUCCESS

Goes to the next resam-
pling page.

Idem

IMGREGISTER RSP-
PAGE EDIT <File-
Name>

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Goes to the page where 
the output image has 
the same name as the 
specified FileName. If 
none is found, a new 
page is added with the 
specified FileName for 
the output image.

Idem

IMGREGISTER RSP-
PAGE GETCURRENT 
(Number)

Output:
LONG

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the number of 
the current resampling 
page.

Idem
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IMGREGISTER RSP-
PAGE GETNBTOTAL 
(Total)

Output:
LONG

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the count of 
resampling pages.

Idem

IMGREGISTER RSP-
PAGE RUN

NONE KIN_INVALID_PARAM
KIN_SUCCESS

Run the resampling of 
the current page.

Idem

IMGREGISTER RSP-
PAGE RUNALL

NONE KIN_INVALID_PARAM
KIN_SUCCESS

Run the resampling for 
all pages.

Idem

IMGREGISTER RSP-
PAGE SETCURRENT 
<page>

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Set the current page to 
the specified number.

Idem

IMGREGISTER RSP-
PAGE UP

NONE KIN_INVALID_PARAM
KIN_SUCCESS

Goes to the previous 
resampling page.

Idem

IMGREGISTER RSP-
PIXELSIZE GET
(PixelSize)

Output:
DOUBLE

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the current 
pixel size.

Image Manager >
Utilities >
Register >   
Apply> 
To Image >
Resampling

IMGREGISTER RSP-
PIXELSIZE SET 
<PixelSize>

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Sets the current pixel 
size.

Idem

IMGREGISTER 
RSPREPORT GET 
(text)

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Gets the report text for 
the current resampling 
page. 

Image Manager >
Utilities >
Register >   
Apply> 
To Image >
Job manager

IMGREGISTER RSP-
TYPE GET (type)

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the type of res-
ampling (NEAREST, 
BILINEAR or CUBIC).

Image Manager >
Utilities >
Register >   
Apply> 
To Image >
Resampling
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IMGREGISTER RSP-
TYPE SET <NEAR-
EST | BILINEAR | 
CUBIC>

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Sets the type of resam-
pling.

Idem

IMGREGISTER RSP-
WINDOW GET 
(Type)

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the type of 
window extent (ALL or 
WARPING or INPUT or 
OUTPUT).

Image Manager >
Utilities >
Register >   
Apply>
Window

IMGREGISTER RSP-
WINDOW SET <ALL 
| WARPING | 
INPUT | OUTPUT>

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Sets the type of win-
dow extent.

Idem

IMGREGISTER 
SHOWCTLPTS GET
(Status)

Output:
SHORT

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the status of 
the Show Control 
Points option. (ON/
OFF)

Image Manager >
Utilities >
Register >
View > 
Show Control 
Points

IMGREGISTER 
SHOWCTLPTS SET-
OFF

NONE KIN_SUCCESS Sets the Show Control 
Point option to OFF.

Idem

IMGREGISTER 
SHOWCTLPTS 
SETON

NONE KIN_SUCCESS Sets the Show Control 
Point option to ON.

Idem

IMGREGISTER TOL-
ERANCEMETER GET 
(tolerance)

Output:
DOUBLE

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the tolerance 
used for the precision 
of the model resolu-
tion (in meters).

IMGREGISTER TOL-
ERANCEMETER SET
<tolerance>

Input:
STRING

KIN_INVALID PARAM
KIN_SUCCESS

Sets the tolerance used 
for the precision of the 
model resolution (in 
meters).

IMGREGISTER TOL-
ERANCERADIAN GET 
(tolerance)

Output:
DOUBLE

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the tolerance 
used for the precision 
of the model resolu-
tion (in radians).
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IMGREGISTER TOL-
ERANCERADIAN 
SET <tolerance>

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Sets the tolerance used 
for the precision of the 
model resolution (in 
radians).

IMGREGISTER 
TOOLFILE CLOSE

NONE KIN_SUCCESS Close the Register File 
tool box.

Image Manager >
Tools >
Register File 

IMGREGISTER 
TOOLFILE OPEN

NONE KIN_SUCCESS Open the Register File 
tool box.

Image Manager >
Tools >
Register File

IMGREGISTER 
TOOLREGISTER 
CLOSE

NONE KIN_ERROR
KIN_SUCCESS

Close the Register tool 
box.

Image Manager >
Tools >
Register 

IMGREGISTER 
TOOLREGISTER 
OPEN

NONE KIN_ERROR
KIN_SUCCESS

Open the Register tool 
box.

Image Manager >
Tools >
Register

IMGREGISTER 
TOOLRESAMPLING 
CLOSE

NONE KIN_SUCCESS Close the Resampling 
File tool box.

Image Manager >
Tools >
Resampling File

IMGREGISTER 
TOOLRESAMPLING 
OPEN

NONE KIN_SUCCESS Open the Resampling 
File tool box.

Image Manager >
Tools >
Resampling File

IMGREGISTER VEC-
TORS COPY

NONE KIN_SUCCESS Starts the Copy Vector 
command. 

Image Manager >
Tools >
Register

IMGREGISTER VEC-
TORS GETMODE
(mode)

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the direction 
of the transformation 
(BaseToUncorrect or 
UncorrectToBase).

Image Manager >
Tools >
Register > 
Copy or Move 
Vector

IMGREGISTER VEC-
TORS MOVE

Starts the Move Vector 
command.

Image Manager >
Tools >
Register 
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IMGREGISTER VEC-
TORS SETBASE-
TOUNCORRECT

NONE KIN_SUCCESS Set the transformation 
direction to BaseToUn-
correct.

Image Manager >
Tools >
Register > 
Copy or Move 
Vector

IMGREGISTER VEC-
TORS SETUNCOR-
RECTTOBASE

NONE KIN_SUCCESS Set the transformation 
direction to Uncorrect-
ToBase.

Image Manager >
Tools >
Register > 
Copy or Move 
Vector

IMGREGISTER VER-
SION GET 
(version) (subver-
sion) (revision) (sub-
revision)

Output:
SHORT
SHORT
SHORT
SHORT

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the current ver-
sion, subversion, revi-
sion and subrevision of 
the module Register. 

IMGREGISTER 
WARNING GET
(Status)

Output:
SHORT

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the status of 
Warning when Renum-
bering option (ON/
OFF).

Image Manager >
Utilities >
Register >
Settings > 
Warning when 
Renumbering

IMGREGISTER 
WARNING SETOFF

NONE KIN_SUCCESS Sets Warning when 
Renumbering option to 
OFF.

Idem

IMGREGISTER 
WARNING SETON

NONE KIN_SUCCESS Sets Warning when 
Renumbering option to 
ON.

Idem

IMGREGISTER WARP-
ING GETMODE
(Mode)

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the warping 
window mode (NOEX-
TEND or BASE or 
MARKS or USERSPECI-
FIED).

Image Manager >
Utilities >
Register >
View > 
Warping Window

IMGREGISTER WARP-
ING GETPLUSMINUS
(Percent)

Output:
DOUBLE

KIN_ERROR
KIN_INVALID_PARAM
KIN_SUCCESS

Returns the percentage 
of increase/decrease of 
the warping window.

Idem
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IMGREGISTER WARP-
ING GETXDIMEN-
SION
(DimensionX)

Output:
DOUBLE

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the X dimen-
sion of the warping 
window.

Idem

IMGREGISTER WARP-
ING GETXORIGIN
(OriginX)

Output:
DOUBLE

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the X origin of 
the warping window.

Idem

IMGREGISTER WARP-
ING GETYDIMEN-
SION
(DimensionY)

Output:
DOUBLE

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the Y dimen-
sion of the warping 
window.

Idem

IMGREGISTER WARP-
ING GETYORIGIN
(OriginY)

Output:
DOUBLE

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the Y origin of 
the warping window.

Idem

IMGREGISTER WARP-
ING SETMODE
< NOEXTEND | 
BASE | MARKS | 
USERSPECIFIED >

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Sets the warping win-
dow mode.

Idem

IMGREGISTER WARP-
ING SETPLUSMINUS
<Percent>

Input:
STRING

KIN_ERROR
KIN_INVALID_PARAM
KIN_SUCCESS

Set the percentage of 
increase/decrease of 
the warping window.

Idem

IMGREGISTER WARP-
ING SETXDIMEN-
SION
< DimensionX >

Input:
STRING

KIN_ERROR
KIN_INVALID_PARAM
KIN_SUCCESS

Sets the X dimension of 
the warping window. 
Only when mode is 
USERSPECIFIED.

Idem

IMGREGISTER WARP-
ING SETXORIGIN
< OriginX >

Input:
STRING

KIN_ERROR
KIN_INVALID_PARAM
KIN_SUCCESS

Sets the X origin of the 
warping window. Only 
when mode is USER-
SPECIFIED.

Idem
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IMGREGISTER WARP-
ING SETYDIMEN-
SION
< DimensionY >

Input:
STRING

KIN_ERROR
KIN_INVALID_PARAM
KIN_SUCCESS

Sets the Y dimension of 
the warping window. 
Only when mode is 
USERSPECIFIED.

Idem

IMGREGISTER WARP-
ING SETYORIGIN
< OriginY >

Input:
STRING

KIN_ERROR
KIN_INVALID_PARAM
KIN_SUCCESS

Sets the Y origin of the 
warping window. Only 
when mode is USER-
SPECIFIED.

Idem
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Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface

IMGTHEME 
ALLVISIBLE CLEAR

NONE KIN_SUCCESS Set the Visible status of 
each theme in the 
current file to OFF.

Image Manager >
Utilities > 
Theme Styler > 
Options > 
Clear All Visible

IMGTHEME 
ALLVISIBLE SET

NONE KIN_SUCCESS Set the Visible status of 
each theme in the 
current file to ON.

Image Manager >
Utilities >
Theme Styler > 
Options > 
Set All Visible

IMGTHEME CELL 
GETCOLOR 
<theme name> (cell 
color)

Input:
STRING
Output:
SHORT

KIN_ERROR
KIN_INVALID_THEME
KIN_INVALID_PARAM
KIN_SUCCESS

Return the cell color of 
the specified theme.

Image Manager >
Utilities > 
Theme Styler > 
Cell Attributes

IMGTHEME CELL 
GETNAME 
<theme name> (cell 
name)

Input:
STRING
Output:
STRING

KIN_ERROR
KIN_INVALID_THEME
KIN_INVALID_PARAM
KIN_SUCCESS

Return the cell name of 
the specified theme.

Image Manager >
Utilities > 
Theme Styler > 
Cell Attributes

IMGTHEME CELL 
GETSYMBOLOGY 
<theme name> 
(status)

Input:
STRING
Output:
SHORT

KIN_ERROR
KIN_INVALID_THEME
KIN_INVALID_PARAM
KIN_SUCCESS

Return the cell's Use 
Symbology status for the 
specified theme.

Image Manager >
Utilities > 
Theme Styler >
Cell Attributes

IMGTHEME CELL 
GETXSCALE 
<theme name> (cell 
scale)

Input:
STRING
Output:
DOUBLE

KIN_ERROR
KIN_INVALID_THEME
KIN_INVALID_PARAM
KIN_SUCCESS

Return the cell's scale in 
X for the specified 
theme.

Image Manager >
Utilities > 
Theme Styler > 
Cell Attributes

IMGTHEME CELL 
GETYSCALE 
<theme name> (cell 
scale)

Input:
STRING
Output:
DOUBLE

KIN_ERROR
KIN_INVALID_THEME
KIN_INVALID_PARAM
KIN_SUCCESS

Return the cell's scale in 
Y for the specified 
theme.

Image Manager > 
Utilities > 
Theme Styler > 
Cell Attributes
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IMGTHEME CELL 
SETCOLOR 
<theme name> <cell 
color>

Input:
STRING,
SHORT

KIN_ERROR
KIN_INVALID_THEME
KIN_INVALID_COLOR
KIN_SUCCESS

Set the cell color of the 
specified theme.

Image Manager > 
Utilities > 
Theme Styler > 
Cell Attributes

IMGTHEME CELL 
SETNAME 
<theme name> <cell 
name>

Input:
STRING,
STRING

KIN_ERROR
KIN_INVALID_THEME
KIN_INVALID_PARAM
KIN_SUCCESS

Set the cell name of the 
specified theme.

Image Manager > 
Utilities > 
Theme Styler > 
Cell Attributes

IMGTHEME CELL 
SETOFFSYMBO-
LOGY <theme name> 

Input:
STRING

KIN_ERROR
KIN_INVALID_THEME
KIN_SUCCESS

Set the cell's Use 
Symbology status to 
OFF for the specified 
theme.

Image Manager >
 Utilities > 
Theme Styler > 
Cell Attributes

IMGTHEME CELL 
SETONSYMBOLOGY 
<theme name> 

Input:
STRING

KIN_ERROR
KIN_INVALID_THEME
KIN_SUCCESS

Set the cell's Use 
Symbology status to ON 
for the specified theme.

Image Manager > 
Utilities > 
Theme Styler > 
Cell Attributes

IMGTHEME CELL 
SETXSCALE 
<theme name> <cell 
scale>

Input:
STRING,
DOUBLE

KIN_ERROR
KIN_INVALID_THEME
KIN_INVALID_PARAM
KIN_SUCCESS

Set the cell's scale in X 
for the specified theme.

Image Manager > 
Utilities > 
Theme Styler > 
Cell Attributes

IMGTHEME CELL 
SETYSCALE 
<theme name> <cell 
scale>

Input:
STRING,
DOUBLE

KIN_ERROR
KIN_INVALID_THEME
KIN_INVALID_PARAM
KIN_SUCCESS

Set the cell's scale in Y 
for the specified theme.

Image Manager > 
Utilities > 
Theme Styler > 
Cell Attributes

IMGTHEME CHANGE 
GETTHEME 
(theme name)

Output:
STRING

KIN_ERROR
KIN_INVALID_PARAM
KIN_SUCCESS

Return the specified 
theme for the Change 
Theme command.

Image Manager > 
Tools > 
Theme > 
Change Theme 
tool settings

IMGTHEME CHANGE 
GO

NONE KIN_ERROR
KIN_SUCCESS

Start the Change Theme 
command.

Image Manager > 
Tools > 
Theme > 
Change Theme

Key-In Parameters Returned Error 
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IMGTHEME CHANGE 
SETTHEME <theme 
name>

Input:
STRING

KIN_ERROR
KIN_INVALID_THEME
KIN_SUCCESS

Specifies the theme for 
the Change Theme 
command.

Image Manager > 
Tools > 
Theme > 
Change Theme 
tool settings

IMGTHEME DIALOG 
CLOSE

NONE KIN_ERROR
KIN_SUCCES

Close the Theme Styler 
dialog.

Image Manager > 
Utilities > 
Theme Styler

IMGTHEME DIALOG 
OPEN

NONE KIN_ERROR
KIN_SUCCESS

Open the Theme Styler 
dialog.

Image Manager > 
Utilities > 
Theme Styler

IMGTHEME DISPLAY 
GET 
(status)

Output:
SHORT

KIN_INVALID_PARAM
KIN_SUCCESS

Return the Theme Styler 
Display status (ON/
OFF).

Image Manager > 
Utilities > 
Theme Styler > 
Options > 
Display

IMGTHEME DISPLAY 
SETOFF

NONE KIN_ERROR
KIN_SUCCESS

Set the Theme Styler 
Display status to OFF.

Image Manager > 
Utilities > 
Theme Styler > 
Options > 
Display

IMGTHEME DISPLAY 
SETON

NONE KIN_ERROR
KIN_SUCCESS

Set the Theme Styler 
Display status to ON.

Image Manager > 
Theme Styler > 
Options > 
Display

IMGTHEME DISPLAY 
TOGGLE

NONE KIN_ERROR
KIN_SUCCESS

Toggle the Theme Styler 
Display status.

Image Manager > 
Utilities > 
Theme Styler > 
Options > 
Display

IMGTHEME 
DLGCELLATTRI-
BUTES CLOSE

NONE KIN_ERROR
KIN_SUCCESS

Close the Cell Attributes 
dialog.

Image Manager > 
Utilities > 
Theme Styler

Key-In Parameters Returned Error 
Codes

Description Graphical 
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IMGTHEME 
DLGCELLATTRI-
BUTES OPEN

NONE KIN_ERROR
KIN_SUCCESS

Open the Cell Attributes 
dialog.

Image Manager > 
Utilities > 
Theme Styler

IMGTHEME 
DLGHATCH CLOSE

NONE KIN_ERROR
KIN_SUCCESS

Close the Hatch Editing 
dialog.

Image Manager > 
Utilities > 
Theme Styler > 
Hatch > 
Edit

IMGTHEME 
DLGHATCH OPEN

NONE KIN_ERROR
KIN_SUCCESS

Open the Hatch Editing 
dialog.

Image Manager > 
Utilities > 
Theme Styler > 
Hatch > 
Edit

IMGTHEME 
DLGPATTERN CLOSE

NONE KIN_ERROR
KIN_SUCCESS

Close the Pattern Editing 
dialog.

Image Manager > 
Utilities > 
Theme Styler > 
Pattern> 
Edit

IMGTHEME 
DLGPATTERN OPEN

NONE KIN_ERROR
KIN_SUCCESS

Open the Pattern 
Editing dialog.

Image Manager > 
Utilities > 
Theme Styler > 
Pattern> 
Edit

IMGTHEME 
DLGTEXTATTRI-
BUTES CLOSE

NONE KIN_ERROR
KIN_SUCCESS

Close the Text Attributes 
dialog.

Image Manager > 
Utilities > 
Theme Styler

IMGTHEME 
DLGTEXTATTRI-
BUTES OPEN

NONE KIN_ERROR
KIN_SUCCESS

Open the Text 
Attributes dialog.

Image Manager > 
Utilities > 
Theme Styler

IMGTHEME 
DLGUPDATE CLOSE

NONE KIN_ERROR
KIN_SUCCESS

Close the Update 
Design File dialog.

Image Manager > 
Utilities > 
Theme Styler > 
Options > 
Update Design 
File

Key-In Parameters Returned Error 
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IMGTHEME 
DLGUPDATE OPEN

NONE KIN_ERROR
KIN_SUCCESS

Open the Update 
Design File dialog.

Image Manager > 
Utilities > 
Theme Styler > 
Options > 
Update Design 
File

IMGTHEME FILE GET
(file name)

Output:
STRING

KIN_ERROR
KIN_INVALID_PARAM
KIN_SUCCESS

Return the current 
theme file name. If no 
file is opened, the return 
value is NONE.

Image Manager > 
Utilities > 
Theme Styler

IMGTHEME FILE 
NEW

NONE KIN_ERROR
KIN_SUCCESS

Create a new theme file. Image Manager > 
Utilities > 
Theme Styler > 
File > 
New

IMGTHEME FILE 
OPEN
[file name]

Input:
STRING

KIN_ERROR
KIN_SUCCESS

Open an existing theme 
file. If file name is not 
specified, a File 
Selection dialog is 
opened.

Image Manager > 
Utilities > 
Theme Styler > 
File > 
Open

IMGTHEME FILE 
SAVE

NONE KIN_ERROR
KIN_SUCCESS

Save the current theme 
file.

Image Manager > 
Utilities > 
Theme Styler > 
File > 
Save

IMGTHEME FILE 
SAVEAS
[file name]

Input:
STRING 

KIN_ERROR
KIN_SUCCESS

Save the current theme 
file under a new name. 
If no file name is 
provided, a File 
Selection dialog is 
opened.

Image Manager > 
Utilities > 
Theme Styler > 
File > 
Save As

IMGTHEME 
FILLTHEME 
GETCOLORNUMBER
<theme name> (color 
number)

Input:
STRING
Output:
SHORT

KIN_ERROR
KIN_INVALID_THEME
KIN_INVALID_PARAM
KIN_SUCCESS

Return the color number 
of the specified theme.

Image Manager > 
Utilities > 
Theme Styler

Key-In Parameters Returned Error 
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IMGTHEME 
FILLTHEME 
GETONOFF
<theme name> 
(status)

Input:
STRING
Output:
SHORT

KIN_ERROR
KIN_INVALID_THEME
KIN_INVALID_PARAM
KIN_SUCCESS

Return the Fill status of 
the specified theme.

Image Manager >
Utilities > 
Theme Styler

IMGTHEME 
FILLTHEME 
SETCOLORNUMBER
<theme name> <color 
number>

Input:
STRING,
SHORT

KIN_ERROR
KIN_INVALID_THEME
KIN_INVALID_COLOR
KIN_SUCCESS

Set the color number of 
the specified theme.

Image Manager > 
Utilities > 
Theme Styler

IMGTHEME 
FILLTHEME SETOFF 
<theme name> 

Input:
STRING

KIN_ERROR
KIN_INVALID_THEME
KIN_SUCCESS

Set the Fill status of the 
specified theme to OFF.

Image Manager > 
Utilities > 
Theme Styler

IMGTHEME 
FILLTHEME SETON 
<theme name> 

Input:
STRING

KIN_ERROR
KIN_INVALID_THEME
KIN_SUCCESS

Set the Fill status of the 
specified theme to ON.

Image Manager > 
Utilities > 
Theme Styler

IMGTHEME 
GLOBALSCALE GET
(scale value)

Output:
DOUBLE

KIN_ERROR
KIN_INVALID_PARAM
KIN_SUCCESS

Return the global scale. Image Manager > 
Utilities > 
Theme Styler

IMGTHEME 
GLOBALSCALE SET
<scale value>

Input:
DOUBLE

KIN_ERROR
KIN_INVALID_PARAM
KIN_SUCCESS

Set the global scale. Image Manager > 
Utilities > 
Theme Styler

IMGTHEME HATCH 
ADD

NONE KIN_ERROR

KIN_SUCCESS

Add the current hatch to 
the current hatch file.

Image Manager > 
Utilities > 
Theme Styler > 
Hatch > 
Edit 

IMGTHEME HATCH 
DELETE

NONE KIN_ERROR
KIN_SUCCESS

Delete the current 
hatch.

Image Manager > 
Utilities > 
Theme Styler > 
Hatch > 
Edit

Key-In Parameters Returned Error 
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IMGTHEME HATCH 
EDIT

NONE KIN_ERROR
KIN_SUCCESS

Open the Hatch Editing 
dialog.

Image Manager > 
Utilities > 
Theme Styler > 
Hatch > 
Edit

IMGTHEME HATCH 
GETCOLOR
< hatch number>  
(color number)

Input:
LONG,
Output:
SHORT

KIN_ERROR
KIN_INVALID_HATCH
KIN_INVALID_PARAM
KIN_SUCCESS

Return the specified 
hatch's color.

Image Manager > 
Utilities > 
Theme Styler > 
Hatch > 
Edit

IMGTHEME HATCH 
GETFILE
(file name)

Input:
LONG,
Output:
STRING

KIN_ERROR
KIN_INVALID_PARAM
KIN_SUCCESS

Return the current 
hatching file opened for 
the hatching tool. If no 
file is opened, the 
returned file name is 
NONE.

Image Manager > 
Utilities > 
Theme Styler

IMGTHEME HATCH 
GETLINETYPE 
< hatch number> (line 
style number) 

Input:
LONG,
Output:
SHORT

KIN_ERROR
KIN_INVALID_HATCH
KIN_INVALID_PARAM
KIN_SUCCESS

Return the specified 
hatch's line style.

Image Manager > 
Utilities > 
Theme Styler > 
Hatch > 
Edit 

IMGTHEME HATCH 
GETLINEWEIGHT 
< hatch number> (line 
weight number)

Input:
LONG,
Output:
SHORT

KIN_ERROR
KIN_INVALID_HATCH
KIN_INVALID_PARAM
KIN_SUCCESS

Return the specified 
hatch's line weight.

Image Manager > 
Utilities > 
Theme Styler > 
Hatch > 
Edit

IMGTHEME HATCH 
GETTYPE 
< hatch number> 
(type)

Input:
LONG,
Output:
STRING

KIN_ERROR
KIN_INVALID_HATCH
KIN_INVALID_PARAM
KIN_SUCCESS

Return the type of 
specified hatch (HATCH 
or CROSSHATCH).

Image Manager > 
Utilities > 
Theme Styler > 
Hatch > 
Edit

IMGTHEME HATCH 
GETXANGLE 
< hatch number> 
(Angle)

Input:
LONG,
Output:
SHORT

KIN_ERROR
KIN_INVALID_HATCH
KIN_INVALID_PARAM
KIN_SUCCESS

Return the specified 
hatch's angle in X.

Image Manager > 
Utilities > 
Theme Styler > 
Hatch > 
Edit 

Key-In Parameters Returned Error 
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IMGTHEME HATCH 
GETXSPACING 
< hatch number> 
(spacing value)

Input:
LONG,
Output:
SHORT

KIN_ERROR
KIN_INVALID_HATCH
KIN_INVALID_PARAM
KIN_SUCCESS

Return the specified 
hatch's spacing in X.

Image Manager > 
Utilities > 
Theme Styler > 
Hatch > 
Edit

IMGTHEME HATCH 
GETYANGLE 
<hatch number> 
(Angle)

Input:
LONG,
Output:
SHORT

KIN_ERROR
KIN_INVALID_HATCH
KIN_INVALID_PARAM
KIN_SUCCESS

Return the specified 
hatch's angle in Y.

Image Manager > 
Utilities > 
Theme Styler > 
Hatch > 
Edit

IMGTHEME HATCH 
GETYSPACING 
< hatch number> 
(spacing value) 

Input:
LONG,
Output:
SHORT

KIN_ERROR
KIN_INVALID_HATCH
KIN_INVALID_PARAM
KIN_SUCCESS

Return the specified 
hatch's spacing in Y.

Image Manager > 
Utilities > 
Theme Styler > 
Hatch > 
Edit 

IMGTHEME HATCH 
MODIFY

NONE KIN_ERROR

KIN_SUCCESS

Modify the current 
hatch.

Image Manager > 
Utilities > 
Theme Styler > 
Hatch > 
Edit

IMGTHEME HATCH 
NEW

NONE KIN_SUCCESS Create a new hatch file. Image Manager > 
Utilities > 
Theme Styler > 
Hatch > 
Edit > 
File > 
New

IMGTHEME HATCH 
OPEN
[file name]

Input:
STRING

KIN_ERROR
KIN_INVALID_PARAM
KIN_SUCCESS

Open an existing hatch 
file. If file name is not 
specified, a File 
Selection dialog is 
opened.

Image Manager > 
Utilities > 
Theme Styler > 
Hatch > 
Edit > 
File > 
Open
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IMGTHEME HATCH 
SAVE

NONE KIN_ERROR
KIN_SUCCESS

Save the current hatch 
file.

Image Manager > 
Utilities > 
Theme Styler > 
Hatch > 
Edit > 
File > 
Save

IMGTHEME HATCH 
SAVEAS
[file name]

Input:
STRING

KIN_ERROR
KIN_INVALID_PARAM
KIN_SUCCESS

Save the current hatch 
file under a new name. 
If file name is not 
specified, a File Creation 
dialog is opened.

Image Manager > 
Utilities > 
Theme Styler > 
Hatch > 
Edit > 
File > 
Save As

IMGTHEME HATCH 
SELECT
[file name]

Input:
STRING

KIN_ERROR
KIN_INVALID_PARAM
KIN_SUCCESS

Assigns a hatch file to 
the current theme file. If 
no file name is 
provided, a File 
Selection dialog is 
opened.

Image Manager > 
Utilities > 
Theme Styler > 
Hatch > 
Select

IMGTHEME HATCH 
SETCOLOR
< hatch number> 
<color number> 

Input:
LONG,
SHORT

KIN_ERROR
KIN_INVALID_HATCH
KIN_INVALID_COLOR
KIN_SUCCESS

Set the specified hatch's 
color. 

Image Manager > 
Utilities > 
Theme Styler > 
Hatch > 
Edit 

IMGTHEME HATCH 
SETLINETYPE 
< hatch number> 
<line style number>

Input:
LONG,
SHORT

KIN_ERROR
KIN_INVALID_HATCH
KIN_INVALID_PARAM
KIN_SUCCESS

Set the specified hatch's 
line style.

Image Manager > 
Utilities > 
Theme Styler > 
Hatch > 
Edit

IMGTHEME HATCH 
SETLINEWEIGHT 
< hatch number> < 
line weight number > 

Input:
LONG,
SHORT

KIN_ERROR
KIN_INVALID_HATCH
KIN_INVALID_PARAM
KIN_SUCCESS

Set the specified hatch's 
line weight.

Image Manager > 
Utilities > 
Theme Styler > 
Hatch > 
Edit 
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IMGTHEME HATCH 
SETNUMBER
<old hatch number> 
<new hatch number>

Input:
SHORT
SHORT

KIN_ERROR
KIN_INVALID_HATCH
KIN_INVALID_PARAM
KIN_SUCCESS

Set the active hatch to 
the specified number.

Image Manager > 
Utilities > 
Theme Styler > 
Hatch >
Edit 

IMGTHEME HATCH 
SETTYPE 
< hatch number> 
<HATCH | 
CROSSHATCH >

Input:
LONG,
SHORT

KIN_ERROR
KIN_INVALID_HATCH
KIN_INVALID_PARAM
KIN_SUCCESS

Set the type of the 
specified hatch.

Image Manager > 
Utilities > 
Theme Styler > 
Hatch > 
Edit 

IMGTHEME HATCH 
SETXANGLE 
< hatch number> 
<Angle>

Input:
LONG,
SHORT

KIN_ERROR
KIN_INVALID_HATCH
KIN_INVALID_PARAM
KIN_SUCCESS

Set the specified hatch's 
angle in X. 

Image Manager >
Utilities > 
Theme Styler > 
Hatch > 
Edit 

IMGTHEME HATCH 
SETXSPACING 
< hatch number> 
<spacing value>

Input:
LONG,
SHORT

KIN_ERROR
KIN_INVALID_HATCH
KIN_INVALID_PARAM
KIN_SUCCESS

Set the specified hatch's 
spacing in X. 

Image Manager > 
Utilities > 
Theme Styler > 
Hatch > 
Edit 

IMGTHEME HATCH 
SETYANGLE 
< hatch number> 
<Angle>

Input:
LONG,
SHORT

KIN_ERROR
KIN_INVALID_HATCH
KIN_INVALID_PARAM
KIN_SUCCESS

Set the specified hatch's 
angle in Y. Only 
available if the Hatch 
type is Cross hatch.

Image Manager > 
Utilities > 
Theme Styler > 
Hatch > 
Edit 

IMGTHEME HATCH 
SETYSPACING 
< hatch number> 
<spacing value>

Input:
LONG,
SHORT

KIN_ERROR
KIN_INVALID_HATCH
KIN_INVALID_PARAM
KIN_SUCCESS

Set the specified hatch's 
spacing in Y. Only 
available if the Hatch 
type is Cross hatch.

Image Manager > 
Utilities > 
Theme Styler > 
Hatch > 
Edit
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IMGTHEME 
IMGVERSION GET
(version) (subversion) 
(revision) 
(subrevision)

Output:
SHORT,
SHORT,
SHORT,
SHORT

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Return the current 
version, subversion, 
revision and subrevision 
of the minimal module 
of the main Descartes 
that can be used with 
this version of Theme 
Styler. Also printed on 
the screen.

IMGTHEME 
PATTERN  
GETROWSPACING
<pattern number> 
(spacing value)

Input:
LONG,
Output:
DOUBLE

KIN_ERROR
KIN_INVALID_
PATTERN
KIN_INVALID_PARAM
KIN_SUCCESS

Return the specified 
pattern's row spacing.

Image Manager > 
Utilities > 
Theme Styler > 
Pattern > 
Edit 

IMGTHEME 
PATTERN GETSCALE 
<pattern number> 
(scale)

Input:
LONG,
Output:
DOUBLE

KIN_ERROR
KIN_INVALID_
PATTERN
KIN_INVALID_PARAM
KIN_SUCCESS

Return the specified 
pattern's scale.

Image Manager > 
Utilities > 
Theme Styler > 
Pattern > 
Edit 

IMGTHEME 
PATTERN  
SETCOLSPACING
<pattern number> < 
spacing value >

Input:
LONG,
DOUBLE

KIN_ERROR
KIN_INVALID_
PATTERN
KIN_INVALID_PARAM
KIN_SUCCESS

Set the specified 
pattern's column 
spacing.

Image Manager > 
Utilities > 
Theme Styler > 
Pattern > 
Edit 

IMGTHEME 
PATTERN ADD

NONE KIN_ERROR

KIN_SUCCESS

Add the current pattern 
to the current patterning 
file.

Image Manager > 
Utilities > 
Theme Styler > 
Pattern > 
Edit 

IMGTHEME 
PATTERN DELETE

NONE KIN_ERROR
KIN_SUCCESS

Delete the current 
pattern.

Image Manager > 
Utilities > 
Theme Styler > 
Pattern > 
Edit 
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IMGTHEME 
PATTERN EDIT

NONE KIN_ERROR
KIN_SUCCESS

Open the Pattern 
Editing dialog.

Image Manager > 
Utilities > 
Theme Styler > 
Pattern> 
Edit

IMGTHEME 
PATTERN GETANGLE 
<pattern number> 
(angle)

Input:
LONG,
Output:
DOUBLE

KIN_ERROR
KIN_INVALID_
PATTERN
KIN_INVALID_PARAM
KIN_SUCCESS

Return the specified 
pattern's angle.

Image Manager > 
Utilities > 
Theme Styler > 
Pattern > 
Edit 

IMGTHEME 
PATTERN 
GETCELLNAME 
<pattern number> 
(cell name) 

Input:
LONG,
Output:
STRING

KIN_ERROR
KIN_INVALID_
PATTERN
KIN_INVALID_PARAM
KIN_SUCCESS

Return the cell name of 
the specified pattern.

Image Manager > 
Utilities > 
Theme Styler > 
Pattern > 
Edit 

IMGTHEME 
PATTERN 
GETCOLSPACING
<pattern number> 
(spacing value) 

Input:
LONG,
Output:
DOUBLE

KIN_ERROR
KIN_INVALID_
PATTERN
KIN_INVALID_PARAM
KIN_SUCCESS

Return the specified 
pattern's column 
spacing.

Image Manager > 
Utilities > 
Theme Styler > 
Pattern > 
Edit 

IMGTHEME 
PATTERN GETFILE
(file name)

Input:
LONG,
Output:
STRING

KIN_ERROR
KIN_INVALID_PARAM
KIN_SUCCESS

Return the current 
patterning file opened 
for the hatching tool. If 
no file is opened, the 
returned file name is 
NONE.

Image Manager > 
Utilities > 
Theme Styler

IMGTHEME 
PATTERN SETSCALE 
<pattern number> 
<scale> 

Input:
LONG,
DOUBLE

KIN_ERROR
KIN_INVALID_
PATTERN
KIN_INVALID_PARAM
KIN_SUCCESS

Set the specified 
pattern's scale.

Image Manager > 
Utilities > 
Theme Styler > 
Pattern > 
Edit 

IMGTHEME 
PATTERN MODIFY

NONE KIN_ERROR

KIN_SUCCESS

Modify the current 
pattern.

Image Manager > 
Utilities > 
Theme Styler > 
Pattern > 
Edit 
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IMGTHEME 
PATTERN NEW

NONE KIN_SUCCESS Create a new patterning 
file.

Image Manager > 
Utilities > 
Theme Styler > 
Pattern > 
Edit > 
File > 
New

IMGTHEME 
PATTERN OPEN
[file name]

Input:
STRING

KIN_ERROR
KIN_INVALID_PARAM
KIN_SUCCESS

Open an existing 
patterning file. If file 
name is not specified, a 
File Selection dialog is 
opened.

Image Manager > 
Utilities > 
Theme Styler > 
Pattern > 
Edit > 
File > 
Open

IMGTHEME 
PATTERN SAVE

NONE KIN_ERROR
KIN_SUCCESS

Save the current 
patterning file.

Image Manager > 
Utilities > 
Theme Styler > 
Pattern> 
Edit > 
File > 
Save

IMGTHEME 
PATTERN SAVEAS
[file name]

NONE KIN_ERROR
KIN_INVALID_PARAM
KIN_SUCCESS

Save the current 
patterning file under a 
new name. If file name 
is not specified, a File 
Selection dialog is 
opened.

Image Manager > 
Utilities > 
Theme Styler > 
Pattern> 
Edit > 
File > 
Save As

IMGTHEME 
PATTERN SELECT
[file name]

Input:
STRING

KIN_ERROR
KIN_SUCCESS

Assign a pattern file to 
the current theme file. If 
file name is not 
specified, a File 
Selection dialog is 
opened.

Image Manager > 
Utilities > 
Theme Styler > 
Pattern> 
Select
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IMGTHEME 
PATTERN SETANGLE 
<pattern number> 
<angle>

Input:
LONG,
DOUBLE

KIN_ERROR
KIN_INVALID_
PATTERN
KIN_INVALID_PARAM
KIN_SUCCESS

Set the specified 
pattern's angle.

Image Manager > 
Utilities > 
Theme Styler > 
Pattern > 
Edit 

IMGTHEME 
PATTERN 
SETCELLNAME
<pattern number> 
<cell name>

Input:
LONG,
STRING

KIN_ERROR
KIN_INVALID_
PATTERN
KIN_INVALID_PARAM
KIN_SUCCESS

Set the cell name 
associated with the 
specified pattern.

Image Manager > 
Utilities > 
Theme Styler > 
Pattern > 
Edit 

IMGTHEME 
PATTERN 
SETNUMBER
<old pattern number> 
<new pattern 
number>

Input:
SHORT
SHORT

KIN_ERROR
KIN_INVALID_
PATTERN
KIN_INVALID_PARAM
KIN_SUCCESS

Set the active pattern to 
the one whose number 
is specified.

Image Manager > 
Utilities > 
Theme Styler > 
Pattern > 
Edit 

IMGTHEME 
PATTERN 
SETROWSPACING 
<pattern number>
<spacing value>

Input:
LONG,
DOUBLE

KIN_ERROR
KIN_INVALID_
PATTERN
KIN_SUCCESS

Set the specified 
pattern's row spacing.

Image Manager > 
Utilities > 
Theme Styler > 
Pattern > 
Edit 

IMGTHEME SELECT 
GETTHEME
(theme name)

Output:
STRING

KIN_ERROR
KIN_INVALID_PARAM
KIN_SUCCESS

Return the theme 
specified in the tool 
settings for the Select 
Theme command.

Image Manager > 
Tools > 
Theme > 
Select Theme tool 
settings

IMGTHEME SELECT 
GO

NONE KIN_ERROR
KIN_SUCCESS

Start the Select Theme 
command.

Image Manager > 
Tools > 
Theme > 
Select Theme

IMGTHEME SELECT 
SETTHEME 
<theme name>

Input:
STRING

KIN_ERROR
KIN_INVALID_THEME
KIN_SUCCESS

Specify the theme for 
the Select Theme 
command.

Image Manager > 
Tools > 
Theme Select 
Theme tool 
settings
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IMGTHEME 
SURFACETHEME 
GETHATCHNUMBER
<theme name> 
(number) 

Input:
STRING
Output:
SHORT

KIN_ERROR
KIN_INVALID_THEME
KIN_INVALID_PARAM
KIN_SUCCESS

Return the hatch 
number of the specified 
theme.

Image Manager > 
Utilities > 
Theme Styler

IMGTHEME 
SURFACETHEME 
GETPATTERNNUMB
ER
<theme name> 
(number)

Input:
STRING
Output:
SHORT

KIN_ERROR
KIN_INVALID_THEME
KIN_INVALID_PARAM
KIN_SUCCESS

Return the pattern 
number of the specified 
theme.

Image Manager > 
Utilities > 
Theme Styler

IMGTHEME 
SURFACETHEME 
SETHATCHNUMBER
<theme name> 
<number>

Input:
STRING,
SHORT

KIN_ERROR
KIN_INVALID_THEME
KIN_INVALID_PARAM
KIN_SUCCESS

Set the hatch number of 
the specified theme.

Image Manager > 
Utilities > 
Theme Styler

IMGTHEME 
SURFACETHEME 
SETPATTERNNUMBE
R
<theme name> 
<number> 

Input:
STRING,
SHORT

KIN_ERROR
KIN_INVALID_THEME
KIN_INVALID_PARAM
KIN_SUCCESS

Set the pattern number 
of the specified theme.

Image Manager > 
Utilities > 
Theme Styler

IMGTHEME TEXT 
GETCHARSPACING 
<theme name> 
(character spacing)

Input:
STRING
Output:
DOUBLE

KIN_ERROR
KIN_INVALID_THEME
KIN_INVALID_PARAM
KIN_SUCCESS

Return the font's 
character spacing for the 
specified theme.

Image Manager > 
Utilities > 
Theme Styler > 
Text Attributes

IMGTHEME TEXT 
GETCOLOR 
<theme name> (color)

Input:
STRING
Output:
SHORT

KIN_ERROR
KIN_INVALID_THEME
KIN_INVALID_PARAM
KIN_SUCCESS

Return the font color for 
the specified theme.

Image Manager > 
Utilities > 
Theme Styler > 
Text Attributes

IMGTHEME TEXT 
GETFONT 
<theme name> (font 
number)

Input:
STRING
Output:
SHORT

KIN_ERROR
KIN_INVALID_THEME
KIN_INVALID_PARAM
KIN_SUCCESS

Return the font number 
of the specified theme.

Image Manager > 
Utilities > 
Theme Styler > 
Text Attributes
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IMGTHEME TEXT 
GETHEIGHT 
<theme name> (font 
height)

Input:
STRING
Output:
DOUBLE

KIN_ERROR
KIN_INVALID_THEME
KIN_INVALID_PARAM
KIN_SUCCESS

Return the font height 
for the specified theme.

Image Manager > 
Utilities > 
Theme Styler > 
Text Attributes

IMGTHEME TEXT 
GETLINESPACING 
<theme name> (line 
spacing)

Input:
STRING
Output:
DOUBLE

KIN_ERROR
KIN_INVALID_THEME
KIN_INVALID_PARAM
KIN_SUCCESS

Return the font's line 
spacing for the specified 
theme.

Image Manager > 
Utilities > 
Theme Styler > 
Text Attributes

IMGTHEME TEXT 
GETMULTILINEJUST 
<theme name> 
(justification)

Input:
STRING
Output:
SHORT

KIN_ERROR
KIN_INVALID_THEME
KIN_INVALID_PARAM
KIN_SUCCESS

Return the multi -line 
text justification for the 
specified theme. The 
(justification) output 
parameter will contain 
one of those values: 
LMT, LMC, LMB, LT, LC, 
LB, CT, CC, CB, RT, RC, 
RB, RMT, RMC or RMB. 
The abbreviations stand 
for Left Margin Top, Left 
Margin Center, …

Image Manager > 
Utilities > 
Theme Styler > 
Text Attributes

IMGTHEME TEXT 
GETSINGLELINEJUST
 <theme name> 
(justification)

Input:
STRING
Output:
SHORT

KIN_ERROR
KIN_INVALID_THEME
KIN_INVALID_PARAM
KIN_SUCCESS

Return the single-line 
text justification for the 
specified theme. The 
(justification) output 
parameter will contain 
one of those values: LT, 
LC, LB, CT, CC, CB, RT, 
RC or RB. The 
abbreviations stand for 
Left Top, Left Center, …

Image Manager > 
Utilities > 
Theme Styler > 
Text Attributes

IMGTHEME TEXT 
GETSLANT 
<theme name> (slant 
value)

Input:
STRING
Output:
DOUBLE

KIN_ERROR
KIN_INVALID_THEME
KIN_INVALID_PARAM
KIN_SUCCESS

Return the font slant for 
the specified theme.

Image Manager > 
Utilities > 
Theme Styler > 
Text Attributes
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IMGTHEME TEXT 
GETUNDERLINE 
<theme name> 
(status)

Input:
STRING
Output:
SHORT

KIN_ERROR
KIN_INVALID_THEME
KIN_INVALID_PARAM
KIN_SUCCESS

Return the text's 
Underline status for the 
specified theme (ON/
OFF).

Image Manager > 
Utilities > 
Theme Styler > 
Text Attributes

IMGTHEME TEXT 
GETVERTICAL 
<theme name> 
(status)

Input:
STRING
Output:
SHORT

KIN_ERROR
KIN_INVALID_THEME
KIN_INVALID_PARAM
KIN_SUCCESS

Return the text's Vertical 
status for the specified 
theme (ON/OFF).

Image Manager > 
Utilities > 
Theme Styler > 
Text Attributes

IMGTHEME TEXT 
GETWIDTH 
<theme name> (font 
width)

Input:
STRING
Output:
DOUBLE

KIN_ERROR
KIN_INVALID_THEME
KIN_INVALID_PARAM
KIN_SUCCESS

Return the font width for 
the specified theme.

Image Manager > 
Utilities > 
Theme Styler > 
Text Attributes

IMGTHEME TEXT 
SETCHARSPACING 
<theme name> 
<character spacing>

Input:
STRING,
DOUBLE

KIN_ERROR
KIN_INVALID_THEME
KIN_INVALID_PARAM
KIN_SUCCESS

Set the font's character 
spacing for the specified 
theme.

Image Manager > 
Utilities > 
Theme Styler > 
Text Attributes

IMGTHEME TEXT 
SETCOLOR 
<theme name> 
<color>

Input:
STRING,
SHORT

KIN_ERROR
KIN_INVALID_THEME
KIN_INVALID_COLOR
KIN_SUCCESS

Set the font color for the 
specified theme.

Image Manager > 
Utilities > 
Theme Styler > 
Text Attributes

IMGTHEME TEXT 
SETFONT 
<theme name> <font 
number>

Input:
STRING,
LONG

KIN_ERROR
KIN_INVALID_THEME
KIN_INVALID_PARAM
KIN_SUCCESS

Set the font number of 
the specified theme.

Image Manager > 
Utilities > 
Theme Styler > 
Text Attributes

IMGTHEME TEXT 
SETHEIGHT 
<theme name> <font 
height>

Input:
STRING,
DOUBLE

KIN_ERROR
KIN_INVALID_THEME
KIN_INVALID_PARAM
KIN_SUCCESS

Set the font height for 
the specified theme.

Image Manager > 
Utilities > 
Theme Styler > 
Text Attributes

IMGTHEME TEXT 
SETLINESPACING 
<theme name> <line 
spacing>

Input:
STRING,
DOUBLE

KIN_ERROR
KIN_INVALID_THEME
KIN_INVALID_PARAM
KIN_SUCCESS

Set the font's line 
spacing for the specified 
theme.

Image Manager > 
Utilities > 
Theme Styler > 
Text Attributes
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IMGTHEME TEXT 
SETMULTILINEJUST 
<theme name> < LMT 
| LMC | LMB | LT | 
LC | LB | CT | CC | 
CB | RT | RC | RB | 
RMT | RMC | RMB >

Input:
STRING,
SHORT

KIN_ERROR
KIN_INVALID_THEME
KIN_INVALID_PARAM
KIN_SUCCESS

Set the multi-line text 
justification for the 
specified theme.

Image Manager > 
Utilities > 
Theme Styler > 
Text Attributes

IMGTHEME TEXT 
SETOFFUNDERLINE 
<theme name> 

Input:
STRING

KIN_ERROR
KIN_INVALID_THEME
KIN_SUCCESS

Set the text's Underline 
status to OFF for the 
specified theme.

Image Manager > 
Utilities > 
Theme Styler > 
Text Attributes

IMGTHEME TEXT 
SETOFFVERTICAL 
<theme name> 

Input:
STRING

KIN_ERROR
KIN_INVALID_THEME
KIN_SUCCESS

Set the text's Vertical 
status to OFF for the 
specified theme.

Image Manager > 
Utilities > 
Theme Styler > 
Text Attributes

IMGTHEME TEXT 
SETONUNDERLINE 
<theme name> 

Input:
STRING

KIN_ERROR
KIN_INVALID_THEME
KIN_SUCCESS

Set the text's Underline 
status to ON for the 
specified theme.

Image Manager > 
Utilities > 
Theme Styler > 
Text Attributes

IMGTHEME TEXT 
SETONVERTICAL 
<theme name> 

Input:
STRING

KIN_ERROR
KIN_INVALID_THEME
KIN_SUCCESS

Set the text's Vertical 
status to ON for the 
specified theme.

Image Manager > 
Utilities > 
Theme Styler > 
Text Attributes

IMGTHEME TEXT 
SETSINGLELINEJUST 
<theme name> <LT | 
LC | LB | CT | CC | 
CB | RT | RC | RB>

Input:
STRING,
SHORT

KIN_ERROR
KIN_INVALID_THEME
KIN_INVALID_PARAM
KIN_SUCCESS

Set the single-line text 
justification for the 
specified theme.

Image Manager > 
Utilities > 
Theme Styler > 
Text Attributes

IMGTHEME TEXT 
SETSLANT 
<theme name> <slant 
value>

Input:
STRING,
DOUBLE

KIN_ERROR
KIN_INVALID_THEME
KIN_INVALID_PARAM
KIN_SUCCESS

Set the font slant for the 
specified theme.

Image Manager > 
Utilities > 
Theme Styler > 
Text Attributes
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IMGTHEME TEXT 
SETWIDTH 
<theme name> <font 
width>

Input:
STRING,
DOUBLE

KIN_ERROR
KIN_INVALID_THEME
KIN_INVALID_PARAM
KIN_SUCCESS

Set the font width for the 
specified theme.

Image Manager > 
Utilities > 
Theme Styler > 
Text Attributes

IMGTHEME THEME 
ADD

NONE KIN_ERROR
KIN_SUCCESS

Add the active theme to 
the theme file.

Image Manager > 
Utilities > 
Theme Styler

IMGTHEME THEME 
DELETE

NONE KIN_ERROR
KIN_SUCCESS

Deletes the active 
theme.

Image Manager > 
Utilities > 
Theme Styler

IMGTHEME THEME 
GETCOLORCON-
TOUR
<theme name> (color 
number)

Input:
STRING
Output:
SHORT

KIN_ERROR
KIN_INVALID_THEME
KIN_INVALID_PARAM
KIN_SUCCESS

Return the contour color 
of the specified theme.

Image Manager > 
Utilities > 
Theme Styler

IMGTHEME THEME 
GETDESCRIPTION
<theme name> 
(description)

Input:
STRING
Output:
STRING

KIN_ERROR
KIN_INVALID_THEME
KIN_INVALID_PARAM
KIN_SUCCESS

Return the description 
of the specified theme.

Image Manager > 
Utilities > 
Theme Styler

IMGTHEME THEME 
GETLEVEL
<theme name> (level 
number)

Input:
STRING
Output:
SHORT

KIN_ERROR
KIN_INVALID_THEME
KIN_INVALID_PARAM
KIN_SUCCESS

Return the level of the 
specified theme.

Image Manager > 
Utilities > 
Theme Styler

IMGTHEME THEME 
GETLINETYPE
<theme name> (line 
type number) 

Input:
STRING
Output:
SHORT

KIN_ERROR
KIN_INVALID_THEME
KIN_INVALID_PARAM
KIN_SUCCESS

Return the line type of 
the specified theme.

Image Manager > 
Utilities > 
Theme Styler

IMGTHEME THEME 
GETLINEWEIGHT
<theme name> 
(weight number) 

Input:
STRING
Output:
SHORT

KIN_ERROR
KIN_INVALID_THEME
KIN_INVALID_PARAM
KIN_SUCCESS

Return the line weight of 
the specified theme.

Image Manager > 
Utilities > 
Theme Styler
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IMGTHEME THEME 
GETNAME 
<theme number> 
(theme name)

Input:
LONG,
STRING

KIN_ERROR
KIN_INVALID_THEME
KIN_INVALID_PARAM
KIN_SUCCESS

Return the theme name 
of the specified theme 
number.

Image Manager > 
Utilities > 
Theme Styler

IMGTHEME THEME 
GETNUMBER <theme 
name> (theme 
number)

Input:
STRING
Output:
LONG

KIN_ERROR
KIN_INVALID_THEME
KIN_INVALID_PARAM
KIN_SUCCESS

Return the theme 
number of the specified 
theme name.

Image Manager > 
Utilities > 
Theme Styler

IMGTHEME THEME 
GETUSE
<theme name> 
(status)

Input:
STRING
Output:
 

KIN_ERROR
KIN_INVALID_THEME
KIN_INVALID_PARAM
KIN_SUCCESS

Return the Use status of 
the specified theme 
(ON/OFF).

Image Manager > 
Utilities > 
Theme Styler

IMGTHEME THEME 
GETVISIBLE
<theme name> 
(status)

Input:
STRING
Output:
SHORT

KIN_ERROR
KIN_INVALID_THEME
KIN_INVALID_PARAM
KIN_SUCCESS

Return the Visible status 
of the specified theme 
(ON/OFF).

Image Manager > 
Utilities > 
Theme Styler

IMGTHEME THEME 
MODIFY

NONE KIN_ERROR

KIN_SUCCESS

Modify the active theme. Image Manager > 
Utilities > 
Theme Styler

IMGTHEME THEME 
QUERY

KIN_ERROR
KIN_SUCCESS

Activates the Query 
theme command.

Image Manager > 
Tools > 
Theme > Query 
Theme

IMGTHEME THEME 
SETCOLORCON-
TOUR
<theme name> <color 
number>

Input:
STRING,
SHORT

KIN_ERROR
KIN_INVALID_THEME
KIN_INVALID_COLOR
KIN_SUCCESS

Set the contour color of 
the specified theme.

Image Manager > 
Utilities > 
Theme Styler

IMGTHEME THEME 
SETDESCRIPTION
<theme name> 
<description>

Input:
STRING,
STRING

KIN_ERROR
KIN_INVALID_THEME
KIN_INVALID_PARAM
KIN_SUCCESS

Set the description of 
the specified theme.

Image Manager > 
Utilities > 
Theme Styler
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IMGTHEME THEME 
SETLEVEL
<theme name> <level 
number>

Input:
STRING,
SHORT

KIN_ERROR
KIN_INVALID_THEME
KIN_INVALID_PARAM
KIN_SUCCESS

Set the level of the 
specified theme.

Image Manager > 
Utilities > 
Theme Styler

IMGTHEME THEME 
SETLINETYPE
<theme name> <line 
type number>

Input:
STRING,
SHORT

KIN_ERROR
KIN_INVALID_THEME
KIN_INVALID_PARAM
KIN_SUCCESS

Set the line type of the 
specified theme.

Image Manager > 
Utilities > 
Theme Styler

IMGTHEME THEME 
SETLINEWEIGHT
<theme name> 
<weight number>

Input:
STRING,
SHORT

KIN_ERROR
KIN_INVALID_THEME
KIN_INVALID_PARAM
KIN_SUCCESS

Set the line weight of the 
specified theme.

Image Manager > 
Utilities > 
Theme Styler

IMGTHEME THEME 
SETNAME 
<old theme name> 
<new theme name>

Input:
STRING
STRING

KIN_ERROR
KIN_INVALID_THEME
KIN_INVALID_PARAM
KIN_SUCCESS

Set the new name of the 
specified theme.

Image Manager > 
Utilities > 
Theme Styler

IMGTHEME THEME 
SETNUMBER <theme 
name> <theme 
number>

Input:
STRING,
LONG

KIN_ERROR
KIN_INVALID_THEME
KIN_INVALID_PARAM
KIN_SUCCESS

Set the number of the 
specified theme.

Image Manager > 
Utilities > 
Theme Styler

IMGTHEME THEME 
SETUSEOFF<theme 
name>

Input:
STRING

KIN_ERROR
KIN_INVALID_THEME
KIN_SUCCESS

Set to OFF the Use status 
of the specified theme.

Image Manager > 
Utilities > 
Theme Styler

IMGTHEME THEME 
SETUSEON 
<theme name> 

Input:
STRING

KIN_ERROR
KIN_INVALID_THEME
KIN_SUCCESS

Set to ON the Use status 
of the specified theme.

Image Manager > 
Utilities > 
Theme Styler

IMGTHEME THEME 
SETVISIBLEOFF 
<theme name>

Input:
STRING

KIN_ERROR
KIN_INVALID_THEME
KIN_SUCCESS

Set to OFF the Visible 
status of the specified 
theme.

Image Manager > 
Utilities > 
Theme Styler

IMGTHEME THEME 
SETVISIBLEON 
<theme name>

Input:
STRING

KIN_ERROR
KIN_INVALID_THEME
KIN_SUCCESS

Set to ON the Visible 
status of the specified 
theme.

Image Manager > 
Utilities > 
Theme Styler
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IMGTHEME 
TOOLTHEME CLOSE

NONE KIN_ERROR
KIN_SUCCESS

Close the Theme tool 
box.

Image Manager > 
Tools > 
Theme

IMGTHEME 
TOOLTHEME OPEN

NONE KIN_ERROR
KIN_SUCCESS

Open the Theme tool 
box.

Image Manager > 
Tools > 
Theme

IMGTHEME 
TOOLTHEMEFILE 
CLOSE

NONE KIN_ERROR
KIN_SUCCESS

Close the Theme File 
tool box.

Image Manager > 
Tools > 
Theme File

IMGTHEME 
TOOLTHEMEFILE 
OPEN

NONE KIN_ERROR
KIN_SUCCESS

Open the Theme File 
tool box.

Image Manager > 
Tools > 
Theme File

IMGTHEME UPDATE 
ALL

NONE KIN_SUCCESS Set every parameter 
(Level, Color, Line Type, 
…) status to ON in the 
Update Design File 
dialog.

Image Manager > 
Utilities > 
Theme Styler > 
Options > 
Update Design 
File

IMGTHEME UPDATE 
GETCELL
(Status)

Output:
SHORT

KIN_ERROR
KIN_INVALID_PARAM
KIN_SUCCESS

Return the Cell status in 
the Update Design File 
dialog (ON/OFF).

Image Manager > 
Utilities > 
Theme Styler > 
Options > 
Update Design 
File

IMGTHEME UPDATE 
GETCOLOR
(Status)

Output:
SHORT

KIN_ERROR
KIN_INVALID_PARAM
KIN_SUCCESS

Return the Color status 
in the Update Design 
File dialog (ON/OFF).

Image Manager > 
Utilities > 
Theme Styler > 
Options > 
Update Design 
File
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IMGTHEME UPDATE 
GETFILL
(Status)

Output:
SHORT

KIN_ERROR
KIN_INVALID_PARAM
KIN_SUCCESS

Return the Fill status in 
the Update Design File 
dialog (ON/OFF).

Image Manager > 
Utilities > 
Theme Styler > 
Options > 
Update Design 
File

IMGTHEME UPDATE 
GETHATCHPATTERN
(Status)

Output:
SHORT

KIN_ERROR
KIN_INVALID_PARAM
KIN_SUCCESS

Return the Hatch/
Pattern status in the 
Update Design File 
dialog (ON/OFF).

Image Manager > 
Utilities > 
Theme Styler > 
Options > 
Update Design 
File

IMGTHEME UPDATE 
GETLEVEL
(Status)

Output:
SHORT

KIN_ERROR
KIN_INVALID_PARAM
KIN_SUCCESS

Return the Level status 
in the Update Design 
File dialog (ON/OFF).

Image Manager > 
Utilities > 
Theme Styler > 
Options > 
Update Design 
File

IMGTHEME UPDATE 
GETLINETYPE
(Status)

Output:
SHORT

KIN_ERROR
KIN_INVALID_PARAM
KIN_SUCCESS

Return the Line Type 
status in the Update 
Design File dialog (ON/
OFF).

Image Manager > 
Utilities > 
Theme Styler > 
Options > 
Update Design 
File

IMGTHEME UPDATE 
GETLINEWEIGHT
(Status)

Output:
SHORT

KIN_ERROR
KIN_INVALID_PARAM
KIN_SUCCESS

Return the Line Weight 
status in the Update 
Design File dialog (ON/
OFF).

Image Manager > 
Utilities > 
Theme Styler > 
Options > 
Update Design 
File

IMGTHEME UPDATE 
GETTEXT
(Status)

Output:
SHORT

KIN_ERROR
KIN_INVALID_PARAM
KIN_SUCCESS

Return the Text status in 
the Update Design File 
dialog (ON/OFF).

Image Manager > 
Utilities > 
Theme Styler > 
Options > 
Update Design 
File
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IMGTHEME UPDATE 
RUN

NONE KIN_ERROR
KIN_SUCCESS

Update the design file. Image Manager > 
Utilities > 
Theme Styler > 
Options > 
Update Design 
File

IMGTHEME UPDATE 
SETCELLOFF

NONE KIN_ERROR
KIN_SUCCESS

Set the Cell status to OFF 
in the Update Design 
File dialog.

Image Manager > 
Utilities > 
Theme Styler > 
Options > 
Update Design 
File

IMGTHEME UPDATE 
SETCELLON

NONE KIN_ERROR
KIN_SUCCESS

Set the Cell status to ON 
in the Update Design 
File dialog.

Image Manager > 
Utilities > 
Theme Styler > 
Options > 
Update Design 
File

IMGTHEME UPDATE 
SETCOLOROFF

NONE KIN_ERROR
KIN_SUCCESS

Set the Color status to 
OFF in the Update 
Design File dialog.

Image Manager > 
Utilities > 
Theme Styler > 
Options > 
Update Design 
File

IMGTHEME UPDATE 
SETCOLORON

NONE KIN_ERROR
KIN_SUCCESS

Set the Color status to 
ON in the Update 
Design File dialog.

Image Manager > 
Utilities > 
Theme Styler > 
Options >
Update Design 
File

IMGTHEME UPDATE 
SETFILLOFF

NONE KIN_ERROR
KIN_SUCCESS

Set the Fill status to OFF 
in the Update Design 
File dialog.

Image Manager > 
Utilities > 
Theme Styler > 
Options > 
Update Design 
File
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IMGTHEME UPDATE 
SETFILLON

NONE KIN_ERROR
KIN_SUCCESS

Set the Fill status to ON 
in the Update Design 
File dialog.

Image Manager > 
Utilities > 
Theme Styler > 
Options > 
Update Design 
File

IMGTHEME UPDATE 
SETLEVELOFF

NONE KIN_ERROR
KIN_SUCCESS

Set the Level status to 
OFF in the Update 
Design File dialog.

Image Manager > 
Utilities > 
Theme Styler > 
Options > 
Update Design 
File

IMGTHEME UPDATE 
SETLEVELON

NONE KIN_ERROR
KIN_SUCCESS

Set the Level status to 
ON in the Update 
Design File dialog.

Image Manager > 
Utilities > 
Theme Styler > 
Options > 
Update Design 
File

IMGTHEME UPDATE 
SETHATCHPATTERN
OFF

NONE KIN_ERROR
KIN_SUCCESS

Set the Hatch/Pattern 
status to OFF in the 
Update Design File 
dialog.

Image Manager > 
Utilities > 
Theme Styler > 
Options > 
Update Design 
File

IMGTHEME UPDATE 
SETLINETYPEOFF

NONE KIN_ERROR
KIN_SUCCESS

Set the Line Type status 
to OFF in the Update 
Design File dialog.

Image Manager > 
Utilities > 
Theme Styler > 
Options > 
Update Design 
File

IMGTHEME UPDATE 
SETLINEWEIGHTOFF

NONE KIN_ERROR
KIN_SUCCESS

Set the Line Weight 
status to OFF in the 
Update Design File 
dialog.

Image Manager > 
Utilities > 
Theme Styler > 
Options > 
Update Design 
File
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IMGTHEME UPDATE 
SETHATCHPATTERN
ON

NONE KIN_ERROR
KIN_SUCCESS

Set the Hatch/Pattern 
status to ON in the 
Update Design File 
dialog.

Image Manager > 
Utilities > 
Theme Styler > 
Options > 
Update Design 
File

IMGTHEME UPDATE 
SETLINETYPEON

NONE KIN_ERROR
KIN_SUCCESS

Set the Line Type status 
to ON in the Update 
Design File dialog.

Image Manager > 
Utilities > 
Theme Styler > 
Options > 
Update Design 
File

IMGTHEME UPDATE 
SETLINEWEIGHTON

NONE KIN_ERROR
KIN_SUCCESS

Set the Line Weight 
status to ON in the 
Update Design File 
dialog.

Image Manager > 
Utilities > 
Theme Styler > 
Options > 
Update Design 
File

IMGTHEME UPDATE 
SETTEXTOFF

NONE KIN_ERROR
KIN_SUCCESS

Set the Text status to 
OFF in the Update 
Design File dialog.

Image Manager > 
Utilities > 
Theme Styler > 
Options > 
Update Design 
File

IMGTHEME UPDATE 
SETTEXTON

NONE KIN_ERROR
KIN_SUCCESS

Set the Text status to ON 
in the Update Design 
File dialog.

Image Manager > 
Utilities > 
Theme Styler > 
Options > 
Update Design 
File

IMGTHEME USEALL 
CLEAR

NONE KIN_ERROR
KIN_SUCCESS

Set to OFF the Use status 
of each theme in the 
current file.

Image Manager > 
Utilities > 
Theme Styler > 
Options > 
Clear All Use

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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IMGTHEME USEALL 
SET

NONE KIN_ERROR
KIN_SUCCESS

Set to ON the Use status 
of each theme in the 
current file.

Image Manager > 
Utilities > 
Theme Styler > 
Options > 
Set All Use

IMGTHEME VERSION 
GET 
(version) (subversion) 
(revision) 
(subrevision)

Output:
SHORT,
SHORT,
SHORT,
SHORT

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the current 
version, subversion, 
revision and subrevision 
of the module Theme 
Styler. 

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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Key-In Parameters Returned Error 
Codes

Description Graphical Inter-
face

IMGTRANSFORM 
IMAGE CORRIDOR

NONE KIN_NOIMAGE
KIN_ERROR
KIN_SUCCESS

Start the Corridor com-
mand.

Image Manager >
Tools > 
Image Transform

IMGTRANSFORM 
IMAGE MERGE

NONE KIN_NOIMAGE
KIN_ERROR
KIN_SUCCESS

Start the Merge Images 
command.

Image Manager >
Tools > 
Image Transform

IMGTRANSFORM 
IMAGE MIRROR

NONE KIN_NOIMAGE
KIN_FILE_READ_ONLY
KIN_ERROR
KIN_SUCCESS

Start the Mirror Image 
command.

Image Manager >
Tools > 
Image Transform

IMGTRANSFORM 
IMAGE MOVE

NONE KIN_NOIMAGE
KIN_FILE_READ_ONLY
KIN_ERROR
KIN_SUCCESS

Start the Move Image 
command.

Image Manager >
Tools > 
Image Transform

IMGTRANSFORM 
IMAGE ROTATE

NONE KIN_NOIMAGE
KIN_FILE_READ_ONLY
KIN_ERROR
KIN_SUCCESS

Start the Rotate Image 
command.

Image Manager >
Tools > 
Image Transform

IMGTRANSFORM 
IMAGE SCALE

NONE KIN_NOIMAGE
KIN_FILE_READ_ONLY
KIN_ERROR
KIN_SUCCESS

Start the Scale Image 
command.

Image Manager >
Tools > 
Image Transform

IMGTRANSFORM 
IMAGE SQUARE

NONE KIN_NOIMAGE
KIN_FILE_READ_ONLY
KIN_ERROR
KIN_SUCCESS

Start the Square Image 
command.

Image Manager >
Tools > 
Image Transform

IMGTRANSFORM 
IMAGE WARP

NONE KIN_NOIMAGE
KIN_FILE_READ_ONLY
KIN_ERROR
KIN_SUCCESS

Start the Warp Image 
command.

Image Manager >
Tools > 
Image Transform
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IMGTRANSFORM 
IMGVERSION GET
(version) (subversion) 
(revision) 
(subrevision)

Output:
SHORT
SHORT
SHORT
SHORT

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the minimum 
required version, 
subversion, revision and 
subrevision of Descartes 
that can be used with 
this version of Image 
Transform.

IMGTRANSFORM 
MERGE GETANGLE
(angle)

Output:
DOUBLE

KIN_INVALID_PARAM 
KIN_ERROR
KIN_SUCCESS

Returns the stepping 
angle of rotation. 

Image Manager >
Tools > Image 
Transform

IMGTRANSFORM 
MERGE 
GETMETHOD
(method)

Output:
STRING

KIN_INVALID_PARAM 
KIN_ERROR
KIN_SUCCESS

Returns the method 
used for selecting the 
area.

Image Manager >
Tools > 
Image Transform

IMGTRANSFORM 
MERGE SETANGLE 
<angle>

Input:
DOUBLE

KIN_INVALID_PARAM 
KIN_PERM_DENIED
KIN_ERROR
KIN_SUCCESS

Set the stepping angle of 
rotation. Only used if 
method is 
ORIENTEDBLOCK.

Image Manager >
Tools > 
Image Transform

IMGTRANSFORM 
MERGE SETMETHOD
<BLOCK | 
ORIENTEDBLOCK | 
ELEMENT >

Input:
STRING

KIN_INVALID_PARAM 
KIN_ERROR
KIN_SUCCESS

Set the method used for 
selecting the area.

Image Manager >
Tools > 
Image Transform

IMGTRANSFORM 
MIRROR GETAXE
(axe)

Output:
STRING

KIN_INVALID_PARAM 
KIN_ERROR
KIN_SUCCESS

Returns the mirror type Image Manager >
Tools > 
Image Transform

IMGTRANSFORM 
MIRROR SETAXE
<HORIZONTAL | 
VERTICAL | 
DOWNUPDIAGONAL
 | UPDOWN-
DIAGONAL >

Input:
STRING

KIN_INVALID_PARAM 
KIN_ERROR
KIN_SUCCESS

Set the mirror type 
(HORIZONTAL or 
VERTICAL or 
DOWNUPDIAGONAL 
or 
UPDOWNDIAGONAL).

Image Manager >
Tools > 
Image Transform

Key-In Parameters Returned Error 
Codes

Description Graphical Inter-
face
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IMGTRANSFORM 
ROTATE 
GETSPECANGLE
(angle)

Output:
DOUBLE

KIN_INVALID_PARAM 
KIN_ERROR
KIN_SUCCESS

Returns the specified 
angle of rotation.

Image Manager >
Tools > 
Image Transform

IMGTRANSFORM 
ROTATE 
GETSTEPANGLE
(angle)

Output:
DOUBLE

KIN_INVALID_PARAM 
KIN_ERROR
KIN_SUCCESS

Returns the step angle of 
rotation.

Image Manager >
Tools > 
Image Transform

IMGTRANSFORM 
ROTATE 
GETMETHOD
(method)

Output:
STRING

KIN_INVALID_PARAM 
KIN_ERROR
KIN_SUCCESS

Returns the method 
used for specifying the 
rotated area and the 
angle of rotation 
(INTERACTIVE or 
SPECIFIED or 
90DEGREES or 
180DEGREES).

Image Manager >
Tools > 
Image Transform

IMGTRANSFORM 
ROTATE 
GETORIENTATION
(orientation)

Output:
STRING

KIN_INVALID_PARAM 
KIN_ERROR
KIN_SUCCESS

Returns the direction of 
the rotation 
(CLOCKWISE or 
COUNTER-
CLOCKWISE). 

Image Manager >
Tools > 
Image Transform

IMGTRANSFORM 
ROTATE 
SETSPECANGLE 
<angle>

Input:
DOUBLE

KIN_INVALID_PARAM 
KIN_PERM_DENIED
KIN_ERROR
KIN_SUCCESS

Set the angle of rotation.
Only used if method is 
SPECIFIED.

Image Manager >
Tools > 
Image Transform

IMGTRANSFORM 
ROTATE 
SETSTEPANGLE 
<angle>

Input:
DOUBLE

KIN_INVALID_PARAM 
KIN_ERROR
KIN_SUCCESS

Set the step angle of 
rotation.

Image Manager >
Tools > 
Image Transform

IMGTRANSFORM 
ROTATE 
SETMETHOD
<INTERACTIVE | 
SPECIFIED | 
90DEGREES | 
180DEGREES >

Input:
STRING

KIN_ERROR
KIN_SUCCESS

Set the method used for 
specifying the rotated 
area and the angle of 
rotation (INTERACTIVE 
or SPECIFIED or 
90DEGREES or 
180DEGREES).

Image Manager >
Tools > 
Image Transform

Key-In Parameters Returned Error 
Codes

Description Graphical Inter-
face
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IMGTRANSFORM 
ROTATE 
SETORIENTATION
<CLOCKWISE | 
COUNTER-
CLOCKWISE>

Input:
STRING

KIN_ERROR
KIN_SUCCESS

Set the direction of the 
rotation (CLOCKWISE 
or 
COUNTERCLOCKWISE
).

Image Manager >
Tools > 
Image Transform

IMGTRANSFORM 
SCALE GETMETHOD
(method)

Output:
STRING

KIN_INVALID_PARAM 
KIN_ERROR
KIN_SUCCESS

Return the method used 
for specifying the 
scaling parameters 
(INTERACTIVE or 
SPECIFIED).

Image Manager >
Tools > 
Image Transform

IMGTRANSFORM 
SCALE GETSCALE 
(value)

Output:
DOUBLE

KIN_INVALID_PARAM 
KIN_ERROR
KIN_SUCCESS

Return the scaling value. Image Manager >
Tools > 
Image Transform

IMGTRANSFORM 
SCALE SETMETHOD 
<INTERACTIVE | 
SPECIFIED>

Input:
STRING

KIN_ERROR
KIN_SUCCESS

Set the method used for 
specifying the scaling 
parameters 
(INTERACTIVE or 
SPECIFIED).

Image Manager >
Tools > 
Image Transform

IMGTRANSFORM 
SCALE SETSCALE 
<value>

Input:
DOUBLE

KIN_INVALID_PARAM 
KIN_PERM_DENIED
KIN_ERROR
KIN_SUCCESS

Set the scaling value.
Only used if method is 
SPECIFIED.

Image Manager >
Tools > 
Image Transform

IMGTRANSFORM 
SQUARE GETAXE
(axe)

Output:
STRING

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Get the axis mode used 
for specifying 2 points 
on an orthogonal line. 

Image Manager >
Tools > 
Image Transform

IMGTRANSFORM 
SQUARE SETAXE
< HORIZONTAL | 
VERTICAL >

Input:
STRING

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Set the horizontal as the 
axis used for specifying 
2 points on an 
orthogonal line.

Image Manager >
Tools > 
Image Transform

IMGTRANSFORM 
TOOL CLOSE

NONE KIN_SUCCES Close Image Transform 
tool box.

Image Manager >
Tools >
 Image Transform

Key-In Parameters Returned Error 
Codes

Description Graphical Inter-
face
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IMGTRANSFORM 
TOOL OPEN

NONE KIN_ERROR
KIN_SUCCESS

Opens Image Transform 
tool box.

Image Manager >
Tools > 
Image Transform

IMGTRANSFORM 
VERSION GET 
(version) (subversion) 
(revision) 
(subrevision)

Output:
SHORT
SHORT
SHORT
SHORT

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the current 
version, subversion, 
revision and subrevision 
of the module Image 
Transform. 

IMGTRANSFORM 
WARP 
GETTRFMODEL
(TrfModel)

Output:
STRING

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Returns the 
transformation model 
used by Warp Image.

Image Manager >
Tools > 
Image Transform

IMGTRANSFORM 
WARP 
SETTRFMODEL
< AFFINE | HELMERT 
| PROJECTIVE | 
SIMILITUDE >

Input:
STRING

KIN_NOIMAGE
KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Set the transformation 
model used by Warp 
Image.

Image Manager >
Tools > 
Image Transform

Key-In Parameters Returned Error 
Codes

Description Graphical Inter-
face
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Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface

IMGVECTORIZE 
ACTIVEZ GET
(ActiveZ)

Output:
DOUBLE

KIN_INVALID_PARAM
KIN_SUCCESS

Return the current value 
of the active depth (Z) 
for the Convert Contour 
Lines command.

Image Manager >
Tools >
Vectorize >
Convert Contour 
Lines

IMGVECTORIZE 
ACTIVEZ SET
<ActiveZ>

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Set the current value of 
the active depth (Z) for 
the Convert Contour 
Lines command.

Idem

IMGVECTORIZE 
ACTIVEZDIRECTION 
GET   (Direction)

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Return the current 
direction of the active 
depth (Z). Directions 
are UP and DOWN.

Idem

IMGVECTORIZE 
ACTIVEZDIRECTION 
SET <UP | DOWN>

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Set the current direction 
of the active depth (Z). 
Directions are UP and 
DOWN.

Idem

IMGVECTORIZE 
ACTIVEZINTERVAL 
GET (Interval)

Output:
DOUBLE

KIN_INVALID_PARAM
KIN_SUCCESS

Return the current 
interval for increasing/
decreasing the active 
depth (Z).

Idem

IMGVECTORIZE 
ACTIVEZINTERVAL 
SET
<Interval>

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Set the current interval 
for increasing/
decreasing the active 
depth (Z).

Idem

IMGVECTORIZE 
ACTIVEZLOCK GET
(Status)

Output:
SHORT

KIN_INVALID_PARAM
KIN_SUCCESS

Return the current status 
of the “Lock” option for 
the active depth (Z) 
(ON/OFF).

Idem

IMGVECTORIZE 
ACTIVEZLOCK 
SETOFF

NONE KIN_ERROR
KIN_SUCCESS

Set the current status of 
the “Lock” option for the 
active depth (Z) to OFF.

Idem
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IMGVECTORIZE 
ACTIVEZLOCK 
SETON

NONE KIN_ERROR
KIN_SUCCESS

Set the current status of 
the “Lock” option for the 
active depth (Z) to ON.

Idem

IMGVECTORIZE 
AUTOCONTINUE 
GET
(Status)

Output:
SHORT

KIN_INVALID_PARAM
KIN_SUCCESS

Return the status of the 
“Auto Continue” toggle 
(ON/OFF).

Image Manager >
Tools >
Vectorize >
Tool Settings

IMGVECTORIZE 
AUTOCONTINUE 
SETOFF

NONE KIN_SUCCESS Set the status of the 
“Auto Continue” toggle 
to OFF.

Idem

IMGVECTORIZE 
AUTOCONTINUE 
SETON

NONE KIN_SUCCESS Set the status of the 
“Auto Continue” toggle 
to ON.

Idem

IMGVECTORIZE 
AUTOCONVERT GET
(Status)

Output:
SHORT

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the current 
status of “Auto Convert” 
(ON/OFF).

Image Manager >
Tools >
Vectorize >
Tool Settings

IMGVECTORIZE 
AUTOCONVERT 
SETOFF

NONE KIN_ERROR
KIN_SUCCESS

Set the current status of 
“Auto Convert” to OFF.

Idem

IMGVECTORIZE 
AUTOCONVERT 
SETON

NONE KIN_ERROR
KIN_SUCCESS

Set the current status of 
“Auto Convert” to ON.

Idem

IMGVECTORIZE 
CELLAUTOERASECO
LOR GET
(Status)

Output:
SHORT

KIN_INVALID_PARAM
KIN_SUCCESS

Return the status of the 
“Auto Set Eraser Color” 
toggle (ON/OFF).

Image Manager >
Tools >
Text/Cells >
Convert Cell

IMGVECTORIZE 
CELLAUTOERASE-
COLOR SETOFF

NONE KIN_SUCCESS Set the status of the 
“Auto Set Eraser Color” 
toggle to OFF.

Idem

IMGVECTORIZE 
CELLAUTOERASECO
LOR SETON

NONE KIN_INVALID_PARAM
KIN_SUCCESS

Set the status of the 
“Auto Set Eraser Color” 
toggle to ON.

Idem

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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IMGVECTORIZE 
CELLERASERASTER 
GET
(Status)

Output:
SHORT

KIN_INVALID_PARAM
KIN_SUCCESS

Return the status of the 
“Erase Raster” toggle 
(ON/OFF).

Idem

IMGVECTORIZE 
CELLERASERASTER 
SETOFF

NONE KIN_SUCCESS Set the status of the 
“Erase Raster” toggle to 
OFF.

Idem

IMGVECTORIZE 
CELLERASERASTER 
SETON

NONE KIN_SUCCESS Set the status of the 
“Erase Raster” toggle to 
ON.

Idem

IMGVECTORIZE 
CELLERASERCOLOR 
GET
(Color)

Output:
SHORT

KIN_INVALID_PARAM
KIN_SUCCESS

Return the current 
eraser color.

Idem

IMGVECTORIZE 
CELLERASERCOLOR 
SET
<Color>

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Set the current eraser 
color.

Idem

IMGVECTORIZE 
CELLERASERCOLOR1
BIT GET
(Color)

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Return the current 
eraser color of 1 bit 
image.

Idem

IMGVECTORIZE 
CELLERASERCOLOR1
BIT SET
< BACKGROUND | 
FOREGROUND >

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Set the current eraser 
color for 1 bit image.

Idem

IMGVECTORIZE 
CELLFILTER GET
(Filter)

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Return the name of the 
current filter for the 
Convert Cell command.

Idem

IMGVECTORIZE 
CELLFILTER SET
<Filter>

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Set the filter for the 
Convert Cell command.

Idem

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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IMGVECTORIZE 
CELLTHEME GET
(Theme)

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Return the name of the 
current theme for the 
Convert Cell command.

Idem

IMGVECTORIZE 
CELLTHEME SET
<Theme>

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Set the theme for the 
Convert Cell command.

Idem

IMGVECTORIZE 
CONTINUE ELEMENT

NONE KIN_SUCCESS Start the Continue 
Element command. 

Image Manager >
Tools >
Vectorize

IMGVECTORIZE 
CONVERT 
ALLCONNECTED-
LINES

NONE KIN_SUCCESS Start the Convert All 
Connected Lines 
command.

Image Manager >
Tools >
Vectorize

IMGVECTORIZE 
CONVERT CELLS

NONE KIN_SUCCESS Start the Convert Cell 
command.

Image Manager >
Tools >
Text/Cells

IMGVECTORIZE 
CONVERT 
CELLSHORIZONTAL

NONE KIN_SUCCESS Start the Convert 
Horizontal Cell 
command.

Image Manager >
Tools >
Text/Cells

IMGVECTORIZE 
CONVERT 
CELLSORIENT

NONE KIN_SUCCESS Start the Convert 
Oriented Cell 
command.

Image Manager >
Tools >
Text/Cells

IMGVECTORIZE 
CONVERT 
CONTOURLINES

NONE KIN_SUCCESS Start the Convert 
Contour Lines 
command.

Image Manager >
Tools >
Vectorize

IMGVECTORIZE 
CONVERT LINES

NONE KIN_SUCCESS Start the Convert Lines 
command.

Image Manager >
Tools >
Vectorize

IMGVECTORIZE 
CONVERT TEXTALL

NONE KIN_SUCCESS Start the Convert Text 
command. 

Image Manager >
Tools >
Text/Cells

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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IMGVECTORIZE 
CONVERT 
TEXTHORIZ

NONE KIN_SUCCESS Start the Select 
horizontal text 
command.

Image Manager >
Tools >
Text/Cells

IMGVECTORIZE 
CONVERT 
TEXTORIENTED

NONE KIN_SUCCESS Start the Select oriented 
text command.

Image Manager >
Tools >
Text/Cells

IMGVECTORIZE 
CSNODESAUTOSNPI
NSVEC GET
(Status)

Output:
SHORT

KIN_INVALID_PARAM
KIN_SUCCESS

Return the status of the 
“Auto Snap/ Insert 
Vector” toggle (ON/
OFF).

Image Manager >
Settings >
Vectorize >
Nodes

IMGVECTORIZE 
CSNODESAUTOSNPI
NSVEC SETOFF

NONE KIN_ERROR
KIN_SUCCESS

Set the status of the 
“Auto Snap/ Insert 
Vector” toggle to OFF.

Idem

IMGVECTORIZE 
CSNODESAUTOSNPI
NSVEC SETON

NONE KIN_ERROR
KIN_SUCCESS

Set the status of the 
“Auto Snap/ Insert 
Vector” toggle to ON.

Idem

IMGVECTORIZE 
CSCENTERVIEW GET
(viewlist)

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Return a view list (view 
numbers separated with 
commas) of Center 
Views that are activated.

Image Manager >
Settings >
Vectorize >
Center Views

IMGVECTORIZE 
CSCENTERVIEW 
SETOFF
<viewlist>

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Deactivate the Center 
Views for the specified 
view numbers. 

Idem

IMGVECTORIZE 
CSCENTERVIEW 
SETON
<viewlist>

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Activate the Center 
Views for the specified 
view numbers.

Idem

IMGVECTORIZE 
CSCONVERT 
GETLINEQUALITY
(LineQuality)

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the line quality 
value.

Image Manager >
Settings >
Vectorize >
Convert

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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IMGVECTORIZE 
CSCCONVERT 
SETLINEQUALITY
< BAD | POOR | 
AVERAGE | GOOD | 
EXCELLENT >

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Sets the value of the line 
quality. Values are: 
BAD, POOR, AVERAGE, 
GOOD or EXCELLENT. 

Idem

IMGVECTORIZE 
CSCONVERT 
GETMAXLINEWIDTH
(LineQuality)

Output:
DOUBLE

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the maximum 
value for the line width.

Image Manager >
Settings >
Vectorize >
Convert

IMGVECTORIZE 
CSCCONVERT 
SETMAXLINEWIDTH
< LineWidth >

Input:
DOUBLE

KIN_INVALID_PARAM
KIN_SUCCESS

Sets the value for the 
maximum line width.

Idem

IMGVECTORIZE 
CSCONVERT 
GETRESOLUTION-
MODE (Mode)

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the resolution 
mode used by convert 
commands.

Image Manager >
Settings >
Vectorize >
Convert

IMGVECTORIZE 
CSCCONVERT 
SETRESOLUTION-
MODE
< FILE | DISPLAY >

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Sets the resolution mode 
used by the convert 
command. Mode are: 
FILE or DISPLAY. 

Idem

IMGVECTORIZE 
CSGENERALUSESTRE
AM GET
(Status)

Output:
SHORT

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the status of the 
“Use Stream 
Parameters” toggle 
(ON/OFF).

Image Manager >
Settings >
Vectorize >
Generalization

IMGVECTORIZE 
CSGENERALUSESTRE
AM SETOFF

NONE KIN_ERROR
KIN_SUCCESS

Set the status of the “Use 
Stream Parameters” 
toggle to OFF.

Idem

IMGVECTORIZE 
CSGENERALUSESTRE
AM SETON

NONE KIN_ERROR
KIN_SUCCESS

Set the status of the “Use 
Stream Parameters” 
toggle to ON.

Idem

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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IMGVECTORIZE 
CSNODESAUTO-
PLACE GET
(Status)

Output:
SHORT

KIN_INVALID_PARAM
KIN_SUCCESS

Return the status of the 
“Auto Place Nodes” 
toggle (ON/OFF).

Image Manager >
Settings >
Vectorize >
Nodes

IMGVECTORIZE 
CSNODESAUTO-
PLACE SETOFF

NONE KIN_ERROR
KIN_SUCCESS

Set the status of the 
“Auto Place Nodes” 
toggle to OFF.

Idem

IMGVECTORIZE 
CSNODESAUTO-
PLACE SETON

NONE KIN_ERROR
KIN_SUCCESS

Set the status of the 
“Auto Place Nodes” 
toggle to ON.

Idem

IMGVECTORIZE 
CSNODESDISPLAY 
GET
(Status)

Output:
SHORT

KIN_INVALID_PARAM
KIN_SUCCESS

Return the status of the 
“Display Nodes” toggle 
(ON/OFF).

Idem

IMGVECTORIZE 
CSNODESDISPLAY 
GETCOLOR
(Color)

Output:
SHORT

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the current 
color used for 
displaying nodes.

Idem

IMGVECTORIZE 
CSNODESDISPLAY 
SETCOLOR
<Color>

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Set the current color 
used for displaying 
nodes.

Idem

IMGVECTORIZE 
CSNODESDISPLAY 
SETOFF

NONE KIN_ERROR
KIN_SUCCESS

Set the status of the 
“Display Nodes” toggle 
to OFF.

Idem

IMGVECTORIZE 
CSNODESDISPLAY 
SETON

NONE KIN_ERROR
KIN_SUCCESS

Set the status of the 
“Display Nodes” toggle 
to ON.

Idem

IMGVECTORIZE 
CSSPYWIN 
GETEXTENT (Extent)

Output:
SHORT

KIN_INVALID_PARAM
KIN_SUCCESS

Return the extent value 
of the Spy Window.

Image Manager >
Settings >
Vectorize >
Spy Window

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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IMGVECTORIZE 
CSSPYWIN 
GETZOOM
(Zoom)

Output:
DOUBLE

KIN_INVALID_PARAM
KIN_SUCCESS

Return the current zoom 
factor for the Spy 
Window.

Idem

IMGVECTORIZE 
CSSPYWIN 
SETEXTENT
<Extent>

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Set the extent value of 
the Spy Window.

Idem

IMGVECTORIZE 
CSSPYWIN 
SETZOOM
<Zoom>

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Set the zoom factor for 
the Spy Window.

Idem

IMGVECTORIZE 
CSWARNINGSTAMPV
SCVT GET
(Status)

Output:
SHORT

KIN_INVALID_PARAM
KIN_SUCCESS

Return status of the 
“Display Auto Stamp VS 
Auto Convert Warning” 
toggle (ON/OFF).

Idem

IMGVECTORIZE 
CSWARNINGSTAMPV
SCVT SETOFF

NONE KIN_ERROR
KIN_SUCCESS

Set the status of the 
“Display Auto Stamp VS 
Auto Convert Warning” 
toggle to OFF.

Idem

IMGVECTORIZE 
CSWARNINGSTAMPV
SCVT SETON

NONE KIN_ERROR
KIN_SUCCESS

Set the status of the 
“Display Auto Stamp VS 
Auto Convert Warning” 
toggle to ON.

Idem

IMGVECTORIZE 
DELETE NODE

NONE KIN_SUCCESS Start the Delete Nodes 
command.

Image Manager >
Tools >
Vectorize

IMGVECTORIZE 
DELETENODE 
GETAREA
(area)

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Return the area type 
used by the Delete 
Nodes command. Area 
types are: NONE, 
BLOCK, ELEMENT, 
FENCE, IMAGE or 
UNLIMITED.

Image Manager >
Tools >
Vectorize >
Delete Nodes

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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IMGVECTORIZE 
DELETENODE 
SETAREA
< NONE | BLOCK | 
ELEMENT | FENCE | 
IMAGE | UN-
LIMITED >

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Set the area type used 
by the Delete Nodes 
command. Area types 
are: NONE, BLOCK, 
ELEMENT, FENCE, 
IMAGE or UNLIMITED.

Idem

IMGVECTORIZE 
DLGSETTINGS OPEN

NONE KIN_SUCCESS Open the Vectorize 
Settings dialog.

Image Manager >
Settings >
Vectorize

IMGVECTORIZE 
FILENODE NEW

NONE KIN_ERROR
KIN_SUCCESS

Create a new node file. Image Manager >
Tools >
Node File

IMGVECTORIZE 
FILENODE OPEN
[FileName]

Input:
STRING

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Open the specified 
node file. If FileName is 
not specified, the File 
Selection dialog opens.

Image Manager >
Tools >
Node File

IMGVECTORIZE 
FILENODE SAVE

NONE KIN_ERROR
KIN_SUCCESS

Save changes to the 
current node file.

Image Manager >
Tools >
Node File

IMGVECTORIZE 
FILENODE SAVEAS
[FileName]

Input:
STRING

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Save the current node 
file in the specified file. 
If FileName is not 
specified, the File 
Creation dialog opens.

Image Manager >
Tools >
Node File 

IMGVECTORIZE 
FILTER GET
(Filter)

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Return the name of the 
current filter used by 
Vectorize tools.

Image Manager >
Tools >
Vectorize

IMGVECTORIZE 
FILTER SET
<Filter>

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Set the name of the 
current filter used by 
Vectorize tools.

ToolVectorize >
Convert lines >
Filter

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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IMGVECTORIZE 
IMGVERSION GET
(version) (subversion) 
(revision) 
(subrevision)

Output:
SHORT
SHORT
SHORT
SHORT

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the required 
version, subversion, 
revision and subrevision 
of Descartes that should 
be used with this 
version of Vectorize. 

IMGVECTORIZE 
PLACE ELEMENT

NONE KIN_SUCCESS Start the Place Element 
command. 

Image Manager >
Tools >
Vectorize

IMGVECTORIZE 
PLACE NODE

NONE KIN_SUCCESS Start the Place Nodes 
command.

Image Manager >
Tools >
Vectorize

IMGVECTORIZE 
PLACENODE 
GETBOUNDARY
(Boundary)

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Return the boundary 
type used by the Place 
Nodes command. Area 
types are: NONE, 
BLOCK, ELEMENT, 
FENCE, IMAGE or 
UNLIMITED.

Image Manager >
Tools >
Vectorize >
Place Nodes

IMGVECTORIZE 
PLACENODE 
SETBOUNDARY
< NONE | BLOCK | 
ELEMENT | FENCE >

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Set the boundary type 
used by the Place Nodes 
command. Area types 
are: NONE, BLOCK, 
ELEMENT, FENCE, 
IMAGE or UNLIMITED.

Image Manager >
Tools >
Vectorize >
Place Nodes

IMGVECTORIZE 
RASTERENTITY GET
(RasterEntity)

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Return the raster entity 
used by convert 
commands.

Image Manager >
Tools >
Vectorize

IMGVECTORIZE 
RASTERENTITY SET
< LINE | OUTLINE >

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Set the raster entity used 
by convert commands. 
Entity are: LINE or 
OUTLINE.

Image Manager >
Tools >
Vectorize

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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IMGVECTORIZE 
RASTERLINEWIDTH 
GET
(LineWidth)

Input:
Dpoint3d 
address
Output:
DOUBLE

KIN_INVALID_PARAM
KIN_NOIMAGE
KIN_INVALID_POINT
KIN_SUCCESS

Returns the line width of 
the raster line under the 
input given point in the 
active image. Returns 
values are in UOR. 

IMGVECTORIZE 
RASTERSNAP GET
(Status)

Output:
SHORT

KIN_INVALID_PARAM
KIN_SUCCESS

Return the current status 
of the “Raster Snap” 
toggle (ON/OFF) used 
by the Vectorize tools.

Image Manager >
Tools >
Vectorize

IMGVECTORIZE 
RASTERSNAP SETOFF

NONE KIN_ERROR
KIN_SUCCESS

Set the current status of 
the “Raster Snap” toggle 
to OFF. 

Image Manager >
Tools >
Vectorize

IMGVECTORIZE 
RASTERSNAP SETON

NONE KIN_ERROR
KIN_SUCCESS

Set the current status of 
the “Raster Snap” toggle 
to ON.

Image Manager >
Tools >
Vectorize

IMGVECTORIZE 
SELECTTEXTFILTER 
GET
(Filter)

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Return the name of the 
current filter for the 
Convert Text command.

Image Manager >
Tools >
Text/Cells >
Convert Text

IMGVECTORIZE 
SELECTTEXTFILTER 
SET
<Filter>

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Set the filter for the 
Convert Text command.

Idem

IMGVECTORIZE 
TENTATIVERASTERS
NAP GET
(Status)

Output:
SHORT

KIN_INVALID_PARAM
KIN_SUCCESS

Return the status of the 
“Tentative” toggle (ON/
OFF).

Image Manager >
Settings >
Draw

IMGVECTORIZE 
TENTATIVERASTERS
NAP SETOFF

NONE KIN_SUCCESS Set the status of the 
“Tentative” toggle to 
OFF.

Idem

IMGVECTORIZE 
TENTATIVERASTER-
SNAP SETON

NONE KIN_SUCCESS Set the status of the 
“Tentative” toggle to 
ON.

Idem

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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IMGVECTORIZE 
TEXTAUTOERASE-
COLOR GET
(Status)

Output:
SHORT

KIN_INVALID_PARAM
KIN_SUCCESS

Return the status of the 
“Auto Set Eraser Color” 
toggle (ON/OFF).

Image Manager >
Tools >
Text/Cells >
Convert Text

IMGVECTORIZE 
TEXTAUTOERASE-
COLOR SETOFF

NONE KIN_SUCCESS Set the status of the 
“Auto Set Eraser Color” 
toggle to OFF.

Idem

IMGVECTORIZE 
TEXTAUTOERASE-
COLOR SETON

NONE KIN_SUCCESS Set the status of the 
“Auto Set Eraser Color” 
toggle to ON.

Idem

IMGVECTORIZE 
TEXTCONVERTNOW 
GET
(Status)

Output:
SHORT

KIN_INVALID_PARAM
KIN_SUCCESS

Return the status of the 
“Convert Now” toggle 
(ON/OFF).

Idem

IMGVECTORIZE 
TEXTCONVERTNOW 
SETOFF

NONE KIN_SUCCESS Set the status of the 
“Convert Now” toggle to 
OFF.

Idem

IMGVECTORIZE 
TEXTCONVERTNOW 
SETON

NONE KIN_SUCCESS Set the status of the 
“Convert Now” toggle to 
ON.

Idem

IMGVECTORIZE 
TEXTERASERASTER 
GET
(Status)

Output:
SHORT

KIN_INVALID_PARAM
KIN_SUCCESS

Return the status of the 
“Erase Raster” toggle 
(ON/OFF).

Idem

IMGVECTORIZE 
TEXTERASERASTER 
SETOFF

NONE KIN_SUCCESS Set the status of the 
“Erase Raster” toggle to 
OFF.

Idem

IMGVECTORIZE 
TEXTERASERASTER 
SETON

NONE KIN_SUCCESS Set the status of the 
“Erase Raster” toggle to 
ON.

Idem

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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IMGVECTORIZE 
TEXTERASERCOLOR 
GET
(Color)

Output:
SHORT

KIN_INVALID_PARAM
KIN_SUCCESS

Return the current 
eraser color.

Idem

IMGVECTORIZE 
TEXTERASERCOLOR 
SET
<Color>

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Set the current eraser 
color.

Idem

IMGVECTORIZE 
TEXTERASERCOLOR
1BIT GET
(Color)

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Return the current 
eraser color for 1 bit 
image.

Idem

IMGVECTORIZE 
TEXTERASERCOLOR
1BIT SET
< BACKGROUND | 
FOREGROUND >

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Set the current eraser 
color for 1 bit image.

Idem

IMGVECTORIZE 
TEXTFILTER GET
(Filter)

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Return the name of the 
current filter for the 
Convert Text command.

Idem

IMGVECTORIZE 
TEXTFILTER SET
<Filter>

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Set the filter for the 
Convert Text command.

Idem

IMGVECTORIZE 
TEXTFIT GET
(Status)

Output:
SHORT

KIN_INVALID_PARAM
KIN_SUCCESS

Return the status of the 
“Fit Text” toggle (ON/
OFF).

Idem

IMGVECTORIZE 
TEXTFIT SETOFF

NONE KIN_SUCCESS Set the status of the “Fit 
Text” toggle to OFF.

Idem

IMGVECTORIZE 
TEXTFIT SETON

NONE KIN_SUCCESS Set the status of the “Fit 
Text” toggle to ON.

Idem

IMGVECTORIZE 
TEXTSHRINK GET
(Status)

Output:
SHORT

KIN_INVALID_PARAM
KIN_SUCCESS

Return the status of the 
“Shrink Selection to 
Text” toggle (ON/OFF).

Idem

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
A-188 MicroStation Descartes User’s Guide



MicroStation Descartes Key-in Tables
Vectorize Key-In
IMGVECTORIZE 
TEXTSHRINK 
SETOFF

NONE KIN_SUCCESS Set the status of the 
“Shrink Selection to 
Text” toggle to OFF.

Idem

IMGVECTORIZE 
TEXTSHRINK SETON

NONE KIN_SUCCESS Set the status of the 
“Shrink Selection to 
Text” toggle to ON.

Idem

IMGVECTORIZE 
TEXTTHEME GET
(Theme)

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Return the name of the 
current theme for the 
Convert Text command.

Idem

IMGVECTORIZE 
TEXTTHEME SET
<Theme>

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Set the theme for the 
Convert Text command.

Idem

IMGVECTORIZE 
THEME GET
(Theme)

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Return the name of the 
current theme used by 
Vectorize tools.

Image Manager >
Tools >
Vectorize 

IMGVECTORIZE 
THEME SET
<Theme>

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Set the theme used by 
Vectorize tools.

Image Manager >
Tools >
Vectorize

IMGVECTORIZE 
TOOLNODES CLOSE

NONE KIN_SUCCESS Close the Node File tool 
box.

Image Manager >
Tools >
Node File

IMGVECTORIZE 
TOOLNODES OPEN

NONE KIN_SUCCESS Open the Node File tool 
box.

Image Manager >
Tools >
Node File

IMGVECTORIZE 
TOOLTEXTCELLS 
CLOSE

NONE KIN_SUCCESS Close the Text / Cells 
tool box.

Image Manager >
Tools >
Text / Cells

IMGVECTORIZE 
TOOLTEXTCELLS 
OPEN

NONE KIN_SUCCESS Open the Text / Cells 
tool box.

Image Manager >
Tools >
Text / Cells

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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IMGVECTORIZE 
TOOLVECTORIZE 
CLOSE

NONE KIN_SUCCESS Close the Vectorize tool 
box.

Image Manager >
Tools >
Vectorize

IMGVECTORIZE 
TOOLVECTORIZE 
OPEN

NONE KIN_SUCCESS Open the Vectorize tool 
box.

Image Manager >
Tools >
Vectorize

IMGVECTORIZE 
VECTORMODE GET
(Mode)

Output:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Return the current mode 
for placing or 
continuing elements. 
Modes are POINT and 
STREAM.

Image Manager >
Tools >
Vectorize >
Place and 
Continue Element

IMGVECTORIZE 
VECTORMODE SET
< POINT | STREAM >

Input:
STRING

KIN_INVALID_PARAM
KIN_SUCCESS

Set the current mode for 
placing or continuing 
elements. Modes are 
POINT and STREAM.

Idem

IMGVECTORIZE 
VECTORSNAP GET
(Status)

Output:
SHORT

KIN_INVALID_PARAM
KIN_SUCCESS

Return the current status 
of the “Vector Snap” 
toggle (ON/OFF). 

Image Manager >
Tools >
Vectorize >
Place Nodes

IMGVECTORIZE 
VECTORSNAP 
SETOFF

NONE KIN_ERROR
KIN_SUCCESS

Set the current status of 
the “Vector Snap” toggle 
to OFF.

Idem

IMGVECTORIZE 
VECTORSNAP SETON

NONE KIN_ERROR
KIN_SUCCESS

Set the current status of 
the “Vector Snap” toggle 
to ON.

Idem

IMGVECTORIZE 
VERSION GET
(version) (subversion) 
(revision) 
(subrevision)

Output:
SHORT
SHORT
SHORT
SHORT

KIN_INVALID_PARAM
KIN_SUCCESS

Returns the current 
version, subversion, 
revision and subrevision 
of Vectorize. 

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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Used with the “dcgen.plt” driver. 

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface

IMGGENPLOT 
BRIGHTNESS GET
(percent)
 

Output:
LONG

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Return the Brightness 
percent value used for 
plotting. 

Image Manager> 
Plot> 
Setup> 
Device

IMGGENPLOT 
BRIGHTNESS SET
<percent>

Input:
LONG

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Set the Brightness 
percent value used for 
plotting. 

Image Manager> 
Image Manager> 
Plot> 
Setup> 
Device

IMGGENPLOT 
CONTRAST GET
(percent)

Input:
LONG

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Return the Contrast 
percent value used for 
plotting.

Image Manager> 
Plot> 
Setup> 
Device

IMGGENPLOT 
CONTRAST SET
<percent>

Input:
LONG

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Set the Contrast percent 
value used for plotting.

Image Manager> 
Plot> Setup> 
Device

IMGGENPLOT 
DIALOG OPEN
 

NONE KIN_ERROR
KIN_SUCCESS

Open the Generic 
Image Plotting Device 
dialog.

Image Manager> 
Plot> 
Setup> 
Device

IMGGENPLOT 
GRAYSCALE GET
(status)

Output:
SHORT

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Get the Grayscale toggle 
value used for plotting.

Image Manager> 
Plot> 
Setup> 
Device

IMGGENPLOT 
GRAYSCALE SETOFF

NONE KIN_ERROR
KIN_SUCCESS

Set to OFF the Grayscale 
toggle used for plotting.

Image Manager> 
Plot> 
Setup> 
Device
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IMGGENPLOT 
GRAYSCALE SETON

NONE KIN_ERROR
KIN_SUCCESS

Set to ON the Grayscale 
toggle used for plotting.

Image Manager> 
Plot> 
Setup> 
Device

IMGGENPLOT FENCE 
GET
(status)

Output:
SHORT

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Return the Fence toggle 
value used for plotting.

Image Manager> 
Plot> 
Setup> 
Device

IMGGENPLOT FENCE 
SETOFF

NONE KIN_ERROR
KIN_SUCCESS

Set to OFF the Fence 
toggle used for plotting.

Image Manager> 
Plot> 
Setup> 
Device

IMGGENPLOT FENCE 
SETON

NONE KIN_ERROR
KIN_SUCCESS

Set to ON the Fence 
toggle used for plotting

Image Manager> 
Plot> 
Setup> 
Device

IMGGENPLOT 
PLOTRASTER GET
(status)

Output:
SHORT

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Return the Plot Raster 
toggle value used for 
plotting.

Image Manager> 
Plot> 
Setup> 
Device

IMGGENPLOT 
PLOTRASTER SETOFF

NONE KIN_ERROR
KIN_SUCCESS

Set to OFF the Plot 
Raster toggle used for 
plotting.

Image Manager> 
Plot> 
Setup> 
Device

IMGGENPLOT 
PLOTRASTER SETON

NONE KIN_ERROR
KIN_SUCCESS

Set to ON the Plot Raster 
toggle used for plotting

Image Manager> 
Plot> 
Setup> 
Device

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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IMGGENPLOT 
RESOLUTION GET
(resolution)
 

Output:
LONG

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Return the Resolution 
value used for plotting.

Image Manager> 
Plot> 
Setup> 
Device

IMGGENPLOT 
RESOLUTION SET
<resolution>
 

Input:
LONG

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Set the Resolution value 
used for plotting.

Image Manager> 
Plot> 
Setup> 
Device

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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Used with the “dcps.plt” driver.

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface

IMGPSPLOT ANGLE 
GET
(angle)

Output:
LONG

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Return the Angle value 
used for plotting.

Image Manager> 
Plot> 
Setup> 
Device

IMGPSPLOT ANGLE 
SET
<angle>

Input 
param: 
LONG

KIN_INVALID_PARAM 
KIN_ERROR
KIN_SUCCESS

Set the Angle value used 
for plotting.

Image Manager> 
Plot> 
Setup> 
Device

IMGPSPLOT 
BRIGHTNESS GET
(percent)

Output:
LONG

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Return the Brightness 
percent value used for 
plotting.

Image Manager> 
Plot> 
Setup> 
Device

IMGPSPLOT 
BRIGHTNESS SET
<percent>

Input:
LONG

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Set the Brightness 
percent value used for 
plotting.

Image Manager> 
Plot> 
Setup> 
Device

IMGPSPLOT 
CONTRAST GET
(percent)

Output:
LONG

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Return the Contrast 
percent value used for 
plotting.

Image Manager> 
Plot> 
Setup> 
Device

IMGPSPLOT 
CONTRAST SET
<percent>

Input:
LONG

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Set the Contrast percent 
value used for plotting.

Image Manager> 
Plot> 
Setup> 
Device

IMGPSPLOT DIALOG 
OPEN
 

NONE KIN_ERROR
KIN_SUCCESS

Open the Postscript 
Image Plotting Device 
dialog.

Image Manager> 
Plot> 
Setup> 
Device
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IMGPSPLOT FENCE 
GET
(status)

Output:
SHORT

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Return the Fence toggle 
value used for plotting.

Image Manager> 
Plot> 
Setup> 
Device

IMGPSPLOT FENCE 
SETOFF

NONE KIN_ERROR
KIN_SUCCESS

Set to OFF the Fence 
toggle used for plotting.

Image Manager> 
Plot> 
Setup> 
Device

IMGPSPLOT FENCE 
SETON

NONE KIN_ERROR
KIN_SUCCESS

Set to ON the Fence 
toggle used for plotting

Image Manager> 
Plot> 
Setup> 
Device

IMGPSPLOT 
FREQUENCY GET
(frequency)

Output:
LONG

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Return the Frequency 
value used for plotting.

Image Manager> 
Plot> 
Setup> 
Device

IMGPSPLOT 
FREQUENCY SET 
<frequency>

Input 
param: 
LONG

KIN_INVALID_PARAM 
KIN_ERROR
KIN_SUCCESS

Set the Frequency value 
used for plotting.

Image Manager> 
Plot> 
Setup> 
Device

IMGPSPLOT 
GRAYSCALE GET
(status)

Output:
SHORT

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Get the Grayscale toggle 
value used for plotting.

Image Manager> 
Plot> 
Setup> 
Device

IMGPSPLOT 
GRAYSCALE SETOFF

NONE KIN_ERROR
KIN_SUCCESS

Set to OFF the Grayscale 
toggle used for plotting.

Image Manager> 
Plot> 
Setup> 
Device

IMGPSPLOT 
GRAYSCALE SETON

NONE KIN_ERROR
KIN_SUCCESS

Set to ON the Grayscale 
toggle used for plotting.

Image Manager> 
Plot> 
Setup> 
Device

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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IMGPSPLOT OUTPUT 
GET
(output)

Output:
STRING

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Return the option value 
for Output. Options are 
8BITS and 24BITS.

Image Manager> 
Plot> 
Setup> 
Device

IMGPSPLOT  
OUTPUT SET
< 8BITS | 24 BITS >

Input 
param:
STRING

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Set the option value for 
Output.

Image Manager> 
Plot> 
Setup> 
Device

IMGPSPLOT 
PLOTRASTER GET
(status)

Output:
SHORT

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Return the Plot Raster 
toggle value used for 
plotting.

Image Manager> 
Plot> 
Setup> 
Device

IMGPSPLOT 
PLOTRASTER SETOFF

NONE KIN_ERROR
KIN_SUCCESS

Set to OFF the Plot 
Raster toggle used for 
plotting.

Image Manager> 
Plot> 
Setup> 
Device

IMGPSPLOT 
PLOTRASTER SETON

NONE KIN_ERROR
KIN_SUCCESS

Set to ON the Plot Raster 
toggle used for plotting

Image Manager> 
Plot> 
Setup> 
Device

IMGPSPLOT 
PRINTERDEFAULT 
GET
(status)

Output:
SHORT

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Return the Printer 
Default toggle value 
used for plotting.

Image Manager> 
Plot> 
Setup> 
Device

IMGPSPLOT 
PRINTERDEFAULT 
SETOFF

NONE KIN_ERROR
KIN_SUCCESS

Set to OFF the Printer 
Default toggle used for 
plotting. 

Image Manager> 
Plot> 
Setup> 
Device

IMGPSPLOT 
PRINTERDEFAULT 
SETON

NONE KIN_ERROR
KIN_SUCCESS

Set to ON the Printer 
Default toggle used for 
plotting.

Image Manager> 
Plot> 
Setup> 
Device

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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IMGPSPLOT 
RESOLUTION GET
(resolution)
 

Output:
LONG

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Return the Resolution 
value used for plotting.

Image Manager> 
Plot> 
Setup> 
Device

IMGPSPLOT 
RESOLUTION SET
<resolution>
 

Input:
LONG

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Set the Resolution value 
used for plotting.

Image Manager> 
Plot> 
Setup> 
Device

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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Used with the “dcrtl.plt” driver.

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface

IMGRTLPLOT 
GRAYSCALE SETON

NONE KIN_ERROR
KIN_SUCCESS

Set to ON the Grayscale 
toggle used for plotting.

Image Manager> 
Plot> 
Setup> 
Device

IMGRTLPLOT 
BRIGHTNESS GET
(percent)
 

Output:
LONG

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Return the Brightness 
percent value used for 
plotting.

Image Manager> 
Plot> 
Setup> 
Device

IMGRTLPLOT 
BRIGHTNESS SET
<percent>

Input:
LONG

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Set the Brightness 
percent value used for 
plotting.

Image Manager> 
Plot> 
Setup> 
Device

IMGRTLPLOT 
CONTRAST GET
(percent)

Input:
LONG

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Return the Contrast 
percent value used for 
plotting.

Image Manager> 
Plot> 
Setup> 
Device

IMGRTLPLOT 
CONTRAST SET
<percent>

Input:
LONG

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Set the Contrast percent 
value used for plotting.

Image Manager> 
Plot> 
Setup> 
Device

IMGRTLPLOT 
DIALOG OPEN
 

NONE KIN_ERROR
KIN_SUCCESS

Open the RTL Image 
Plotting Device dialog.

Image Manager> 
Plot> 
Setup> 
Device

IMGRTLPLOT FENCE 
GET
(status)

Output:
SHORT

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Return the Fence toggle 
value used for plotting.

Image Manager> 
Plot> 
Setup> 
Device
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IMGRTLPLOT FENCE 
SETOFF

NONE KIN_ERROR
KIN_SUCCESS

Set to OFF the Fence 
toggle used for plotting.

Image Manager> 
Plot> 
Setup> 
Device

IMGRTLPLOT FENCE 
SETON

NONE KIN_ERROR
KIN_SUCCESS

Set to ON the Fence 
toggle used for plotting

Image Manager> 
Plot> 
Setup> 
Device

IMGRTLPLOT 
GRAYSCALE GET
(status)

Output:
SHORT

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Get the Grayscale toggle 
value used for plotting.

Image Manager> 
Plot> 
Setup> 
Device

IMGRTLPLOT 
GRAYSCALE SETOFF

NONE KIN_ERROR
KIN_SUCCESS

Set to OFF the Grayscale 
toggle used for plotting.

Image Manager> 
Plot> 
Setup> 
Device

IMGRTLPLOT 
PLOTRASTER GET 
(status)

Output:
SHORT

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Return the Plot Raster 
toggle value used for 
plotting.

Image Manager> 
Plot> 
Setup> 
Device

IMGRTLPLOT 
PLOTRASTER SETOFF

NONE KIN_ERROR
KIN_SUCCESS

Set to OFF the Plot 
Raster toggle used for 
plotting.

Image Manager> 
Plot> 
Setup> 
Device

IMGRTLPLOT 
PLOTRASTER SETON

NONE KIN_ERROR
KIN_SUCCESS

Set to ON the Plot Raster 
toggle used for plotting

Image Manager> 
Plot> 
Setup> 
Device

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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IMGRTLPLOT 
RESOLUTION GET
(resolution)
 

Output:
LONG

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Return the Resolution 
value used for plotting.

Image Manager> 
Plot> 
Setup> 
Device

IMGRTLPLOT 
RESOLUTION SET
<resolution>
 

Input:
LONG

KIN_INVALID_PARAM
KIN_ERROR
KIN_SUCCESS

Set the Resolution value 
used for plotting.

Image Manager> 
Plot> 
Setup> 
Device

Key-In Parameters Returned Error 
Codes

Description Graphical 
Interface
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