
3 Fundamentals
This chapter briefly presents the basic concepts, mechanisms and features of 
MicroStation Descartes, or indicates where to find relevant information in this 
guide. Each basic aspect of MicroStation Descartes is covered such as the user 
interface conventions, the project paradigm, the tool boxes, the image 
mosaicking capabilities, or the handling of colors associated with images. 
Setting preferences are also covered.
How to Start MicroStation Descartes
MicroStation Descartes is an application running in the 
MicroStation environment. To start MicroStation Descartes, you 
can:

• Start MicroStation and then load MicroStation Descartes with 
the key-in MDL LOAD DCARTES.

OR

• Load the application through the “dcartes” workspace.

✍ For more information, see “Loading and Starting MicroStation 
Descartes” on page 4-1.

MicroStation/J Support
MicroStation Descartes Version 7.0 is fully compatible with the 
new MicroStation/J MDL programs as well as the new directory 
structure.

✍ Contact your local vendor or Bentley Systems for more 
information on how to upgrade to MicroStation/J.

MicroStation Descartes User Interface Conventions
MicroStation Descartes is a combination of MDL and C 
programming and has been designed to seamlessly integrate into 
the MicroStation environment. Therefore, you will find that all 
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tool boxes, menus, dialog boxes, and other interface operations 
are consistent with MicroStation conventions.

Similarly, MicroStation Descartes follows MicroStation conventions 
for displaying images in views and for editing design files. 
However, since MicroStation Descartes has been designed to 
support a project metaphor, you will discover that you have a 
great deal of flexibility in the way that you can work.

The MicroStation Descartes project contains basic parameters 
about your actual project and working session, as well as 
information that defines the relationship between the files. This 
organization permits a level of abstraction so that you can work 
with the information contained in various files in a natural way.

MicroStation Descartes Main Menu
The main menu of MicroStation Descartes is in the menu bar of 
the Image Manager dialog box. The structure of this menu is 
detailed in “Image Manager Menu Structure” on page 4-3.

The menu items of each Image Manager menu are explained in 
Chapter 4. See:

• “Image Manager File menu” on page 4-7

• “Image Manager File > Project sub menu” on page 4-11

• “Image Manager Edit menu” on page 4-13

• “Image Manager Display menu” on page 4-15

• “Image Manager Settings menu” on page 4-17

• “Image Manager Tools menu” on page 4-20

• “Image Manager Utilities menu” on page 4-28

• “Image Manager Help menu” on page 4-30

If you load MicroStation Descartes with the “dcartes” workspace, 
all menu items of MicroStation Descartes are integrated in the 
appropriate menus of MicroStation and there is a one-to-one 
equivalence with the Image Manager menu items. In Chapter 4, 
there is a note with each description of the Image Manager menu 
items that explicitly tells its equivalent in the MicroStation menu.
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Workspaces
MicroStation Descartes is transparently interfaced with 
MicroStation through workspaces. With a workspace, you can 
reconfigure the MicroStation menus, tools, and other features as 
you wish, and integrate your own menu items, tools, or other 
features.

The “dcartes” workspace, which is provided with MicroStation 
Descartes, is used to fully integrate the MicroStation Descartes 
menu items, tools, or other features to the MicroStation user 
interface.

You can also develop other ways of configuring the MicroStation 
Descartes user interface by creating workspaces by yourself. You 
can take “dcartes” as a template and make as many changes as 
you want and save it under a new name. For more information, 
see “Customizing the Workspace” on page 18-3.

Tool Frames and Tool Boxes
All of the functionality of MicroStation Descartes is also accessible 
through the tool boxes. 

All tool frames and tool boxes can be accessed from the Image 
Manager Tools menu, where they are listed in alphabetical order 
(see “Image Manager Tools menu” on page 4-20).

Alternatively, the tool boxes specific for an application can be 
accessed from the Tools menu of the dialog box related to this 
application. For instance, the Register dialog box provides access 
to two tool boxes: Register and Register File.

Each tool box provides access to a few tools of the same family. 

Four tool frames are provided with MicroStation Descartes. They 
are the four first items in the Image Manager Tools menu.

• Image Main is used to open the Image Main tool frame and 
provides access to all other tool boxes (see “Image Main” on 
page 4-21).

• Prepare is used to open the Prepare Image tool frame and 
provides access to all tools needed for transforming or 
registering images (see “Prepare” on page 4-21).

• Edit is used to open the Edit Image tool frame and provides 
access to all tools needed for editing images (see “Edit” on 
page 4-21).
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• Convert to Vector is used to open the Convert to Vector tool 
frame and provides access to all tools needed for carrying out 
raster to vector conversion (see “Convert To Vector” on page 
4-21).

You can build your own sets of tool boxes by picking any tool 
from MicroStation Descartes or from MicroStation itself, and 
putting them into new boxes or frames. To learn more about 
customizing tool boxes and tool frames, see “Customizing the 
Workspace” on page 18-3.

MicroStation Descartes Projects
With the MicroStation Descartes project capability, you can save 
and retrieve all features associated with images and image 
operations:

• The lists of images opened in each MicroStation view

• The organization parameters for each view (stacking order, 
visibility, transparency, translucency)

• The open tool boxes for this project

• The open dialog boxes for this project

• Several parameter settings with various tools or dialog boxes

When you restore a previously saved project, all work and data 
reappear exactly as they were when saved.

The parameters and the links to the data of a project can be kept 
in a Project file (with a PRJ extension), or be attached to the active 
design file. 

The project changes continuously while you are working. For 
example, operations such as opening or closing files, using tools 
with various configurations, or setting parameters, change the 
content of your project. However, the Project file is not changed 
until you save the project through the file interface.

The following procedures show how to create a new project, to 
save a project or to restore a previously saved project from a 
Project file, and how to attach or detach a project to the design 
file, manually or automatically.

✍ To carry out the following procedures, it is assumed that you have 
already loaded MicroStation Descartes. To do so, see “Loading 
and Starting MicroStation Descartes” on page 4-1.
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Managing Project files
You can manually control your project and manage Project files 
by choosing the following items from the File > Project sub menu 
of Image Manager (or from the File > Image Project sub menu of 
the “dcartes” workspace):

• New (Project)

• Open (Project)

• Save (Project)

• Save (Project) As

➤ To create a new project

1. Open the Image Manager dialog box by choosing Descartes - 
Image Manager from the File menu of MicroStation.

2. Choose Project > New from the Image Manager File menu.

OR, if the “dcartes” workspace is loaded:

1. Choose Image Project > New from the MicroStation File 
menu.

This action:

• Clears all project settings and resets all relevant parameters to 
default values.

• Gives the new project the temporary name Untitled which is 
displayed in the title bar of the Image Manager dialog box.

✍ If a Project file is already open, it will be closed but not saved, 
before the new project is started. If a project is attached to the 
design file, it is detached but not saved.

➤ To open an existing project

1. Locate or open the Image Manager dialog box.

2. Choose Project > Open from the Image Manager File menu.

OR, if the “dcartes” workspace is loaded:

1. Choose Image Project > Open from the MicroStation File 
menu.

This choice retrieves a dialog box that permits you to open an 
existing project file. If a Project file is already open, it will be 
closed but not saved before the new one is opened. If a project is 
attached to the design file, it is detached but not saved.
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When you open an existing project:

• MicroStation Descartes tools and dialog boxes are opened or 
closed.

• Open views are updated.

• Files and lists are loaded.

• Parameters are set to the status that they had when the project 
was last saved.

• The name of the project displays in the title bar of the Image 
Manager dialog box.

➤ To save a project

1. Locate or open the Image Manager dialog box.

2. Choose Project > Save from the Image Manager File menu.

OR, if the “dcartes” workspace is loaded:

1. Choose Image Project > Save from the MicroStation File 
menu.

The project is saved using the current name, in the specified 
directory, and on the specified disk. If the project is Untitled, 
the Save Project dialog box opens. (If the Save and Attach 
Automatically toggle is on, Save behaves a little differently. 
See Attaching a project to a design file, later in this chapter.)

➤ To save a project under a different name

1. Locate or open the Image Manager dialog box.

2. Choose Project > Save As from the Image Manager File menu.

OR, if the “dcartes” workspace is loaded:

1. Choose Image Project > Save As from the MicroStation File 
menu.

The Save Project dialog box then opens. Use this dialog box 
to save the project under any filename, in any directory, and 
on any disk.

After a project is saved, the new name displays in the title bar.

✍ The Save Project and Save Project As options always automatically 
invoke MicroStation’s File > Save Settings command.
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Attaching a project to a design file
MicroStation Descartes provides controls to attach or detach your 
project to the active design file. You can do so by using the 
following features:

• Attach

• Detach

• Save and Attach Automatically

The first two features (Attach and Detach) are items from the 
File > Project sub menu of Image Manager (or from the 
File > Image Project sub menu of the “dcartes” workspace). 

The third is controlled by the Save and Attach Automatically 
toggle in the Project Settings dialog box. 

Save and Attach Automatically
Used to turn on or off the capability of automatically saving and 
attaching the current project to the active design file.

Save Full Path
If on, the full path of the Project file will be used to attach the 
project. If off, only the filename will be attached. 

✍ To open this dialog box, choose Project from the Settings menu of 
Image Manager (or Settings > Image > Project with the “dcartes” 
workspace).

When a project is attached to a given design file, it automatically 
opens as soon as MicroStation Descartes and this design file are 
both opened. Then, all images, data, parameters, tools, or other 
features belonging to MicroStation Descartes will be seamlessly 
attached to the design.

Project Settings
dialog box
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➤ To attach a project to a design file

1. Locate or open the Image Manager dialog box.

2. Choose Project > Attach from the Image Manager File menu.

OR, if the “dcartes” workspace is loaded:

1. Choose Image Project > Attach from the MicroStation File 
menu.

➤ To let MicroStation Descartes automatically control your 
project

1. Locate or open the Project Settings dialog box.

2. Turn (or leave) on the Save and Attach Automatically toggle.

In this (default) situation, MicroStation Descartes automatically 
and transparently controls your project. A project is automatically 
assigned to the design file and belongs to it as long as you work 
with this design, session after session.

When Save and Attach Automatically is on, the project is 
automatically attached and saved in each of the following 
situations:

• When you exit MicroStation Descartes or MicroStation.

• When you save the project.

✍ If the project is Untitled, its name is changed to the name of the 
active design file with the PRJ extension and this project file is 
saved in the same directory as the design file. You can also define 
the workspace variable MS_IMGPROJECT_DIR for the directory 
where you want to keep your projects. If this variable is defined, 
the project will be saved in this directory with the name of the 
active design plus the PRJ extension. If the variable is not defined, 
the default is the same directory as the design file.

• When the current design file is closed by choosing one of 
these items from the MicroStation menu: New (Design), Open 
(Design), or Close (Design).

If you let MicroStation Descartes automatically and transparently 
control your project and you want to “copy and paste” the 
resulting project to another design file, perform the following 
procedure.
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➤ To “copy and paste” a project from one design to another 
design file

1. Save the project into a file.

2. Close the design.

3. Open the target design file.

4. Open the Project file you saved in step 1.

5. Attach the project.

Managing groups of images with projects
With MicroStation Descartes, all image files can be managed 
separately. Even images in a mosaic may be saved as separate 
files. With a project, you can manage up to eight mosaics or 
groups of images (one per view). Since a project can be saved to 
a file and restored for later use, you can build as many mosaics or 
groups of images as you want.

Each mosaic or group of images can be composed of any number 
of images in individual files. Each image can have a different 
resolution or a different color type. You can move images up or 
down. Overlapping images can hide or be hidden by others. You 
can also control the transparency or translucency of images in a 
view to achieve the right look for your mosaics or to manage a 
stack of images. 

With a Project file, you can save not only the lists of images, but 
all other stacking or mosaicking parameters. When you restore 
this Project file, you will retrieve all of the images properly 
organized in the appropriate views.

Copy Project
A MicroStation Descartes project includes several pieces of 
information, attached files like images, nodes, color filters, etc. 
and different settings related to the project session. Copy Project 
is used to gather all the files of a project and manipulate them as 
one object.
MicroStation Descartes User’s Guide 3-9



3 Fundamentals
Copy Project
Copy Project is useful to:

• Send projects to other users utilizing MicroStation Image 
Manager to display images.

MicroStation Image Manager is found in several applications 
such as MicroStation Descartes, MicroStation ReproGraphics, 
and others.

• Publish projects on the Web with ModelServer products.

ModelServer products allow to seamlessly publish very large 
datasets via an internet/network connection. ModelServer 
products are Project file compatible which allows a recipient 
of a project file to efficiently publish your data.

• Make backup copies of a project.

Make quick backup copies of your projects without forgetting 
any files. Since all project related files are contained in the 
project file, creating backups with Copy Project ensures that 
all files will be backed up.

Copy Project dialog box
The copy project operation is entirely set through the Copy 
Project dialog box. The Copy Project dialog box is described 
below.

Copy Project
dialog box
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Method

Two types of method can be chosen to copy a project:

• Copy Files

This method copies the project and all the attached files into 
the selected directory. Use to backup a project or to copy a 
project over another location on the network.

• Create Archive File

This method stores the project and all attached files in the 
self-extracting single file selected.

Save Directories

When turned on, this feature will duplicate the directory structure 
directly under the Copy To destination directory.

• When Copy Files is selected and Save Directories is ON

The path to which a file is copied consists of the path 
displayed in the Copy To section concatenated with the path 
of the file to copy. Example, 

If the file to copy is: \Files\projects\project_a.prj

If the Copy to is set to: 
\\ComputerName\ShareName\NewProjects

The result is: 
\\ComputerName\ShareName\NewProjects\Files\projects\p
roject_a.prj

• When Copy Files is selected and Save Directories is OFF

Only the Copy To path is used.

• When Create Archive File is chosen and Save Directories is 
ON.

The names of the directories of each file are saved with the 
file to be archived.

• When Create Archive File is chosen and Save Directories is 
OFF.

All project files are copied directly in the archive file without 
saving the path of each file.

Overwrite Existing Files

When ON, copied files and archive are allowed to overwrite 
existing files with the same name. This allows to use this feature 
from MDL or Basic program and be sure that the process will not 
be interrupted.
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Copy To group > Select button

Is used to select the path where the file will be copied. 

Archive File group > Select button

It is used to select the path and file name where the self-
extracting executable will be created and stored.

✍ The default value will be the path of the MicroStation 
environment variable MS_ARCHIVE where the file name for the 
archive is the name of the project file. If the project name is 
“MyProject.prj,” the archive will be named “MyProject.exe.”

Use the following procedure to backup a project.

➤ To create a backup or a copy of a project

1. From the Image Manager File menu, select Project > Copy 
Project.

The Copy Project dialog box opens.

2. From the Method option list select Copy Files.

3. If you want to have the same directory structure, turn on Save 
Directories.

4. To update an existing backup, ensure that Overwrite Existing 
Files is turned ON.

5. Click the Select button and choose the location where to 
create the project to.

6. Click OK to begin the copy project process.

Use the following procedure create a self-extracting archive of a 
project.

Copy Project
dialog box
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➤ To create a self-extracting archive of a project

1. From the Image Manager File menu, select Project > Copy 
Project.

The Copy Project dialog box opens.

2. From the Method option list select Create Archive File.

3. If you want to save directory structure, turn on Save 
Directories.

4. To update an existing archive, ensure that Overwrite Existing 
Files is turned ON.

5. Click the Select button and choose the location where to copy 
the archive.

6. Click OK to begin the creation/update of the archive.

Supporting Raster Reference Files
MicroStation provides another means to manage images by 
attaching them to the design as “Reference Raster Files” (see the 
MicroStation User’s Guide for more information about attaching 
and managing Raster Reference Files).

MicroStation Descartes supports the raster reference files by 
detaching them from the design file and attaching them to the 
project, or conversely. 

Copy Project
dialog box
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To do so, use the following items from the File > Project sub 
menu of Image Manager (or from the File > Image Project sub 
menu of the “dcartes” workspace): 

• Import Raster Reference — detaches all the raster reference 
files from the design file and attaches them to the project.

• Export Raster Reference — detaches images from the project 
and attaches them directly to the design file as raster 
reference files.

W Some image file formats, including the HMR images, are not 
supported by MicroStation as raster reference files. These are not 
“exported” by the Export Raster Reference command.

W Raster References will be removed as a result of Import Raster 
References.

W Particular settings of Raster References (foreground color, invert, 
transparency, etc.) will not be imported as a result of Import 
Raster Reference.

W Particular settings of Images (transparency, translucency, etc.) will 
not be exported as a result of Export Raster Reference.

Managing and Selecting Files
In MicroStation Descartes, your project settings and status are 
managed through a standard file interface. Additionally, several 
distinct file types that are used as building blocks in your projects 
are also managed through the same file interface. If you are 
familiar with the standard file interfaces that are used in 
MicroStation, you should find the MicroStation Descartes file 
interface easy to use.

In MicroStation Descartes, file interfaces are used to manage the 
following types of files:

File Type Extension

Project file PRJ

Image files HMR, CIT, COT, RGB, RLE, A, P, JPG, 
PCX, RS, TGA, TIF, BMP, CAL, RLC, 
INT, TG4, BUM

Color Table file TBL

Color Filter file FTR
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The file interface is used to create, open, select, and save the 
various types of files that are used in MicroStation Descartes and 
the usual operations that are supported are New, Open, Save and 
Save As.

To support selection of files, MicroStation Descartes provides a 
simple and standard selection interface. When the File Selection 
dialog box is open, the title of the dialog box reflects the current 
file type. The files listed for selection in the File list box have an 
extension specific to the file type (for example, FTR is the 
extension for a Color Filter file). The current directory displays 
above the Directories list box. You can change any of these 
selections.

To select a file, double-click on its name in the Files list box, or 
select the name and click OK, or enter the name into the Files 
field and click OK. The File Selection dialog box then closes and 
the selected file opens in the appropriate application. To create a 
new file, enter the file name in the Files field. Click the Cancel 
button in the File Selection dialog box to abort a File Open or a 
File Save As.

The dialog boxes for opening or saving images have more 
functionality. For example, they support several file extensions. 
The Open Image dialog box allows multiple file selection. It also 
provides a preview window to display a thumbnail of a selected 
image prior to opening it. See “Open Images dialog box” on page 
5-19 and “Save As dialog box” on page 5-25.

Theme file THM

Hatch file HAT

Pattern file PAT

Node file NOD

Register file RGR

Resampling file RSP

Open Filter File
dialog box
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Image File Type Issues
The HMR format, which is described in the next section, is 
optimized for speed and efficiency with MicroStation Descartes. 

MicroStation Descartes also supports a large number of image file 
formats and image file types. See the “Image File Formats Table” 
on page 15-10 for a complete list.

To use an image of another format or type, it is recommended 
that you convert it into a HMR Image file. See Chapter 14, 
Converting Image Formats, for more information on batch 
conversion.

You can also load non-HMR images natively. If you do so, you 
may experience side effects such as:

• Longer time to open an image

• Longer time to close an image

• No georeference

• A loss of information upon opening or closing an image

When you load an image of any format or type with more than 
256 colors, it is temporarily reduced to 256 colors. Upon closing 
this image, you will be warned that the source image is going to 
be permanently reduced to 256 colors. A loss of information or 
properties can result. You can choose to save your image as an 
HMR file, in which case the source image is left unchanged.

While they are opened, all images with more than two colors 
have a color palette. Some image properties such as transparency, 
translucency and color filters are connected to the color palette of 
the open images. File types such as 24 bit RGB or 8 bit gray scale 
cannot save a color palette when they are closed. The temporary 
palettes that belong to these images are lost upon closing them. 
When an image of this kind is reopened, a new color palette is 
created. In some circumstances, however, the new color palette 
will not be the same as the previous one. Then, the image 
properties such as transparency, translucency and the color filters 
are no longer compatible, and they are lost.

To avoid all side effects of this kind, it is recommended that you 
convert your images into the HMR format while you are working 
with MicroStation Descartes, and keep the source images in their 
original format. When you finish working with the images, you 
can convert the working image copies back to their original 
format. 

When you intend to stamp vector data into an image with more 
than two colors, make sure you assign enough colors for this 
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purpose (see “Stamping into 256 color images” on page 11-7). 
Then, the Stamp Vector tool works smoothly.

World File Support
MicroStation Descartes provides enhance support for worldfiles. 
All supported raster formats can now have their own worldfiles.

Why Use WorldFiles?
You will utilize worldfiles when the raster format you will use to 
distribute and/or publish your image(s), such as TIFF, BMP or 
JPG, does not support an embedded header and/or 
transformation matrix. Several formats do not support the matrix, 
here is a list these formats.

• tiff

• jpg

• bmp

• cal

• rgb

• rs

• a

• p

• tga

• pcx

The worldfile must accompany the raster file. They can either be 
zipped together or simply reside in the same directory. In the 
event that the raster file is used in a spatially reference geographic 
environment, such as MicroStation, the worldfile is then used to 
spatially position the raster file.

Naming Convention
The world file is an ASCII text file that is associated with an image 
by the following naming convention.
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As a standard, the prefix of the worldfile is identical to the one of 
the raster file it belongs to. Examples:

• SHADOW.TIF and SHADOW.TFW

• FLOOR.JPG and FLOOR.JGW

• HOUSE.BMP and HOUSE.BPW

As for the suffix, the following applies:

• If the image file name has a three-character extension (e.g., 
image1.tif), the worldfile has the same name followed by an 
extension containing the first and last letters of the image’s 
extension and ending with a “w” (for example, image1.tfw). 

• If the extension has more or less than 3 characters, including 
no extension at all, then the world file name is formed by 
simply appending a “w” to the image file name. Examples:

• tif=tfw

• jpg=jgw

• bmp=bpw

• cal=clw

• rgb=rbw

• rs=rsw

• a=aw

• p=pw

• tga=taw

• pcx=pxw
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Color Table Concepts in HMR Images
Each HMR image has a unique color table independent of the 
MicroStation color table. This approach permits Image Manager to 
display more than one image at a time should the combined 
colors of the displayed images exceed the number of available 
colors. This is not the situation with 24 bit displays, but Image 
Manager supports displays with a smaller number of colors, such 
as 256 (or 8 bit).

In such cases, Image Manager always builds a compromise color 
table that takes all images into account and uses this color table 
for all images in all views. Since Image Manager sorts image color 
tables by intensity, all images display very well. Gray scale 
images, in fact, should appear consistent because the color tables 
for most gray scale images are either very similar or identical.

The image being edited becomes the active image and it is given 
more weight, since it provides its color palette to the display and 
all other images are mapped to this palette.

In Image Manager, only applicable with MicroStation 95 and SE, 
the Exact MicroStation Colors are divided into Exact Design 
Colors or Exact Image Colors. All elements drawn with colors 
reserved as Exact Design Colors are always represented exactly, 
regardless of the color table of the active image. The same 
concept applies to the background color, which is usually 
assigned an Exact Design Color. Elements drawn with a color not 
assigned an Exact Design Color are represented with the nearest 
Exact Design Color or with the nearest Exact Image Color.

The number of Exact MicroStation Colors can be set by using the 
MicroStation Preferences > Drawing item. Alternatively, you can 
set the Exact Design Colors as well as the Exact Image Colors 
through the Image Manager Settings > Preferences > Color menu 
item. (See “Memory Allocation dialog box” on page 3-20.)

✍ With 24 bit displays and with color PostScript devices, each image 
is displayed or plotted using its own color table (use of a single 
color table is for 8 bit displays only).
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Settings Preferences
The Settings > Preferences sub menu of Image Manager offers 
two options:

Memory

Opens the Memory Allocation dialog box.

Color Distribution

Opens the Color Distribution dialog box.

Memory Allocation dialog box
Image Manager maintains two types of buffers that contain image 
data. The image file buffers hold image data in 64 Kb blocks (256 
by 256 pixels). The screen tile buffers hold ready-to-display data 
in a definable block size.

Increasing the number of image file buffers improves the 
performance when you need to quickly go from one location to 
another across one or more images. Increasing the number of 
screen tile buffers improves performance when you update views, 
pan locally in the same region of an image, or slightly change the 
zoom factor in the same region of an image.

The following rules should be observed when configuring the 
memory settings:

• Do not allocate more memory than you have available on 
your system. A quick way to evaluate how much memory to 
use for image display is to subtract 4 Mb from the total 
memory installed on your system. The result is the maximum 

Memory Allocation
dialog box
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amount of memory that you should allocate for both the 
image file buffers and the screen tile buffers.

• Set Screen Tile Size to 256 by 256. Normally, these values 
should not be set to values other than 256 by 256.

• Be sure that you have enough Screen Tile Buffers to account 
for the number of pixels that will be displayed in the views. 
Otherwise, the performance of view update operations will 
be less than optimal (some screen tiles will need to be 
recalculated on each view update).

• Once you set the Screen Tile Buffers, set the Image File 
Buffers as high as you can to take full advantage of all 
remaining memory.

To change the default settings, choose Memory from the 
Preferences menu to open the Memory Allocation dialog box. Use 
this dialog box to optimize the memory allocation for image input 
and image display buffers.

Image File Buffers
Used to set the number of buffers. The total amount of memory 
allocated to the image input also displays.

Screen Tile Buffers
Used to set the number of buffers. The total amount of memory 
allocated to the screen tiles also displays. This memory contains 
the sections of images, or tiles, exactly as they display on screen.

Tile Size
Used to set the X and Y dimensions of the screen tile buffers.

✍ Keep in mind the following:

• You must restart MicroStation Descartes so that the new 
values take effect.

• The default values yield good performance with 8 Mb of 
memory. If more memory is available or if you wish to 
increase the performance of the image display, set the buffers 
to higher values.
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Color Distribution dialog box - MicroStation 95 and SE
Used to set the distribution between the colors used for 
displaying design elements and the colors used for displaying 
images, or to support 24 bit displays.

Exact Design Colors
Used to enter the number of exact colors that you wish to reserve 
for the drawing of design elements. When you edit this field, the 
Exact Image Colors field automatically updates.

✍ This parameter is saved with the project.

Exact MicroStation Colors
Used to set the number of fixed colors available to MicroStation 
for other applications. This field can also be edited from the 
Drawing item in the MicroStation Preferences dialog box. When 
you set this parameter, the Exact Design Colors and the Exact 
Image Colors fields are updated according to the equation 
explained below in Exact Image Colors.

Exact Image Colors
Used to set the number of colors available for the display of 
images. When you set this parameter, the Exact Design Colors 
field updates according to this equation:

I = M - D

where:

I is the number of Exact Image colors,
M is the number of Exact MicroStation colors,
D is the number of Exact Design colors.

24 bit
Used to support 24 bit display devices and allow full RGB display.

Color Distribution
dialog box
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Color Distribution dialog box - MicroStation/J

24 bit
Used to support 24 bit display devices and allow full RGB display.

Image Manager - Environment Variable for Open Image Path
A environment variable can be created and set to point to a 
specific directory.

MS_OPEN_DEFAULTDIR - Environment Variable

Create and set this environment variable to your favorite 
directory. Once set, the Image Manager File Open command 
always opens the dialog box and points into this directory.

If the path is not valid, Image Manager uses the last accessed path 
for the File Open dialog box.

➤ To create and set the environment variable.

1. Start MicroStation and select DCARTES for the workspace

2. From the Workspace menu, select Configuration.

The Configuration dialog box opens.

3. From the Category list, select Extensions.

4. Click the New button.

The New Configuration Variable dialog box opens.

5. Enter the values for the specified fields as described below.

Variable: MS_OPEN_DEFAULTDIR

New Value: The path and directory you want Image Manager 
to point to.

6. Click OK to create and save the new variable.

7. Click OK to close the Configuration dialog box.

8. Click Yes to save the configuration file.
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It is not necessary to restart MicroStation or MicroStation 
Descartes. Simply access the Open Image dialog box and it will 
point to the specified directory.

✍ If the directory does not exist or the path contains an error, you 
will not be notified. If you notice that the Image Open dialog box 
does not point to the directory you specified, edit the variable and 
make sure the path you have entered is valid and exists.
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