Introducing Image Draping

Draping an Image - Tutorial

Now that we have covered the basics of draping with an
overview of the process, we are prepared to drape an image.

O Setup for draping

1.

Start Microstation SE.
The MicroStation Manager dialog box opens.

Set the settings as follows:

MicroStation Manager B

File  Directory

Files: Directories:

-Austation\dearteshtutorialt
dtm.dgn =2 o

lezsonl.dgn [ win32app Cancel |
lezson2 dgn [P ustation

lezson3.dgn [ deartes

lezsond. dgn = tutorial

lezzonb.dgn

lezzonB.dgn

lezzon?.dgn

leszon?h.dan

List Files of Type: Dirives:

MicroStation Design Files [*.dgn] 'l |d: :I

™ Open Design Files Read-Only

p— wiorkspace: [doartes
Froject: |default
Interface: [dcartes

Style:  Statuz Bar I

HEE

4
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3. Click OK.

& din.dgn (3D) - MicroStation SE [_[5]x]
Fie Edt Element Seftings Tools Ulilies Workspace Window Help

|Dl=(a] 8] #[=]8] <]~ 2] 0z

[ETET |

[06 — o — o] @)

B | & window 1-Tap View

Element Selection H7 (@ [Level=1 [

[0 The design file has been set for two open views, 1 and 2. View 1
is the TOP view and View 2 is the ISOMETRIC view.

1 The design file is already attached to a project for the image,
DRAPE.HMR, and opens automatically.

The environment is ready for draping. We will now create a local
palette file.
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O Creating the custom palette file

1. From the Settings menu, select Rendering > Define Materials.
The Define Materials dialog box opens.

gDeﬁne Materials: Untitled E
File
Materials: Shading: _Phong vI Ambient: |1.DD Dl T i 1}
Display: _Sphere vI Diffuge: |D.BD Dl || 1.0
- Specular [0.40 o] [l 1.0
Finish: [0.50 of L0 10
Transmit: |D.DD DlIl 1.0
r Baze Color... | r Specular Color... |
V' Cast Shadows ml
—Map:  Pattern Vll
Mame: ™ Transparent Background
Weight: [1.00 of 1.0
I aterial Mame: | Angle: ID.DD ™ Elevation Drape
Sigex: [1.0000 Dffget ¢ [0.0000 Surface vI
sdd | Delte | Replass v: [1.0000 v: [00000 | I Fiip
Breview |
Clear | Edt | Select.. |
2. Turn on Base Color and Specular Color.
3. In the Material Name field, enter Template.
4. Press <Return> and click the Add button.
5. From the Define Materials File menu, select Save Palette As.
6. Browse into the \dcartes\tutorial directory and enter

MYPALETTE as the file name and click OK.

This creates a custom palette file where all materials will now
reside. It will not be a reference to the material; therefore, if
something should happen to your MicroStation directory
structure, your materials will not be affected.

The next step is to add the required materials to our palette. For
this exercise, we will need the MicroStation Descartes Procedural
Material named DCDRAPE.PMA. Extract the Procedural Material

by opening the Palette File containing its definition and add it to

our custom palette.

0 Adding the DCDRAPE material

1. From the Define Materials File menu, select Open Palette.

2. Find and open DCDRAPE.PAL from the ustation\material

directory.
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3. From the Material pane, highlight the DCDRAPE item.
This stores the properties in the Define Materials dialog box.

gDeﬁne Materials: c:\win32app\ustation\material\dcdrape.pal

File
Materials: Shading: _Phong vI Ambient: |1.DD Dl T i 1}
Display: _Sphere vI Diffuze: |D.BD Dl || 1.0
Specular [0.40 o] | 1.0
-
Firish: [ 0.90 of I ]
Transmit: |D.DD 1] |I| 1.0
I Baze Color... | v Specular Color... |
¥ Cast Shadows ml
—Map:  Pattern Vll
Mame: dcdrape V' Transparent Background
wieight: [1.00 of [ ] 1.0
I aterial Mame: |dcdrape Angle: ID.DD ™ Elevation Drape
Sigex: [1.0000 Dffgetx: [0.0000 Master Units vI
sdd | | Delte | Replacs v: [1.0000 v: [0.0000 | I Fiip
Breview |
Clear | Edt | Select.. |

4. Open the custom palette file, MYPALETTE.PAL.

Notice the settings for the DCDRAPE material remains the same,
as the material template had already been defined. Now it is
possible to assign the DCDRAPE Procedural Material to a template
or to add it to the list.

0 Adding the DCDRAPE material to our list

1. Click on the Material Name field and press the <Return> key.
This enables the Add button.
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2. Click Add.
Note that the DCDRAPE material is now in the list.

gDeﬁne Materials: c:\win32app\ustation\dcartes\tutorialimypalette_pal

File
Materials: Shading: _Phong vI Ambient: |1.DD Dl T i 1}
Template Display: _Sphere vI Diffuse: | 0.50 of [ 1.0
Specuiar [000 0] ] 10
~
Firish: [ 0.90 of I ]
Transmit: |D.DD 1] |I| 1.0
I Baze Color... | v Specular Color... |
¥ Cast Shadows ml
—Map:  Pattern Vll
Mame: dcdrape V' Transparent Background
wieight: [1.00 of [ ] 1.0
I aterial Mame: |dcdrape Angle: ID.DD ™ Elevation Drape
Sigex: [1.0000 Dffgetx: [0.0000 Master Units vI
Add | Delete Feplace 5 [1.0000 v: (00000 | T Flip
Frenview
Clear | Edt | Select.. |

3. Close the Define Materials dialog box.
An Alert box opens asking if you wish to save the changes to
the MYPALETTE.PAL file.

4. Click Yes.

[0 The creation of the palette is performed only once. From this
point on, you will be working from the MYPALETTE.PAL palette
file.

[l If you wish to add more materials to your palette file, simply
follow the steps above.

The last step before draping is to instruct the Rendering process
to which element(s) the DCDRAPE procedural material is to be
applied. To do this, we will use the Assign Materials dialog box.
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O Assigning the DCDRAPE material to the 3D model DTM

1. From the Settings menu, select Rendering > Assign Materials.
The Assign Materials dialog box opens.

gAssign Materials: c:\win32appiustation\dcartes\tutorialidtm_mat

File Tools

M aterial: Levels Colors

Palette:

From the Assign Materials File menu, select Open Palette.

3. Open your custom palette, MYPALETTE.PAL.

Note that this creates a Material Table file named after the
prefix name of the master design file, in this case, DTM.DGN.

4. From the Palette pane, highlight DCDRAPE.
From the Assign Materials Tools menu, select Assign By

Selection.

gAssign Materials: c:\win32appiustation\dcartes\tutorialidtm_mat

Colars

Palette:  mypalette. pal

Display: _Sphere

|

Attach Material
Delete baterial Attachment

Set Environment Maps 3
Llear Environment baps

Freview Material
Edit Material

Template

-

5. From any view, identify a blue element from the DTM.

8-6 MicroStation Descartes Tutorial Workbook



Introducing Image Draping
Draping an Image - Tutorial

6. Accept the element by entering a data point in the
background of the view away from any element.

Notice the left pane showing the assignment of the DCDRAPE
material. The DCDRAPE material is assigned to ALL BLUE(1)
elements located on LEVEL 10.

gAssign Materials: c:\win32appiustation\dcartes\tutorialidim_mat
File  Tools

Material: Levels Colors Palette:  mypalette. pal Display: _Sphere ¥ |

Template
dedrape

7. Close the Assign Materials dialog box and click Yes when
prompted to save the changes.

0 Draping the image
1. From the Settings menu, select Rendering > Global Lighting.

The Global Lighting dialog opens. Ensure that Solar is turned
on and that Ambient, Flashbulb and Solar Shadows are off.

£ Global Lighting [x]
™ Ambient Intensity: | 0.30 NonemFull Calor... |

7| Elashbulb Intensity: | 0.30 | Mone [l il [E] Full | Color.. |
v Salar Intengity: | 1.00 NonemFull Caolor... |

™ Solar Shadows

Solar Shadow Reslutior: [512 o[ [ 4096

Solar Direction Yectar 3 |D.1930 o |-D.318 i |D.92?U ™ Lock

Azimuth Angle: I 148,78 Altitude Angle: I Ea.112

Locati Time
Longitude: IT * |3_ Time: IT : IW Fid vI
Latitude: [42 | * 21 Daylight |
GMT Offset: [ 5.0 Date: _July M | EN
‘ear IW
LCities... | Map... | Zones... |
™ Add Sky Light to all Solar and Distant Lights Calor... |

2. From the Location group, click the Cities button then
highlight Boston and click OK.

This sets the Solar Lighting for the city of Boston and will be
applied according to the Time Date and Year settings.
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3. From the Time group, ensure that the following parameters
match:

Time: 12:00 PM
Daylight

Date: July 3
Year: 1997

4. Ensure that Add Sky Light to All Solar and Distant Lights is off.
From the Utilities menu, select Render > Phong.

6. Enter a data point in View 2.
Watch as the draping is processed.

2 dim.dan (3D) - MicroStation SE [_[51x]
Fie Edit Elemert I

EEEE B EER [ EELE

o= e = |

|2 Global Lighting

I~ Ambient  Intensity: [000 None [T [T ] Full Color,
I~ Blashbub  Intensity: [000 | None T T [ Fuil Color,
W Solar Intensity [1.00 | None [ [0 Ful | Coler.

I~ Sglar Shadows

Solar Shadow Resolution: [512 () e 1

Solar DiteetionVector % [01920 Y. [0318 | Z: [09270 | [ Lok
Azpouth Argle: [T4878 | Alftude Angle: [E8.112 |
Location Time
Longiude: [71°[3 Time: [12 : [00 | _PM ¥
Latiwde: [42 2 [21

GMT Dffeet [5.0 Jul ~|[z

Date:
Gies. Map. Zones. Vear: 1857

I~ Add Sky Light ta all Solar and Distant Lights

Constant Shading > Select view Hj [@ [Level=1 [

Setting Light for the Scene

Draping uses the MicroStation Rendering engine. Rendering is
directly related to lighting. Adding lights makes the draping more
visible. Removing all light renders the rendered view in complete
darkness, whereas nothing will be visible. There are different
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types of lighting for this exercise. We will explore Flashbulb and
Gamma Correction.

In the previous draping exercise, Solar Lighting parameters were
set for noon on a sunny July day in 1997 thus the brightest time of
day. Our draped image would be darker if we were to change the
time of day parameter, thereby changing the inclination of the sun
reducing the sunlight. An alternative way of obtaining more light
for this scene is to add a Flashbulb and/or to increase the Gamma
Correction factor.

0 Adding a Flashbulb

1. From the Settings menu, select Rendering > Global Lighting.
The Global Lighting dialog box opens.
2. Turn on Flashbulb and set the other parameters as follows

Intensity: 1.0
Color: White

[_[57x]

| & Window 1-Top View
& Global Lighting || 8 Modify Color
I AmbientIntersiy [1.30 | None [T =] A Full | Color s Ce S = P (s

Wirgfiame:  Dihered: violet

Ny et red
I¥ Flashbub Intensty: [T00 None ST [0 Ful | Colo. | Ironiis
[ Solar Intensy: [1.00 Mone [ [0 Full | Colo. W ] white smoke

[
T Solar Shadons el geen
Solar Shadow Resolution: [E12 oI 1 4058 .
Sl Direcion Veotor & [01530 | . [0318 | 2 [08270 | [ Lock i) e cents

Colar Madel _RGB (0-255)
Aeimuth Argle: [T9578 | Alftude Angl: [66.112 =eries
Bed: [255

Location Time

il »
Longiude: [71 = [3 Tirg [12 | [00 | _PM_* o (B | P

Blue: [755
Latiude: [42 = [21 Dalight ¥ F -1, =
GMT Dffset: [50 Date: _Juy =[5 g g
= = o Cancel

2 Lites. Map. Zones. e L

I Add Sky Light to all Solar and Distant Lights Color,

Canstant Shading » Select vie [l (@ [tevel-1 [l

3. Close the Global Lighting dialog box.
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4. Phong Render View 2 by clicking View.
You will notice an increase of brightness for the image.

In addition to natural lighting, it is also possible to adjust the
gamma correction setting. MicroStation SE describes this setting as
follows:

“Affects the brightness of rendered images on the Right/primary
(and, if present, a Left/secondary) screen. Gamma correction
compensates for the spectral characteristics of the display (or
printer). The default value of 1.0 is close to ideal for most
monitors. The valid range is 0.1 to 3.0. Increasing the Gamma
Correction setting has the effect of lightening images; decreasing
it darkens images. A change in this preference is effective the next
time a view is updated.”

O Increasing the Gamma Correction

1. From the Workspace menu, select Preferences.
The Preferences dialog box opens.

2. From the Category list, highlight View Windows.

3. From the right pane, change Gamma Correction to 1.5.

Preferences [dcartes] [ <]

Lategory Custamize view window look/layout.

Description V' Scroll Bars on Yiew Windows 0K

goTiahblmy ™ Black Background -+ White ;I
atabase .

Drawing " Tile Like IGDS Cancel |

GUI Dptions

lcon Colors ¥ Use Backing Store

Input

Memory Uzage
Operation
Reference File

Tags

Teut

Tools

Tranglation [CharSet)
view Windows

Gamma Corection:

Direct Drawing: 0O =

Focus [tem Description

Right screen gamma canection. MicroStation 4.« default was 2.2, H

Haxig 1.0

4. Click OK.

5. Phong Render View 2 by clicking View.
Try different settings to experiment the effects of these settings.
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Setting Up For Continuous Draping

Rendered views automatically erase when updated. MicroStation
has a setting to instruct specific views to always display rendered
views using a target render mode.

O Setting up specific View Attributes

1.

4.

From the Settings menu, select Rendering > View Attributes.
The View Attributes dialog box opens.

Set View Number to 2.
This displays the view attributes for View 2.

Set Display to Phong Shading and Distance Cueing to None.

g Rendering Yiew Attributes E
Wiew Mumber. 2 vI

[+ Delayed Display v Shadows
¥ Pattem/Bump Maps ™ Iransparency

Display: _Phong Shading vI

Distance Cueing:  Mone hd I

7 Eisphics hecsiciator | Sefiings.. |
apply | al |

Click Apply.
View 2 will be updated and Phong Rendered.

Each time View 2 is updated, all rendered objects will be Phong
Rendered.

Saving Draped Views

Once the image has been successfully draped on the 3D model, it
is useful to save the Rendered View. The saved view can be:

Distributed for others to visualize it
Plotted

Opened at a later time for references on the Shading, Lighting
or any other aspect of rendering that can be optimized before
the final draping
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0 To save a draped view
1. From the Utilities menu, select Image > Save.
The Save Image dialog box opens.
2. Set the parameters as follows:

Save Image B

Miew: 2 vI
Fommat:  JPEG [JFIF]
LCompreszion:  Minimum Loss

Mode:  Grey Scale
Shading: Phong
Shading Type:  Mormal
Fesolution: 3 | 310 i |453
Garmma Corection: l E]

d]4[4[4]4

r Banded Renderi

[T Render Image In Bands

Memary [kBytes]: I A03 Continue. .. |

Murnber of Bands: |3

Save... I Cancel |

3. Click Save.

The Save Image As dialog box opens with the following
parameters:

File Name: DTM.JPG
Output directory: ...\out\image\

4. Save the file in the mse\out\image directory and name it
DTM.JPG.

5. Click OK.
View the saved image using the Display Image dialog box.

O Viewing a saved image

1. From the Utilities menu, select Image > Display.

The Display Image dialog box opens and should already be
pointing at the image you have just saved, DTM.JPG

2. Highlight DTM.JPG and click OK.

The Display Image dialog box loads and displays the image.
Several features are available through the pull-down menus.

3. Close the Display Image dialog box.
[0 Complete this tutorial by trying Walk Throughs, Fly Throughs, and

Animations. These features are all compatible with Image
Draping.
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