
7 Raster-to-Vector Conversion
Preview
In this lesson, you will learn how to:

• Set up the Vectorize for Advanced Conversion

• Use Themes in a Digitizing or Conversion Project

• Use the Vectorize Place Element Tool with the Raster Snap 
Feature

• Use the Vectorize Auto Convert Feature

• Use the Vectorize Convert Lines Tool

• Place and Delete Nodes

• Convert Cells and Text

Advanced Conversion Techniques
In MicroStation Descartes, four different methods are offered to 
you for document conversion.

• Conventional using Place Element tool and Raster Snap.

• Conventional using Place Element tool Raster Snap and Auto 
Continue feature.

• Convert Lines tool.

• Working with Nodes

You will get to digitize the same section of a drawing using these 
four methods.
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➤ Set up MicroStation Descartes

1. From the MicroStation Manager dialog box, select 
Workspace > dcartes.

2. Open the LESSON7.DGN file supplied with the tutorial in the 
…\dcartes\tutorial directory.

3. From the MicroStation Tools menu, select Image and the 
following tool boxes:

Image Control tool box

Theme tool box

Vectorize tool box
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➤ Open an image

1. Find the CONVERT.HMR image that is supplied with the 
tutorial. The file is in the …\dcartes\tutorial directory. 
Highlight the image.

2. Set the Image Preview setting to on. 

Notice the display of a thumbnail of the image in the Preview 
window.
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3. Make sure that the setting for View 1 is set to on. Click OK to 
open the image.

4. Dock the tools and arrange the screen as shown below.
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➤ Set up a Theme file

A Theme file has been created and attached to the project.

1. From the Theme tool box, select the Theme Styler Dialog tool.

The Theme Styler dialog box opens.

2. From the File menu, select Open.

The Open Theme File dialog box opens.

3. Find LESSON7.THM file that is supplied with the tutorial in 
the …\dcartes\tutorial directory. Select LESSON7.THM and 
click OK.
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4. Set the Road theme to on.

An X appears beside the Road name in the list box.

5. Close the Theme Styler dialog box.

➤ Creating a Project File and attaching it to the design file

1. From the MicroStation Settings menu, select Image > Project.

The Project Settings dialog box opens.

2. Set Save & Attach Automatically to on.

When on, a project is automatically created and saved each 
time you exit MicroStation Descartes.

3. Close the Project Settings dialog box.

➤ Setting up for document conversion

1. From the Vectorize tool box, select the Place Element tool.

2. From the tool settings, set the following parameters:

Raster Snap: On

Auto Convert: Off

Filter: Foreground

Entity: Line

Erase Raster: Off

Mode: Point

Theme: Road

Notice the box in the center of your pointer. This box serves 
as the foreground color locator. In order to Raster Snap to the 
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foreground color, this box MUST be over the foreground 
color of the image.

Depending on the scale and zoom factor in which you are 
working, you may need to adjust the size of the locate 
tolerance. The following shows appropriate and 
inappropriate locate tolerance sizes.

Locator

GOOD

The locator is over one line, snap occurs on this line.

GOOD

The locator is over one line, snap occurs on this line.
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When the tolerance is too big, snap can occur on any raster 
line. Therefore, snap will not always occur on the line to 
which you are pointing.

Besides the zooming factor, you also have to consider the 
distance between the raster lines.

To adjust the locate tolerance, use the following key-in: 

Key-in: SET LOCATE tolerance
OR

From the MicroStation Workspace menu, select Preferences. 
Then from the Category list, select Operation.

✍ For more information on the Locate Tolerance feature, consult the 
MicroStation User’s Guide and/or MicroStation Reference Guide.

3. From the MicroStation Workspace menu, select Preferences.

The Preferences dialog box opens.

4. From the Category list, select Operation.

5. Find the Locate Tolerance field, set the value to 10 and 
click OK.

6. From the Image Control tool box, select Fit Images to View.

7. Enter a data point in Window 1.

Note locations 1, 2 and 3. These locations highlight the 60' 
WIDE GAS PIPELINE EASEMENT. This pipeline is delimited 
by two raster lines. For the next exercise, you will work on 
the top raster line delimited by locations 1 to 3.

NOT GOOD

The locator is over two lines, snap occurs on the line 
closest to the center of the locator.
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Working With Nodes

Nodes appear in your drawing each time you create an element 
with the following Vectorize tools:

• Place Element

• Continue Element

• Convert Lines

• Convert All Connected Lines 

A node indicates the presence of a vertex on an element. The 
node is used to connect elements together so they can share the 
same UOR. When converting, a node connects all intersected 
lines by inserting a vertex on each crossing element.

Inserting nodes is most useful when using the Convert All 
Connected Lines tool. By default, this tool automatically converts 
all raster lines and when it comes to an intersection, starts 
converting in all directions. Inserting nodes at specific locations 
prevents the conversion of the whole document. This gives you 
better control over the automated process.

Nodes have precedence over a raster snap. When a data point is 
entered over a node, the inserted vertex is automatically 
connected to the node and not placed using the Raster Snap 
feature.

Nodes are not placed/created inside the design file. Nodes are 
stored in a node file. The node file is then read and each node is 
drawn on your screen. Therefore, nodes are not design elements.
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➤ Conventional Document Conversion

1. Fit View in Window 1.

2. From the Vectorize tool box, select the Place Element tool.

3. From the tool settings box, set Raster Snap to on.

4. Enter a data point at location 1 and enter points until you 
reach location 3.

5. Place your pointer so that the locator is touching the line 
work for each data point you enter.

✍ Use the Vectorize function key features to navigate in the image.

• Use <F5> to center the view using the position of the pointer.

• Use <F6> to center the view using the last entered point.

• Use <F8> to use the Spy Window.

✍ If you make a mistake and place a point at the wrong location:

• Use <F2> to undo data points.

• Use <F3> to redo data points.
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6. To see the effect of the Raster Snap feature, simply snap/data 
point at the Raster Snap test location.

Press <F2> once.

From the tool settings, set Raster Snap to off.

Snap/data point at the same location.

Note that the line is not snapped to the raster line.

The next step is to delete what you have just done.

➤ Deleting the elements and Nodes

1. Fit View in Window 1.

2. Place a fence from location F1 to F2.

3. From the Fence tool box, select Delete Fence Content and 
enter a data point to confirm.

4. From the Vectorize tool box, select the Delete Nodes tool.
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5. From the tool settings window, set Area to Fence and enter a 
data point to confirm.

Nodes are little red boxes that appear when you reset/
confirm the placement of an element with the Place Element 
tool.

In the next exercise, you will work on the raster lines delimiting 
the GAS PIPELINE.

➤ Document Conversion with the Auto Convert feature

1. Window Area around locations 3 and 4.

2. From the Vectorize tool box, select the Place Element tool.

3. From the tool settings, set Raster Snap, Erase Raster and Auto 
Convert to on.
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4. Snap/data point at location 1.

Note the message in the status bar, ENTER DIRECTION OR 
RESET TO COMPLETE.

When using Place Element with Auto Convert, you must 
specify in which direction you wish to convert the current 
raster line.

5. Enter a data point at location 2.

This informs the Auto Convert feature to convert the line in 
this upper-right direction.

The entire raster line is converted.

6. Reset to terminate/confirm placement of the element.

Notice that the raster line under the vector has been erased.

7. Snap/data point at location 4 and then at location 5. See what 
happens when the conversion process runs over an 
intersection.

You are asked again to choose a direction in order to 
continue the conversion process.
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8. Snap/data point at location 6.

The entire raster line is converted.

If necessary, use the <F6> (Center on Last Point) to see the 
end of the line.

9. Reset to complete placement of this line. 

➤ Document Conversion Using Convert Lines tool

1. Window Area around locations 3 and F2.

Note that each location is exactly positioned at an 
intersection.

2. From the Vectorize tool box, select the Convert Lines tool.

3. From the tool settings, set Auto Continue and Erase Raster to 
OFF.

4. Snap/data point to location A through E.

Note that no direction is required here. The process is 
executed in all directions. Using an intersection enables us to 
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simultaneously convert at least three different raster line 
segments.

5. Continue with locations F through K. but this time, from the 
tools settings, turn ON Erase Raster.

Notice that converted raster lines are automatically 
deleted (erased).
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➤ Adding Nodes for Automated Processing

1. Window Area around locations 7 and 8.

2. From the Vectorize tool box, select the Place Nodes tool.

3. From the tool settings, set Boundary to Block. 

This instructs the node to raster snap the element and also to 
connect it with any other intersected elements by inserting a 
vertex so that all intersected elements on that node can share 
the same UOR.

4. Snap/data point to location 7 and then 8.

Nodes are added to raster lines along the boundaries of the 
block. This prevents the Convert All Connected Lines tool to 
exceed the limit set by the nodes.
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➤ Document Conversion using Convert All Connected 
Lines

1. From the Vectorize tool box, select the Convert All Connected 
Lines tool.

2. From the tool settings, set as follows:

Filter: Foreground

Theme: Road 

Erase Raster: Off

3. Snap/data point at location 9.

The conversion process begins. You can see the lines appear 
as they are created.

Note that the creation of lines does not exceed the limits set 
by the nodes you have previously placed.

The final result looks as follows.

4. Close LESSON7.DGN and CONVERT.HMR.
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Converting Cells and Text
Text and symbols appearing on an image can be converted into 
lines. But it is more useful to convert symbols into cells and raster 
text into text elements (type 17). The following exercises show 
you how to easily replace raster symbols with MicroStation cells 
and raster text with MicroStation text elements.

➤ Converting Cells

1. Open the LESSON7B.DGN file supplied with the tutorial in 
the …\dcartes\tutorial directory.

2. Find the DRAWING.HMR image that is supplied with the 
tutorial. The file is in the …\dcartes\tutorial directory. 
Highlight the image and open it.

3. Window Area around location A.

The Window 1 area should look as follows.

4. From the MicroStation Element menu, select Cells.

The Cell Library dialog box opens.

5. From the File menu, select Attach.

The Attach Cell Library dialog box opens.

6. From the …\dcartes\tutorial directory, select LESSON7.CEL 
and click OK.

7. Select the LES5 cell from the list box.

8. From the Active Cells option group, click the following 
buttons:

Placement

Terminator

Point

Pattern

9. Close the Cell Library dialog box.
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10. From the MicroStation Tools menu, select Image > Text/Cells.

The Text/Cells tool box opens.

11. From the Text/Cells tool box, select the Convert Cell tool and 
set the tool settings as follows:

Theme: None

Erase Raster: OFF

12. Snap/data point at location A1.

The cell is automatically placed.

13. Delete the cell.

14. Update View and try it again with the Erase Raster tool setting 
set to on.

The raster symbol is erased.

15. Window Area around location B.

The Window 1 area should look as follows.

16. From the Text/Cells tool box, select the Convert Oriented Cell 
tool.

17. Snap/data point at location B1.

18. Move the pointer to set the orientation and reset.

The cell is automatically placed and the raster symbol erased.

19. Move the pointer to size the cell, then enter a data point and 
press Reset.

20. Fit View in Window 1.
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➤ To convert text

1. Window Area around location A.

The Window 1 area should look as follows.

2. From the MicroStation Tools menu, select Image > Text/Cells.

The Text/Cells tool box opens.

3. From the Text/Cells tool box, select the Select Horizontal Text 
tool and set the tool settings as follows:

Convert Now: ON

Shrink Selection To Text: ON

Filter: Foreground

4. Select the raster text by entering a data point at location A2 
and location A3.

Note that the selection is automatically shrunken to fit the 
extent of the raster text.

5. Set the tool settings as follows:

Theme: None

Fit Text: ON

Erase Raster: OFF

Text Editor: V007
7-20 MicroStation Descartes Tutorial Workbook



Raster-to-Vector Conversion
Converting Cells and Text
6. Click Done.

The text is pasted to fit the raster text.

7. Repeat steps 3 to 6 and set the Erase Raster tool settings 
to on.

8. Click Done.

The raster text is erased.

When several raster text entries have to be converted, you 
may want to do it in a batch.

9. Fit View in Window 1.

➤ Converting Multiple Raster Text

1. Window Area around location C.

Window 1 should look as follows.

2. From the Text/Cells tool box, select the Select Horizontal Text 
tool and set the tool settings as follows:

Convert Now: OFF

Shrink Selection To Text: ON

Filter: Foreground

3. Select the raster text in three distinct groups as follows.

Notice that the selections are automatically shrunken to fit the 
extent of the raster text.
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4. From the Text/Cells tool box, select the Convert Text tool and 
set the tool settings as follows:

Theme: None

Fit Text: ON

Erase Raster: OFF 

Notice that the first text selection “L -003-” is highlighted.

5. From the Text Editor box, proceed as follows:

TEXT: L -003 — Click the right arrow button.

TEXT: AA — Click the right arrow button.

TEXT: HCC-4” — Click the End button.

6. Update View for Window 1.

The text is pasted to fit the raster text.

Practice
This lesson does not cover all of the functions related to 
Advanced Conversion Techniques. You should explore other 
functions by reviewing chapter 11 “Preparing Theme Symbology” 
and chapter 12 “Vectorizing” of the MicroStation Descartes User’s 
Guide.

Here are a few of the functions you should explore:

• Convert Lines with the Auto Continue feature

• Converting Contours

• Managing Node Files
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