
5 Image Interpretation
Preview
In this lesson, you will learn how to:

• Set up Vectorization 

• Use the Vectorize Heads-up Digitizing Functions

• Use Spy Window

• Use Raster Snap

• Set up Theme Styler 

• Open a Theme File

• Display Themes

• Modify a Theme

• Create a Hatch

• Create a Theme

• Set a Theme
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➤ Set up MicroStation Descartes

1. From the MicroStation Manager dialog box, select 
Workspace > dcartes.

2. Open the LESSON5.DGN file supplied with the tutorial. The 
file is in the …\dcartes\tutorial directory.

3. From the MicroStation Tools menu, select Image > Image 
Control and dock it under the MicroStation Main tool box.

4. From the MicroStation Tools menu, select Image and the 
Vectorize and Theme tool boxes.

➤ Open an image

1. From MicroStation File menu, select Open > Image. 

The Open Images dialog box opens.

2. Find the EAST-ANG.HMR image that is supplied with the 
tutorial in the …\dcartes\tutorial directory. Highlight the 
image.

Vectorize tool box

Theme tool box
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3. Set the Image Preview setting to on. 

Notice the display of a thumbnail of the image in the Preview 
window.

4. Check that the settings for View 1 is set to on.

5. Click OK to open the image.

The screen should appear as follow.
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6. Using the Select Images/Active Image tool, double-click on 
EAST-ANG.HMR to make it the active image.

➤ Set up Vectorize

1. From the Vectorize tool box, select the Vectorize Settings tool.

2. Click on Center Views in the Category box. Turn off all 
toggles except the one for View 1. 

3. Select OK to confirm and exit.
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4. Window Area around locations 1 and 2 in Window 1. 

Window 1 should appear as follows.

You are now ready to digitize.

Snap-Assisted Digitizing

➤ Digitize a drawing

1. From the Vectorize tool box, select the Place Element tool.

2. Set the tool setting as follows:

Raster Snap: OFF

Auto Convert: OFF

Mode: Point

Theme: None

Erase Raster: OFF

3. Set the Active Color to Red and the Line Weight to 3 in the 
MicroStation Primary Tools tool box.
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4. In Window 1, enter a data point at location 1. Digitize the 
road until you reach the location 2. 

Your data points should be entered as displayed in the image 
below.

5. Select <F5> to recenter the view around the cursor position. 

Only Window 1 will be recentered, since it is the only view 
with Center Views set to on. If other views were on, they 
would also be recentered around the same point regardless of 
their scale. The next location, 3, will now be visible. Enter a 
data point at location 3. Repeat step 5 to digitize 3, 4 and 5.

6. If you make a mistake when you enter a data point, do not be 
concerned. Press <F2> two times. Notice that the data points 
are removed. Also notice that you are still in the Place 
Element function and that you can immediately enter the next 
data point.

7. Press <F3> three times to reinsert the points that were 
removed. Note that you can use <F2> and <F3> to quickly 
correct mistakes by moving along the captured line string. 
Accept the element.

You can restart a line string that was terminated at any time 
without losing your previous work.
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8. From the Vectorize tool box, select the Continue Element tool.

9. In Window 1, enter a data point on the element at the point 
that was accepted in the previously at location 5.

The line string highlights for acceptance.

10. Enter a data point and resume digitizing up to location 6.

11. To convince yourself that the line string can be treated as one 
entity, press <F2> five times. Each time that you press <F2>, 
you remove a point. To reinsert the points, press <F3> five 
times.

12. You may also use the digitizing functions to snap to a line. To 
practice this function, select the Place Element tool. Place 
your pointer at location 6, just over the line.

13. Press <F4> to snap the new line to the element. The element 
highlights for acceptance. Accept the element with a data 
point. Resume digitizing up to location 7.

The snap creates a node at the break point of the line string 
and segments the target element creating a node at the 
intersection point.

At any time while you digitize, you may use a View Control 
tool. The digitizing function temporarily suspends while the 
View Control function is executed. The digitizing function is 
restarted by entering Reset. Use the Zoom In control as you 
digitize to practice this feature.
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➤ Use the Spy Window

1. Move the pointer to where you want to enter the next point 
and press <F8>. 

This action opens the Spy Window, centered around the 
pointer position.

2. Digitize a point inside the Spy Window for better precision.

3. Press <F8> twice to open and close the Spy Window. (Notice 
that <F8> is a function key to open or close the Spy Window.)

4. Enter two more data points with the Spy Window (use <F6> if 
you need to recenter the view) and Reset.

This action terminates your line string and permanently 
inserts the element into the design file.

5. Fit View in Window 1.
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➤ Digitize precisely with Raster Snap 

1. Window Area around location 8.

2. From the Vectorize tool box, select the Place Element tool. 
Check that Raster Snap is set to on.

3. Snap/data point at location 8. Notice that you are close to but 
not on the raster lines. Make sure that the line falls within the 
square about the pointer.

4. Enter several points in the same manner and use <F5> if 
necessary. Use locations 9 to 11 to guide you if you are 
unsure. 

The Raster Snap feature continuously adjusts the points and 
the resulting line string fits well over the raster line. 

5. Press Reset to terminate the line string

6. Fit View in Window 1.
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➤ Set up Theme Styler

1. From the Theme tool box, select the Theme Styler Dialog tool.

The Theme Styler dialog box opens. 

➤ Open a Theme File

1. From the File menu of the Theme Styler dialog box, select 
Open. 

The Open Theme File dialog box opens.

2. Find and open the LESSON5.THM file that is supplied with 
the tutorial. The file is in the …\dcartes\tutorial directory.

You will see a list of themes displayed in the Theme Styler 
dialog box.
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3. Highlight the ROAD theme in the list box to select the ROAD 
as the active theme.

➤ Display a Theme

Theme Styler resymbolizes the elements in your file according to 
the theme definitions that are presently active.

1. From the Options menu, turn on the Display item. Use 
Update View to refresh the display in Window 1. 

Notice that the vectors are now resymbolized with the theme 
symbology.

2. You may selectively turn on or off themes with the Theme 
Styler dialog box.

Notice the X on the left hand side of the theme in the Theme 
list box. This X indicates that the theme is on. Double-click 
on the ROAD theme in the Theme Styler dialog box. Notice 
that the X is not displayed. The lack of an X indicates that the 
theme is off.

3. From the View Control bar of Window 1, select Update View. 

Notice that all the ROADS are not displayed now.

4. Repeat steps 2 and 3 for the HOUSE theme. 

Notice that the HOUSE is not displayed.

5. To turn all the themes back on, double-click on ROAD and 
on HOUSE, and then execute an Update View of Window 1.

➤ Modify a Theme

Theme Styler permits you to change the definition of a theme.

1. From the list of themes in the Theme Styler dialog box, click 
on the ROAD theme. 

The Theme Styler Description group now contains the 
definition of the ROAD theme.

2. From the Line Weight option menu, select weight #8.

3. From the Contour Color option menu, select blue.

4. Click Modify.
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5. Execute an Update View of Window 1. The ROADS will now 
be resymbolized.

6. Theme Styler does not affect the original design elements. 
Turn off the Display toggle and update Window 1. 

Notice that the elements revert to their original symbology.

7. Turn on the Display toggle and update Window 1. 

Notice that the elements are again resymbolized.

➤ Create a Theme

Theme Styler permits you to define a theme from within a work 
session. The best approach is to start with an existing theme and 
then to modify its definition parameters to create a new theme.

1. From the Theme Styler dialog box, select the HOUSE theme 
in the list of themes. The definition of the theme displays.

2. The next task is to create a specific theme for B_HOUSE. 
Enter the following parameters into the Description box.

Field Value(s)

No 40

Name B_HOUSE
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3. Keep the default values for all other parameters.

4. Click the Add button. 

The new theme is created.

➤ Attach a Theme to graphic elements

Once a theme is created, it may be applied to graphic elements.

1. Execute a Window Area around locations 12 and 13.

2. Create a selection set with the elements located at locations 
12 to 13.

3. From the Theme tool box, select the Change Theme tool.

4. From the tool settings window, select B_House to make it the 
Active Theme.

5. Enter a data point anywhere in Window 1.

The selection set is updated with the Active theme definition.

Level 1

Description Big House

Line Type #0

Line Weight #4

Contour Color Red

Field Value(s)
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➤ Digitize with an Active Theme

1. Fit View and then Window Area around locations 14 and 15.

2. From the Vectorize tool box, select the Place Element tool.

3. In the Place Element settings box, set the active theme to 
B_House.

4. Digitize the houses between locations 14 and 15 and use 
<F7> to close polygons surrounding each house.

Notice that the house line is drawn in the symbology of the 
B_House Theme.

➤ Create a hatch

Theme Styler permits you to define a hatch that can be used with 
a theme.

1. From the Hatch menu of the Theme Styler dialog box, select 
Edit. 

The Hatch Editing dialog box opens.
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2. Enter the following parameters into the Description box.

3. Click the Add button. The new hatch will now be created.

4. From the File menu of the Hatch Editing dialog box, select 
Save As. Enter LESSON5.HAT in the Save File dialog box and 
click OK to save the file.

5. Click OK to exit. 

6. From the list of themes in Theme Styler, select the B_House 
theme.

This action displays the definition of that theme.

7. From the Hatch menu of the Theme Styler dialog box, select 
Select. The Select Hatch File dialog box opens. 

8. Select the LESSON5.HAT file that you have just created and 
click OK. This name displays in the Hatch File field in the 
Theme Styler dialog box.

9. Locate the Surface option group. Enter 1 in the Hatch # field.

10. Click Modify. 

You have now added a hatch to the Cross Hatch theme.

Field Value(s)

No 1

Type Cross Hatch

Line Style #0

Line Weigh #1

Color Yellow

Spacing x: 1.5 y: 1.5

Angle x: 45    y: -45
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11. Execute an Update View and then a Fit View in Window 1 to 
see the effect of the change.

Practice
This lesson does not cover all of the functions related to Image 
Interpretation. You should explore other functions by reviewing 
chapter 12 “Vectorizing,” chapter 13 “Converting Text and 
Symbols from Raster to Vector” and chapter 11 “Preparing Theme 
Symbology” of the MicroStation Descartes User’s Guide.

Here are a few of the functions you should explore:

• Vectorize Place Element tool using Raster Snap, Auto Convert 
and Erase Raster

• Raster Snap on Tentative

• Line and Outline mode on surfaces

• Patterns

• Update Design File

• Select Theme Tool

• Query Theme Tool
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