
3 Georeferencing and Mosaics
Preview
This lesson highlights all of the basic operations you need to 
create a seamless mosaic image. 

This lesson starts the process from freshly-scanned images and 
continues through the following operations:

• Batch Conversion and Color Compression

• Contrast Stretch

• Georeferencing

• Resampling

• Creating a Seamless Look

Batch Conversion and Color Compression
One of the most important operations is to properly prepare the 
images. This section focuses on:

• Converting the images

• Allowing room in the color tables for a transparent color
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3 Georeferencing and Mosaics
Batch Conversion and Color Compression
➤ Set up MicroStation Descartes

1. From the MicroStation Manager dialog box, select 
Workspace > dcartes.

2. Open the LESSON3.DGN file supplied with the tutorial. The 
file should be in the …\dcartes\tutorial directory.

Converting the Images
For this exercise, we will use the Batch Conversion feature. This 
feature, through its complete interface, allows us to specify all of 
the required parameters in order to obtain images at the proper 
scale and format and to standardize the number of gray levels in 
the color tables.

W Though images can be opened as is, it does not allow to reduce 
the number of colors. By batch converting, all three images will 
have a reserved color for the transparent color.
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Georeferencing and Mosaics
Converting the Images
➤ To convert the images

1. From the MicroStation File menu, select Batch Conversion.

The Batch Conversion dialog box opens.

2. Change the directory to …\dcartes\tutorial and select 197.TIF, 
198.TIF and 199.TIF.

You can also set the List of File Types to TIFF (*.tif) to reduce 
the number and types of images to display in the Files list 
box.

✍ Multiple selections are accessible by pressing the <Ctrl> and/or 
<Shift> key while clicking.

3. Set the Output section as follows:

Type: HMR[*.hmr]

Pixel Type: Gray Scale

Data Compression: Deflate

Directory: …\dcartes\tutorial

Next, we will set the number of gray levels for each image so that 
all the images will look alike and also to free the last color that 
will be used for applying transparency.
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Batch Conversion and Color Compression
➤ To set the Color Compression options

1. Select Color Compression.

The Color Compression Setup dialog box opens.

2. Set the number of colors to 254.

We will use color 254 for background transparent color.

3. Click OK.

4. Click OK in the Batch Conversion dialog box to start the 
batch conversion process.

The Batch Conversion Progress dialog box opens. 

5. When the three files are successfully converted, click OK.

Optimizing the Contrast and Tone Balance
These features allows you to optimize the color table so that all 
images display identical contrast and shade.

There are two methods that can be used to sharpen and balance 
images that will form a mosaic. The quickest or easiest method 
consists on using one single tool - Tone Balance along with the 
Average method. 

Tone Balance creates a tone balance among all selected images 
by averaging the Histograms of all three images. The resulting 
Averaged Histogram is then applied to the images. In this 
scenario, all images are changed.

The preferred method is to choose the best image, apply a 
Contrast Stretch and then proceed with a Tone Balance using this 
corrected image as a Reference. In this scenario, all images except 
the one chosen as the reference are modified by applying the 
histogram of the reference image to all other selected images. 
This is the method that we will use.
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Georeferencing and Mosaics
Optimizing the Contrast and Tone Balance
➤ To optimize the contrast

1. From the MicroStation File menu, open the Descartes - Image 
Manager dialog box and select View 2.

2. Open all three images in the following order.

199.hmr = Top position
198.hmr = Middle position
197.hmr = Bottom position

3. From the Image Manager dialog box, select Display > Fit All 
Images to View and enter a data point in view 2.

4. Set 199.HMR as active, either by double-clicking on the file 
name in the Image Manager dialog box or using the Select 
Images/Active Image tool and double-clicking on the image.

5. From the MicroStation Utilities menu select Image 
Enhancements > Contrast Stretch.

The Contrast Stretch dialog box opens.

6. Enter 20 in the Minimum field and 175 in the Maximum field 
and press <Enter> or <Tab>.

Notice the Exploration Devices getting into position at the 
entered indexes. Notice also that the image is now much 
clearer.

7. In the exponent field, enter “0.70.”

Notice the curve (green diagonal line) which is now slightly 
concave.

8. Click Done.

A Warning dialog box opens prompting you to apply the 
changes to the image’s color table.

9. Click Yes.
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3 Georeferencing and Mosaics
Batch Conversion and Color Compression
➤ To Tone Balance all three images

1. From the Tools menu, select Image > Mosaic.

The Mosaic tool box opens.

2. Select the Tone Balance tool.

3. From the tool settings, set Mode to From Reference and 
Source Area to Entire Image.

4. In turn, select 197.HMR and 198.HMR.

5. Accept the selection with a reset.

6. Select the image to use as the Reference, 199.HMR.

This is the image we have done a Contrast Stretch earlier.

7. With 199.hmr highlighted with a dotted line, accept with a 
data point.

All three images are now similarly balanced.

Georeferencing and Resampling the Images
Now that all of the images are ready, the next step is to fit them in 
to the design file.

1. From the MicroStation Tools menu, choose Image > Register.

2. From the Register tool box, select the Register Dialog tool.

The Register dialog box opens.

3. Be sure the Model Selected is (3 pts or +) Affine-1.

4. From the View menu of the Register dialog box select Views 
Displaying Uncorrected Data. Turn on View 2 and turn on 
Also Display Non Warped Elements.
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Georeferencing and Mosaics
Georeferencing and Resampling the Images
5. From the View menu, set Dynamic Warping in Views 
Displaying Uncorrected Data item to on.

6. Fit View in Window 1. Select image 197.HMR and Bring To 
Front. Fit Image To View and set image as active. At this point, 
you should see the design file in Window 1 and the image 
197.HMR in Window 2.

7. From the Register tool box, select the Place Control Points 
tool. 

8. Place the base control point on the vector data in Window 1 
as displayed below.
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3 Georeferencing and Mosaics
Batch Conversion and Color Compression
9. Place the uncorrected point on the image in Window 2 as 
displayed below.

When you have placed the uncorrected control point, 
Register moves and redisplays the vector data on your image. 
Register also adds the pair of points to the Register dialog box 
in the list of control point.

10. Repeat this warping process using the control points shown 
below. Place the point first on the vector data (shown on left 
here) and the second one on the image (shown on right). 
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Georeferencing and Mosaics
Georeferencing and Resampling the Images
After placing these points, the vector data should appear to 
be correctly overlaid on the image.

Point 2:

Point 3:

Point 4:

Point 5:
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3 Georeferencing and Mosaics
Batch Conversion and Color Compression
➤ Resample an Image

1. From the Register tool box, select the Resample Image tool. 

The Resampling dialog box opens. 

Note that the input image is the image set as active. The 
output image is automatically assigned (in this case, it is 
grayed out). The model file is the name of the current image 
plus the extension.rgr (in this case, 197.RGR). 

✍ Make sure that Create a New Image is turned off.

2. Close the Resampling dialog box and from the File menu of 
the Register dialog box, select New to begin a new.RGR file. 

3. From the Register dialog box, select Affine-1 for the Model.

4. Select image 198.hmr and bring it to front. 

5. Do a Fit Image to View and set the image as active. 

6. From the Register tool box, select the Place Control Points 
tool. 

7. Place the base control point on the vector data in Window 1 
and then place the uncorrected point on the image in 
Window 2, using the following points.

When you have placed the uncorrected control point, 
Register moves and redisplays the vector data on your image. 
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Georeferencing and Mosaics
Georeferencing and Resampling the Images
Register also adds the pair of points to the Register dialog box 
in the list of control points.

Point 1:

Point 2:

Point 3:

Point 4:
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3 Georeferencing and Mosaics
Batch Conversion and Color Compression
Point 5:

8. From the Register tool box, select the Resample Image tool. 

The Resampling dialog box opens. Be sure you are on page 
2/2 and the input image is 198.HMR and the model file is 
198.RGR. The output image must be grayed out. If not, turn 
OFF Create a New Image option.

9. From the File menu of the Register dialog box, select New to 
begin a new.RGR file. 

10. From the Register dialog box, select Affine-1 for the Model.
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Georeferencing and Mosaics
Georeferencing and Resampling the Images
11. Repeat steps 5 through 8 to georeference and resample 
199.HMR using the following control points.

Point 1:

Point 2:

Point 3:

Point 4:
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Batch Conversion and Color Compression
Point 5:

12. When you have completed the georeferencing for each image 
and your resampling file has three pages, click Run All. An 
Alert dialog box will ask you if you really want to submit the 
resampling of images. Click OK.

13. When the resampling is complete, 197.HMR, 198.HMR and 
199.HMR will be automatically moved under the design file 
elements. 

After a Fit View, Window 2 should look as follows.
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Georeferencing and Mosaics
Creating the Seamless Look
Creating the Seamless Look
Creating the seamless look is achieved by removing unwanted 
portions of an image’s overlap factor and boundary while using 
the image beneath to replace the removed portions of the top 
image. It’s like cutting down two pieces of a puzzle.

The cutting process can be achieved automatically or semi-
automatically. During the process, the top image is cut. To hide 
the seam of the cut, “feathering” is applied alongside the seam on 
both images. This renders the seam nearly invisible. To achieve 
such results, we will use the Define Seam tool from the Mosaic 
tool box.

➤ To create a seamless mosaic

1. From the MicroStation Tools menu, select Image > Mosaic.

2. Before going on, using the Send to Back and/or Bring to 
Front tools, set the images to match the following order.

199.hmr = Top position
198.hmr = Middle position
197.hmr = Bottom position

✍ From the Image Manager dialog box, the image at the top of the 
list is always the one on the top.

3. From the Mosaic tool box, select the Define Seam tool.

4. From the tools settings window, set the values as follows:

If you look at the status bar, you will notice the message: 
Define Seam > Select First Image.
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3 Georeferencing and Mosaics
Batch Conversion and Color Compression
5. Enter a data point on the top image, 199.hmr.

• You can enter the data point on the image name located at 
the bottom-right corner.

• A blue outline surrounds the image.

• If you look at the status bar, you will notice the message:
Define Seam > Select Second Image.

Blue Outline
Click Here to select the image
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Creating the Seamless Look
6. Enter a data point on the center image, 198.hmr.

• You can enter the data point on the image name located at 
the bottom-right corner.

• A blue outline surrounds the image.

• If you look at the status bar, you will notice the following 
message: Define Seam > Accept to mosaic images.

7. If you have selected the right images: 

• Confirm the selection using a data point.

• Or Reset and restart from step 3.

8. At this point a lot of activity appears in the status bar. This is 
normal, sit back and wait until the automated mosaic is 
terminated.

Blue Outline
Click Here to select the image

Seam and cutting Area
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Batch Conversion and Color Compression
9. Repeat the same process for 197.HMR and 198.HMR.

The final result should look as follows.

➤ Creating a new image using Corridor

1. Place a block using the MicroStation Place Block tool that 
includes the three images you have just warped, but excludes 
labels and marks.

2. Using the MicroStation Copy tool, copy an element and place 
it below the mosaic.

3. From the MicroStation Tools menu, select Image > Image 
Transform.

4. Select the Corridor tool.

5. Identify the closed element previously created over the 
mosaic as the source polygon and accept it.

6. Identify the element below the mosaic as the destination 
polygon and accept it. 

The Output Image Creation dialog box opens.

7. Set the Image section as follows:

Output File Name: …\dcartes\tutorial\final.hmr

Data Compression: Deflate

Finished Mosaic
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Creating the Seamless Look
8. Set the DGN Elements section as follows:

Copy DGN Elements: ON

Copy Mode: Clip

9. Click Options and set as follows:

Output Color Table: Active Image

Background Color: 254

Transparent: ON

Color Min.: 0

Color Max: 255

Leave the other settings as they are.

10. Click OK, then click Run. 

At the end of the process, final.hmr automatically opens.

Congratulations! You have created a nice mosaic.
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