
2 Positioning Images
Preview
In this lesson you will learn how to:

• Set up MicroStation Descartes to Position Images

• Quickly Position an Image with Square

• Quickly Warp an Image with Warp

• Move and Scale an Image

In this lesson, you will also learn basic georeferencing techniques. 
In this part of the lesson, you will learn how to:

• Set up Register

• Reference an Image

• Save a Model

• Resample an Image

• Add an Image to a Project
MicroStation Descartes Tutorial Workbook 2-1



2 Positioning Images
Positioning Images
Positioning Images

➤ Set up MicroStation Descartes

1. From the MicroStation Manager dialog box, select 
Workspace > dcartes. 

2. Open the design file LESSON2.DGN that is supplied with the 
tutorial. The file is in the …\dcartes\tutorial directory. 

3. From the MicroStation Tools menu, select Image > Image 
Control and dock it under the MicroStation Main tool box.

➤ Open an image

1. From the MicroStation File menu, select Open > Image. 

The Open Images dialog box opens.

2. Find the SQUARE.HMR image that is supplied with the 
Tutorial. The file is in the …\dcartes\tutorial directory. 
Highlight the image.
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3. Set the Image Preview setting to on. Notice the display of a 
thumbnail of the image in the Preview window.

4. Check that the setting for View 1 and 2 are set to on. 

5. Click OK to open the image.

The screen should appear as follows.
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➤ Position an image with Square

1. Using the Select Images/Active Image tool, double-click on 
SQUARE.HMR to make it the active image.

2. From the MicroStation Tools menu, select Image > Image 
Transform.

3. From Image Transform tool box, select the Square Image tool.

The Image Transform Image Square settings tool box opens. 

4. In the tool settings window, set Axis to Horizontal and ensure 
that Create A New Image is turned OFF.

5. Notice that the cursor in Window 1 changes to a cross. Use 
the Square tool to adjust the image to a horizontal position 
just as you would arrange a drawing on a drafting table.

6. Enter a data point in the target image.

7. To enter the first horizontal point, snap at location 1 and 
enter a data point.

8. To enter the second horizontal point, snap at location 2 and 
enter a data point.

The image then adjusts to be square to your view.

Warping Images Quickly With Warp

➤ Position an image with Warp

1. Bring Window 2 to front. Notice that the shape of the design 
block element is similar but not identical to the shape of the 
image. The objective of this exercise is to warp the image to 
fit exactly within the space and shape defined by the design 
block.

2. From the Image Control tool box, select Select Images/Active 
Image and double-click on the image at location 5.
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3. From the Image Transform tool box, select the Warp Image 
tool.

The Image Transform Warp settings tool box opens. 

4. From the tool settings window, set Method to 3 (pts) Affine 
(Move, Rotate, Scale, Lean) and ensure that Create A New 
Image is turned OFF.

Notice that the pointer changes to a crosshair. You will use 
the crosshair to identify points on the image that correspond 
to points on the design block element.

5. Enter a data point in the target image.

6. Select the first point on the image at location 1.

7. Select the corresponding point at location 1 on the design 
block element.

8. Repeat the procedure for locations 2 and 3 only.
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9. Accept the points by entering a data point.

The image will then be warped to fit the target geometric 
space.

Modifying Images

➤ Moving an image

1. From the MicroStation Tools menu, select Image > Undo/
Redo.

2. Undo the Warp you have done previously by selecting the 
Undo Image tool.

3. From the Image Transform tool box, select Modify Image.

Notice that the pointer changes to a cross with a “bull’s-eye” 
in the center.
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4. Enter a data point in the target image at location 1.

Be sure to be on the image, tentative on the marker.

5. Tentative/Accept at location 5. Move the pointer and notice 
that the image travels with your pointer movements. Snap/
confirm to location 4 and notice that the image is fixed in a 
new location.

6. Click the Undo tool to return the image to its original 
position.

➤ Scaling an image

1. From the Image Transform tool box, select Modify Image. 

2. Enter a data point in the target image a location 4.

This point identifies the image and also positions the Origin 
Handle. This handle acts like an “Anchor Point.” Operations 
like rotate and affine are done about that point.

3. Snap/data point to location 1. 

Notice that the pointer now changes to an X shape.

4. Notice also that an outline shape appears. Without clicking, 
move the pointer towards location 5. Notice that the shape or 
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scale of the outline changes to adjust to your movements. 
Snap/data point at location 5.

Note that the location of the Origin handle stays “fixed.” All 
other pixels of the image are repositioned for the exception 
of this point.

The image immediately scales to fit the outline scale.

➤ Modifying the geometry of an image (Rotation and 
Affinity)

1. From the Image Transform tool box, select Modify Image. 

2. Enter a data point in the target image a location 5.

This sets the target image as well as the Origin handle.

3. Enter a data point on the “arc double-headed arrow” located 
at the top-right corner of the image, just above the scaling 
handle. 

Notice that the pointer now changes to an X shape. You have 
selected the Rotation handle. The rotation handles allow you 
to rotate the image about the Origin handle.

4. Notice also that an outline shape appears. Without clicking, 
move the pointer towards location 2. Notice that the 

Rotation Handle at 
location 5
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orientation of the outline changes to adjust to your 
movements. Snap/data point at location 2.

The image immediately displays to fit the outline orientation.

Note that the location of the Origin handle stays “fixed.” All 
other pixels of the image are repositioned for the exception 
of this point.

5. Next, you will modify the affinity of the image. Enter a data 
point on the Affinity handle (double headed straight arrow) 
located between locations 2 and 5.

6. Notice that an outline shape appears. Without clicking, move 
the pointer towards location 5. Notice that the geometry of 

Location of the 
Affinity Handle
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the outline changes to adjust to your movements. Snap/data 
point at location 2.

The image immediately displays to fit the outline affinity.

Note that the location of the Origin handle stays “fixed.” All 
other pixels of the image are repositioned for the exception 
of this point.
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Complete this section to learn how to warp with geometric 
precision.

➤ Set up MicroStation Descartes for Register

1. Close Window 1 and 2. Make sure Windows 3 and 4 are 
opened.

2. From the MicroStation Tools menu, select Image > Register.

The Register tool box opens. 

3. From the Register tool box, select the Register Dialog tool.

The Register dialog box opens.

4. From the MicroStation File menu, select Open > Image. 

The Open Images dialog box opens.

5. Find the MAP_3.HMR image that is supplied with the Tutorial. 
This file is in the …\dcartes\tutorial directory.

6. Set the image preview to on. Notice the display of a 
thumbnail of the image in the Preview window.
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7. From the Views group, set View 3 on and all other views off 
and click OK.

MAP_3.HMR opens and displays in Window 3.

8. From the Image Control tool box, select Select Images/Active 
Image tool and double-click on MAP_3.HMR to make it the 
active image.

A dotted border appears around the image meaning that this 
image is the active image.
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9. Arrange the screen as follows.

➤ Set up Register

You are now ready to set up the Register dialog box. If necessary, 
bring the dialog box to the foreground.

1. The first step is to indicate which view contains uncorrected 
data. In this exercise, View 3 contains an uncorrected image. 
From the Register dialog box, select View > Views Displaying 
Uncorrected Data.

The Views Displaying Uncorrected Data dialog box opens.

2. Turn on View 3 and Also Display Non Warped Elements.

3. Click OK to close the dialog box.
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4. From the View menu, set the Dynamic Warping in Views 
Displaying Uncorrected Data item to on.

5. From the Settings menu, select Colors for Control Points.

The Colors for Control Points dialog box opens.

6. Set the colors as follows:

Base: 2(Green)

Uncorrected: 3(Red)

7. Click OK.

8. Specify the mathematical model that you will use to correct 
the image. Set the Model Selected option of the Register 
dialog box to (3 pts or +) Affine item.

This choice becomes the model that will be applied.
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➤ Reference an image

You are now ready to begin. 

1. From the Register tool box, select the Place Control Points 
tool. Place the base control point mark on the vector data in 
Window 4 by snapping/data point at location 1 as displayed 
below.

✍ When snapping to location markers in Window 4, snap to the 
marker. Do not try to snap on the element. The location of the 
marker has been precisely positioned for optimal results.

At any time during the referencing process you may use the 
MicroStation view control and view image control functions to 
display the image and vector data. Use a scale appropriate for the 
placement of the control points.

✍ Notice that in the views displaying uncorrected data, the Fit View 
function will not work on the uncorrected vector data. You 
should use the Fit Images to View function to get a fit in the 
uncorrected data view. 
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2. Place the uncorrected control point mark on the image in 
View 3 by snapping/data point at location 1 as displayed 
below.

When you have placed the uncorrected control point, 
Register warps and redisplays the vector data on the image 
displayed in an uncorrected view window. Register also adds 
the pair of points to the Register dialog box in the list of 
control points and calculates the residuals when more then 
four points are placed. 

3. Repeat steps 1 and 2 for the remaining pairs of control points 
as follows.

At this point, the Register dialog box displays all four (4) pairs 
of control points and Residual Values.

4. In this tutorial, the base control points are selected and 
displayed in Window 4. This method is not required. After 
you have selected the first control point, you may select all 
the other base control points in the same window as the 
uncorrected image (in this case Window 3).

The third point was placed in the wrong location to illustrate 
that you can change your mind about the location of the 
point. You can now correct the placement of point 3.

5. From the Register tool box, select the Move Control Points 
tool. 

Window 4 - Vector
Base System

Window 3 - Image
Uncorrected System

Location 2 Location 2

Location 3 Location 3

Location 4 Location 4
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6. Select the uncorrected control point 3. When highlighted, the 
pointer takes the form of the chosen control point. You must 
select the uncorrected control point. If the selection is not 
correct, click Reset to be offered the next control point. 

Move the highlighted pointer to the position indicated by 
location 5 and snap/data point. 

The vectors are now redisplayed. If the other points are also 
in the correct position, the vectors should now fit much 
better.
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➤ To resample an image

The last step in the process is to resample the image to fit it to the 
vectors. 

1. From the Register tool box, select the Resample Image tool.

The Resampling dialog box opens.

Register automatically creates the resampling entry by using 
the following known data:

Input Image: Uses the Active Image.

Model: Uses the file prefix of the input image.

Output Image: Uses the file prefix of the input image plus a 
number.

2. Ensure that Create A New Image is turned OFF.

Since Affine model is supported by the Transformation Matrix, 
there is no need to physically resample the image pixel by 
pixel. The image will resample dynamically using the 
Transformation Matrix.

✍ The image can be physically resampled at any time. Simply select 
File > Save As > Image. From the Save As dialog, select Options 
button and turn ON the Resample item.

3. Leave all other parameters set to their default values. 

You are now ready to resample the image. 

4. Click the Run Page button in the Job Manager group of the 
Resampling dialog box.

An alert box asks if you wish to submit this image for 
resampling. 
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5. Click OK to confirm. 

The image is instantaneously processed.

6. Fit Image to View in Window 3.

The image is now resampled.

✍ In the event that the result in not satisfactory, simply undo the 
resampling (Image Undo tool) and add more points, move 
existing points and try another model.

➤ Visualizing the scene

This procedure ensures that Register settings are turned off so that 
the image and vectors are displayed in their respective geometric 
space.

1. Close the Resampling dialog box.

2. Bring the Register dialog box to the foreground.

3. From the View menu, select Views Displaying 
Uncorrected Data and turn off all settings.

4. From the File menu, select New.

5. Close the Register dialog box.

6. From the Image Control tool box, select Fit Images to View.
MicroStation Descartes Tutorial Workbook 2-19



2 Positioning Images
Basic Warping with Register
7. Enter a data point in window 3.

The screen should look as follows.

8. From the File menu, select Image Project > Attach.

A Warning dialog box opens informing you that MAP_3.HMR 
was previously modified and not saved.

9. Since we have only modified one image, you can click either 
button, Save or Save as HMR.

At this point, a project file is created and attached to 
Lesson2.dgn. The project file is automatically named after the 
design file, in this case lesson2.prj.
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✍ You can also give a different name to the project by first selecting, 
Image Project > Save As and then selecting Image Project>Attach 
from the File menu. 

Practice
This lesson does not cover all of the functions related to 
Positioning Images. You should further explore these other 
functions by reviewing chapter 7 “Transforming Images: and 
chapter 8 “Registering Images and Vector Data” of the 
MicroStation Descartes User’s Guide. 

Here are a few of the functions you should explore:

• Mirror and Rotate an Image.

• Resample with an Input Window

• Resample with an Output Window

• Resample with the Standard MicroStation Descartes Models

• Batch Resampling

• Warp Vectors

• Thin Plate Spline model.
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