Managing Files and Viewing Images

Preview
In this lesson you will learn how to:
= Start MicroStation Descartes
= Setup the MicroStation Descartes Workspace
= Open an Image
= Display and Explore an Image
= Add Images to Several Views
= Add Several Images to a View
= Apply Images to Other Views
= Control Image Visibility
< Print a View

= Save a Project
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File Management and Viewing Images

O Setup MicroStation Descartes
1. Start MicroStation.

2. From the MicroStation Manager dialog box, select
Workspace > dcartes.

MicroStation Manager B
File  Directory
Files: Directories:
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52002, dgn [ win32app Cancel |
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™ Open Design Files Read-Only
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3. Open the LESSON1.DGN file that is supplied with the tutorial.
The file should be in the ...\dcartes\tutorial directory.
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4. From the MicroStation Tools menu, select Image > Image
Control and dock it under the Main tool box of MicroStation.

O Open an image

1. From the MicroStation File menu, select Open > Image.

The Open Images dialog box opens. You can also access this
dialog box from the Open Image tool of the Image File tool
box (Tools > Image > Image File).

2. Find the SATELLIT.HMR image that is supplied with the
Tutorial. The file should be in the ...\dcartes\tutorial
directory. Highlight the image.
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3. Set the Image Preview setting to on. Notice the display of a
thumbnail of the image in the Preview window.

Open Images <]
. cel
| cwin3Z2apphdoartesiimage’ satelit hmr
Files: Directories:
aerial.hmr = et Cancel |
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4. Ensure that the setting for View 1 is set to on. Click OK to
open the image.

The screen appears as follows.
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105 — o~ — | @] 0[=[d] 8] [m[a@] o[~ 2] \

b || 25w indow 1 I [= B | |7 Window 2 o] x|
+ +

Display complate ‘ - .
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O Display and explore the image

& =15M & F=]= 6.
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From the Image Control tool box, select the Fit Images to View
tool and click in Window 1.

The image that was added to the list for View 1 now displays
at such a scale that the complete image fits into the view.

From the MicroStation View Control bar in Window 1 select
the Update View tool and notice that the design file and the
image are redrawn.

To experience the speed of Image Manager and to
demonstrate its integration into MicroStation, use all the View
Control tools on the image (Window Area, Zoom +, Zoom -).

Execute a Fit View and then a Dynamic Pan (<Shift> data
button). The image pans effortlessly.

Window Area on the image and then try the Pan again.

The Pan feature may be used at any time, at any scale, and in
any view to move around on the image.

Execute a Fit View in Window 1.

0 Add an image to another View

1.

From the MicroStation File menu, select
Image Display > Apply To.

Enter a data point in Window 1.
The Apply to dialog box opens.

Set View 2 to on and click OK.
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4. From the Image Control tool box, select the Fit Images to View
tool and click in Window 2.

The image that was added to the list for View 2 now displays
at such a scale that the complete image fits into the view.

The result should look as follows.
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O Add several images to a View

MicroStation Descartes permits you to open several images in the
same View.

1. From the MicroStation File menu, select Open > Image.
The Open Images dialog box opens.

2. Find the AERIAL.HMR image that is supplied with the
Tutorial. The file should be in the ...\dcartes\tutorial
directory. Highlight the image.
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3. Set the Image Preview setting to on. Notice the display of a
thumbnail of the image in the Preview window.
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4. Check that the setting for View 1 is set to on. Click OK.
Notice that both images are now visible in your display.

# lesson1.dgn (2D - MicroStation 95 [_[C]
File Edit Element Settings Took Utiities Workspace ‘window Help

Display complele | -

5. From the Image Control tool box, select the Select Images/
Active Image tool.
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6. Select the image in Window 1 by entering a data point at
location 2.

Notice the border that appears around the image. This border
indicates that the image is part of the active selection set.

7. From the Image Control tool box, select the Fit Images to View
tool and click on View 1.

The image now displays at such a scale that the complete
image fits into the view.

8. From the View Control Bar of Window 1, select Fit View.
This action allows you to view both images simultaneously.

& +=15F =2 o] =

0 To Apply All Images of a Window to All Open Windows

1. From the MicroStation File menu, select Image
Display > Apply to All.

2. Enter a data point in Window 1.
This action copies the images from Window 1 to Window 2.

| | = P ] ] o
3. Fit View in Window 2.

W Applying a set of images of one view to another view overwrites
the set of images in the target view.
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4. From the View Control Bar of Window 2, select Window Area
and define the area by snapping to locations 1 and 2.

Observe the following result.

& Window 2 I [=]
*

5. From the Image Control tool box, select the Fit Images to View
tool and click on View 1.
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6. From the Image Control tool box, select the Actual Image
Resolution (1:1) tool and click on View 1.

& window 1

& | =] ST ] 2ol 7. Fit View in Window 1.
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0 Turn images on or off

You can control the display of each image in a view by turning
the image on or off.

1. From the Image Control tool box, select the Select Images/
Active Image tool.

2. Select the image in Window 1 by entering a data point at
location 1.

Notice the border that appears around the image. This border
indicates that the image is part of the active selection set.
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3. From MicroStation File menu, select
Image Display > Image Off.
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4. Click anywhere in Window 1. The action updates the view
and applies the on or off action to all images in the selection
set.

Notice that SATELLIT.HMR does not display. Only
AERIAL.HMR is now visible.
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5. Turn SATELLIT.HMR back on. From the MicroStation File
menu, select Image Display > Image On. Click anywhere in
Window 1.

Notice that the image is turned on.
6. You may also turn more than one image on or off at a time.

Select the Select Images/Active Image tool and select both
images in Window 1.

Select the first image by entering a data point at location 1.
Press and hold down the <Ctrl> key and enter a data point a
location 2.

7. From MicroStation File menu, select
Image Display > Image Off. Click anywhere in Window 1.
Notice that both images are turned off.

8. From the MicroStation File menu, select Image
Display > Image On. Click anywhere in Window 1.
Notice that both images are turned on.
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O Printa View

In this exercise, you will print the present contents of Window 1
with your Windows system printer. If you have a DOS installation,
skip this exercise and try the next one: Create a Plot File.
1. From the MicroStation File menu, select Print/Plot.

The MicroStation Plot dialog box opens.

A IS[=] E3

File Configuration Entity  Setup  PenTable

S|A| ¢

| iew 1 | Fen T able:

Flotter: ... \win32apphustation'plotdrdegen. plt

2. From the Setup menu of the Plot dialog box, select Driver.

The Select Plotter Driver File dialog box opens. Find and
select the DCGEN.PLT file located in the PLOTDRYV sub-
directory of MicroStation.

From the Entity menu, select View > 1.

From Setup menu, select Device.
The Descartes - Image Plotting dialog box opens.

5. Turn on Plot Raster Images and Gray Scale. Accept all other
default values by clicking OK.

6. From the Setup menu of the Plot dialog box, select Page.

7. Select the appropriate printer and paper size, and turn on
Landscape in the Orientation box.

8. Click OK to confirm.
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9. From the File menu, select Preview.

The MicroStation Plot Preview dialog box opens. The Setup
menu items allows you to set the correct parameters for your

printer.

Eile  Configuration Entity Setup  PenTable

Platter: ... win32appiustation\plotdrvidegen. plt

| View 1 | Pen Table

10. When you are satisfied with the preview, select Plot from the
File menu.

This action initiates the printing of all the vector and raster
elements found in Window 1. The resulting page will be
printed on your system printer.

11. Exit the Plot Preview dialog box by selecting Exit from the
File menu.

Create a plot file

In this exercise, you will prepare a plot file from the present
content of Window 1 and use a DOS command to send it to your
printer.
1. From the MicroStation File menu, select Print/Plot.

The MicroStation Plot dialog box opens.

2. From the Entity menu, select View > 1.

3. From the Setup menu, select Driver. This action opens the
Select Plotter Driver File dialog box. Find and open the
DCPS.PLT (PostScript) or DCRTL.PLT (HP/RTL) file located in
the PLOTDRYV sub-directory of MicroStation.
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4. From the Setup menu, select Device.
The Descartes - Image Plotting dialog box opens.

5. Turn on Plot Raster Images and Gray Scale. Accept all other
default values by clicking OK.

Descartes - PostScript Image Plotting B

% Plot Raster Images [T UseFence
x fﬁ.r;a_l.,l Scale Output: 8 bits I

Lontrast: | 50 & Brightness: I a0 &

DOutput Resoluti
M aximum Resalution: | 80 Fixelz/IM
Output Size of Raster Data: 710 Kb

X Use Printer's Default Screen
" Halftone Settings ‘

FErequency |55 cell/iM - Angle |45 [eg

| oK I Cancel I

6. From the Setup menu, select Page.
The Page Setup dialog box opens.

7. Select the appropriate paper size and turn on Rotate 90°.
Click OK to confirm.

8. From the File menu, select Preview.

The MicroStation Plot Preview dialog box opens. The Setup
menu items allow you to set the correct parameters for your
printer.

9. When you are satisfied with the preview, select Plot from the
File menu.
This action opens the Save Plot As dialog box to enter the
filename of the plot file that will be created. Find the
...\dcartes\tutorial directory and accept the default plot file
name (lesson1.000).
Click OK to initiate the creation of your plot file. The plot file
will include all the vector and raster elements found in
view 1.

10. Exit the Plot Preview dialog box by choosing Exit from the
File menu.

11. To print or plot your work, exit to DOS and send the file to
your printer or plotter with the command:

COPY /B LESSON1.000 LPT1 (or the appropriate printer port).
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Projects

MicroStation Descartes permits you to save the status of your
working environment at a given time as a project. Projects can be
saved in two distinct fashions.

By saving all the settings in a Project File (.PRJ file).

In this case, a file is created and it contains all the settings at
the time the project was last saved. The project can then be
opened at any time using the MicroStation File > Image
Project > Open item.

By attaching the current status to a design file.

When attached to a design file, the project automatically
opens and loads each time the design file is opened.

0 Attach/Detach and setting Automatic Save and Attach
Project to a design file

1.

At this point, the project attached to the design file is
attached. From the MicroStation Settings menu, select
Image > Project.

The Project Settings dialog box opens.

g Project Settings [ %]

™ Save Full Path

When on, a project file, named after the design file prefix, is
automatically created, attached and saved upon closing and/
or exiting MicroStation Descartes and/or MicroStation.

When off, you must manually attach and save your project
file.

0 Save a project under a different name

1.

From the MicroStation File menu, select
Image Project > Save As.

You will be prompted to enter a file name in the Save Project
dialog box.

Browse through the ...\dcartes\tutorial directory.
Enter the file name LESSON1A.
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Practice

This lesson does not cover all of the functions related to File
Management and Viewing Images. You should explore other
functions by reviewing chapter 5 “Displaying Images with Image
Manager” and chapter 15 “Plotting and Printing Images with
MicroStation Descartes” of the MicroStation Descartes User’s
Guide.

Here are a few of the functions that you should explore:
= Open Target Image Formats

= Save as Target Image Formats

= Batch Conversion

= Image Properties

< Bring to Front

= Send to Back
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